unbound-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %global with_munin 0
  4. %{?!enable_gost: %global enable_gost 1}
  5. # not ready yet
  6. %{?!with_python: %global with_python 0}
  7. %define _sharedstatedir /var/lib
  8. Summary: Validating, recursive, and caching DNS(SEC) resolver
  9. Name: unbound
  10. Version: 1.10.0
  11. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  12. Group: System Environment/Daemons
  13. Distribution: Vine Linux
  14. Vendor: Project Vine
  15. Packager: iwaim, daisuke
  16. License: BSD
  17. Url: http://www.unbound.net/
  18. Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
  19. Source1: unbound.init
  20. Source3: unbound.munin
  21. Source4: dlv.isc.org.key
  22. Source5: root.key
  23. Source6: root.anchor
  24. Source7: icannbundle.pem
  25. Source8: unbound.cron
  26. Source9: example.com.key
  27. Source10: example.com.conf
  28. Source11: block-example.com.conf
  29. Source100: unbound.service
  30. Source101: unbound-keygen.service
  31. Source102: unbound-anchor.service
  32. Source103: unbound-anchor.timer
  33. Source104: tmpfiles-unbound.conf
  34. Source105: unbound.sysconfig
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  36. BuildRequires: flex
  37. BuildRequires: libevent-devel
  38. BuildRequires: expat-devel
  39. %if %{with_python}
  40. BuildRequires: python-devel python-rpm-macros swig
  41. %endif
  42. %if %{enable_gost}
  43. BuildRequires: openssl-devel >= 1.0.0
  44. %else
  45. BuildRequires: openssl-devel
  46. %endif
  47. # Required for SVN versions
  48. #BuildRequires: bison
  49. %if %{with systemd}
  50. %global piddir /run/%{name}
  51. BuildRequires: systemd
  52. %{?systemd_requires}
  53. %else
  54. %global piddir %{_localstatedir}/run/%{name}
  55. Requires(post): chkconfig
  56. Requires(preun): chkconfig
  57. Requires(preun): initscripts
  58. Requires(postun): initscripts
  59. %endif
  60. Requires(pre): shadow-utils
  61. %description
  62. Unbound is a validating, recursive, and caching DNS(SEC) resolver.
  63. The C implementation of Unbound is developed and maintained by NLnet
  64. Labs. It is based on ideas and algorithms taken from a java prototype
  65. developed by Verisign labs, Nominet, Kirei and ep.net.
  66. Unbound is designed as a set of modular components, so that also
  67. DNSSEC (secure DNS) validation and stub-resolvers (that do not run
  68. as a server, but are linked into an application) are easily possible.
  69. %if %{with_munin}
  70. %package munin
  71. Summary: Plugin for the munin / munin-node monitoring package
  72. Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
  73. Group: System Environment/Daemons
  74. Requires: munin-node
  75. Requires: %{name} = %{version}-%{release}, bc
  76. %description munin
  77. Plugin for the munin / munin-node monitoring package
  78. %endif
  79. %package devel
  80. Summary: Development package that includes the unbound header files
  81. Group: Development/Libraries
  82. Requires: %{name}-libs = %{version}-%{release}, openssl-devel
  83. %description devel
  84. The devel package contains the unbound library and the include files
  85. %package libs
  86. Summary: Libraries used by the unbound server and client applications
  87. Group: Applications/System
  88. Requires(post): /sbin/ldconfig
  89. Requires(postun): /sbin/ldconfig
  90. Requires: openssl >= 0.9.8g-12
  91. %description libs
  92. Contains libraries used by the unbound server and client applications
  93. %if %{with_python}
  94. %package python
  95. Summary: Python modules and extensions for unbound
  96. Group: Applications/System
  97. Requires: %{name}-libs = %{version}-%{release}
  98. %description python
  99. Python modules and extensions for unbound
  100. %endif
  101. %package -n compat32-%{name}-libs
  102. Summary: Libraries used by the unbound server and client applications
  103. Group: Applications/System
  104. Requires: %{name}-libs = %{version}-%{release}
  105. Requires(post): /sbin/ldconfig
  106. Requires(postun): /sbin/ldconfig
  107. Requires: openssl >= 0.9.8g-12
  108. %description -n compat32-%{name}-libs
  109. Contains libraries used by the unbound server and client applications
  110. %prep
  111. %setup -q
  112. %build
  113. %configure --with-libevent --with-pthreads --with-ssl \
  114. --disable-rpath --enable-debug --disable-static \
  115. --enable-relro-now --enable-pie \
  116. --enable-subnet --enable-ipsecmod \
  117. --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
  118. --with-pidfile=%{piddir}/%{name}.pid \
  119. %if %{with_python}
  120. --with-pythonmodule --with-pyunbound \
  121. %endif
  122. %if !%{enable_gost}
  123. --disable-gost \
  124. %endif
  125. --enable-sha2 \
  126. --disable-sha1 \
  127. --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
  128. %{__make} %{?_smp_mflags}
  129. %install
  130. rm -rf %{buildroot}
  131. %{__make} DESTDIR=%{buildroot} install
  132. install -d 0755 %{buildroot}%{_initrddir}
  133. %if %{with systemd}
  134. install -d -m 0755 %{buildroot}%{_unitdir} %{buildroot}%{_sysconfdir}/sysconfig
  135. install -p -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/unbound.service
  136. install -p -m 0644 %{SOURCE101} %{buildroot}%{_unitdir}/unbound-keygen.service
  137. install -p -m 0644 %{SOURCE103} %{buildroot}%{_unitdir}/unbound-anchor.timer
  138. install -p -m 0644 %{SOURCE102} %{buildroot}%{_unitdir}/unbound-anchor.service
  139. install -p -m 0644 %{SOURCE105} %{buildroot}%{_sysconfdir}/sysconfig/unbound
  140. # Install tmpfiles.d config
  141. install -d -m 0755 %{buildroot}%{_tmpfilesdir} %{buildroot}%{_sharedstatedir}/unbound
  142. install -m 0644 %{SOURCE104} %{buildroot}%{_tmpfilesdir}/unbound.conf
  143. %else
  144. install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
  145. install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
  146. install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
  147. %endif
  148. install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
  149. echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
  150. %if %{with_munin}
  151. # Install munin plugin and its softlinks
  152. install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
  153. install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
  154. install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
  155. install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
  156. for plugin in unbound_munin_hits unbound_munin_queue \
  157. unbound_munin_memory unbound_munin_by_type \
  158. unbound_munin_by_class unbound_munin_by_opcode \
  159. unbound_munin_by_rcode unbound_munin_by_flags \
  160. unbound_munin_histogram; do
  161. ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
  162. done
  163. %endif
  164. # install root and DLV key
  165. install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
  166. install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
  167. install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
  168. # remove static library from install (fedora packaging guidelines)
  169. rm -rf %{buildroot}%{_libdir}/*.la
  170. %if %{with_python}
  171. rm -rf %{buildroot}%{python_sitelib}/*/*.la
  172. %endif
  173. mkdir -p %{buildroot}%{_localstatedir}/run/unbound
  174. # Install directories for easier config file drop in
  175. install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
  176. install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
  177. install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
  178. install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
  179. %clean
  180. rm -rf ${RPM_BUILD_ROOT}
  181. %files
  182. %defattr(-,root,root,-)
  183. %license doc/LICENSE
  184. %doc doc/README doc/CREDITS doc/FEATURES
  185. %if %{with systemd}
  186. %attr(0644,root,root) %{_tmpfilesdir}/unbound.conf
  187. %{_unitdir}/%{name}.service
  188. %{_unitdir}/%{name}-keygen.service
  189. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  190. %else
  191. %attr(0755,root,root) %{_initrddir}/%{name}
  192. %endif
  193. %attr(0755,root,root) %dir %{_sysconfdir}/%{name}
  194. %attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
  195. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
  196. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
  197. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
  198. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
  199. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
  200. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
  201. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
  202. %{_sbindir}/*
  203. %exclude %{_sbindir}/unbound-anchor
  204. %{_mandir}/*/*
  205. %if %{with_python}
  206. %files python
  207. %{python_sitelib}/*
  208. %endif
  209. %if %{with_munin}
  210. %files munin
  211. %defattr(-,root,root,-)
  212. %config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
  213. %{_datadir}/munin/plugins/unbound*
  214. %endif
  215. %files devel
  216. %defattr(-,root,root,-)
  217. %{_libdir}/libunbound.so
  218. %{_includedir}/unbound.h
  219. %{_libdir}/pkgconfig/libunbound.pc
  220. %doc README
  221. %files libs
  222. %defattr(-,root,root,-)
  223. %license doc/LICENSE
  224. %doc doc/README
  225. %{_sbindir}/unbound-anchor
  226. %{_libdir}/libunbound.so.*
  227. %{_sysconfdir}/%{name}/icannbundle.pem
  228. %dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
  229. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
  230. %attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
  231. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
  232. %if %{with systemd}
  233. %{_unitdir}/unbound-anchor.timer
  234. %{_unitdir}/unbound-anchor.service
  235. %else
  236. %attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
  237. %endif
  238. %if %{build_compat32}
  239. %files -n compat32-%{name}-libs
  240. %defattr(-,root,root,-)
  241. %{_libdir}/libunbound.so.*
  242. %endif
  243. %pre libs
  244. getent group unbound >/dev/null || groupadd -r unbound
  245. getent passwd unbound >/dev/null || \
  246. useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
  247. -c "Unbound DNS resolver" unbound
  248. exit 0
  249. %post libs
  250. /sbin/ldconfig
  251. /sbin/runuser --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem" --shell /bin/sh unbound ||:
  252. %if %{with systemd}
  253. %systemd_post unbound-anchor.timer
  254. # start the timer only if installing the package to prevent starting it, if it was stopped on purpose
  255. if [ "$1" -eq 1 ]; then
  256. # the Unit is in presets, but would be started after reboot
  257. /bin/systemctl start unbound-anchor.timer >/dev/null 2>&1 || :
  258. fi
  259. %endif
  260. %if %{with systemd}
  261. %preun libs
  262. %systemd_preun unbound-anchor.timer
  263. %endif
  264. %postun libs
  265. /sbin/ldconfig
  266. %if %{with systemd}
  267. %systemd_postun_with_restart unbound-anchor.timer
  268. %endif
  269. %post
  270. %if %{with systemd}
  271. %systemd_post unbound.service
  272. %systemd_post unbound-keygen.service
  273. %else
  274. /sbin/chkconfig --add %{name}
  275. %endif
  276. # dnssec-conf used to contain our DLV key, but now we include it via unbound
  277. # If unbound had previously been configured with dnssec-configure, we need
  278. # to migrate the location of the DLV key file (to keep DLV enabled, and because
  279. # unbound won't start with a bad location for a DLV key file.
  280. sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
  281. %preun
  282. %if %{with systemd}
  283. %systemd_preun unbound.service
  284. %systemd_preun unbound-keygen.service
  285. %else
  286. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  287. /sbin/service %{name} stop >/dev/null 2>&1
  288. /sbin/chkconfig --del %{name}
  289. fi
  290. %endif
  291. %postun
  292. %if %{with systemd}
  293. %systemd_postun_with_restart unbound.service
  294. %systemd_postun unbound-keygen.service
  295. %else
  296. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  297. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  298. fi
  299. %endif
  300. %post -n compat32-%{name}-libs
  301. /sbin/ldconfig
  302. %postun -n compat32-%{name}-libs
  303. /sbin/ldconfig
  304. %changelog
  305. * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-2
  306. - rebuilt with libevent-2.1.11.
  307. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
  308. - updated to 1.10.0.
  309. - added systemd support (disabled as default).
  310. - disabled munin.
  311. * Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
  312. - updated to 1.9.6.
  313. * Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
  314. - updated to 1.9.4.
  315. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
  316. - updated to 1.9.3.
  317. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
  318. - updated to 1.9.2.
  319. * Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
  320. - added a subpackage 'compat32-unbound-libs'.
  321. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
  322. - updated to 1.8.1.
  323. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  324. - updated root.key and root.anchor.
  325. * Thu Oct 4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
  326. - update to 1.8.0
  327. - drop mesh patch (Patch0): upstream fixed
  328. * Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
  329. - Fix mesh state assertion failure due to callback removal. (Patch0)
  330. * Sun May 6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
  331. - enable ECDSA support
  332. - enable GOST support
  333. * Sat May 5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
  334. - update to 1.7.1
  335. - add pkgconfig file in devel sub package
  336. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
  337. - updated to 1.6.7.
  338. * Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
  339. - update to 1.6.4
  340. * Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
  341. - update to 1.6.3
  342. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
  343. - update to 1.6.2
  344. - disables SHA1 support
  345. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
  346. - update to 1.6.1
  347. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
  348. - fix Requires and BuildRequres
  349. - drop ldns
  350. * Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
  351. - update to 1.6.0
  352. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
  353. - new upstream release.
  354. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
  355. - new upstream release.
  356. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
  357. - new upstream release.
  358. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
  359. - new upstream release.
  360. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
  361. - update to 1.5.3
  362. * Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
  363. - update to 1.5.1
  364. * Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
  365. - move create user script to libs subpackage
  366. * Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
  367. - add {B,C}.ROOT-SERVERS.NET. IPv6 address
  368. * Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
  369. - update to 1.4.22
  370. - move root.key to /var/lib/unbound
  371. - add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
  372. - add unbound.cron
  373. - move keys and unbound-anchor to libs subpackage
  374. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
  375. - new upstream release
  376. * Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
  377. - new upstream release
  378. * Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
  379. - new upstream release
  380. - drop glob patch (Patch1): upstream merged
  381. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
  382. - new upstream release
  383. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
  384. - update to 1.4.17
  385. - add root.key for DNSSEC
  386. - enable munin subpackage by default
  387. - buildrequire ldns-devel >= 1.6.13
  388. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
  389. - rebuild with python-2.7.2
  390. * Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
  391. - new upstream release
  392. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
  393. - new upstream release
  394. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
  395. - new upstream releas
  396. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
  397. - new upstream release
  398. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
  399. - new upstream release
  400. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
  401. - rebuilt with libevent-2.0.10
  402. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
  403. - new upstream release
  404. - add enable_gost flag: default disable
  405. - add BuildRequires: expat-devel
  406. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
  407. - new upstream release
  408. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
  409. - new upstream release
  410. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
  411. - initial build for Vine Linux: based Fedora 1.4.3-1.fc14
  412. - update to 1.4.4
  413. - build without munin
  414. * Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
  415. - Update to 1.4.3 that fixes 64bit crasher
  416. * Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
  417. - Updated to 1.4.2
  418. - Updated unbound.conf with new options
  419. - Enabled pre-fetching DNSKEY records (DNSSEC speedup)
  420. - Enabled re-fetching popular records before they expire
  421. - Enabled logging of DNSSEC validation errors
  422. * Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
  423. - Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
  424. with pthreads
  425. * Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
  426. - Change make/configure lines to attempt to fix -lphtread linking issue
  427. * Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
  428. - Removed dependancy for dnssec-conf
  429. - Added ISC DLV key (formerly in dnssec-conf)
  430. - Fixup old DLV locations in unbound.conf file via %%post
  431. - Fix parent child disagreement handling and no-ipv6 present [svn r1953]
  432. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
  433. - Updated to 1.4.1
  434. - Changed %%define to %%global
  435. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
  436. - Bump version
  437. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
  438. - Upgraded to 1.3.4. Security fix with validating NSEC3 records
  439. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
  440. - rebuilt with new openssl
  441. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
  442. - Updated to 1.3.3
  443. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  444. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  445. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  446. - Added missing glob patch to cvs
  447. - Place python macros within the %%with_python check
  448. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  449. - Updated to 1.3.0
  450. - Added unbound-python sub package. disabled for now
  451. - Patch from svn to fix DLV lookups
  452. - Patches from svn to detect wrong truncated response from BIND 9.6.1 with
  453. minimal-responses)
  454. - Added Default-Start and Default-Stop to unbound.init
  455. - Re-enabled --enable-sha2
  456. - Re-enabled glob.patch
  457. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
  458. - unbound-iterator.patch was not commited
  459. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
  460. - Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
  461. * Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
  462. - Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
  463. * Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
  464. - enable DNSSEC only if it is enabled in sysconfig/dnssec
  465. * Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
  466. - add DNSSEC support to initscript and enabled it per default
  467. - add requires dnssec-conf
  468. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  469. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  470. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
  471. - updated to 1.2.1
  472. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
  473. - rebuild with new openssl
  474. * Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
  475. - Updated to 1.2.0
  476. - Added dependancy on minimum SSL for CVE-2008-5077
  477. - Added dependancy on bc for unbound-munin
  478. - Added minimum requirement of libevent 1.4.5. Crashes with older versions
  479. (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
  480. - Removed dependancy on selinux-policy (will get used when available)
  481. - Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
  482. - Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
  483. - Enable val-clean-additional to drop addition unsigned data from signed
  484. response.
  485. - Removed patches (got merged into upstream)
  486. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
  487. - Modified scandir patch to silently fail when wildcard matches nothing
  488. - Patch to allow unbound-checkconf to find empty wildcard matches
  489. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
  490. - Added scandir patch for trusted-keys-file: option, which
  491. is used to load multiple dnssec keys in bind file format
  492. * Mon Dec 8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
  493. - Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
  494. * Mon Dec 1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
  495. - We did not own the /etc/unbound directory (#474020)
  496. - Fixed cvs anomalies
  497. * Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
  498. - removed all obsolete chroot related stuff
  499. - label control certs after generation correctly
  500. * Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
  501. - Updated to unbound 1.1.1 which fixes a crasher and
  502. addresses nlnetlabs bug #219
  503. * Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
  504. - Remove the chroot, obsoleted by SElinux
  505. - Add additional munin plugin links supported by unbound plugin
  506. - Move configuration directory from /var/lib/unbound to /etc/unbound
  507. - Modified unbound.init and unbound.conf to account for chroot changes
  508. - Updated unbound.conf with new available options
  509. - Enabled dns-0x20 protection per default
  510. * Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
  511. - unbound-1.1.0-log_open.patch
  512. - make sure log is opened before chroot call
  513. - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
  514. - removed /dev/log and /var/run/unbound and /etc/resolv.conf from
  515. chroot, not needed
  516. - don't mount files in chroot, it causes problems during updates
  517. - fixed typo in default config file
  518. * Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
  519. - Updated to version 1.1.0
  520. - Updated unbound.conf's statistics options and remote-control
  521. to work properly for munin
  522. - Added unbound-munin package
  523. - Generate unbound remote-control key/certs on first startup
  524. - Required ldns is now 1.4.0
  525. * Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
  526. - Only call ldconfig in -libs package
  527. - Move configure into build section
  528. - devel subpackage should only depend on libs subpackage
  529. * Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
  530. - Fix CFLAGS getting lost in build
  531. - Don't enable interface-automatic:yes because that
  532. causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
  533. * Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
  534. - Split off unbound-libs, make build verbose
  535. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
  536. - FSB compliance, chroot fixes, initscript fixes
  537. * Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
  538. - Upgraded to 1.0.2
  539. * Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
  540. - upgraded to new release
  541. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
  542. - Build against ldns-1.3.0
  543. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
  544. - Split of -devel package, fixed dependancies, make rpmlint happy
  545. * Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
  546. - Using parts from ports collection entry by Jaap Akkerhuis.
  547. - Using Fedoraproject wiki guidelines.
  548. * Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
  549. - Initial version.