orc-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. Name: orc
  2. Summary: The Oil Run-time Compiler
  3. Version: 0.4.11
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: BSD
  7. URL: http://code.entropywave.com/projects/orc/
  8. Source0: http://code.entropywave.com/download/orc/orc-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: gtk-doc, libtool
  11. %description
  12. Orc is a library and set of tools for compiling and executing
  13. very simple programs that operate on arrays of data. The "language"
  14. is a generic assembly language that represents many of the features
  15. available in SIMD architectures, including saturated addition and
  16. subtraction, and many arithmetic operations.
  17. %package doc
  18. Summary: Documentation for Orc
  19. Group: Development/Documentation
  20. Requires: %{name} = %{version}-%{release}
  21. #BuildArch: noarch
  22. %description doc
  23. Documentation for Orc.
  24. %package devel
  25. Summary: Development files and static libraries for Orc
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: %{name}-compiler
  29. Requires: pkgconfig
  30. %description devel
  31. This package contains the files needed to build packages that depend
  32. on orc.
  33. %package compiler
  34. Summary: Orc compiler
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: pkgconfig
  38. %description compiler
  39. The Orc compiler, to produce optimized code.
  40. %prep
  41. %setup -q
  42. autoreconf -vif
  43. %build
  44. export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
  45. export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
  46. %configure --disable-static --enable-gtk-doc
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf %{buildroot}
  50. make install DESTDIR=%{buildroot} INSTALL="install -p"
  51. # Remove unneeded files.
  52. find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
  53. rm -rf %{buildroot}/%{_libdir}/orc
  54. touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h
  55. %clean
  56. rm -rf %{buildroot}
  57. %check
  58. make check || true
  59. %post -p /sbin/ldconfig
  60. %postun -p /sbin/ldconfig
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc COPYING README
  64. %{_libdir}/liborc-*.so.*
  65. %files doc
  66. %defattr(-,root,root,-)
  67. %doc %{_datadir}/gtk-doc/html/orc/
  68. %files devel
  69. %defattr(-,root,root,-)
  70. %doc examples/*.c
  71. %{_includedir}/%{name}-0.4/
  72. %{_libdir}/liborc-*.so
  73. %{_libdir}/pkgconfig/orc-0.4.pc
  74. %files compiler
  75. %defattr(-,root,root,-)
  76. %{_bindir}/orcc
  77. %changelog
  78. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  79. - new upstream release
  80. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
  81. - rebuilt with rpm-4.8.1 for pkg-config
  82. * Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
  83. - build with -O1 (not -O2) to fix build failure on ppc
  84. (like as the Debian package does)
  85. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
  86. - Initial build for Vine Linux
  87. * Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
  88. - Added removed testing libraries to package.
  89. * Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
  90. - Updated to 0.4.5.
  91. - Removed testing libraries from package.
  92. * Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
  93. - Docs as noarch.
  94. - Sanitize timestamps of header files.
  95. - orcc in -compiler subpackage.
  96. * Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
  97. - Updated to 0.4.4: Includes bugfixes for x86_64.
  98. * Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
  99. - Running autoreconf to prevent building problems.
  100. - Added missing files to docs.
  101. - Added examples to devel docs.
  102. * Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
  103. - Updated to 0.4.3
  104. * Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
  105. - Removed unused libdir
  106. * Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
  107. - Specfile cleanup
  108. - Removed tools subpackage
  109. - Added docs subpackage
  110. * Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
  111. - Use orc as pakage name
  112. - spec-file cleanup
  113. - Added devel requirements
  114. - Removed an rpath issue
  115. * Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
  116. - Initial release