nghttp2-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %bcond_with test
  3. Summary: Experimental HTTP/2 client, server and proxy
  4. Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
  5. Name: nghttp2
  6. Version: 1.12.0
  7. Release: 2%{?_dist_release}
  8. License: MIT
  9. Group: Applications/Internet
  10. URL: https://nghttp2.org/
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
  14. %if %{with test}
  15. BuildRequires: CUnit-devel
  16. %endif
  17. BuildRequires: jemalloc-devel
  18. BuildRequires: libboost-devel
  19. BuildRequires: libboost-thread
  20. BuildRequires: libev-devel
  21. BuildRequires: openssl-devel
  22. BuildRequires: zlib-devel
  23. Requires: libnghttp2 = %{version}-%{release}
  24. %description
  25. This package contains the HTTP/2 client, server and proxy programs.
  26. %description -l ja
  27. This package contains the HTTP/2 client, server and proxy programs.
  28.  このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
  29. が含まれています。
  30. %package -n libnghttp2
  31. Summary: A library implementing the HTTP/2 protocol
  32. Summary(ja): HTTP/2ライブラリ
  33. Group: Development/Libraries
  34. %description -n libnghttp2
  35. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  36. version 2 (HTTP/2) protocol in C.
  37. %description -l ja -n libnghttp2
  38.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  39. 実装したライブラリです。
  40. %package -n libnghttp2-devel
  41. Summary: Files needed for building applications with libnghttp2
  42. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  43. Group: Development/Libraries
  44. Requires: libnghttp2%{?_isa} = %{version}-%{release}
  45. Requires: pkgconfig
  46. %description -n libnghttp2-devel
  47. The libnghttp2-devel package includes libraries and header files needed
  48. for building applications with libnghttp2.
  49. %description -l ja -n libnghttp2-devel
  50.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  51. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  52. す。
  53. %package -n compat32-libnghttp2
  54. Summary: A library implementing the HTTP/2 protocol
  55. Summary(ja): HTTP/2ライブラリ
  56. Group: Development/Libraries
  57. %description -n compat32-libnghttp2
  58. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  59. version 2 (HTTP/2) protocol in C.
  60. %description -l ja -n compat32-libnghttp2
  61.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  62. 実装したライブラリです。
  63. %package -n compat32-libnghttp2-devel
  64. Summary: Files needed for building applications with libnghttp2
  65. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  66. Group: Development/Libraries
  67. Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
  68. Requires: pkgconfig
  69. %description -n compat32-libnghttp2-devel
  70. The libnghttp2-devel package includes libraries and header files needed
  71. for building applications with libnghttp2.
  72. %description -l ja -n compat32-libnghttp2-devel
  73.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  74. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  75. す。
  76. %prep
  77. %setup -q
  78. %build
  79. LIBEV_CFLAGS=`pkg-config --cflags libev`
  80. CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  81. CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  82. %configure \
  83. --enable-app \
  84. --enable-asio-lib \
  85. --with-pic \
  86. --with-boost \
  87. --with-boost-asio \
  88. --with-boost-system \
  89. --with-boost-thread \
  90. --disable-python-bindings \
  91. --disable-static \
  92. --without-libxml2 \
  93. --without-spdylay
  94. # avoid using rpath
  95. sed -i libtool \
  96. -e 's/^runpath_var=.*/runpath_var=/' \
  97. -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
  98. make %{?_smp_mflags} V=1
  99. %install
  100. %make_install
  101. # not needed on Fedora/RHEL
  102. rm -f $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
  103. # will be installed via %%doc
  104. rm -f "$RPM_BUILD_ROOT%{_datadir}/doc/nghttp2/README.rst"
  105. %post -n libnghttp2
  106. /sbin/ldconfig
  107. %postun -n libnghttp2
  108. /sbin/ldconfig
  109. %post -n compat32-libnghttp2
  110. /sbin/ldconfig
  111. %postun -n compat32-libnghttp2
  112. /sbin/ldconfig
  113. %check
  114. %if %{with test}
  115. # test the just built library instead of the system one, without using rpath
  116. export "LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$LD_LIBRARY_PATH"
  117. make %{?_smp_mflags} check
  118. %endif
  119. %files
  120. %{_bindir}/h2load
  121. %{_bindir}/nghttp
  122. %{_bindir}/nghttpd
  123. %{_bindir}/nghttpx
  124. %{_datadir}/nghttp2
  125. %{_mandir}/man1/h2load.1*
  126. %{_mandir}/man1/nghttp.1*
  127. %{_mandir}/man1/nghttpd.1*
  128. %{_mandir}/man1/nghttpx.1*
  129. %files -n libnghttp2
  130. %{_libdir}/libnghttp2*.so.*
  131. %{!?_licensedir:%global license %%doc}
  132. %license COPYING
  133. %files -n libnghttp2-devel
  134. %{_includedir}/nghttp2
  135. %{_libdir}/pkgconfig/libnghttp2*.pc
  136. %{_libdir}/libnghttp2*.so
  137. %doc README.rst
  138. %if %{build_compat32}
  139. %files -n compat32-libnghttp2
  140. %{_libdir}/libnghttp2*.so.*
  141. %{!?_licensedir:%global license %%doc}
  142. %license COPYING
  143. %files -n compat32-libnghttp2-devel
  144. %{_includedir}/nghttp2
  145. %{_libdir}/pkgconfig/libnghttp2*.pc
  146. %{_libdir}/libnghttp2*.so
  147. %doc README.rst
  148. %endif
  149. %changelog
  150. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
  151. - added compat32-* packages.
  152. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  153. - new upstream release.
  154. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
  155. - initial build for Vne Linux.
  156. * Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
  157. - update to the latest upstream release
  158. * Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
  159. - update to the latest upstream release
  160. * Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
  161. - update to the latest upstream release
  162. * Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
  163. - update to the latest upstream release
  164. * Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
  165. - update to the latest upstream release
  166. * Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
  167. - update to the latest upstream release
  168. * Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
  169. - update to the latest upstream release (fixes CVE-2016-1544)
  170. * Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
  171. - make the package compile with gcc-6
  172. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  174. * Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
  175. - update to the latest upstream release
  176. * Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
  177. - update to the latest upstream release (fixes CVE-2015-8659)
  178. * Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
  179. - update to the latest upstream release
  180. * Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
  181. - update to the latest upstream release
  182. * Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
  183. - update to the latest upstream release
  184. * Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
  185. - update to the latest upstream release
  186. * Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
  187. - update to the latest upstream release
  188. * Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
  189. - update to the latest upstream release
  190. * Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
  191. - update to the latest upstream release
  192. * Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
  193. - update to the latest upstream release
  194. * Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
  195. - update to the latest upstream release
  196. * Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
  197. - update to the latest upstream release
  198. * Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
  199. - packaged for Fedora (#1237247)