curl-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.49.1
  6. Release: 2%{?_dist_release}
  7. License: MIT
  8. Group: Applications/Internet
  9. URL: http://curl.haxx.se/
  10. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
  11. # patch making libcurl multilib ready
  12. Patch101: 0101-curl-7.32.0-multilib.patch
  13. # prevent configure script from discarding -g in CFLAGS (#496778)
  14. Patch102: 0102-curl-7.36.0-debug.patch
  15. # use localhost6 instead of ip6-localhost in the curl test-suite
  16. Patch104: 0104-curl-7.19.7-localhost6.patch
  17. # work around valgrind bug (#678518)
  18. Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: libnghttp2-devel
  21. BuildRequires: openssl-devel libidn-devel zlib-devel
  22. BuildRequires: openldap-devel gnutls-devel
  23. BuildRequires: openssh-server
  24. BuildRequires: openssh-clients
  25. BuildRequires: pkgconfig
  26. %if "%{?_dist_release}" != "vl6"
  27. BuildRequires: libssh2-devel
  28. %endif
  29. Requires: ca-certificates
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: daisuke
  33. %description
  34. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  35. Dict servers, using any of the supported protocols. cURL is designed
  36. to work without user interaction or any kind of interactivity. cURL
  37. offers many useful capabilities, like proxy support, user
  38. authentication, FTP upload, HTTP post, and file transfer resume.
  39. %package devel
  40. Summary: Files needed for building applications with libcurl.
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: openssl-devel libidn-devel zlib-devel
  44. %description devel
  45. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  46. Dict servers, using any of the supported protocols. The curl-devel
  47. package includes files needed for developing applications which can
  48. use cURL's capabilities internally.
  49. #'
  50. ## to build compat32 for x86_64 architecture support
  51. %package -n compat32-%{name}
  52. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  53. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  54. Group: System Environment/Libraries
  55. %description -n compat32-%{name}
  56. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  57. Dict servers, using any of the supported protocols. cURL is designed
  58. to work without user interaction or any kind of interactivity. cURL
  59. offers many useful capabilities, like proxy support, user
  60. authentication, FTP upload, HTTP post, and file transfer resume.
  61. %package -n compat32-%{name}-devel
  62. Summary: Files needed for building applications with libcurl.
  63. Group: Development/Libraries
  64. %description -n compat32-%{name}-devel
  65. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  66. Dict servers, using any of the supported protocols. The curl-devel
  67. package includes files needed for developing applications which can
  68. use cURL's capabilities internally.
  69. #'
  70. %prep
  71. %setup -q
  72. # Fedora patches
  73. %patch101 -p1
  74. %patch102 -p1
  75. %patch104 -p1
  76. %patch107 -p1
  77. %build
  78. %configure \
  79. --with-ssl=%{_prefix} \
  80. --with-gnutls \
  81. --with-libidn \
  82. --with-nghttp2 \
  83. --enable-ipv6 \
  84. --enable-threaded-resolver \
  85. --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  86. %if "%{?_dist_release}" != "vl6"
  87. --with-libssh2 \
  88. %endif
  89. --enable-ldaps \
  90. --disable-static \
  91. --enable-hidden-symbols
  92. make %{?_smp_mflags}
  93. %install
  94. rm -rf $RPM_BUILD_ROOT
  95. make DESTDIR=$RPM_BUILD_ROOT install
  96. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  97. %clean
  98. rm -rf $RPM_BUILD_ROOT
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %files
  102. %defattr(-,root,root)
  103. %license COPYING
  104. %doc CHANGES README
  105. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  106. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  107. %doc docs/TheArtOfHttpScripting docs/TODO
  108. %{_bindir}/curl
  109. #{_datadir}/curl/*
  110. %{_libdir}/*.so.*
  111. %{_mandir}/man1/*.1*
  112. %files devel
  113. %defattr(-,root,root)
  114. %{_bindir}/curl-config
  115. %{_includedir}/curl
  116. %{_libdir}/*.so
  117. %{_libdir}/pkgconfig/*.pc
  118. %{_mandir}/man1/curl-config.1*
  119. %{_mandir}/man3/*
  120. %{_datadir}/aclocal/libcurl.m4
  121. ## to build compat32 for x86_64 architecture support
  122. %if %{build_compat32}
  123. %files -n compat32-%{name}
  124. %defattr(-,root,root)
  125. %{_libdir}/*.so.*
  126. %files -n compat32-%{name}-devel
  127. %defattr(-,root,root)
  128. %{_libdir}/*.so
  129. %{_libdir}/pkgconfig/*.pc
  130. %endif
  131. %changelog
  132. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  133. - added HTTP/2 support.
  134. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  135. - new upstream release with security fix.
  136. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  137. - new upstream release.
  138. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  139. - new upstream release
  140. - built with openssl 1.0.2g
  141. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  142. - new upstream release with security fix .
  143. - removed Patch108 (fixed in upstream).
  144. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  145. - new upstream release with security fix
  146. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  147. - new upstream release
  148. - add libcurl.m4 to -devel package
  149. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  150. - new upstream release
  151. - import upstream/fedora patches
  152. - disable libssh2 on Vine Linux 6
  153. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  154. - new upstream reelase
  155. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  156. - update to 7.28.0
  157. - add configure options
  158. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  159. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  160. - use ca-certificates package
  161. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  162. - R: ca-certificates
  163. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  164. - new upstream release
  165. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  166. - add patch100 for fix CVE-2011-2192 (gssapi)
  167. - add Vendor/Distri tags
  168. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  169. - rebuild with openssl-1.0.0c
  170. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  171. - rebuilt with rpm-4.8.1 for pkg-config
  172. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  173. - new upstream release
  174. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  175. - new upstream release with security fix
  176. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  177. - added compat32 subpackages
  178. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  179. - new upstream release
  180. - use "_smp_mflags" flag
  181. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  182. - rebuild with openldap-2.4.11
  183. - add BR: openldap-devel
  184. - remove static library
  185. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  186. - new upstream release with security fix (CVE-2009-0037)
  187. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  188. - new upstream release
  189. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  190. - new upstream release
  191. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  192. - new upstream release
  193. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  194. - new upstream release
  195. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  196. - new upstream release
  197. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  198. - rebuilt with openssl-0.9.8e
  199. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  200. - new upstream release
  201. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  202. - new upstream release
  203. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  204. - new upstream release
  205. - add pkgconfig file to devel package
  206. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  207. - new upstream release
  208. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  209. - new upstream release
  210. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  211. - new upstream release
  212. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  213. - added libidn, zlib in Requires
  214. - added libidn-devel, zlib-devel in BuildPrereq
  215. - added zlib-devel in curl-devel's Requires
  216. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  217. - added openssl-devel, libidn-devel in curl-devel's Requires
  218. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  219. - new upstream release
  220. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  221. - new upstream release
  222. - rebuild with openssl-0.9.7d
  223. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  224. - upstream release
  225. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  226. - add %%{_datadir}/curl/* to %%files section
  227. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  228. - source upgrade
  229. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  230. - source upgrade
  231. - add PreReq: ldconfig
  232. - add %%{_libdir}/*.la to %%files devel section
  233. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  234. - build for VineSeed
  235. - add Requires: openssl
  236. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  237. - automated rebuild
  238. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  239. - 7.9.2
  240. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  241. - include curl-config in curl-devel
  242. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  243. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  244. - added openssl-devel build req
  245. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  246. - built for the distro
  247. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  248. - upgrade to curl-7.7.2.
  249. - enable IPv6.
  250. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  251. - rebuilt against openssl-0.9.6-1
  252. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  253. - fixed mising ldconfigs
  254. - updated to 7.5.2, bug fixes
  255. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  256. - updated to 7.5.1
  257. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  258. - update to 7.4.1 to fix bug #20337, problems with curl -c
  259. - not using patch anymore, it's included in the new source. Keeping
  260. for reference
  261. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  262. - fix bogus req in -devel package
  263. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  264. - devel package needed defattr so that root owns the files
  265. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  266. - update to 7.3
  267. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  268. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  269. - enable SSL support
  270. - fix packager tag
  271. - move buildroot to %%{_tmppath}
  272. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  273. - fixed vendor tag for bug #15028
  274. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  275. - rebuilt
  276. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  277. - workaround alpha build problems with optimizations
  278. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  279. - rebuilt
  280. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  281. - put man pages in correct place
  282. - use %%makeinstall
  283. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  284. - updated to 6.5.2
  285. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  286. - updated sources to 6.2
  287. - gzip man page
  288. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  289. - changed group
  290. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  291. - changelog started
  292. - general cleanups, changed prefix to /usr, added manpage to files section
  293. - including in Powertools