texlive-collection-binextra-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
  3. ## tlpdb2rpmspec collection-binextra
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %bcond_with firstbuild
  8. %define tex_destdir %{_datadir}
  9. %define texmf %{tex_destdir}/texmf
  10. %define texlive_src %{tex_destdir}/texlive-sources
  11. %define build_tex_destdir %{buildroot}%{tex_destdir}
  12. %define build_texmf %{buildroot}%{texmf}
  13. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  14. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  15. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
  16. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  17. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  18. %define vartexfonts %{_var}/lib/texmf/fonts
  19. Summary: TeX Live: TeX auxiliary programs
  20. Summary(ja): TeX Live: TeX auxiliary programs
  21. Name: texlive-collection-binextra
  22. Version: 2011
  23. Release: 1%{?_dist_release}
  24. License: GPL+, LGPLv2+, LPPL, Knuth, Freely redistributable without restriction, Public Domain, Artistic, GPLv3+
  25. Group: Applications/Publishing
  26. URL:http://www.tug.org/texlive/
  27. Requires: texlive = %{version}
  28. Requires: texlive-collection-basic = %{version}
  29. Requires(post): texlive = %{version}
  30. Requires(postun): texlive = %{version}
  31. BuildRequires: texlive-sources = %{version}
  32. BuildArch: noarch
  33. Buildroot: %{_tmppath}/%{name}-%{version}-root
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: munepi
  37. %description
  38. The TeX Live software distribution offers a complete TeX system for a
  39. variety of Unix, Macintosh, Windows and other platforms. It
  40. encompasses programs for editing, typesetting, previewing and printing
  41. of TeX documents in many different languages, and a large collection
  42. of TeX macros and font libraries.
  43. The distribution includes extensive general documentation about TeX,
  44. as well as the documentation for the included software packages.
  45. This package is a collection of TeX auxiliary programs:
  46. Various useful, but non-essential, support programs. Includes
  47. programs and macros for DVI file manipulation, literate
  48. programming, patgen, and the TeX Works Editor.
  49. This package contains the following CTAN packages:
  50. a2ping: Advanced PS, PDF, EPS converter.
  51. asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
  52. bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
  53. bibtexu:
  54. bundledoc: Bundle together all the files needed to build a LaTeX document.
  55. chktex: Check for errors in LaTeX documents.
  56. ctie: C version of tie (merging Web change files).
  57. cweb: A Web system in C.
  58. de-macro: Expand private macros in a document.
  59. detex: Strip TeX from a source file.
  60. dtl: Tools to dis-assemble and re-assemble DVI files.
  61. dvi2tty: Produce ASCII from DVI.
  62. dviasm: A utility for editing DVI files.
  63. dvicopy: Copy DVI files, flattening VFs.
  64. dvidvi: Convert one DVI file into another.
  65. dviljk: DVI to Laserjet output.
  66. dvipng: A fast DVI to PNG/GIF converter.
  67. dvipos:
  68. dvisvgm: Converts DVI files to Scalable Vector Graphics format (SVG).
  69. findhyph: Find hyphenated words in a document.
  70. fragmaster: Using psfrag with PDFLaTeX.
  71. hyphenex: Generate a hyphenation exceptions file.
  72. installfont: A bash script for installing a LaTeX font family.
  73. lacheck: LaTeX checker.
  74. latex2man: Translate LaTeX-based manual pages into Unix man format.
  75. latexdiff: Determine and mark up significant differences between latex files.
  76. latexmk: Fully automated LaTeX document generation routine.
  77. listings-ext: Automated input of source.
  78. mkjobtexmf: Generate a texmf tree for a particular job.
  79. patgen:
  80. pdfcrop: Crop PDF graphics.
  81. pdfjam: Shell scripts interfacing to pdfpages.
  82. pdftools: PDF-related utilities, including PostScript-to-PDF conversion
  83. pkfix: Replace pk fonts in PostScript with Type 1 fonts.
  84. pkfix-helper: Make PostScript files accessible to pkfix.
  85. purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
  86. seetexk: Utilities for manipulating DVI files.
  87. sty2dtx: Create a .dtx file from a .sty file.
  88. synctex:
  89. texcount: Count words in a LaTeX document.
  90. texdef: Display the definitions of TeX commands.
  91. texdiff: Compare documents and produce tagged merge.
  92. texdirflatten: Collect files related to a LaTeX job in a single directory.
  93. texdoc: Documentation access for TeX distributions.
  94. texloganalyser: Analyse TeX logs.
  95. texware: Utility programs for use with TeX.
  96. tie: Allow multiple web change files.
  97. tpic2pdftex: Use tpic commands in PDFTeX.
  98. web: original web programs tangle and weave
  99. xindy: A general-purpose index processor.
  100. %description -l ja
  101. TeX Live ソフトウェアディストリビューションは、
  102. さまざまな Unix, Macintosh, Windows、および
  103. 他のプラットホームに対して完全な TeX システムを提供します。
  104. 多くの異なった言語を含む TeX ドキュメントの
  105. 編集、組版、閲覧、印刷するためのプログラム、
  106. そして、TeX マクロやフォントライブラリの大きなコレクションを
  107. 同梱しています。
  108. このディストリビューションは
  109. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  110. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  111. このパッケージは以下のようなパッケージ集です。
  112. TeX auxiliary programs:
  113. Various useful, but non-essential, support programs. Includes
  114. programs and macros for DVI file manipulation, literate
  115. programming, patgen, and the TeX Works Editor.
  116. このパッケージは以下の CTAN パッケージを含んでいます:
  117. a2ping: Advanced PS, PDF, EPS converter.
  118. asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
  119. bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
  120. bibtexu:
  121. bundledoc: Bundle together all the files needed to build a LaTeX document.
  122. chktex: Check for errors in LaTeX documents.
  123. ctie: C version of tie (merging Web change files).
  124. cweb: A Web system in C.
  125. de-macro: Expand private macros in a document.
  126. detex: Strip TeX from a source file.
  127. dtl: Tools to dis-assemble and re-assemble DVI files.
  128. dvi2tty: Produce ASCII from DVI.
  129. dviasm: A utility for editing DVI files.
  130. dvicopy: Copy DVI files, flattening VFs.
  131. dvidvi: Convert one DVI file into another.
  132. dviljk: DVI to Laserjet output.
  133. dvipng: A fast DVI to PNG/GIF converter.
  134. dvipos:
  135. dvisvgm: Converts DVI files to Scalable Vector Graphics format (SVG).
  136. findhyph: Find hyphenated words in a document.
  137. fragmaster: Using psfrag with PDFLaTeX.
  138. hyphenex: Generate a hyphenation exceptions file.
  139. installfont: A bash script for installing a LaTeX font family.
  140. lacheck: LaTeX checker.
  141. latex2man: Translate LaTeX-based manual pages into Unix man format.
  142. latexdiff: Determine and mark up significant differences between latex files.
  143. latexmk: Fully automated LaTeX document generation routine.
  144. listings-ext: Automated input of source.
  145. mkjobtexmf: Generate a texmf tree for a particular job.
  146. patgen:
  147. pdfcrop: Crop PDF graphics.
  148. pdfjam: Shell scripts interfacing to pdfpages.
  149. pdftools: PDF-related utilities, including PostScript-to-PDF conversion
  150. pkfix: Replace pk fonts in PostScript with Type 1 fonts.
  151. pkfix-helper: Make PostScript files accessible to pkfix.
  152. purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
  153. seetexk: Utilities for manipulating DVI files.
  154. sty2dtx: Create a .dtx file from a .sty file.
  155. synctex:
  156. texcount: Count words in a LaTeX document.
  157. texdef: Display the definitions of TeX commands.
  158. texdiff: Compare documents and produce tagged merge.
  159. texdirflatten: Collect files related to a LaTeX job in a single directory.
  160. texdoc: Documentation access for TeX distributions.
  161. texloganalyser: Analyse TeX logs.
  162. texware: Utility programs for use with TeX.
  163. tie: Allow multiple web change files.
  164. tpic2pdftex: Use tpic commands in PDFTeX.
  165. web: original web programs tangle and weave
  166. xindy: A general-purpose index processor.
  167. %package doc
  168. Summary: TeX Live: Documentation files of %{name}
  169. Group: Applications/Publishing
  170. Requires: %{name} = %{version}-%{release}
  171. %description doc
  172. This package contains documentation files of %{name}.
  173. %prep
  174. %build
  175. %install
  176. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  177. PREF=%{buildroot}%{tex_destdir}
  178. manifest=(
  179. texmf-dist/bibtex/csf/base/88591lat.csf
  180. texmf-dist/bibtex/csf/base/88591sca.csf
  181. texmf-dist/bibtex/csf/base/README.TEXLIVE
  182. texmf-dist/bibtex/csf/base/ascii.csf
  183. texmf-dist/bibtex/csf/base/cp437lat.csf
  184. texmf-dist/bibtex/csf/base/cp850lat.csf
  185. texmf-dist/bibtex/csf/base/cp850sca.csf
  186. texmf-dist/bibtex/csf/base/cp866rus.csf
  187. texmf-dist/bibtex/csf/base/csfile.txt
  188. texmf-dist/bibtex/csf/polish-csf/88592pl.csf
  189. texmf-dist/bibtex/csf/polish-csf/cp1250pl.csf
  190. texmf-dist/bibtex/csf/polish-csf/cp852pl.csf
  191. texmf-dist/bibtex/csf/polish-csf/iso8859-7.csf
  192. texmf-dist/doc/support/bundledoc/README
  193. texmf-dist/scripts/bundledoc/arlatex
  194. texmf-dist/scripts/bundledoc/bundledoc
  195. texmf-dist/tex/latex/bundledoc/miktex.cfg
  196. texmf-dist/tex/latex/bundledoc/texlive-unix.cfg
  197. texmf-dist/doc/plain/cweb/cwebman.dvi
  198. texmf-dist/tex/plain/cweb/cwebmac.tex
  199. texmf-dist/tex/plain/cweb/pdfXcwebmac.tex
  200. texmf-dist/tex/plain/cweb/pdfcwebmac.tex
  201. texmf-dist/tex/plain/cweb/pdfdcwebmac.tex
  202. texmf-dist/tex/plain/cweb/pdffcwebmac.tex
  203. texmf-dist/tex/plain/cweb/pdficwebmac.tex
  204. texmf-dist/tex/plain/cweb/pdfwebmac.tex
  205. texmf-dist/doc/support/de-macro/README
  206. texmf-dist/doc/support/de-macro/user-guide.pdf
  207. texmf-dist/doc/support/de-macro/user-guide.tex
  208. texmf-dist/scripts/de-macro/de-macro
  209. texmf-dist/scripts/dviasm/dviasm.py
  210. texmf-dist/doc/support/findhyph/Makefile
  211. texmf-dist/doc/support/findhyph/README
  212. texmf-dist/doc/support/findhyph/findhyph.bat
  213. texmf-dist/doc/support/findhyph/findhyph.txt
  214. texmf-dist/scripts/findhyph/findhyph
  215. texmf-dist/doc/support/fragmaster/AUTHORS
  216. texmf-dist/doc/support/fragmaster/COPYING
  217. texmf-dist/doc/support/fragmaster/CREDITS
  218. texmf-dist/doc/support/fragmaster/Changes
  219. texmf-dist/doc/support/fragmaster/README
  220. texmf-dist/doc/support/fragmaster/README.de
  221. texmf-dist/doc/support/fragmaster/example/document.pdf
  222. texmf-dist/doc/support/fragmaster/example/document.ps
  223. texmf-dist/doc/support/fragmaster/example/document.tex
  224. texmf-dist/doc/support/fragmaster/example/parabel.eps
  225. texmf-dist/doc/support/fragmaster/example/parabel.pdf
  226. texmf-dist/doc/support/fragmaster/example/parabel_fm
  227. texmf-dist/doc/support/fragmaster/example/parabel_fm.eps
  228. texmf-dist/doc/support/fragmaster/example/parabel_fm.gp
  229. texmf-dist/doc/support/fragmaster/example/parabel_fm.pdf
  230. texmf-dist/doc/support/fragmaster/fragmaster.pdf
  231. texmf-dist/scripts/fragmaster/fragmaster.pl
  232. texmf-dist/source/generic/hyphenex/GNUmakefile
  233. texmf-dist/source/generic/hyphenex/README
  234. texmf-dist/source/generic/hyphenex/hyphenex.pl
  235. texmf-dist/source/generic/hyphenex/hyphenex.sh
  236. texmf-dist/source/generic/hyphenex/tb0hyf.pdf
  237. texmf-dist/source/generic/hyphenex/tb0hyf.tex
  238. texmf-dist/source/generic/hyphenex/test.tex
  239. texmf-dist/tex/generic/hyphenex/ushyphex.tex
  240. texmf-dist/doc/support/installfont/LICENSE
  241. texmf-dist/doc/support/installfont/README
  242. texmf-dist/doc/support/installfont/installfont
  243. texmf-dist/doc/support/installfont/installfont.pdf
  244. texmf-dist/doc/support/installfont/installfont.tex
  245. texmf-dist/doc/support/installfont/manifest.txt
  246. texmf-dist/scripts/installfont/installfont-tl
  247. texmf-dist/doc/support/latex2man/CHANGES
  248. texmf-dist/doc/support/latex2man/INSTALL
  249. texmf-dist/doc/support/latex2man/Makefile
  250. texmf-dist/doc/support/latex2man/README
  251. texmf-dist/doc/support/latex2man/THIS-IS-VERSION-1.24
  252. texmf-dist/doc/support/latex2man/latex2man-CHANGES.html
  253. texmf-dist/doc/support/latex2man/latex2man.1
  254. texmf-dist/doc/support/latex2man/latex2man.css
  255. texmf-dist/doc/support/latex2man/latex2man.html
  256. texmf-dist/doc/support/latex2man/latex2man.pdf
  257. texmf-dist/doc/support/latex2man/latex2man.tex
  258. texmf-dist/doc/support/latex2man/latex2man.texi
  259. texmf-dist/doc/support/latex2man/latex2man.trans
  260. texmf-dist/doc/support/latex2man/latex2man.txt
  261. texmf-dist/scripts/latex2man/latex2man
  262. texmf-dist/tex/latex/latex2man/latex2man.cfg
  263. texmf-dist/tex/latex/latex2man/latex2man.sty
  264. texmf-dist/doc/latex/latexdiff/CHANGES
  265. texmf-dist/doc/latex/latexdiff/LICENSE
  266. texmf-dist/doc/latex/latexdiff/Makefile
  267. texmf-dist/doc/latex/latexdiff/README
  268. texmf-dist/doc/latex/latexdiff/contrib/latexdiff-wrap
  269. texmf-dist/doc/latex/latexdiff/contrib/latexdiff.spec
  270. texmf-dist/doc/latex/latexdiff/example/example-draft.tex
  271. texmf-dist/doc/latex/latexdiff/example/example-rev.tex
  272. texmf-dist/doc/latex/latexdiff/latexdiff
  273. texmf-dist/doc/latex/latexdiff/latexdiff-fast
  274. texmf-dist/doc/latex/latexdiff/latexdiff-man.pdf
  275. texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  276. texmf-dist/scripts/latexdiff/latexdiff.pl
  277. texmf-dist/scripts/latexdiff/latexrevise.pl
  278. texmf-dist/doc/support/latexmk/CHANGES
  279. texmf-dist/doc/support/latexmk/COPYING
  280. texmf-dist/doc/support/latexmk/INSTALL
  281. texmf-dist/doc/support/latexmk/README
  282. texmf-dist/doc/support/latexmk/example_rcfiles/README
  283. texmf-dist/doc/support/latexmk/example_rcfiles/asymptote_latexmkrc
  284. texmf-dist/doc/support/latexmk/example_rcfiles/glossary_latexmkrc
  285. texmf-dist/doc/support/latexmk/example_rcfiles/pdflatexmkrc
  286. texmf-dist/doc/support/latexmk/example_rcfiles/sagetex_latexmkrc
  287. texmf-dist/doc/support/latexmk/extra-scripts/README1
  288. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call
  289. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call.bat
  290. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call
  291. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call.bat
  292. texmf-dist/doc/support/latexmk/extra-scripts/kickxdvi
  293. texmf-dist/doc/support/latexmk/extra-scripts/l1
  294. texmf-dist/doc/support/latexmk/extra-scripts/l2
  295. texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk
  296. texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk_README.txt
  297. texmf-dist/doc/support/latexmk/extra-scripts/startacroread
  298. texmf-dist/doc/support/latexmk/latexmk.bat
  299. texmf-dist/doc/support/latexmk/latexmk.pdf
  300. texmf-dist/doc/support/latexmk/latexmk.txt
  301. texmf-dist/scripts/latexmk/latexmk.pl
  302. texmf-dist/doc/latex/listings-ext/README
  303. texmf-dist/doc/latex/listings-ext/THIS_IS_VERSION_v67
  304. texmf-dist/doc/latex/listings-ext/getversion.tex
  305. texmf-dist/doc/latex/listings-ext/hyperref.cfg
  306. texmf-dist/doc/latex/listings-ext/listings-ext.bib
  307. texmf-dist/doc/latex/listings-ext/listings-ext.el
  308. texmf-dist/doc/latex/listings-ext/listings-ext.makemake
  309. texmf-dist/doc/latex/listings-ext/listings-ext.mk
  310. texmf-dist/doc/latex/listings-ext/listings-ext.pdf
  311. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_a.java
  312. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_b.java
  313. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_c.java
  314. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_d.java
  315. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_e.java
  316. texmf-dist/doc/latex/listings-ext/listings-ext_test_a.tex
  317. texmf-dist/doc/latex/listings-ext/listings-ext_test_d.tex
  318. texmf-dist/doc/latex/listings-ext/listings.cfg
  319. texmf-dist/source/latex/listings-ext/listings-ext.dtx
  320. texmf-dist/source/latex/listings-ext/listings-ext.ins
  321. texmf-dist/scripts/listings-ext/listings-ext.sh
  322. texmf-dist/tex/latex/listings-ext/listings-ext.sty
  323. texmf-dist/doc/generic/mkjobtexmf/README
  324. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.html
  325. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.ltx
  326. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.pdf
  327. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.txt
  328. texmf-dist/source/generic/mkjobtexmf/Makefile.in
  329. texmf-dist/source/generic/mkjobtexmf/configure
  330. texmf-dist/source/generic/mkjobtexmf/configure.ac
  331. texmf-dist/source/generic/mkjobtexmf/install-sh
  332. texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  333. texmf-dist/doc/support/pdfcrop/README
  334. texmf-dist/scripts/pdfcrop/pdfcrop.pl
  335. texmf-dist/doc/support/pdfjam/COPYING
  336. texmf-dist/doc/support/pdfjam/PDFjam-README.html
  337. texmf-dist/doc/support/pdfjam/VERSION
  338. texmf-dist/doc/support/pdfjam/pdfdroplets.png
  339. texmf-dist/doc/support/pdfjam/pdfjam.conf
  340. texmf-dist/doc/support/pdfjam/tests.zip
  341. texmf-dist/scripts/pdfjam/pdf180
  342. texmf-dist/scripts/pdfjam/pdf270
  343. texmf-dist/scripts/pdfjam/pdf90
  344. texmf-dist/scripts/pdfjam/pdfbook
  345. texmf-dist/scripts/pdfjam/pdfflip
  346. texmf-dist/scripts/pdfjam/pdfjam
  347. texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  348. texmf-dist/scripts/pdfjam/pdfjam-slides3up
  349. texmf-dist/scripts/pdfjam/pdfjam-slides6up
  350. texmf-dist/scripts/pdfjam/pdfjoin
  351. texmf-dist/scripts/pdfjam/pdfnup
  352. texmf-dist/scripts/pdfjam/pdfpun
  353. texmf-dist/doc/support/pkfix/README
  354. texmf-dist/scripts/pkfix/pkfix.pl
  355. texmf-dist/doc/support/pkfix-helper/README
  356. texmf-dist/doc/support/pkfix-helper/encoding-samples.pdf
  357. texmf-dist/doc/support/pkfix-helper/encoding-samples.tex
  358. texmf-dist/scripts/pkfix-helper/pkfix-helper
  359. texmf-dist/doc/support/purifyeps/README
  360. texmf-dist/scripts/purifyeps/purifyeps
  361. texmf-dist/doc/support/sty2dtx/README
  362. texmf-dist/scripts/sty2dtx/sty2dtx.pl
  363. texmf-dist/doc/support/texcount/QuickReference.pdf
  364. texmf-dist/doc/support/texcount/QuickReference.tex
  365. texmf-dist/doc/support/texcount/README
  366. texmf-dist/doc/support/texcount/TeXcount.pdf
  367. texmf-dist/doc/support/texcount/TeXcount.tex
  368. texmf-dist/doc/support/texcount/macros.tex
  369. texmf-dist/scripts/texcount/texcount.pl
  370. texmf-dist/doc/support/texdef/INSTALL
  371. texmf-dist/doc/support/texdef/README
  372. texmf-dist/scripts/texdef/texdef.pl
  373. texmf-dist/doc/support/texdiff/README
  374. texmf-dist/scripts/texdiff/texdiff
  375. texmf-dist/scripts/texdirflatten/texdirflatten
  376. texmf-dist/texdoc/texdoc.cnf
  377. texmf-dist/doc/support/texloganalyser/README
  378. texmf-dist/scripts/texloganalyser/texloganalyser
  379. )
  380. %__mkdir_p ${PREF}/texmf-dist
  381. for i in "${manifest[@]}"; do
  382. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  383. done
  384. ## make symlinks of core script utils
  385. mk_symlinks=(
  386. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  387. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  388. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  389. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  390. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  391. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  392. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  393. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  394. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  395. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  396. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  397. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  398. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  399. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  400. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  401. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  402. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  403. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  404. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  405. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  406. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  407. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  408. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  409. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  410. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  411. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  412. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  413. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  414. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  415. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  416. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  417. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  418. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  419. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  420. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  421. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  422. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  423. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  424. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  425. texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
  426. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  427. texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
  428. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  429. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  430. texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
  431. texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
  432. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  433. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  434. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  435. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  436. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  437. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  438. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  439. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  440. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  441. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  442. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  443. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  444. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  445. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  446. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  447. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  448. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  449. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  450. texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
  451. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  452. texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
  453. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  454. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  455. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  456. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  457. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  458. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  459. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  460. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  461. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  462. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  463. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  464. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  465. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  466. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  467. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  468. )
  469. %__mkdir_p %{buildroot}%{_bindir}
  470. pushd %{buildroot}%{_bindir}
  471. for i in "${mk_symlinks[@]}"; do
  472. tlc=$(echo $i | cut -f 1 -d",")
  473. lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  474. rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  475. [ "%{name}" = "$tlc" ] || continue
  476. [ -f $rlnk ] || exit 1
  477. %__ln_s $rlnk $lnk || exit 1
  478. done
  479. popd
  480. ## Files list
  481. find %{buildroot} -type f -or -type l | \
  482. %__sed -e "s|%{buildroot}||g" > filelist.full
  483. find %{buildroot}%{texmf}-dist -type d | \
  484. %__sed -e "s|^%{buildroot}|%dir |" \
  485. -e "s|$|/|" >> filelist.full
  486. ## subpackages
  487. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  488. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  489. %__mv -f filelist.tmp filelist.full
  490. %clean
  491. %__rm -rf %{buildroot}
  492. %post
  493. %{exec_texhash}
  494. exit 0
  495. %postun
  496. if [ "$1" = 0 ]; then
  497. %{exec_texhash}
  498. fi
  499. exit 0
  500. %files -f filelist.full
  501. %defattr(-,root,root,-)
  502. %files -f filelist.doc doc
  503. %defattr(-,root,root,-)
  504. %changelog
  505. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  506. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-binextra
  507. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  508. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-binextra
  509. - make symlinks of core script utils (texlive-collection-binextra,
  510. texlive-collection-context, texlive-collection-fontutils,
  511. texlive-collection-langgreek, texlive-collection-langindic,
  512. texlive-collection-latex, texlive-collection-latexextra,
  513. texlive-collection-latexrecommended, texlive-collection-pictures,
  514. texlive-collection-pstricks, texlive-collection-science)
  515. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  516. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-binextra
  517. - improved %%post
  518. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  519. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-binextra
  520. - removed arch dependent binaries (texlive-collection-latexextra)
  521. - fixed perl path
  522. - improved updmap process in %%post and %%postun
  523. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  524. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-binextra