gwenhywfar-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. %bcond_with qt5
  2. Summary: A multi-platform helper library for other libraries
  3. Name: gwenhywfar
  4. Version: 5.7.3
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: LGPLv2+
  10. URL: https://www.aquamaniac.de/sites/aqbanking/index.php
  11. Source0: https://github.com/aqbanking/gwenhywfar/archive/refs/tags/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: openssl-devel
  14. BuildRequires: gnutls-devel
  15. BuildRequires: libgcrypt-devel
  16. BuildRequires: gettext
  17. %if %{with qt5}
  18. Requires: %{name}-gui-qt5 = %{version}-%{release}
  19. %else
  20. Obsoletes: %{name}-gui-qt5 < 5.7.3
  21. %endif
  22. %description
  23. This is Gwenhywfar, a multi-platform helper library for networking and
  24. security applications and libraries. It is heavily used by libchipcard
  25. and AqBanking/AqHBCI, the German online banking libraries.
  26. %package devel
  27. Summary: Gwenhywfar development kit
  28. Group: programming
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: %{name}-gui-cpp = %{version}-%{release}
  31. Requires: %{name}-gui-gtk3 = %{version}-%{release}
  32. %if %{with qt5}
  33. Requires: %{name}-gui-qt5 = %{version}-%{release}
  34. %endif
  35. Requires: pkgconfig
  36. %description devel
  37. This package contains gwenhywfar-config and header files for writing and
  38. compiling programs using Gwenhywfar.
  39. %package gui-cpp
  40. Summary: Gwenhywfar GUI framework for cpp
  41. Group: system
  42. Requires: %{name} = %{version}-%{release}
  43. %description gui-cpp
  44. This package contains the cpp gwenhywfar GUI backend.
  45. %package gui-gtk3
  46. Summary: Gwenhywfar GUI framework for GTK3
  47. Group: system
  48. BuildRequires: gtk3-devel
  49. Requires: %{name} = %{version}-%{release}
  50. Obsoletes: %{name}-gui-gtk2 < 5.7.0
  51. %description gui-gtk3
  52. This package contains the gtk3 gwenhywfar GUI backend.
  53. %if %{with qt5}
  54. %package gui-qt5
  55. Summary: Gwenhywfar GUI framework for Qt5
  56. Group: system
  57. BuildRequires: qt5-rpm-macros
  58. BuildRequires: qt5-qtbase-devel
  59. BuildRequires: qt5-linguist
  60. Requires: %{name} = %{version}-%{release}
  61. Obsoletes: %{name}-gui-qt4 < 5.7.0
  62. %description gui-qt5
  63. This package contains the qt5 gwenhywfar GUI backend.
  64. %endif
  65. %debug_package
  66. %prep
  67. %setup -q
  68. autoreconf -iv
  69. %build
  70. # help configure find qt5 lrelease/lupdate
  71. export PATH=$PATH:%{_qt5_bindir}
  72. %configure \
  73. --disable-static \
  74. --enable-system-certs \
  75. --with-guis="gtk3" \
  76. %if %{with qt5}
  77. --with-qt5-qmake=%{_bindir}/qmake-qt5 \
  78. --with-qt5-moc=%{_bindir}/moc-qt5 \
  79. --with-qt5-uic=%{_bindir}/uic-qt5 \
  80. %endif
  81. %{nil}
  82. # kill rpath
  83. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  84. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  85. make %{?_smp_mflags}
  86. %install
  87. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  88. make DESTDIR=$RPM_BUILD_ROOT install
  89. # use system ca-certificates
  90. rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
  91. ln -sf %{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  92. $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
  93. find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
  94. %find_lang %{name}
  95. %clean
  96. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  97. %files -f %{name}.lang
  98. %defattr(-,root,root)
  99. %license COPYING
  100. %doc AUTHORS README ChangeLog
  101. %{_bindir}/gct-tool
  102. %{_libdir}/libgwenhywfar.so.*
  103. %{_libdir}/%{name}
  104. %dir %{_datadir}/%{name}
  105. %{_datadir}/%{name}/dialogs
  106. %{_datadir}/%{name}/ca-bundle.crt
  107. %files devel
  108. %defattr(-,root,root)
  109. %exclude %{_bindir}/gct-tool
  110. %{_bindir}/*
  111. %{_includedir}/gwenhywfar*
  112. %{_libdir}/*.so
  113. %{_libdir}/pkgconfig/*.pc
  114. %{_libdir}/cmake/*
  115. %{_datadir}/aclocal/gwenhywfar.m4
  116. %{_datadir}/gwenbuild
  117. %{_datadir}/%{name}/gwenbuild
  118. %{_datadir}/%{name}/typemaker*
  119. %files gui-cpp
  120. %defattr(-,root,root)
  121. %{_libdir}/libgwengui-cpp.so.*
  122. %files gui-gtk3
  123. %defattr(-,root,root)
  124. %{_libdir}/libgwengui-gtk3.so.*
  125. %if %{with qt5}
  126. %files gui-qt5
  127. %defattr(-,root,root)
  128. %{_libdir}/libgwengui-qt5.so.*
  129. %endif
  130. %changelog
  131. * Sat Oct 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.7.3-1
  132. - new upstream release.
  133. - built with openssl-3.0.0.
  134. - dropped ldconfig scriptlets.
  135. - disabled qt5 as default.
  136. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.6.0-1
  137. - new upstream release.
  138. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20.2-1
  139. - new upstream release.
  140. - switched guis to gtk3 and qt5.
  141. - added a subpackage "gui-cpp".
  142. * Sat Dec 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.3-2
  143. - rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
  144. * Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.3-1
  145. - new upstream release
  146. - add BuildRequires: gtk2-devel, qt4-devel
  147. - create gui-gtk2, gui-qt4 subpackages (based on Fedora)
  148. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.3-3
  149. - rebuilt with openssl-1.0.0d
  150. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.3-2
  151. - rebuilt with rpm-4.8.1 for pkg-config
  152. * Sat Feb 13 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.11.3-1
  153. - new upstream release
  154. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0-1
  155. - new upstream release
  156. - built with gnutls-2.6.3
  157. * Sat Sep 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.1-1
  158. - new upstream release
  159. - applied new versioning policy
  160. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.2-0vl1
  161. - new upstream release
  162. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.1-2vl1
  163. - initial build for VineSeed
  164. * Wed Oct 10 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-2
  165. - fix build, rebuild for buildid
  166. * Fri Aug 3 2007 Bill Nottingham <notting@redhat.com>
  167. - tweak license tag
  168. * Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-1
  169. - update to 2.6.1
  170. * Mon Jun 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.0-1
  171. - update to 2.6.0
  172. * Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.5.4-1
  173. - update to 2.5.4
  174. * Thu Feb 22 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-7
  175. - build for Extras
  176. * Wed Jan 10 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-6
  177. - make gwen-public-ca.crt %%config(noreplace)
  178. * Tue Jan 9 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-5
  179. - spec tweaks
  180. * Thu Sep 7 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-4
  181. - rebuild for fixed debuginfo (#205501)
  182. * Tue Sep 5 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-3
  183. - fix multilib conflicts (#205213)
  184. * Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-2
  185. - rather than modifying the m4 file, make gwenhywfar-config use pkgconfig
  186. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.0-1.1
  187. - rebuild
  188. * Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-1
  189. - update to 2.3.0
  190. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.2
  191. - bump again for double-long bug on ppc(64)
  192. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.1
  193. - rebuilt for new gcc4.1 snapshot and glibc changes
  194. * Thu Dec 22 2005 Bill Nottingham <notting@redhat.com> 1.99.2-1
  195. - update to 1.99.2
  196. - use the pkgconfig file, not gwenhywfar-config
  197. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  198. - rebuilt
  199. * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> 1.7.2-3
  200. - rebuilt against new openssl
  201. * Wed Mar 2 2005 Bill Nottingham <notting@redhat.com> 1.7.2-2
  202. - rebuild against new openssl
  203. * Wed Feb 9 2005 Bill Nottingham <notting@redhat.com> 1.7.2-1
  204. - initial packaging, adopt upstream package