xorg-x11-drv-intel-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate 20100625
  4. Summary: Xorg X11 Intel video driver
  5. Summary(ja): Xorg X11 Intel ビデオドライバ
  6. Name: xorg-x11-drv-intel
  7. Epoch: 1
  8. Version: 2.15.0
  9. Release: 3%{?_dist_release}
  10. URL: http://intellinuxgraphics.org/
  11. License: MIT
  12. Group: User Interface/X Hardware Support
  13. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  14. Source2: intel.xinf
  15. Source3: intel-gpu-tools-%{gputoolsdate}.tar.bz2
  16. # patches from upstream git
  17. # http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
  18. Patch1: xf86-video-intel-2.15.0-git9d6e02.patch
  19. # import from ubuntu/debian package
  20. Patch101: intel-2.15.0-copy-fb.patch
  21. # vine patch
  22. # disable DRI on SandyBridge/IvyBridge for now.
  23. Patch200: intel-2.15.0-sandybridge-disable-dri.patch
  24. ExclusiveArch: %{ix86} x86_64 ia64
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. BuildRequires: autoconf, automake, libtool
  27. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  28. BuildRequires: libXvMC-devel
  29. BuildRequires: libGL-devel >= 7.10
  30. BuildRequires: libdrm-devel >= 2.4.25
  31. BuildRequires: kernel-headers >= 2.6.33
  32. BuildRequires: libudev-devel
  33. BuildRequires: libxcb-devel >= 1.5
  34. BuildRequires: xcb-util-devel
  35. Requires: hwdata
  36. Requires: xorg-x11-server-Xorg
  37. Requires: xcb-util
  38. Obsoletes: xorg-x11-drv-i810
  39. Provides: xorg-x11-drv-i810
  40. #Conflicts: kudzu < 1.2.42-1
  41. %description
  42. X.Org X11 Intel video driver.
  43. %package devel
  44. Summary: Xorg X11 Intel video driver XvMC development package
  45. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  46. Group: Development/System
  47. Requires: %{name} = %{epoch}:%{version}-%{release}
  48. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  49. %description devel
  50. X.Org X11 Intel video driver XvMC development package.
  51. %package -n intel-gpu-tools
  52. Summary: Debugging tools for Intel graphics chips
  53. Group: Development/Tools
  54. %description -n intel-gpu-tools
  55. Debugging tools for Intel graphics chips
  56. %prep
  57. %setup -q -n xf86-video-intel-%{version} -b3
  58. %patch1 -p1 -b .git9d6e02
  59. #%patch101 -p1 -b .copy-fb
  60. %patch200 -p1 -b .disable-dri
  61. %build
  62. autoreconf -vi
  63. %configure \
  64. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  65. --enable-dri --enable-xvmc
  66. make
  67. pushd ../intel-gpu-tools-%{gputoolsdate}
  68. autoreconf -v --install
  69. %configure
  70. make
  71. popd
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  76. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  77. pushd ../intel-gpu-tools-%{gputoolsdate}
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. popd
  80. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %triggerpostun -- XOrg < 7.0
  84. if (grep -q i810 /etc/X11/xorg.conf)
  85. then
  86. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  87. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  88. fi ||:
  89. %files
  90. %defattr(-,root,root,-)
  91. %{driverdir}/intel_drv.so
  92. %{_datadir}/hwdata/videoaliases/intel.xinf
  93. %{_libdir}/libI810XvMC.so.*
  94. %{_libdir}/libIntelXvMC.so.*
  95. %{_mandir}/man4/i*
  96. %files devel
  97. %defattr(-,root,root,-)
  98. %{_libdir}/libI810XvMC.so
  99. %{_libdir}/libIntelXvMC.so
  100. %files -n intel-gpu-tools
  101. %defattr(-,root,root,-)
  102. %{_bindir}/intel_*
  103. %{_mandir}/man1/intel_*.1*
  104. %changelog
  105. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  106. - drop patch1-3 and replaced with new patch1 from git master
  107. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  108. - update intel-gpu-tools
  109. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  110. - add Patch1-3 from upstream
  111. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  112. - new upstream release
  113. - drop upstream patches: 107-115
  114. - temporary disabled patch101
  115. - BR: libdrm >= 2.4.25
  116. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  117. - add Patch101-115 from ubuntu/debian package
  118. - Patch101: Plymouth integration patch
  119. - Patch107: Check null return from uxa_acquire_solid()
  120. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  121. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  122. - Patch110,114: Cherry picks to fix a large number of build warnings.
  123. - Patch111: Fix clipped window plane offset
  124. - Patch112: Fix issue where vertical green line and strange colors
  125. shows up when playing gstreamer with certain videos,
  126. when dragged. (LP 460677)
  127. - Patch113: Fixes GPU lockup during login with
  128. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  129. error messages listed in the gpu dump text. (LP 710321)
  130. - Patch115: Don't fill up Xorg.0.log with
  131. "get vblank counter failed: Invalid argument" warnings.
  132. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  133. - rebuild with xserver-1.10.0
  134. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  135. - new upstream release
  136. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  137. - new upstream release
  138. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  139. - rebuild with xserver-1.9.2
  140. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  141. - new upstream release
  142. - add Patch40: fix uxa planemask (backported)
  143. - add Patch61: add support for backlight on macbooks
  144. - add Patch62: disable page flipping for stability
  145. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  146. - new upstream release
  147. - drop patch70
  148. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  149. - rebuild again with xserver-1.8rc
  150. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  151. - add intel-gpu-tools as sub-package
  152. - rebuild with libdrm-2.4.18
  153. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  154. - new upstream release
  155. - import Patch1,2,60,70 from fedora
  156. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  157. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  158. - add BR; libudev-devel and autoreconf for Patch60
  159. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  160. - rebuild with libdrm-2.4.17
  161. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  162. - new upstream release
  163. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  164. - new upstream release (hopefully fixes severe issues w/ efifb)
  165. - drop all patches already upstreamed; import Patch20/21 from Fedora
  166. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  167. - import Patch121,122 from ubuntu
  168. - build with libdrm-2.4.12 which fixes vt switch crash
  169. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  170. - apply patch114 to fix Xv with non-GEM kernel
  171. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  172. - update to 2.6.3
  173. - add patch106,107,115,118,119,120 from ubuntu
  174. - add Patch106: remove triple buffering
  175. - add Patch107: remove page flipping
  176. - add Patch115: fix crash Xv overlay
  177. - add Patch118: drop legacy3d
  178. - add Patch119: fix crashes in drm bo
  179. - add Patch120: fix vt switch
  180. - add patch130-134 from upstream git
  181. - add Patch130: fix another vt switch leak
  182. - add Patch131: Create known output configuration at EnterVT time
  183. - add Patch132: fix leak of some 965 render state on VT switch
  184. - add Patch133: fix crash with fake bufmgr and UXA
  185. - add Patch134: fix EnterVT/LeaveVT
  186. - add Patch135: add new chip supoprt
  187. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  188. - revert to 2.6.1, add Epoch
  189. - add Patch103-121 from ubuntu
  190. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  191. - new upstream release
  192. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  193. - new upstream release
  194. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  195. - new upstream release
  196. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  197. - add Patch5 - Dont die on irq handler failure
  198. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  199. - new upstream release
  200. - add BR: libdrm-devel >= 2.4.0-3
  201. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  202. - import Patch10,11,12 from ubuntu
  203. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  204. - new upstream release
  205. - add triggerpostun script to replace i810 driver to intel driver
  206. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  207. - new upstream release
  208. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  209. - new upstream release
  210. - rename i810.xinf to intel.xinf
  211. - update intel.xinf (add Intel 4 series)
  212. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  213. - rebuild with new xserver
  214. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  215. - new upstream release
  216. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  217. - new upstream release
  218. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  219. - new upstream release
  220. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  221. - initial build for Vine Linux
  222. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  223. - Rebuild for new server ABI.
  224. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  225. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  226. - hook up ch7017 (bz#408471)
  227. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  228. - xf86-video-intel 2.2.0
  229. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  230. - xf86-video-intel 2.1.99.
  231. - Drop the i810 driver. Time to move on.
  232. - Require xserver 1.4.99.1
  233. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  234. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  235. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  236. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  237. for textured Xv to use as an offscreen pixmap so xv actually works under
  238. compiz - granted it may be unusably slow but at least stuff shows up.
  239. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  240. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  241. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  242. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  243. - intel-2.1.1-quirk-update.patch - update quirks from master
  244. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  245. - i810.xinf: Flip everything over to -intel by default now. Still install
  246. i810 driver just in case.
  247. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  248. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  249. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  250. - xf86-video-intel 2.1.1.
  251. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  252. - xf86-video-intel 2.1.0.
  253. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  254. - Update Requires and BuildRequires.
  255. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  256. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  257. 965GME, G33, Q33, and Q35 chips.
  258. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  259. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  260. DRI clients are active, for better battery life.
  261. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  262. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  263. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  264. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  265. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  266. rename this at some point.
  267. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  268. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  269. 915GM.
  270. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  271. - i810.xinf: More intel whitelisting (#214011, #234877)
  272. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  273. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  274. - i810.xinf: Point 965GM support at the intel driver since it's not present
  275. in old i810.
  276. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  277. - xf86-video-intel-1.9.93 (RC3).
  278. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  279. - fix typo with 945GM pci id from my laptop
  280. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  281. - xf86-video-intel 1.9.92 (RC2).
  282. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  283. - Updated modesetting driver to one that will actually work with a 1.3 server.
  284. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  285. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  286. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  287. code anywhere
  288. - Disown the module
  289. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  290. - update modesetting driver to git snapshot from today
  291. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  292. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  293. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  294. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  295. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  296. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  297. actually require kudzu to run.
  298. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  299. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  300. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  301. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  302. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  303. driver match the corresponding terrible heuristic in the server.
  304. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  305. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  306. correctly distinguish between Mac Mini and Macbook Pro.
  307. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  308. - i810.xinf: PCI IDs for i965.
  309. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  310. - i810.xinf: Uppercase PCI IDs.
  311. * Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  312. - Update i810 to 1.6.5, should fix DRI.
  313. - Add kuzdu requires.
  314. - i810.xinf: Start whitelisting devices over to intel.
  315. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  316. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  317. you know, load.
  318. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  319. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  320. LFP special casing in favor of the blacklist.
  321. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  322. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  323. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  324. and is selected with Driver "intel" in xorg.conf. Individual devices will
  325. whitelist over to "intel" until that branch gets merged into head.
  326. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  327. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  328. the BIOS is known to lie.
  329. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  330. - Today's snapshot: I2C bus creation fix.
  331. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  332. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  333. clock when computing the modes list.
  334. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  335. in centimeters as the size of the display in pixels.
  336. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  337. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  338. probing.
  339. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  340. - Update again for a mode comparison bugfix.
  341. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  342. - Update to today's git; crash fixes, better pre-915 support, slightly better
  343. autoconfigurability.
  344. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  345. - rebuild
  346. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  347. - Fix Revision number to match naming policy.
  348. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  349. - Add back modesetting changes.
  350. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  351. - Roll back modesetting changes and build for fc5 aiglx repo.
  352. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  353. - Snapshot of the git modesetting branch.
  354. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  355. - Update i810.xinf to include entries for E7221 and 945GM.
  356. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  357. - Add with_dri macro to spec file, and conditionalize build time DRI support
  358. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  359. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  360. to pick up proto-devel as well.
  361. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  362. - Rebuild for 7.1 ABI fix.
  363. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  364. - Bump for fc5-bling build.
  365. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  366. - Update to 1.6.0 from 7.1RC1.
  367. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  368. - Add patch to add missing #include's, specifically assert.h.
  369. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  370. - Update to CVS snapshot of 20060322.
  371. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  372. - rebuilt for new gcc4.1 snapshot and glibc changes
  373. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  374. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  375. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  376. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  377. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  378. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  379. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  380. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  381. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  382. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  383. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  384. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  385. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  386. - Fix *.la file removal.
  387. - Added 'devel' subpackage for XvMC .so
  388. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  389. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  390. - Update BuildRoot to use Fedora Packaging Guidelines.
  391. - Deglob file manifest.
  392. - Limit "ExclusiveArch" to x86, x86_64, ia64
  393. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  394. - Initial spec file for i810 video driver generated automatically
  395. by my xorg-driverspecgen script.