gnash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # ghelp/omf/scrollkeeper support
  3. # not working as of version 0.8.7
  4. %define scrollkeeper 0
  5. # kde and klash support
  6. %define kde_support 0
  7. Name: gnash
  8. Version: 0.8.7
  9. Release: 4%{?_dist_release}
  10. Summary: GNU flash movie player
  11. Group: Applications/Multimedia
  12. License: GPLv3+
  13. URL: http://www.gnu.org/software/gnash/
  14. Source0: http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
  15. Source1: http://www.getgnash.org/gnash-splash.swf
  16. Source2: gnash.desktop
  17. # register KComponentData properly in KDE 4 KPart
  18. Patch0: gnash-0.8.3-fix-kde4-port.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: libxml2-devel libpng-devel libjpeg-devel libogg-devel
  21. BuildRequires: libboost-devel curl-devel freetype-devel fontconfig-devel
  22. BuildRequires: libboost-date-time libboost-serialization libboost-thread
  23. BuildRequires: SDL-devel
  24. BuildRequires: agg-devel
  25. BuildRequires: python-devel
  26. BuildRequires: libXv-devel
  27. %if %{kde_support}
  28. #BuildRequires: kde-filesystem
  29. BuildRequires: kdelibs-devel
  30. %endif
  31. BuildRequires: gtkglext-devel
  32. BuildRequires: docbook2X
  33. #BuildRequires: %{_bindir}/docbook2pdf
  34. BuildRequires: gstreamer-devel >= 0.10%
  35. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  36. %if %{scrollkeeper}
  37. BuildRequires: scrollkeeper
  38. %endif
  39. BuildRequires: giflib-devel
  40. BuildRequires: gettext
  41. BuildRequires: desktop-file-utils
  42. BuildRequires: speex-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: pygtk2-devel
  45. BuildRequires: libtool-ltdl-devel
  46. BuildRequires(check): dejagnu
  47. %if %{scrollkeeper}
  48. Requires(post): scrollkeeper
  49. Requires(postun): scrollkeeper
  50. %endif
  51. Requires(post): /sbin/ldconfig
  52. Requires(postun): /sbin/ldconfig
  53. Requires(post): /sbin/install-info
  54. Requires(preun): /sbin/install-info
  55. %description
  56. Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
  57. supports SWF v7, with better SWF v8 and v9 support under heavy development.
  58. Gnash includes initial parser support for SWF v8 and v9. Not all
  59. ActionScript 2 classes are implemented yet, but all of the most heavily
  60. used ones are. Many ActionScript 2 classes are partially implemented;
  61. there is support for all of the commonly used methods of each
  62. class.
  63. %package plugin
  64. Summary: Web-client flash movie player plugin
  65. Requires: %{name} = %{version}-%{release}
  66. # this doesn't prevent wrong dependencies, in case a package
  67. # provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
  68. # and another unrelated webbrowser is installed, like w3m-el.
  69. # Moreover konqueror could provide webclient some day
  70. Requires: %{_libdir}/mozilla/plugins webclient
  71. Group: Applications/Internet
  72. %description plugin
  73. The gnash flash movie player plugin for firefox or mozilla.
  74. %if %{kde_support}
  75. %package klash
  76. Summary: Konqueror flash movie player plugin
  77. Requires: %{name} = %{version}-%{release}
  78. Group: Applications/Multimedia
  79. %description klash
  80. The gnash flash movie player plugin for Konqueror.
  81. %endif
  82. %package cygnal
  83. Summary: Streaming media server
  84. Requires: %{name} = %{version}-%{release}
  85. Group: Applications/Multimedia
  86. %description cygnal
  87. Cygnal is a streaming media server that's Flash aware.
  88. %package devel
  89. Summary: Gnash header files
  90. Requires: %{name} = %{version}-%{release}
  91. Group: Development/Libraries
  92. %description devel
  93. Gnash header files can be used to write external Gnash extensions or to embed
  94. the Gnash GTK+ widget into a C/C++ application.
  95. %package -n python-gnash
  96. Summary: Gnash Python bindings
  97. Requires: %{name} = %{version}-%{release}
  98. Group: Applications/Multimedia
  99. %description -n python-gnash
  100. Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
  101. application.
  102. %prep
  103. %setup -q
  104. %patch0 -p1 -b .fix-kde4
  105. %if %{kde_support}
  106. # Hack as autoreconf breaks build
  107. sed -i -e 's!kapp.h!kapplication.h!g' configure
  108. sed -i -e 's!libkdeui.la!libkdeui.so!g' configure
  109. # Currently kde4-gnash (from kde4 branch) links against various KDE libraries,
  110. # but only needs Qt -- remove the superfluous linkage
  111. sed -i -e 's!\$(KDE4_LIBS)!!g' gui/Makefile.in
  112. %endif
  113. # we don't want any builtin ltdl built, configure wants always either
  114. # ltdl-install or ltdl-convenience, hack that out
  115. sed -i -e 's/test x"\${enable_ltdl_convenience-no}" != xno/false/g' configure
  116. # and don't build the loader part of libltdl either
  117. sed -i -e 's/\$(LT_DLLOADERS)//g' libltdl/Makefile.in
  118. # link to the system libltdl instead of the bundled one
  119. # this is hardcoded in the makefiles, so --without-included-ltdl doesn't help
  120. sed -i -e 's!\$(top_builddir)/libltdl/libltdlc.la!-lltdl!g' \
  121. */Makefile.in */*/Makefile.in
  122. # delete bundled libltdl stuff to make sure it's not used
  123. rm -f libltdl/*.[ch] libltdl/*/*.[ch]
  124. iconv -f latin1 -t utf8 < AUTHORS > AUTHORS.utf8
  125. touch -r AUTHORS AUTHORS.utf8
  126. mv AUTHORS.utf8 AUTHORS
  127. %build
  128. %configure --disable-static --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
  129. --enable-docbook --enable-ghelp --enable-media=GST \
  130. --disable-dependency-tracking --disable-rpath \
  131. --enable-cygnal \
  132. --enable-sdkinstall \
  133. --enable-python \
  134. %if %{kde_support}
  135. --enable-gui=gtk,kde4,sdl,fb \
  136. --with-kde4-prefix=%{_kde4_prefix} \
  137. --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
  138. --with-kde4-incl=%{_kde4_includedir} \
  139. %else
  140. --enable-gui=gtk,sdl,fb \
  141. %endif
  142. --without-included-ltdl
  143. %if %{kde_support}
  144. # make sure the Qt 4 moc etc. tools are found
  145. export PATH=%{_qt4_prefix}/bin:$PATH
  146. #doesn't work currently: %%{?_smp_mflags}
  147. # override KDE4_LIBS because configure doesn't detect it properly
  148. make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
  149. %else
  150. #doesn't work currently: %%{?_smp_mflags}
  151. make
  152. %endif
  153. %install
  154. rm -rf $RPM_BUILD_ROOT
  155. make install install-plugins \
  156. DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
  157. %if %{kde_support}
  158. KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
  159. KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
  160. KDE4_CONFIGDIR=%{_kde4_configdir} \
  161. KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
  162. %endif
  163. rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
  164. %if %{kde_support}
  165. # KDE 4 doesn't need the .la file anymore, thankfully
  166. rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
  167. %endif
  168. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  169. rm -rf __dist_docs
  170. mkdir __dist_docs
  171. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnash/* __dist_docs/
  172. rmdir $RPM_BUILD_ROOT%{_datadir}/doc/gnash
  173. cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnash/
  174. mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
  175. # a wrapper to avoid gnash erroring out if there is no argument.
  176. # Instead open gnash-splash.swf.
  177. # this should not be needed in the next version.
  178. # FIXME: Do we still need this with 0.8.7?
  179. cat > $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper << EOF
  180. #! /bin/sh
  181. if [ "z\$1" = 'z' ]; then
  182. gnash %{_datadir}/gnash/gnash-splash.swf
  183. else
  184. gnash "\$@"
  185. fi
  186. EOF
  187. chmod a+x $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper
  188. sed -e 's;/usr/libexec;%{_libexecdir};' %{SOURCE2} > gnash.desktop
  189. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
  190. desktop-file-install --vendor="fedora" \
  191. --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
  192. gnash.desktop
  193. mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  194. cp -p ./gui/images/GnashG.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  195. %find_lang %{name}
  196. %clean
  197. rm -rf $RPM_BUILD_ROOT
  198. %post
  199. /sbin/ldconfig
  200. %if %{scrollkeeper}
  201. scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
  202. %endif
  203. /sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  204. /sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
  205. update-desktop-database &> /dev/null || :
  206. touch --no-create %{_datadir}/icons/hicolor
  207. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  208. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  209. fi
  210. %preun
  211. if [ $1 = 0 ]; then
  212. /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  213. /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
  214. fi
  215. %postun
  216. /sbin/ldconfig
  217. %if %{scrollkeeper}
  218. scrollkeeper-update -q || :
  219. %endif
  220. update-desktop-database &> /dev/null || :
  221. touch --no-create %{_datadir}/icons/hicolor
  222. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  223. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  224. fi
  225. %files -f %{name}.lang
  226. %defattr(-,root,root,-)
  227. %doc README AUTHORS COPYING NEWS
  228. %doc __dist_docs/*
  229. %config(noreplace) %{_sysconfdir}/gnashpluginrc
  230. %config(noreplace) %{_sysconfdir}/gnashrc
  231. %{_bindir}/dumpshm
  232. %{_bindir}/fb-gnash
  233. %{_bindir}/flvdumper
  234. %{_bindir}/gtk-gnash
  235. %{_bindir}/sdl-gnash
  236. %{_bindir}/soldumper
  237. %{_bindir}/gnash
  238. %{_bindir}/gprocessor
  239. %{_bindir}/findmicrophones
  240. %{_bindir}/findwebcams
  241. %dir %{_libdir}/gnash
  242. %{_libdir}/gnash/*.so*
  243. %{_mandir}/man1/gnash.1*
  244. %{_mandir}/man1/dumpshm.1*
  245. %{_mandir}/man1/gprocessor.1*
  246. %{_mandir}/man1/soldumper.1*
  247. %{_mandir}/man1/flvdumper.1*
  248. %{_mandir}/man1/findmicrophones.1*
  249. %{_mandir}/man1/findwebcams.1*
  250. %{_mandir}/man1/gtk-gnash.1*
  251. %{_infodir}/gnash*
  252. %{_datadir}/gnash/
  253. %{_datadir}/icons/hicolor/32x32/apps/*.png
  254. %{_datadir}/applications/*.desktop
  255. %{_libexecdir}/gnash-wrapper
  256. %if %{scrollkeeper}
  257. %{_datadir}/omf/gnash/
  258. %endif
  259. %files plugin
  260. %defattr(-,root,root,-)
  261. %{_libdir}/mozilla/plugins/libgnashplugin.so
  262. %if %{kde_support}
  263. %files klash
  264. %defattr(-,root,root,-)
  265. %{_kde4_bindir}/kde4-gnash
  266. %{_kde4_libdir}/kde4/libklashpart.so
  267. %{_kde4_appsdir}/klash/
  268. %{_kde4_datadir}/kde4/services/klash_part.desktop
  269. %{_mandir}/man1/kde4-gnash.1*
  270. %endif
  271. %files cygnal
  272. %defattr(-,root,root,-)
  273. %config(noreplace) %{_sysconfdir}/cygnalrc
  274. %{_bindir}/cygnal
  275. %{_mandir}/man1/cygnal.1*
  276. %{_mandir}/man1/rtmpget.1*
  277. %dir %{_libdir}/cygnal
  278. %{_libdir}/cygnal/plugins/*.so*
  279. %files devel
  280. %defattr(-,root,root,-)
  281. %{_includedir}/gnash/
  282. %{_libdir}/pkgconfig/gnash.pc
  283. %files -n python-gnash
  284. %defattr(-,root,root,-)
  285. %{python_sitearch}/gtk-2.0/*
  286. %changelog
  287. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
  288. - add BuildRequires: python-devel, libXv-devel
  289. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
  290. - rebuilt with libboost-1.45.0
  291. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
  292. - rebuilt with rpm-4.8.1 for pkg-config
  293. * Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
  294. - initial build for Vine Linux: based Fedora 0.8.7-1.fc14
  295. * Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
  296. - update to 0.8.7
  297. - make scrollkeeper a conditional (still disabled as it's not working)
  298. - drop gnash-0.8.3-manual.patch, should no longer be needed
  299. - drop gnash-0.8.6-python-install-dir.patch, fixed upstream
  300. * Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
  301. - delete bundled libltdl stuff to make sure it's not used
  302. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
  303. - don't build libltdlc.a
  304. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
  305. - --without-included-ltdl (CVE-2009-3736)
  306. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
  307. - Rebuild for new Boost (1.41.0)
  308. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
  309. - Add missing Epoch to Requires
  310. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
  311. - Install icon to the correct place (#551621)
  312. * Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
  313. - One more try at using the correct dir
  314. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
  315. - Patch was reversed
  316. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
  317. - Patch Makefile.in, not Makefile.am
  318. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
  319. - Pick up python modules from the right dir
  320. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
  321. - Install python modules in the right dir
  322. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
  323. - Add cygnal plugins
  324. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
  325. - Update to 0.8.6, increase epoch.
  326. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
  327. - update to HEAD
  328. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
  329. - update to HEAD
  330. * Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
  331. - don't package headers in -widget, only in -devel (no duplicate files)
  332. - own %%{_includedir}/gnash/ in -devel
  333. - add missing %%defattr for -devel and -widget
  334. - make -devel and -widget require the main package (with exact VR)
  335. - fix -devel group and description
  336. - rename gnash-widget to python-gnash as per the naming guidelines
  337. * Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
  338. - use %%{_includedir}, not %%{_prefix}/include
  339. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
  340. - Install the python module in the sitearch dir
  341. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
  342. - One more 64bit fix
  343. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
  344. - Fix the packaging in 64bits
  345. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
  346. - upload the .swf file
  347. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
  348. - merge upstream changes into the spec
  349. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
  350. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  351. * Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
  352. - rebuild for new Boost
  353. * Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
  354. - explicitly link the KlashPart against the libraries it uses
  355. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
  356. - add missing speex-devel and gstreamer-plugins-base-devel BR
  357. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
  358. - update to 0.8.5
  359. - remove use_kde3_executable_hack
  360. - remove autoreconf
  361. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
  362. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  363. * Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
  364. - rebuild for new boost
  365. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
  366. - add missing portions of KDE 4 port from upstream kde4 branch
  367. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
  368. - add 3 more patches from bero to fix the KDE 4 viewer executable
  369. - disable use_kde3_executable hack
  370. * Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
  371. - add a desktop file
  372. * Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
  373. - update KDE 4 patch (undo the backporting and use original patch)
  374. - patch to make autoreconf work
  375. - add missing BR giflib-devel, gettext
  376. - omit unrecognized --with-qtdir
  377. * Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
  378. - update to 0.8.4
  379. * Thu Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
  380. - use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
  381. so it can easily be disabled or removed once the KDE 4 executable is fixed)
  382. * Thu Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
  383. - register KComponentData properly in KDE 4 KPart
  384. * Wed Oct 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
  385. - KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
  386. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
  387. - include %%_libdir/gnash directory
  388. * Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
  389. - add glib in the link, thanks Daniel Drake (#452767)
  390. * Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
  391. - update to 0.8.3
  392. * Wed Apr 9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
  393. - ship libklashpart (#441601)
  394. * Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
  395. - don't ship libltdl.so.3 (#436725)
  396. * Fri Mar 7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
  397. - update to 0.8.2
  398. * Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
  399. - add patch from Martin Stransky to fix wrapped plugin #281061
  400. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
  401. - info files are empty, don't install them
  402. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
  403. - omf/scrollkeeper doc is broken, remove it
  404. * Fri Sep 7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
  405. - better documentation generation
  406. * Wed Sep 5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
  407. - update to 0.8.1
  408. - agg is now the default renderer
  409. * Fri Aug 3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
  410. - rebuild for boost soname change
  411. * Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
  412. - update to 0.8.0
  413. * Wed May 9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
  414. - fix CVE-2007-2500 (fix 239213)
  415. * Sat Nov 6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
  416. - update for 0.7.2 release.
  417. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
  418. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  419. * Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
  420. - plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
  421. temporarily, but there is no better solution yet) #207613
  422. * Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
  423. - add defattr for klash
  424. - add warnings in the description about stability
  425. * Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
  426. - remove superfluous buildrequires autoconf
  427. - rename last patch to gnash-plugin-tempfile-dir.patch
  428. - add README.fedora to plugin to explain tmpdirs
  429. * Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
  430. - source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
  431. - add plugin-tempfile-dir.patch for plugin to use a safe tempdir
  432. * Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
  433. - buildrequire autotools (Michael Knox)
  434. * Fri Jun 2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
  435. - add gnash-continue_on_info_install_error.patch to avoid
  436. - buildrequire libXmu-devel
  437. * Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
  438. - configure with --disable-rpath
  439. - buildrequire docbook2X
  440. - remove devel files
  441. * Sun May 7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
  442. - update to 0.7.1 alpha release
  443. * Sat Apr 22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
  444. - install the info file. Various tweaks for my system based on
  445. Patrice's latest patch,
  446. * Fri Feb 3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
  447. - initial packaging