swig-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %define tcl 0
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): Connects C/C++/Objective C to some high-level programming languages
  5. Name: swig
  6. Version: 2.0.4
  7. Release: 2%{?_dist_release}
  8. License: GPLv3+ and BSD
  9. Group: Development/Tools
  10. URL: http://swig.sourceforge.net/
  11. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  12. Patch1: swig-1.3.23-pylib.patch
  13. Patch4: swig203-rh706140.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: perl, python-devel, pcre-devel
  16. %if %{tcl}
  17. BuildRequires: tcl-devel
  18. %endif
  19. %if %{guile}
  20. BuildRequires: guile-devel
  21. %endif
  22. BuildRequires: autoconf, automake, gawk, nkf
  23. Obsoletes: swig-runtime
  24. %description
  25. Simplified Wrapper and Interface Generator (SWIG) is a software
  26. development tool for connecting C, C++ and Objective C programs with a
  27. variety of high-level programming languages. SWIG is primarily used
  28. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  29. Eiffel and Guile. SWIG is normally used to create high-level
  30. interpreted programming environments, systems integration, and as a
  31. tool for building user interfaces
  32. %package doc
  33. Summary: Documentation files for SWIG
  34. Summary(ja): Documentation files for SWIG
  35. License: BSD
  36. Group: Development/Tools
  37. BuildArch: noarch
  38. %description doc
  39. This package contains documentation for SWIG and useful examples
  40. %prep
  41. %setup -q -n swig-%{version}
  42. %patch1 -p1 -b .pylib
  43. %patch4 -p1 -b .rh706140
  44. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  45. # (specific req/prov filtering). Before you remove this hack make sure you don't
  46. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  47. cat << \EOF > %{name}-prov
  48. #!/bin/sh
  49. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  50. EOF
  51. %define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  52. chmod +x %{__perl_provides}
  53. cat << \EOF > %{name}-req
  54. #!/bin/sh
  55. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  56. EOF
  57. %define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  58. chmod +x %{__perl_requires}
  59. for all in CHANGES README; do
  60. iconv -f ISO88591 -t UTF8 < $all > $all.new
  61. touch -r $all $all.new
  62. mv -f $all.new $all
  63. done
  64. %build
  65. ./autogen.sh
  66. %configure
  67. make %{?_smp_mflags}
  68. # Test suite is currently broken
  69. #make check
  70. %install
  71. rm -rf %{buildroot}
  72. pushd Examples/
  73. # Remove all arch dependent files in Examples/
  74. find -type f -name 'Makefile.in' | xargs rm -f --
  75. # We don't want to ship files below.
  76. rm -rf test-suite
  77. find -type f -name '*.dsp' | xargs rm -f --
  78. find -type f -name '*.dsw' | xargs rm -f --
  79. # Convert files to UNIX format
  80. for all in `find -type f`; do
  81. nkf --unix $all
  82. chmod -x $all
  83. done
  84. popd
  85. make DESTDIR=%{buildroot} install
  86. %clean
  87. rm -rf %{buildroot}
  88. %files
  89. %defattr(-,root,root,-)
  90. %{_bindir}/*
  91. %{_datadir}/swig
  92. %{_mandir}/man1/ccache-swig.1*
  93. %doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
  94. %doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
  95. %files doc
  96. %defattr(-,root,root,-)
  97. %doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  98. %changelog
  99. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  100. - rebuild with python-2.7.2
  101. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  102. - update to 2.0.4
  103. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  104. - add missing man file(s) to the filelist
  105. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  106. - new upstream release
  107. - rebuild with new toolchain
  108. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  109. - new upstream release
  110. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  111. - new upstream release
  112. - removed php-devel and ruby-devel from BuildPreReq:.
  113. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  114. - new upstream release
  115. - use %%configure
  116. - remove runtime subpackage
  117. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  118. - 1.3.21-0vl2
  119. - un-libtoolize (tarball have already been libtoolized).
  120. - fix %%clean.
  121. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  122. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  123. - 1.3.21-0vl1
  124. - update version
  125. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  126. - 1.3.20-0vl1
  127. - update version
  128. * Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  129. - update version
  130. * Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  131. - update version
  132. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  133. - import to Vine Linux
  134. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  135. - BM.
  136. - Clean up specs.
  137. - 1.3a3.
  138. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  139. - Use makeinstall macros.
  140. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  141. - Provides: swig
  142. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  143. - rebuild with new perl
  144. - cleanup
  145. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  146. - Rebuilt on kenobi
  147. - Don't use prefix
  148. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  149. - First RPM for Mandrake