screen-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. Summary: A screen manager that supports multiple logins on one terminal.
  2. Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
  3. Name: screen
  4. Version: 4.8.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/System
  8. Source0: https://ftp.gnu.org/gnu/screen/screen-%{version}.tar.gz
  9. Source1: screen.pam
  10. Patch1: screen-4.3.1-libs.patch
  11. Patch2: screen-4.3.1-screenrc.patch
  12. Patch3: screen-E3.patch
  13. Patch4: screen-4.3.1-suppress_remap.patch
  14. Patch5: screen-4.3.1-crypt.patch
  15. Patch6: screen-4.8.0-expand-d_xtermosc.patch
  16. Requires: ncurses
  17. Requires(post,preun): /sbin/install-info
  18. BuildRequires: ncurses-devel, texinfo, perl
  19. BuildRequires: pam-devel
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. The screen utility allows you to have multiple logins on just one
  25. terminal. Screen is useful for users who telnet into a machine or
  26. are connected via a dumb terminal, but want to use more than just
  27. one login.
  28. Install the screen package if you need a screen manager that can
  29. support multiple logins on one terminal.
  30. %description -l ja
  31. 一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
  32. ユーティリティです。telnetで操作しているユーザやダムターミナルから
  33. 接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
  34. 便利なプログラムです。
  35. %prep
  36. %setup -q
  37. %autosetup -p1
  38. %build
  39. autoreconf -vfi
  40. %configure \
  41. --enable-pam \
  42. --enable-locate \
  43. --enable-telnet \
  44. --enable-colors256 \
  45. --with-sys-screenrc=%{_sysconfdir}/screenrc
  46. # configure can figure out these values.
  47. #perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
  48. #perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
  49. perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
  50. perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
  51. perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
  52. rm -f doc/screen.info*
  53. # fails with %{?_smp_mflags}
  54. make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. mkdir -p $RPM_BUILD_ROOT/etc/skel
  58. perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
  59. %makeinstall DDESTDIR=$RPM_BUILD_ROOT
  60. ( cd $RPM_BUILD_ROOT
  61. # gzip -9nf .%{_infodir}/screen.info*
  62. # strip .%{_bindir}/screen-%{version}
  63. rm -f .%{_bindir}/screen.old .%{_bindir}/screen
  64. mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
  65. )
  66. install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
  67. install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
  68. # Better not forget to copy the pam file around
  69. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
  70. install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/screen
  71. # Remove files from the buildroot which we don't want packaged
  72. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  77. if [ -d /tmp/screens ]; then
  78. # we're not setuid root anymore
  79. chmod 777 /tmp/screens
  80. fi
  81. %preun
  82. if [ $1 = 0 ]; then
  83. /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  84. fi
  85. %files
  86. %defattr(-,root,root)
  87. %license COPYING
  88. %doc NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
  89. #%attr(755,root,root) %{_bindir}/screen
  90. %{_bindir}/screen
  91. %{_mandir}/man1/screen.*
  92. %{_infodir}/screen.info*
  93. %{_datadir}/screen
  94. %config(noreplace) %{_sysconfdir}/screenrc
  95. %config(noreplace) %{_sysconfdir}/pam.d/screen
  96. %config /etc/skel/.screenrc
  97. %changelog
  98. * Thu Feb 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.0-1
  99. - update to 4.8.0.
  100. - re-imported patches from rawhide.
  101. * Fri Apr 20 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.6.2-1
  102. - update to 4.6.2
  103. - change License
  104. - sync fc28 package
  105. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.3-4
  106. - rebuild with VineSeed environment
  107. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.3-3vl6
  108. - build on current VineSeed
  109. - add execvpe patch (Patch0) based upstream git
  110. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
  111. - spec in UTF-8
  112. - add Patch12 to build against glibc-2.8
  113. - fix typo (from --enable-color256 to --enable-colors256)
  114. thanks Minematsu Hiroki-san for pointing this out
  115. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
  116. - used %%{?_dist_release}
  117. * Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
  118. - rebuild for VineSeed
  119. * Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
  120. - rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
  121. * Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
  122. - add BuildRequires: texinfo, perl
  123. * Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
  124. - upstream release with security fix (build for Vine 4.0)
  125. * Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
  126. - use License instead of Copyright
  127. * Sat Jun 5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
  128. - new upstream release
  129. - add %%{_datadir}/screen in %%files
  130. - no replace configuration file: /etc/screenrc
  131. * Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
  132. - eliminate %%{_bindir} from %%files section
  133. * Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
  134. - update to 3.9.13
  135. - add FAQ instead of a symbolic link to FAQ
  136. - remove unnecessary patches
  137. * Thu Nov 1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
  138. - update to 3.9.10 (security update)
  139. * Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
  140. - update to 3.9.9
  141. - rebuild by current Seed
  142. - remove makeinfo patch, jbj patch
  143. * Sat Mar 10 2001 sagami@vinelinux.org
  144. - made minor spec fixes
  145. * Fri Mar 2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
  146. - update to 3.9.8
  147. - update 3.9.5-jbj.patch for 3.9.8
  148. - add hascrypt patch
  149. * Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  150. - 3.9.5-1vl3
  151. - built with gcc-2.95.3
  152. - partially used rpmmacros
  153. * Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  154. - 3.9.5-1vl2
  155. - fixed %files section to handle compressed man page
  156. * Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
  157. - updated to 3.9.5
  158. * Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  159. - 3.9.4-5vl1
  160. - merged missing patches from screen-3.9.4-3 on Red Hat 6.1
  161. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  162. - you know, we weren't just patching in Unix98 pty support for fun.
  163. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  164. - put screendir in ~
  165. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  166. - update to 3.9.4.
  167. * Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
  168. - force tty permissions/group
  169. * Sat Jun 5 1999 Dale Lovelace <dale@redhat.com>
  170. - permissions on /etc/skel/.screenrc to 644
  171. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  172. - take out warning of directory permissions so root can still use screen
  173. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  174. - take out warning of directory ownership so root can still use screen
  175. * Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
  176. - patched in utempter support, turned off setuid bit
  177. * Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
  178. - fixed unix98 pty support
  179. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  180. - auto rebuild in the new build environment (release 3)
  181. * Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
  182. - add patch for Unix98 pty support
  183. * Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
  184. - update to 3.7.6.
  185. * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
  186. - build root
  187. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  188. - translations modified for de, fr, tr
  189. * Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  190. - upgraded to 3.7.4
  191. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  192. - removed glibc 1.99 specific patch
  193. * Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
  194. - added install-info support
  195. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  196. - built against glibc