zint-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. Summary: A barcode generator and library
  2. Summary(ja): Zintバーコード作成プログラム
  3. Name: zint
  4. Version: 2.4.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. URL: http://www.zint.org.uk
  8. Source: http://downloads.sourceforge.net/project/%{name}/%{name}/%{version}/%{name}-%{version}.src.tar.gz
  9. Group: Applications/Engineering
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. BuildRequires: cmake
  12. BuildRequires: libpng-devel
  13. BuildRequires: zlib-devel
  14. Packager: owa
  15. %description
  16. Zint is a C library for encoding data in several barcode variants. The
  17. bundled command-line utility provides a simple interface to the library.
  18. Features of the library:
  19. - Over 50 symbologies including all ISO/IEC standards, like QR codes.
  20. - Unicode translation for symbologies which support Latin-1 and
  21. Kanji character sets.
  22. - Full GS1 support including data verification and automated insertion of
  23. FNC1 characters.
  24. - Support for encoding binary data including NULL (ASCII 0) characters.
  25. - Health Industry Barcode (HIBC) encoding capabilities.
  26. - Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
  27. - Verification stage for SBN, ISBN and ISBN-13 data.
  28. %package devel
  29. Summary: Library and header files for %{name}
  30. Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. C library and header files needed to develop applications using %{name}.
  35. The API documentation can be found ont the project website:
  36. http://www.zint.org.uk/zintSite/Manual.aspx
  37. %package qt
  38. Summary: Zint Barcode Studio GUI and library
  39. Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
  40. Group: Applications/Engineering
  41. Requires: %{name} = %{version}-%{release}
  42. BuildRequires: qt4-devel >= 4.4
  43. BuildRequires: desktop-file-utils
  44. %description qt
  45. Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
  46. barcodes which can then be embedded in documents or HTML pages, and a library
  47. which can be used to incorporate barcode generation functionality into other
  48. software.
  49. %package qt-devel
  50. Summary: Library and header files for %{name}-qt
  51. Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
  52. Group: Development/Libraries
  53. Requires: %{name}-devel = %{version}-%{release}
  54. Requires: %{name}-qt = %{version}-%{release}
  55. %description qt-devel
  56. C library and header files needed to develop applications using %{name}-qt.
  57. %prep
  58. %setup -q
  59. # remove BSD-licensed file required for Windows only (just to ensure that this package is plain GPLv3+)
  60. rm -f backend/ms_stdint.h
  61. # remove bundled getopt sources (we use the corresponding Fedora package instead)
  62. rm -f frontend/getopt*.*
  63. %build
  64. %cmake CMakeLists.txt
  65. make VERBOSE=1 %{?_smp_mflags}
  66. cat <<EOF >zint-qt.desktop
  67. [Desktop Entry]
  68. Encoding=UTF-8
  69. Name=Zint Barcode Studio
  70. Name[ja]=Zintバーコードスタジオ
  71. Comment=Zint Barcode Studio
  72. Comment[ja]=バーコードを作成するツールです
  73. GenericName=Zint Barcode Studio
  74. Exec=zint-qt
  75. Icon=zint
  76. Terminal=false
  77. Type=Application
  78. Categories=Utility;
  79. EOF
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
  84. install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
  85. desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post -p /sbin/ldconfig
  89. %postun -p /sbin/ldconfig
  90. %post -n %{name}-qt -p /sbin/ldconfig
  91. %postun -n %{name}-qt -p /sbin/ldconfig
  92. %files
  93. %defattr(-,root,root,-)
  94. %doc COPYING readme
  95. %{_bindir}/%{name}
  96. %{_libdir}/libzint.so.*
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %{_includedir}/%{name}.h
  100. %{_libdir}/libzint.so
  101. %files qt
  102. %defattr(-,root,root,-)
  103. %{_bindir}/%{name}-qt
  104. %{_libdir}/libQZint.so.*
  105. %{_datadir}/applications/%{name}-qt.desktop
  106. %files qt-devel
  107. %defattr(-,root,root,-)
  108. %{_includedir}/qzint.h
  109. %{_libdir}/libQZint.so
  110. %changelog
  111. * Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
  112. - initial build for Vine