libtiff-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of functions for manipulating TIFF format image files.
  3. Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
  4. Name: libtiff
  5. Version: 4.0.8
  6. Release: 1%{_dist_release}
  7. License: distributable
  8. Group: System Environment/Libraries
  9. Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
  10. URL: http://www.simplesystems.org/libtiff/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: zlib-devel libjpeg-devel
  13. %define LIBVER %(echo %{version} | cut -f-2 -d.)
  14. %ifarch x86_64
  15. Provides: libtiff.so.4()(64bit)
  16. %else
  17. Provides: libtiff.so.4
  18. %endif
  19. Obsoletes: libtiff4
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: daisuke, iwamoto
  23. Patch0: libtiff-am-version.patch
  24. Patch1: libtiff-make-check.patch
  25. %description
  26. The libtiff package contains a library of functions for manipulating
  27. TIFF (Tagged Image File Format) image format files. TIFF is a widely
  28. used file format for bitmapped images. TIFF files usually end in the
  29. .tif extension and they are often quite large.
  30. The libtiff package should be installed if you need to manipulate TIFF
  31. format image files.
  32. %description -l ja
  33. libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
  34. 扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
  35. 広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
  36. 拡張子が使われ,サイズは概して大きめです.
  37. TIFF 形式の画像ファイルを扱う必要があるならば,
  38. libtiff パッケージを是非インストールして下さい.
  39. %package devel
  40. Summary: Development tools for programs which will use the libtiff library.
  41. Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
  42. Group: Development/Libraries
  43. Requires: libtiff = %{version}
  44. %description devel
  45. This package contains the header files and static libraries for
  46. developing programs which will manipulate TIFF format image files
  47. using the libtiff library.
  48. If you need to develop programs which will manipulate TIFF format
  49. image files, you should install this package. You'll also need to
  50. install the libtiff package.
  51. #'
  52. %description devel -l ja
  53. このパッケージには,libtiff ライブラリを使って TIFF 形式の
  54. 画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
  55. スタティックライブラリが収められています.
  56. TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
  57. このパッケージをインストールして下さい.libtiff パッケージも同時に
  58. インストールする必要があります.
  59. ## to build compat32 for x86_64 architecture support
  60. %package -n compat32-%{name}
  61. Summary: A library of functions for manipulating TIFF format image files.
  62. Group: System Environment/Libraries
  63. Requires: %{name} = %{version}
  64. Provides: libtiff.so.4
  65. Obsoletes: compat32-libtiff4
  66. %description -n compat32-%{name}
  67. The libtiff package contains a library of functions for manipulating
  68. TIFF (Tagged Image File Format) image format files. TIFF is a widely
  69. used file format for bitmapped images. TIFF files usually end in the
  70. .tif extension and they are often quite large.
  71. The libtiff package should be installed if you need to manipulate TIFF
  72. format image files.
  73. %package -n compat32-%{name}-devel
  74. Summary: Development tools for programs which will use the libtiff library.
  75. Group: Development/Libraries
  76. Requires: compat32-%{name} = %{version}
  77. Requires: %{name}-devel = %{version}
  78. %description -n compat32-%{name}-devel
  79. This package contains the header files and static libraries for
  80. developing programs which will manipulate TIFF format image files
  81. using the libtiff library.
  82. If you need to develop programs which will manipulate TIFF format
  83. image files, you should install this package. You'll also need to
  84. install the libtiff package.
  85. #'
  86. %prep
  87. %setup -q -n tiff-%{version}
  88. %patch0 -p1
  89. %patch1 -p1
  90. # Use build system's libtool.m4, not the one in the package.
  91. rm -f libtool.m4
  92. libtoolize --force --copy
  93. aclocal -I . -I m4
  94. automake --add-missing --copy
  95. autoconf
  96. autoheader
  97. %build
  98. export CFLAGS="%{optflags} -fno-strict-aliasing"
  99. %configure \
  100. --enable-ld-version-script \
  101. --with-jpeg-lib-dir=%{_libdir} \
  102. --disable-cxx
  103. %__make %{?_smp_mflags}
  104. %__make clean
  105. %install
  106. rm -fr $RPM_BUILD_ROOT
  107. %makeinstall
  108. rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
  109. ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
  110. rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
  111. %post -p /sbin/ldconfig
  112. %postun -p /sbin/ldconfig
  113. %if %{build_compat32}
  114. %post -n compat32-%{name} -p /sbin/ldconfig
  115. %postun -n compat32-%{name} -p /sbin/ldconfig
  116. %endif
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %files
  120. %defattr(-,root,root)
  121. %doc COPYRIGHT README RELEASE-DATE VERSION
  122. %{_bindir}/*
  123. %{_libdir}/libtiff*.so.*
  124. %{_mandir}/man1/*
  125. %files devel
  126. %defattr(-,root,root)
  127. %doc TODO html ChangeLog
  128. %{_includedir}/*
  129. %{_libdir}/libtiff*.so
  130. %{_libdir}/pkgconfig/*.pc
  131. %{_mandir}/man3/*
  132. ## to build compat32 for x86_64 architecture support
  133. %if %{build_compat32}
  134. %files -n compat32-%{name}
  135. %defattr(-,root,root)
  136. %{_libdir}/libtiff.so.*
  137. %files -n compat32-%{name}-devel
  138. %defattr(-,root,root)
  139. %{_libdir}/libtiff.so
  140. %endif
  141. %changelog
  142. * Sat Jun 3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
  143. - update to 4.0.8
  144. - drop patches; upstream fixed
  145. - HylaFAX patch (Patch2)
  146. - CVE patches (Patch3..16)
  147. * Sat May 6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  148. - imported patches from rawhide.
  149. - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
  150. - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
  151. * Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  152. - new upstream release.
  153. - drooped patch1-11: fixed in upstream.
  154. * Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
  155. - add patch1-11 from fc21 to fix security issues
  156. * Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
  157. - new upstream release with security fix (CVE-2012-4447)
  158. - drop *.a files from -devel packages
  159. * Thu Aug 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
  160. - new upstream release with security fixes (CVE-2012-2088, 2113)
  161. - drop patch1 (is included in new release)
  162. * Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
  163. - Obosletes: libtiff4 and compat32-libtiff4 (vl6)
  164. * Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
  165. - fix R: for compat32 package
  166. * Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
  167. - add libtiff.so.4 for compatibility
  168. - add pkgconfig file
  169. * Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  170. - new upstream release
  171. - add patch1 to fix CVE-2012-1173
  172. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
  173. - new upstream release
  174. - drop all patches (are included in new release)
  175. - remove if-endif for Vine 4.x
  176. - add Vendor/Distri tags
  177. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
  178. - add some patches from RHEL6 3.9.4-1.el6_0.3
  179. - fix for CVE-2011-0192 (Patch11)
  180. - fix for CVE-2011-1167 (Patch12)
  181. - fix for CVE-2009-5022 (Patch13)
  182. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
  183. - rebuilt with rpm-4.8.1-3
  184. * Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
  185. - new upstream release
  186. - add patch4-10 from fedora
  187. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
  188. - new upstream release
  189. - remove BC: freeglut-devel
  190. - add patch1,2,4,5 from fedora
  191. - drop obsolete patches
  192. * Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
  193. - change if-endif to make both i386 and compat32 packages
  194. * Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
  195. - add patch5 for fix CVE-2009-2347 (Integer Overflow)
  196. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
  197. - add patch4 for fix lzw underflow security issue
  198. - add if branch Vine4/5 in devel files section (*.la are included or not)
  199. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
  200. - removed *.la
  201. - spec in utf-8
  202. * Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
  203. - fix changelog typo (3.8.4 -> 3.8.2)
  204. - new versioning policy
  205. - add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
  206. * Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
  207. - fix libdir in libtiff.la
  208. - add BuildConflicts: freeglut-devel
  209. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
  210. - rebuilt without glut-devel
  211. * Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
  212. - add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
  213. * Fri Jun 9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
  214. - new upstream release
  215. - remove obsolete patches
  216. - add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
  217. - delete duped docs
  218. - add --disable-cxx to configure option
  219. - add *.la to devel package
  220. * Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
  221. - added compat32-* packages for x86_64 architecture support
  222. - added --with-jpeg-lib-dir=%{_libdir} to configure
  223. * Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
  224. - new upstream release
  225. - remove obsolete patches
  226. - cleanup specs
  227. * Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
  228. - rebuild for Vine3.1
  229. * Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
  230. - add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
  231. - update URL
  232. * Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
  233. - build for Vine2.6
  234. * Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
  235. - fix changelog: proper name
  236. * Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
  237. - add symlink to shared lib by running ldconfig at compile time
  238. * Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
  239. - add patch8-13 from Fedora Core
  240. --* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
  241. --- fix some integer and buffer overflows (#134853, #134848)
  242. - add patch14 from SUSE LINUX
  243. --* Wed Oct 20 2004 - meissner@suse.de
  244. --- Do not crash if we are using unsupported codecs (like OJPEG).
  245. * Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
  246. - rebuild with new toolchains
  247. - to use License instead of Copyright
  248. * Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  249. - 3.5.7-6vl1
  250. - based on 3.5.7-6 from Rawhide
  251. * Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  252. - 3.5.5-8vl1
  253. - based on 3.5.5-8 from Rawhide
  254. - added Japanese summary and description
  255. * Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
  256. - rebuild
  257. * Mon Aug 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
  258. - added a tiff-to-ps.fpi filter for printing
  259. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  260. - automatic rebuild
  261. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  262. - apply Peter Skarpetis's fix for the 32-bit conversion
  263. * Mon Jul 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  264. - make man pages non-executable (#12811)
  265. * Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  266. - remove CVS repo info from data directories
  267. * Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  268. - fix build rooting
  269. - fix syntax error in configure script
  270. - move man pages to %{_mandir}
  271. * Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  272. - rebuild for an errata release
  273. * Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  274. - update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
  275. * Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  276. - fix fax2ps swapping height and width in the bounding box
  277. * Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
  278. - move man pages from devel package to the regular one
  279. - integrate Frank Warmerdam's fixed .fax handling code (keep until next release
  280. of libtiff)
  281. - fix fax2ps breakage (bug #8345)
  282. * Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
  283. - set MANDIR=man3 to make multifunction man pages friendlier
  284. * Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  285. - fix URLs
  286. * Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  287. - link shared library against libjpeg and libz
  288. * Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  289. - enable zip and jpeg codecs
  290. - change defattr in normal package to 0755
  291. - add defattr to -devel package
  292. * Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
  293. - update to 3.5.4
  294. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  295. - auto rebuild in the new build environment (release 6)
  296. * Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
  297. - build for glibc 2.1
  298. * Wed Jun 10 1998 Prospector System <bugs@redhat.com>
  299. - translations modified for de
  300. * Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
  301. - rebuilt against fixed jpeg libs (libjpeg-6b)
  302. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  303. - translations modified for de, fr, tr
  304. * Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
  305. - new version to replace the one from libgr
  306. - patched for glibc
  307. - added shlib support