WebKit-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 2.4.11
  16. Release: 2%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi, Takemikaduchi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk2-devel
  32. BuildRequires: harfbuzz-icu-devel
  33. BuildRequires: libjpeg-turbo-devel
  34. BuildRequires: libtool
  35. BuildRequires: libxslt-devel
  36. BuildRequires: libXt-devel
  37. BuildRequires: pcre-devel
  38. BuildRequires: sqlite3-devel
  39. BuildRequires: geoclue-devel
  40. BuildRequires: gcr-devel
  41. BuildRequires: gstreamer1-devel
  42. BuildRequires: gstreamer1-plugins-base-devel
  43. BuildRequires: enchant-devel
  44. BuildRequires: libwebp-devel
  45. BuildRequires: libsecret-devel
  46. BuildRequires: gobject-introspection-devel
  47. BuildRequires: gsettings-desktop-schemas
  48. BuildRequires: gtk-doc
  49. %if %{with pango}
  50. BuildRequires: pango-devel
  51. %else
  52. BuildRequires: cairo-devel
  53. BuildRequires: fontconfig-devel
  54. BuildRequires: freetype2-devel
  55. %endif
  56. BuildRequires: libsoup-devel >= 2.28.2
  57. %description
  58. WebKit is an open source web browser engine.
  59. %package gtk
  60. Summary: GTK+ port of WebKit
  61. Summary(ja): WebKit の GTK+ ポート
  62. Group: Development/Libraries
  63. Provides: webkitgtk = %{version}-%{release}
  64. %description gtk
  65. %{name} is an open-source Web content engine library. This package contains
  66. the shared libraries for the WebKit GTK+ port as well as the sample
  67. GtkLauncher tool.
  68. %package gtk-devel
  69. Summary: Development package for %{name}
  70. Summary(ja): %{name} の開発パッケージ
  71. Group: Development/Libraries
  72. Provides: webkitgtk-devel = %{version}-%{release}
  73. Requires: %{name}-gtk = %{version}-%{release}
  74. Requires: pkgconfig
  75. Requires: gtk2-devel
  76. Requires: libsoup-devel >= 2.28.2
  77. %description gtk-devel
  78. The %{name}-gtk-devel package contains libraries, build data, and header
  79. files for developing applications that use %{name}-gtk.
  80. Please note that the WebKit/GTK+ API is not yet stable. This should
  81. only be used as a "preview" rather than a stable platform library.
  82. %package docs
  83. Summary: Documentation for %{name}
  84. Summary(ja): %{name} のドキュメント
  85. Group: Documentation
  86. Provides: webkitgtk-docs = %{version}-%{release}
  87. Provides: %{name}-doc = %{version}-%{release}
  88. %description docs
  89. %{name} is an open-source Web content engine library. This package contains
  90. the documentation for %{name}, including various LICENSE, README, and
  91. AUTHORS files.
  92. %prep
  93. %setup -q -n webkitgtk-%{version}
  94. %build
  95. %configure \
  96. --with-gtk=2.0 \
  97. --disable-webkit2 \
  98. --enable-icon-database \
  99. --enable-jit \
  100. --enable-geolocation \
  101. --enable-introspection=yes \
  102. --enable-webgl \
  103. --enable-dependency-tracking \
  104. %{?with_coverage: --enable-coverage } \
  105. %{?with_pango: --with-font-backend=pango } \
  106. %{?with_wml: --enable-wml }
  107. make %{?_smp_mflags}
  108. # workaround for bug 488112
  109. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  110. ##touch JavaScriptCore/AllInOneFile.cpp
  111. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  112. %install
  113. rm -rf %{buildroot}
  114. make install DESTDIR=%{buildroot}
  115. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  116. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  117. # Finally, copy over and rename the various files for %%doc inclusion.
  118. %add_to_doc_files Source/WebKit/LICENSE
  119. %add_to_doc_files Source/WebKit/gtk/NEWS
  120. %add_to_doc_files Source/WebCore/icu/LICENSE
  121. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  122. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  123. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  124. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  125. %add_to_doc_files Source/JavaScriptCore/THANKS
  126. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  127. %add_to_doc_files Source/JavaScriptCore/icu/README
  128. %find_lang WebKitGTK-2.0
  129. %clean
  130. rm -rf %{buildroot}
  131. %post gtk -p /sbin/ldconfig
  132. %posttrans gtk
  133. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  134. %postun gtk
  135. /sbin/ldconfig
  136. if [ $1 -eq 0 ] ; then
  137. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  138. fi
  139. # %files -f webkit.lang gtk
  140. %files gtk -f WebKitGTK-2.0.lang
  141. %defattr(-,root,root,-)
  142. %doc
  143. %{_libdir}/*.so.*
  144. %{_libexecdir}/WebKit/
  145. %{_bindir}/jsc-1
  146. %{_libdir}/girepository-1.0/*.typelib
  147. #%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
  148. %{_datadir}/webkitgtk-1.0/*
  149. %files gtk-devel
  150. %defattr(-,root,root,-)
  151. %exclude %{_libdir}/*.la
  152. %{_includedir}/webkitgtk-1.0
  153. %{_libdir}/*.so
  154. %{_libdir}/pkgconfig/*.pc
  155. %{_datadir}/gir-1.0/*.gir
  156. %files docs -f docfiles.list
  157. %defattr(-,root,root,-)
  158. %{_datadir}/gtk-doc/html/webkitgtk
  159. %{_datadir}/gtk-doc/html/webkitdomgtk
  160. %changelog
  161. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-2
  162. - rebuilt with new toolchain.
  163. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.11-1
  164. - new usptream release
  165. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-2
  166. - rebuild with icu-56.1
  167. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-1
  168. - new usptream release
  169. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.8-1
  170. - new usptream release
  171. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.7-1
  172. - new usptream release
  173. * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.5-1
  174. - new upstream release
  175. * Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
  176. - new upstream release
  177. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
  178. - new upstream release
  179. * Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
  180. - new upstream release
  181. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
  182. - new upstream release
  183. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
  184. - new upstream release
  185. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
  186. - new upstream release
  187. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
  188. - rebuild with icu-52.1
  189. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
  190. - new upstream release
  191. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
  192. - new upstream release
  193. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
  194. - new upstream release
  195. - add BuildRequires: libwebp-devel, libsecret-devel
  196. - change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
  197. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  198. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  199. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  200. - new upstream release
  201. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  202. - new upstream release
  203. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  204. - new upstream release
  205. - add BuildRequires: ruby
  206. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  207. - new upstream release
  208. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  209. - new upstream release
  210. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  211. - new upstream release
  212. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  213. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  214. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  215. - new upstream release
  216. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  217. - new upstream release
  218. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  219. - new upstream release
  220. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  221. - new upstream release
  222. * Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
  223. - new upstream release
  224. - delete Patch0
  225. - add BuildRequires: gtk-doc
  226. * Fri Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
  227. - new upstream release
  228. * Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
  229. - new upstream release
  230. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
  231. - new upstream release
  232. - add BuildRequires: gobject-introspection-devel
  233. - add configure option (--enable-introspection=yes)
  234. - add Patch0 (WebKit-1.2.5-gir.patch)
  235. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
  236. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  237. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  238. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  239. - new upstream release
  240. - add Requires: libsoup-devel (devel package)
  241. - fix configure (remove unrecognized option)
  242. - drop Patch100
  243. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  244. - rebuilt again on ppc
  245. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  246. - new upstream release
  247. - rebuilt with libicu-4.4
  248. - added Patch100 for compiling with libicu-4.4
  249. - s/sqlite-devel/sqlite3-devel/
  250. - s/freetype-devel/freetype2-devel/
  251. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  252. - updated to 1.1.18
  253. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  254. - change BR from libsoup to libsoup-devel
  255. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  256. - new upstream release.
  257. - add Vendor, Distribution and Packager.
  258. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  259. - update to webkit-1.1.10 release version
  260. - added BuildRequires: enchant-devel
  261. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  262. - update to webkit-1.1.6 release version
  263. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  264. - update to new upstream snapshot (svn r41944)
  265. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  266. - update to new upstream snapshot (svn r40471)
  267. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  268. - update to new upstream snapshot (svn r37056)
  269. - disable html5video by default
  270. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  271. - update to new upstream snapshot (svn r36882)
  272. - build with gnome-2.24
  273. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  274. - build without pango by default.
  275. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  276. - update to new upstream snapshot (svn r36053)
  277. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  278. - update to new upstream snapshot (svn r34655)
  279. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  280. - initial build for Vine Linux
  281. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  282. - rebuild for new icu
  283. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  284. - Update to new upstream snapshot (SVN 34279) anyway
  285. - Add BR: libXt-devel
  286. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  287. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  288. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  289. subdirectories either.)
  290. - Reference: bug 442200 (RFE: WebKit Migration)
  291. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  292. tree).
  293. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  294. - Update to new upstream snapshot (SVN 32531).
  295. - Fix bug 443048 and hopefully fix bug 444445
  296. - Modify the process of building GTK+ port a bit
  297. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  298. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  299. - Update to new upstream snapshot (SVN 31787).
  300. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  301. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  302. - Switch to using autotools for building the GTK+ port.
  303. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  304. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  305. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  306. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  307. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  308. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  309. file location mismatch)
  310. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  311. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  312. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  313. - Update to new upstream snapshot (SVN 30667)
  314. - Add some build fixes for GCC 4.3:
  315. + gcc43.patch
  316. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  317. - Autorebuild for GCC 4.3
  318. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  319. - Update to new upstream snapshot (SVN 29336).
  320. - Drop TCSpinLock pthread workaround (fixed upstream):
  321. - TCSpinLock-use-pthread-stubs.patch
  322. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  323. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  324. - Add patch to forcibly build the TCSpinLock code using the pthread
  325. implementation:
  326. + TCSpinLock-use-pthread-stubs.patch
  327. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  328. - Package renamed from WebKitGtk.
  329. - Update to SVN 28482.
  330. - Build both the GTK and Qt ports, putting each into their own respective
  331. subpackages.
  332. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  333. the build-webkit script from upstream.
  334. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  335. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  336. - Initial packaging for Fedora.