123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340 |
- Summary: Network monitoring tools including ping.
- Summary(ja): ping 等のネットワークモニタツール集
- Name: iputils
- Version: 20161105
- Release: 2%{?_dist_release}
- # some parts are under the original BSD (ping.c)
- # some are under GPLv2+ (tracepath.c)
- License: BSD and GPLv2+
- Group: System Environment/Daemons
- URL: https://github.com/iputils/iputils
- Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
- Source1: ifenslave.tar.gz
- Source3: rdisc.initd
- Source5: rdisc.sysconfig
- Source6: ninfod.initd
- Source7: ninfod.sysconfig
- Source10: bsd.txt
- Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
- Patch0: iputils-rh.patch
- Patch1: iputils-ifenslave.patch
- Patch2: 0001-arping-tracepath-removed-unused-idna-header.patch
- Patch3: 0002-traceroute6-use-getaddrinfo-IDNA-conversion.patch
- Patch4: 0003-ping6-simplified-IDNA-usage.patch
- Patch5: 0004-ping-use-libidn2-instead-of-libidn.patch
- # Vine Source(s)/Patch(es)
- Source1000: iputils-s20161105-ja.po
- Patch1000: iputils-s20161105-gettext.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: docbook-utils perl-SGMLSpm
- BuildRequires: glibc-kernheaders >= 2.4-8.19
- BuildRequires: libidn2-devel
- BuildRequires: openssl-devel
- BuildRequires: libcap-devel
- Requires(post): chkconfig
- Requires(preun): chkconfig
- Requires(preun): initscripts
- Requires(postun): initscripts
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- The iputils package contains basic utilities for monitoring a network,
- including ping. The ping command sends a series of ICMP protocol
- ECHO_REQUEST packets to a specified network host to discover whether
- the target machine is alive and receiving network traffic.
- %prep
- %setup -q -a 1 -n %{name}-s%{version}
- cp %{SOURCE10} %{SOURCE11} .
- %patch0 -p1
- %patch1 -p1
- %patch2 -p1
- %patch3 -p1
- %patch4 -p1
- %patch5 -p1
- #
- %patch1000 -p1 -b .gettext
- # add ja.po
- cp %{SOURCE1000} po/ja.po
- %build
- %ifarch s390 s390x
- export CFLAGS="$RPM_OPT_FLAGS -fPIE"
- %else
- export CFLAGS="$RPM_OPT_FLAGS -fpie"
- %endif
- export LDFLAGS="-pie -Wl,-z,relro,-z,now"
- make %{?_smp_mflags} arping clockdiff ping rdisc tracepath ninfod
- gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
- make -C doc man
- make -C po
- %install
- rm -rf ${RPM_BUILD_ROOT}
- mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
- mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
- mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
- install -c clockdiff ${RPM_BUILD_ROOT}%{_sbindir}/
- install -cp arping ${RPM_BUILD_ROOT}/sbin/
- ln -s /sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
- install -cp ping ${RPM_BUILD_ROOT}/bin/
- install -cp ifenslave ${RPM_BUILD_ROOT}/sbin/
- install -cp rdisc ${RPM_BUILD_ROOT}/sbin/
- install -cp tracepath ${RPM_BUILD_ROOT}/bin/
- install -cp ninfod/ninfod ${RPM_BUILD_ROOT}/sbin/
- ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
- ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
- ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
- ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
- mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
- install -cp doc/clockdiff.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- install -cp doc/arping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- install -cp doc/ping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- install -cp doc/rdisc.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- install -cp doc/tracepath.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- install -cp doc/ninfod.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- install -cp ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
- ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
- ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
- find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
- install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
- install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
- install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
- install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
- install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
- make -C po install DESTDIR=$RPM_BUILD_ROOT
- %find_lang %{name}
- iconv -f ISO88591 -t UTF8 RELNOTES -o RELNOTES.tmp
- touch -r RELNOTES RELNOTES.tmp
- mv -f RELNOTES.tmp RELNOTES
- %post
- /sbin/chkconfig --add rdisc
- /sbin/chkconfig --add ninfod
- %preun
- if [ $1 = 0 ]; then
- service rdisc stop >/dev/null 2>&1
- service ninfod stop >/dev/null 2>&1
- /sbin/chkconfig --del rdisc
- /sbin/chkconfig --del ninfod
- fi
- %postun
- if [ "$1" -ge "1" ]; then
- service rdisc condrestart >/dev/null 2>&1 || :
- service ninfod condrestart >/dev/null 2>&1 || :
- fi
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %files -f %{name}.lang
- %defattr(-,root,root)
- %doc bsd.txt gpl-2.0.txt RELNOTES README.*
- %{_sbindir}/clockdiff
- /sbin/arping
- %{_sbindir}/arping
- %attr(4755,root,root) /bin/ping
- /sbin/ifenslave
- /sbin/rdisc
- /bin/tracepath
- /sbin/ninfod
- %{_sbindir}/ping
- %{_sbindir}/ping6
- %{_sbindir}/tracepath
- %{_sbindir}/tracepath6
- %{_mandir}/man8/*
- %{_sysconfdir}/rc.d/init.d/rdisc
- %{_sysconfdir}/rc.d/init.d/ninfod
- %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
- %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
- %changelog
- * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
- - fixed initscripts.
- * Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
- - updated to 20161105.
- - updated gettext patch and translation.
- - updated license.
- * Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
- - update to 20140519
- - update URL to new upstream
- - update gettext patch and translation
- * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
- - new upstream release
- - merget with fedora/20101006-8
- - update gettext patch and ja.po
- * Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
- - rebuild to add sign..
- * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
- - new upstream release
- - spec in utf-8
- * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
- - remove traceroute6 that is now provided by traceroute package.
- - merge changes from FC
- * Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
- - ppc patch (Patch110) removed (it's no necessary now)
- * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
- - update to 20020927 merged with 20020927-13
- - update i18n patch, ja.po
- * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
- - Fixed unaligned access problem on ia64 (#101417)
- * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
- - Dont use own headers, use glibc and kernheaders.
- * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
- - fix build with new glibc-kernheaders
- * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
- - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
- * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
- - One more update to ifenslave.c
- * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
- - Updated ifenslave.c and README.bonding to latest version.
- * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
- - Bumped release and rebuilt
- * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
- - Fixed DNS lookup problems (#68212).
- - Added warning if binding problem failed on subinterface (#81640).
- * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
- - Removed bonding tarball and replaced it with ifenslave.c and README
- - FHS compliance for all tools, now to be found in /bin with compat symlinks to
- old places.
- * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
- - Updated to latest upstream version.
- * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
- - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
- - Fixed ipv6 error printing problem (#66659).
- * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
- - Added a patch to activate the rdisc server (#64270).
- - Display the countermeasures warning only in verbose (#55236)
- * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
- - quit trying to build HTML versions of the man pages
- * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
- - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
- * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
- - Update to iputils-ss020124.
- * Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
- - changed Patch110 to have clear_bit() within the ipv6 source for ppc
- * Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
- - based on 20001110-7 from Rawhide
- - merged Vine changes from 20001010-1vl4
- --- Mon Jul 16 2001 <sagami@vinelinux.org>
- - 20001010-1vl4
- - use %%{find_lang} to fix so as not to own locale dir
- --- Thu Jun 07 2001 <sagami@vinelinux.org>
- - 20001010-1vl3: rebuilt for %%{_mandir}
- --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
- - 20001010-1vl2
- - remove ping6 for ppc
- - added Japanese summary and description
- --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
- - added ja.po and nls patch
- * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
- - Fixed buffer overflow problem in traceroute6.c (#51135)
- * Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
- - Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
- * Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
- - Fixed ping statistics overflow bug (#43801)
- * Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
- - Fixed a bunch of compiler warnings (#37131)
- - Fixed wrong exit code for no packets and deadline (#40323)
- - Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
- /usr/sbin/ provided for backwards compatibility.
- * Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
- - install in.rdisc.8c as rdisc.8
- * Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
- - update to ss001110
- - doco fixes (#23844).
- * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
- - update to ss001007.
- * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
- - fix spelling mistake (#15714).
- * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
- - turn on -U on machines without TSC (#15223).
- * Tue Aug 1 2000 Jeff Johnson <jbj@redhat.com>
- - better doco patch (#15050).
- * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
- - fix include-glibc/ to work with new glibc 2.2 resolver headers
- * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
- - automatic rebuild
- * Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
- - FHS packaging.
- - update to ss000418.
- - perform reverse DNS lookup only once for same input.
- * Sun Mar 5 2000 Jeff Johnson <jbj@redhat.com>
- - include README.ifenslave doco.
- - "ping -i N" was broke for N >= 3 (#9929).
- - update to ss000121:
- -- clockdiff: preserve raw socket errno.
- -- ping: change error exit code to 1 (used to be 92,93, ...)
- -- ping,ping6: if -w specified, transmit until -c limit is reached.
- -- ping,ping6: exit code non-zero if some packets not received within deadline.
- * Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
- - man page corrections (#9690).
- * Wed Feb 9 2000 Jeff Johnson <jbj@jbj.org>
- - add ifenslave.
- * Thu Feb 3 2000 Elliot Lee <sopwith@redhat.com>
- - List /usr/sbin/rdisc in %files list.
- * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
- - add remaining binaries.
- - casts to remove compilation warnings.
- - terminate if -w deadline is reached exactly (#8724).
- * Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
- - create (only ping for now, traceroute et al soon).
|