xorg-x11-drv-intel-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate1 20130611
  4. %define gputoolsdate2 20110817
  5. %if "%{?_dist_release}" >= "vl7"
  6. %define accel sna
  7. %define gputoolsdate 20130611
  8. %else
  9. %define accel sna
  10. %define gputoolsdate 20110817
  11. %endif
  12. Summary: Xorg X11 Intel video driver
  13. Summary(ja): Xorg X11 Intel ビデオドライバ
  14. Name: xorg-x11-drv-intel
  15. Epoch: 1
  16. Version: 2.21.15
  17. Release: 2%{?_dist_release}
  18. URL: http://intellinuxgraphics.org/
  19. License: MIT
  20. Group: User Interface/X Hardware Support
  21. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  22. Source2: intel.xinf
  23. Source3: intel-gpu-tools-%{gputoolsdate1}.tar.bz2
  24. Source4: intel-gpu-tools-%{gputoolsdate2}.tar.bz2
  25. # vine patch
  26. ExclusiveArch: %{ix86} x86_64 ia64
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. BuildRequires: autoconf, automake, libtool
  29. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  30. BuildRequires: libXvMC-devel
  31. BuildRequires: libGL-devel >= 7.10
  32. BuildRequires: libdrm-devel >= 2.4.25
  33. BuildRequires: kernel-headers >= 2.6.33
  34. BuildRequires: libudev-devel
  35. BuildRequires: libxcb-devel >= 1.5
  36. BuildRequires: xcb-util-devel
  37. BuildRequires: cairo-devel
  38. Requires: hwdata
  39. Requires: xorg-x11-server-Xorg
  40. Requires: xcb-util
  41. Obsoletes: xorg-x11-drv-i810
  42. Provides: xorg-x11-drv-i810
  43. #Conflicts: kudzu < 1.2.42-1
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: daisuke
  47. %description
  48. X.Org X11 Intel video driver.
  49. %package devel
  50. Summary: Xorg X11 Intel video driver XvMC development package
  51. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  52. Group: Development/System
  53. Requires: %{name} = %{epoch}:%{version}-%{release}
  54. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  55. %description devel
  56. X.Org X11 Intel video driver XvMC development package.
  57. %package -n intel-gpu-tools
  58. Summary: Debugging tools for Intel graphics chips
  59. Group: Development/Tools
  60. %description -n intel-gpu-tools
  61. Debugging tools for Intel graphics chips
  62. %prep
  63. %setup -q -n xf86-video-intel-%{version} -b3 -b4
  64. %build
  65. autoreconf -vi
  66. %if "%{?_dist_release}" < "vl7"
  67. export CFLAGS="-I/usr/include/X11/dri"
  68. %endif
  69. %configure \
  70. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  71. --enable-dri --enable-xvmc \
  72. --enable-sna --enable-uxa \
  73. --with-default-accel=%{accel} \
  74. --enable-xaa=no
  75. make
  76. pushd ../intel-gpu-tools-%{gputoolsdate}
  77. autoreconf -v --install
  78. %configure --disable-nouveau --disable-dumper
  79. make
  80. popd
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  85. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  86. pushd ../intel-gpu-tools-%{gputoolsdate}
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. popd
  89. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %triggerpostun -- XOrg < 7.0
  93. if (grep -q i810 /etc/X11/xorg.conf)
  94. then
  95. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  96. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  97. fi ||:
  98. %files
  99. %defattr(-,root,root,-)
  100. %{driverdir}/intel_drv.so
  101. %{_datadir}/hwdata/videoaliases/intel.xinf
  102. %{_libdir}/libI810XvMC.so.*
  103. %{_libdir}/libIntelXvMC.so.*
  104. %{_mandir}/man4/i*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_libdir}/libI810XvMC.so
  108. %{_libdir}/libIntelXvMC.so
  109. %files -n intel-gpu-tools
  110. %defattr(-,root,root,-)
  111. %{_bindir}/*
  112. %{_mandir}/man1/intel_*.1*
  113. %changelog
  114. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
  115. - rebuild with VineSeed environment
  116. * Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
  117. - new upstream release
  118. * Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
  119. - new upstream release
  120. - change default accel method to sna.
  121. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
  122. - new upstream release
  123. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
  124. - new upstream release
  125. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  126. - new upstream release
  127. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  128. - new upstream release
  129. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  130. - new upstream release
  131. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  132. - new upstream release
  133. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  134. - new upstream release
  135. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  136. - new upstream release
  137. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  138. - new upstream release
  139. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  140. - new upstream release
  141. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  142. - rebuild with xcb-util-0.3.9
  143. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  144. - disable sna, enable uxa
  145. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  146. - new upstream release
  147. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  148. - rebuild with xserver-1.12.0
  149. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  150. - new upstream release
  151. - enable sna
  152. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  153. - disable sna/vmap
  154. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  155. - new upstram release
  156. - disable copy-fb patch
  157. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  158. - rebuild with xserver-1.11.1.902
  159. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  160. - add --enable-sna --enable-vmap
  161. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  162. - new upstream release
  163. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  164. - rebuild with xcb-util-0.3.8
  165. - drop Patch200
  166. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  167. - update to disable copy_fb on sandybridge/ivybridge
  168. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  169. - update intel.xinf
  170. - add patch10 from fedora
  171. - Clamp VGA pixel clock to 250MHz,
  172. anything higher's going to look awful anyway. (#559426)
  173. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  174. - drop patch1-3 and replaced with new patch1 from git master
  175. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  176. - update intel-gpu-tools
  177. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  178. - add Patch1-3 from upstream
  179. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  180. - new upstream release
  181. - drop upstream patches: 107-115
  182. - temporary disabled patch101
  183. - BR: libdrm >= 2.4.25
  184. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  185. - add Patch101-115 from ubuntu/debian package
  186. - Patch101: Plymouth integration patch
  187. - Patch107: Check null return from uxa_acquire_solid()
  188. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  189. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  190. - Patch110,114: Cherry picks to fix a large number of build warnings.
  191. - Patch111: Fix clipped window plane offset
  192. - Patch112: Fix issue where vertical green line and strange colors
  193. shows up when playing gstreamer with certain videos,
  194. when dragged. (LP 460677)
  195. - Patch113: Fixes GPU lockup during login with
  196. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  197. error messages listed in the gpu dump text. (LP 710321)
  198. - Patch115: Don't fill up Xorg.0.log with
  199. "get vblank counter failed: Invalid argument" warnings.
  200. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  201. - rebuild with xserver-1.10.0
  202. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  203. - new upstream release
  204. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  205. - new upstream release
  206. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  207. - rebuild with xserver-1.9.2
  208. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  209. - new upstream release
  210. - add Patch40: fix uxa planemask (backported)
  211. - add Patch61: add support for backlight on macbooks
  212. - add Patch62: disable page flipping for stability
  213. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  214. - new upstream release
  215. - drop patch70
  216. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  217. - rebuild again with xserver-1.8rc
  218. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  219. - add intel-gpu-tools as sub-package
  220. - rebuild with libdrm-2.4.18
  221. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  222. - new upstream release
  223. - import Patch1,2,60,70 from fedora
  224. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  225. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  226. - add BR; libudev-devel and autoreconf for Patch60
  227. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  228. - rebuild with libdrm-2.4.17
  229. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  230. - new upstream release
  231. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  232. - new upstream release (hopefully fixes severe issues w/ efifb)
  233. - drop all patches already upstreamed; import Patch20/21 from Fedora
  234. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  235. - import Patch121,122 from ubuntu
  236. - build with libdrm-2.4.12 which fixes vt switch crash
  237. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  238. - apply patch114 to fix Xv with non-GEM kernel
  239. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  240. - update to 2.6.3
  241. - add patch106,107,115,118,119,120 from ubuntu
  242. - add Patch106: remove triple buffering
  243. - add Patch107: remove page flipping
  244. - add Patch115: fix crash Xv overlay
  245. - add Patch118: drop legacy3d
  246. - add Patch119: fix crashes in drm bo
  247. - add Patch120: fix vt switch
  248. - add patch130-134 from upstream git
  249. - add Patch130: fix another vt switch leak
  250. - add Patch131: Create known output configuration at EnterVT time
  251. - add Patch132: fix leak of some 965 render state on VT switch
  252. - add Patch133: fix crash with fake bufmgr and UXA
  253. - add Patch134: fix EnterVT/LeaveVT
  254. - add Patch135: add new chip supoprt
  255. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  256. - revert to 2.6.1, add Epoch
  257. - add Patch103-121 from ubuntu
  258. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  259. - new upstream release
  260. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  261. - new upstream release
  262. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  263. - new upstream release
  264. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  265. - add Patch5 - Dont die on irq handler failure
  266. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  267. - new upstream release
  268. - add BR: libdrm-devel >= 2.4.0-3
  269. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  270. - import Patch10,11,12 from ubuntu
  271. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  272. - new upstream release
  273. - add triggerpostun script to replace i810 driver to intel driver
  274. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  275. - new upstream release
  276. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  277. - new upstream release
  278. - rename i810.xinf to intel.xinf
  279. - update intel.xinf (add Intel 4 series)
  280. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  281. - rebuild with new xserver
  282. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  283. - new upstream release
  284. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  285. - new upstream release
  286. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  287. - new upstream release
  288. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  289. - initial build for Vine Linux
  290. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  291. - Rebuild for new server ABI.
  292. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  293. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  294. - hook up ch7017 (bz#408471)
  295. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  296. - xf86-video-intel 2.2.0
  297. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  298. - xf86-video-intel 2.1.99.
  299. - Drop the i810 driver. Time to move on.
  300. - Require xserver 1.4.99.1
  301. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  302. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  303. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  304. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  305. for textured Xv to use as an offscreen pixmap so xv actually works under
  306. compiz - granted it may be unusably slow but at least stuff shows up.
  307. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  308. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  309. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  310. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  311. - intel-2.1.1-quirk-update.patch - update quirks from master
  312. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  313. - i810.xinf: Flip everything over to -intel by default now. Still install
  314. i810 driver just in case.
  315. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  316. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  317. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  318. - xf86-video-intel 2.1.1.
  319. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  320. - xf86-video-intel 2.1.0.
  321. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  322. - Update Requires and BuildRequires.
  323. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  324. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  325. 965GME, G33, Q33, and Q35 chips.
  326. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  327. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  328. DRI clients are active, for better battery life.
  329. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  330. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  331. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  332. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  333. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  334. rename this at some point.
  335. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  336. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  337. 915GM.
  338. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  339. - i810.xinf: More intel whitelisting (#214011, #234877)
  340. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  341. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  342. - i810.xinf: Point 965GM support at the intel driver since it's not present
  343. in old i810.
  344. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  345. - xf86-video-intel-1.9.93 (RC3).
  346. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  347. - fix typo with 945GM pci id from my laptop
  348. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  349. - xf86-video-intel 1.9.92 (RC2).
  350. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  351. - Updated modesetting driver to one that will actually work with a 1.3 server.
  352. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  353. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  354. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  355. code anywhere
  356. - Disown the module
  357. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  358. - update modesetting driver to git snapshot from today
  359. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  360. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  361. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  362. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  363. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  364. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  365. actually require kudzu to run.
  366. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  367. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  368. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  369. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  370. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  371. driver match the corresponding terrible heuristic in the server.
  372. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  373. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  374. correctly distinguish between Mac Mini and Macbook Pro.
  375. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  376. - i810.xinf: PCI IDs for i965.
  377. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  378. - i810.xinf: Uppercase PCI IDs.
  379. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  380. - Update i810 to 1.6.5, should fix DRI.
  381. - Add kuzdu requires.
  382. - i810.xinf: Start whitelisting devices over to intel.
  383. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  384. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  385. you know, load.
  386. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  387. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  388. LFP special casing in favor of the blacklist.
  389. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  390. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  391. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  392. and is selected with Driver "intel" in xorg.conf. Individual devices will
  393. whitelist over to "intel" until that branch gets merged into head.
  394. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  395. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  396. the BIOS is known to lie.
  397. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  398. - Today's snapshot: I2C bus creation fix.
  399. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  400. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  401. clock when computing the modes list.
  402. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  403. in centimeters as the size of the display in pixels.
  404. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  405. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  406. probing.
  407. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  408. - Update again for a mode comparison bugfix.
  409. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  410. - Update to today's git; crash fixes, better pre-915 support, slightly better
  411. autoconfigurability.
  412. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  413. - rebuild
  414. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  415. - Fix Revision number to match naming policy.
  416. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  417. - Add back modesetting changes.
  418. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  419. - Roll back modesetting changes and build for fc5 aiglx repo.
  420. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  421. - Snapshot of the git modesetting branch.
  422. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  423. - Update i810.xinf to include entries for E7221 and 945GM.
  424. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  425. - Add with_dri macro to spec file, and conditionalize build time DRI support
  426. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  427. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  428. to pick up proto-devel as well.
  429. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  430. - Rebuild for 7.1 ABI fix.
  431. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  432. - Bump for fc5-bling build.
  433. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  434. - Update to 1.6.0 from 7.1RC1.
  435. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  436. - Add patch to add missing #include's, specifically assert.h.
  437. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  438. - Update to CVS snapshot of 20060322.
  439. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  440. - rebuilt for new gcc4.1 snapshot and glibc changes
  441. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  442. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  443. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  444. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  445. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  446. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  447. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  448. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  449. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  450. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  451. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  452. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  453. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  454. - Fix *.la file removal.
  455. - Added 'devel' subpackage for XvMC .so
  456. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  457. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  458. - Update BuildRoot to use Fedora Packaging Guidelines.
  459. - Deglob file manifest.
  460. - Limit "ExclusiveArch" to x86, x86_64, ia64
  461. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  462. - Initial spec file for i810 video driver generated automatically
  463. by my xorg-driverspecgen script.