freerdp-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241
  1. #define rcnumber rc4
  2. Name: freerdp
  3. Summary: Remote Desktop Protocol client
  4. Summary(ja): リモートデスクトッププロトコルクライアント
  5. Version: 2.1.0
  6. Release: 1%{?rcnumber:.%{rcnumber}}%{?_dist_release}
  7. Group: Applications/Internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: http://www.freerdp.com/
  12. Source0: https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: xmlto
  16. BuildRequires: alsa-lib-devel
  17. BuildRequires: cups-devel
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXcursor-devel
  20. BuildRequires: libXdamage-devel
  21. BuildRequires: libXext-devel
  22. BuildRequires: libXinerama-devel
  23. BuildRequires: libxkbfile-devel
  24. BuildRequires: libXv-devel
  25. BuildRequires: libusb1-devel
  26. BuildRequires: zlib-devel
  27. BuildRequires: openssl-devel
  28. BuildRequires: pulseaudio-libs-devel
  29. BuildRequires: pcsc-lite-devel
  30. BuildRequires: desktop-file-utils
  31. Provides: xfreerdp = %{version}-%{release}
  32. Obsoletes: freerdp-plugins < 2.0.0
  33. Requires: %{name}-libs = %{version}-%{release}
  34. %description
  35. The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
  36. project.
  37. xfreerdp can connect to RDP servers such as Microsoft Windows
  38. machines, xrdp and VirtualBox.
  39. %package libs
  40. Summary: Core libraries implementing the RDP protocol
  41. Summary(ja): RDPプロトコル実装のコアライブラリ
  42. Group: System Environment/Libraries
  43. %description libs
  44. libfreerdp implements the core of the RDP protocol.
  45. libfreerdpchanman can be used to load plugins that can handle channels
  46. in the RDP protocol.
  47. libfreerdpkbd implements functionality for handling keyboards in X.
  48. %package devel
  49. Summary: Development files for %{name}
  50. Summary(ja): %{name}の開発ファイル
  51. Group: Development/Libraries
  52. Requires: %{name}-libs = %{version}-%{release}
  53. Requires: pkgconfig
  54. %description devel
  55. The %{name}-devel package contains libraries and header files for
  56. developing applications that use %{name}-libs.
  57. %prep
  58. %setup -q
  59. cat << EOF > xfreerdp.desktop
  60. [Desktop Entry]
  61. Type=Application
  62. Name=X FreeRDP
  63. NoDisplay=true
  64. Comment=Connect to RDP server and display remote desktop
  65. Icon=%{name}
  66. Exec=/usr/bin/xfreerdp
  67. Terminal=false
  68. Categories=Network;RemoteAccess;
  69. EOF
  70. %build
  71. %cmake \
  72. -DCMAKE_BUILD_TYPE=Release \
  73. -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
  74. -DWITH_ALSA=ON \
  75. -DWITH_CUPS=ON \
  76. -DWITH_OPENSSL=ON \
  77. -DWITH_PCSC=ON \
  78. -DWITH_PULSE=ON \
  79. -DWITH_X11=ON \
  80. -DWITH_XCURSOR=ON \
  81. -DWITH_XEXT=ON \
  82. -DWITH_XINERAMA=ON \
  83. -DWITH_XKBFILE=ON \
  84. -DWITH_XV=ON \
  85. -DWITH_ZLIB=ON \
  86. -DWITH_CUNIT=OFF \
  87. -DWITH_DIRECTFB=OFF \
  88. -DWITH_FFMPEG=OFF \
  89. %ifarch x86_64
  90. -DWITH_SSE2=ON \
  91. %else
  92. -DWITH_SSE2=OFF \
  93. %endif
  94. .
  95. make %{?_smp_mflags}
  96. pushd winpr/tools/makecert-cli
  97. make %{?_smp_mflags}
  98. popd
  99. %install
  100. rm -rf %{buildroot}
  101. %makeinstall DESTDIR=%{buildroot}
  102. %makeinstall DESTDIR=%{buildroot} COMPONENT=tools
  103. find %{buildroot} -name "*.a" -delete
  104. # No need for keymap files when using xkbfile
  105. rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
  106. desktop-file-install --dir=%{buildroot}%{_datadir}/applications xfreerdp.desktop
  107. install -p -D resources/FreeRDP_Icon_256px.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  108. %clean
  109. rm -rf %{buildroot}
  110. %post
  111. # This is no gtk application, but try to integrate nicely with GNOME if it is available
  112. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  113. %post libs -p /sbin/ldconfig
  114. %postun libs -p /sbin/ldconfig
  115. %files
  116. %defattr(-,root,root,-)
  117. %{_datadir}/applications/xfreerdp.desktop
  118. %{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  119. %{_bindir}/winpr-hash
  120. %{_bindir}/winpr-makecert
  121. %{_bindir}/xfreerdp
  122. %{_mandir}/man1/winpr-hash.1.*
  123. %{_mandir}/man1/winpr-makecert.1.*
  124. %{_mandir}/man1/xfreerdp.1.*
  125. %files libs
  126. %defattr(-,root,root,-)
  127. %license LICENSE
  128. %doc README ChangeLog
  129. %{_libdir}/lib*.so.*
  130. %{_mandir}/man7/wlog.*
  131. %files devel
  132. %defattr(-,root,root,-)
  133. %{_includedir}/*
  134. %{_libdir}/cmake/*
  135. %{_libdir}/lib*.so
  136. %{_libdir}/pkgconfig/*.pc
  137. %changelog
  138. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  139. - updated to 2.1.0.
  140. * Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1.rc4
  141. - updated to 2.0.0-RC4.
  142. - dropped all patches.
  143. - dropped subpackage 'freerdp-plugins'.
  144. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  145. - add BuildRequires: alsa-lib-devel
  146. * Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
  147. - update to 1.0.2
  148. - fixed typo in Group
  149. - dropped Patch0 and Patch1
  150. - added Patch2 to build with current xmlto
  151. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  152. - update to 1.0.1
  153. - import patches from fedora package.
  154. - add BRs.
  155. * Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  156. - initial build for Vine Linux
  157. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  159. * Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
  160. - rebuild on rawhide because of broken dependencies
  161. * Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
  162. - freerdp-0.8.2
  163. * Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
  164. - make -devel require pkgconfig
  165. - first official Fedora package
  166. * Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
  167. - freerdp-0.8.1
  168. * Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
  169. - hack the generated libtool to not set rpath on x86_64
  170. - configure with alsa explicitly
  171. * Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
  172. - freerdp-0.7.4
  173. - cleanup of packaging structure
  174. * Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
  175. - 0.7.3
  176. - fix some minor pylint warnings
  177. * Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
  178. - 0.7.2
  179. - Address many comments from cwickert:
  180. - - cleanup of old formatting, alignment with spectemplate-lib.spec and
  181. cwickert spec from #616193
  182. - - add alsa as build requirement
  183. - - remove superfluous configure options and disable static libs
  184. - - add missing rpm groups
  185. * Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
  186. - First official release, first review request