herqq-vl.spec 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. %define _qt4_ver 4.8.0
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
  5. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  6. Name: herqq
  7. Summary: A software library for building UPnP devices and control points
  8. Version: 1.0.0
  9. Release: 4%{?_dist_release}
  10. # test application is GPLv3 but we do not ship it
  11. License: LGPLv3+
  12. Group: System Environment/Libraries
  13. URL: http://herqq.org/
  14. Source0: http://downloads.sourceforge.net/project/hupnp/hupnp/%{name}-%{version}.zip
  15. Patch2: herqq-1.0.0-qtsoap-library.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: qt4-devel
  19. BuildRequires: qtsoap-devel
  20. Requires: qt4 >= %{_qt4_version}
  21. %description
  22. Herqq UPnP (HUPnP) is a software library for building UPnP
  23. devices and control points conforming to the UPnP Device
  24. Architecture version 1.1.
  25. %package devel
  26. Summary: Development files for %{name}
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: qt4-devel >= %{_qt4_version}
  30. %description devel
  31. Header files for developing applications using %{name}.
  32. %prep
  33. %setup -q
  34. # lQtSolutions to lqtsoap
  35. %patch2 -p1 -b .qtsoap-library
  36. %build
  37. # we have to disable bundled QtSOAP library
  38. qmake PREFIX=%{_prefix} -config DISABLE_QTSOAP \
  39. -config DISABLE_TESTAPP -config USE_QT_INSTALL_LOC
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. make INSTALL_ROOT=%{buildroot} install
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %post -p /sbin/ldconfig
  47. %postun -p /sbin/ldconfig
  48. %files
  49. %doc hupnp/ChangeLog hupnp/LICENSE_LGPLv3.txt
  50. %{_qt4_libdir}/libHUpnp.so.1*
  51. %files devel
  52. %{_qt4_libdir}/libHUpnp.so
  53. %{_qt4_headerdir}/HUpnpCore/
  54. %changelog
  55. * Mon Oct 27 2014 Ryoiochi INAGAKI <ryo1@toki.waseda.jp> - 1.0.0-4
  56. - added Group tag
  57. - added %%clean section
  58. * Sun Jan 8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  59. - rebuilt with qt-4.8.0
  60. * Sun Jul 31 2011 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  61. - Initial build for Vine Linux
  62. * Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 1.0.0-1
  63. - post-review update to 1.0.0
  64. * Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-3
  65. - fix license to LGPLv3+
  66. - qt4 header dir for consistency
  67. - shlib soname tracked in %files
  68. - -devel should not duplicate COPYING
  69. * Tue Jul 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-2
  70. - qtsoap library
  71. - cleanup SPEC file
  72. * Tue Feb 22 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-1
  73. - Initial spec file