libtorrent-rasterbar-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: libtorrent-rasterbar
  4. Version: 1.1.6
  5. Release: 1%{?_dist_release}
  6. Summary: A C++ BitTorrent library aiming to be the best alternative
  7. Summary(ja): 最良の代替手段となることを目指す C++ BitTorrent ライブラリ
  8. Group: System Environment/Libraries
  9. License: BSD
  10. URL: http://www.rasterbar.com/products/libtorrent/
  11. Source0: http://downloads.sourceforge.net/libtorrent/libtorrent-rasterbar-%{version}.tar.gz
  12. # https://github.com/arvidn/libtorrent/releases/download/libtorrent-1_1/libtorrent-rasterbar-%{version}.tar.gz
  13. Source1: %{name}-COPYING.Boost
  14. Source2: %{name}-COPYING.zlib
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: asio-devel
  17. BuildRequires: libboost-devel libboost-filesystem libboost-program-options libboost-chrono
  18. BuildRequires: libboost-python libboost-regex libboost-system libboost-thread libboost-random
  19. BuildRequires: libtool
  20. BuildRequires: python-devel
  21. BuildRequires: python-setuptools
  22. BuildRequires: zlib-devel
  23. ## Necessary for 'rename'...
  24. BuildRequires: util-linux
  25. ## The following is taken from it's website listing...mostly.
  26. %description
  27. %{name} is a C++ library that aims to be a good alternative to all
  28. the other BitTorrent implementations around. It is a library and not a full
  29. featured client, although it comes with a few working example clients.
  30. Its main goals are to be very efficient (in terms of CPU and memory usage) as
  31. well as being very easy to use both as a user and developer.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Summary(ja): %{name} の開発ファイル
  35. Group: Development/Libraries
  36. License: BSD and zlib and Boost
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: pkgconfig
  39. ## Same include directory. :(
  40. Conflicts: libtorrent-devel
  41. ## Needed for various headers used via #include directives...
  42. Requires: asio-devel
  43. Requires: libboost-devel
  44. Requires: openssl-devel
  45. %description devel
  46. The %{name}-devel package contains libraries and header files for
  47. developing applications that use %{name}.
  48. The various source and header files included in this package are licensed
  49. under the revised BSD, zlib/libpng, and Boost Public licenses. See the various
  50. COPYING files in the included documentation for the full text of these
  51. licenses, as well as the comments blocks in the source code for which license
  52. a given source or header file is released under.
  53. %package examples
  54. Summary: Example clients using %{name}
  55. Summary(ja): %{name} で使用する模範クライアント
  56. Group: Applications/Internet
  57. License: BSD
  58. Requires:%{name} = %{version}-%{release}
  59. %description examples
  60. The %{name}-examples package contains example clients which intend to
  61. show how to make use of its various features. (Due to potential
  62. namespace conflicts, a couple of the examples had to be renamed. See the
  63. included documentation for more details.)
  64. %package python
  65. Summary: Python bindings for %{name}
  66. Summary(ja): %{name} の Python バインディング
  67. Group: System Environment/Libraries
  68. License: Boost
  69. Requires: %{name} = %{version}-%{release}
  70. %description python
  71. The %{name}-python package contains Python language bindings (the 'libtorrent'
  72. module) that allow it to be used from within Python applications.
  73. %prep
  74. %setup -q -n "libtorrent-rasterbar-%{version}"
  75. ## The RST files are the sources used to create the final HTML files; and are
  76. ## not needed.
  77. %{__rm} -f docs/*.rst
  78. ## Ensure that we get the licenses installed appropriately.
  79. %{__install} -p -m 0644 COPYING COPYING.BSD
  80. %{__install} -p -m 0644 %{SOURCE1} COPYING.Boost
  81. %{__install} -p -m 0644 %{SOURCE2} COPYING.zlib
  82. ## Finally, ensure that everything is UTF-8, as it should be.
  83. iconv -t UTF-8 -f ISO_8859-15 AUTHORS -o AUTHORS.iconv
  84. %{__mv} AUTHORS.iconv AUTHORS
  85. %build
  86. %configure --disable-static \
  87. --enable-examples \
  88. --enable-tests \
  89. --enable-python-binding \
  90. CXXFLAGS="-std=c++11"
  91. # ## Use the system libtool to ensure that we don't get unnecessary RPATH
  92. # ## hacks in our final build.
  93. # %{__make} %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  94. %{__make} %{?_smp_mflags}
  95. %install
  96. %{__rm} -rf %{buildroot}
  97. # ## Ensure that we preserve our timestamps properly.
  98. # export CPPROG="%{__cp} -p"
  99. # %{__make} install DESTDIR=%{buildroot} INSTALL="%{__install} -c -p"
  100. %{__make} install DESTDIR=%{buildroot}
  101. %{__rm} %{buildroot}%{_libdir}/*.la
  102. ## Do the renaming due to the somewhat limited %%_bindir namespace.
  103. rename client torrent_client %{buildroot}%{_bindir}/*
  104. %check
  105. %{__make} check
  106. %clean
  107. %{__rm} -rf %{buildroot}
  108. %post -p %{_syssbindir}/ldconfig
  109. %postun -p %{_syssbindir}/ldconfig
  110. %files
  111. %defattr(-,root,root,-)
  112. %doc AUTHORS ChangeLog COPYING
  113. %{_libdir}/libtorrent-rasterbar.so.*
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %doc COPYING.Boost COPYING.BSD COPYING.zlib docs/
  117. %{_libdir}/pkgconfig/libtorrent-rasterbar.pc
  118. %{_includedir}/libtorrent/
  119. %{_libdir}/libtorrent-rasterbar.so
  120. %files examples
  121. %{_bindir}/bt_get*
  122. %{_bindir}/*torrent*
  123. %{_bindir}/connection_tester
  124. #%{_bindir}/enum_if
  125. #%{_bindir}/fragmentation_test
  126. #%{_bindir}/parse_hash_fails
  127. # %{_bindir}/parse_request_log
  128. # %{_bindir}/rss_reader
  129. %{_bindir}/stats_counters
  130. %{_bindir}/upnp_test
  131. #%{_bindir}/utp_test
  132. %files python
  133. %defattr(-,root,root,-)
  134. %doc AUTHORS ChangeLog COPYING.Boost bindings/python/{simple_,}client.py
  135. %{python_sitearch}/python_libtorrent-%{version}-py?.?.egg-info
  136. %{python_sitearch}/libtorrent.so
  137. %changelog
  138. * Thu Jan 18 2018 Toshiaki Ara <ara_t@384.jp> - 1.1.6-1
  139. - new upstream release
  140. - add configure option: --enable-tests and CXXFLAGS="-std=c++11"
  141. - delete old comments
  142. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.9-2
  143. - rebuild with gcc-5.4.0
  144. * Tue Jun 14 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.9-1
  145. - new upstream release
  146. - added Buildrequires: libboost-chrono, libboost-random
  147. - deleted --with-zlib=system in %%configure
  148. - fixed -examples %%files
  149. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.13-3
  150. - rebuild with openssl-1.0.2
  151. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.16.13-2
  152. - moved python subpackage to System Environment/Libraries Group
  153. * Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16.13-1
  154. - new upstream release
  155. * Mon May 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16.9-1
  156. - new upstream release
  157. * Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.10-1
  158. - new upstream release
  159. - changed BuildRequires: util-linux-ng to util-linux
  160. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 0.15.4-3
  161. - rebuilt with libboost-1.45.0
  162. * Mon Jan 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-2
  163. - rebuilt with openssl-1.0.0c
  164. - deleted unrecognized configure option (--with-asio)
  165. * Tue Oct 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-1
  166. - new upstream release
  167. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.3-2
  168. - rebuild with rpm-4.8.1 for pkg-config file
  169. * Tue Sep 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.3-1
  170. - new upstream release
  171. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.2-1
  172. - new upstream release
  173. * Sun Jul 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-1
  174. - new upstream release
  175. * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.0-1
  176. - new upstream release
  177. * Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.9-1
  178. - new upstream release
  179. - applied new naming policy to spec
  180. * Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 0.14.8-2
  181. - rebuilt with new toolchain, python-2.6.4-3
  182. * Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.8-1
  183. - new upstream release
  184. * Thu Dec 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.7-1
  185. - new upstream release
  186. * Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.6-1
  187. - initial build for VineSeed
  188. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.14.4-3
  189. - rebuilt with new openssl
  190. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.4-2
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  192. * Tue Jun 02 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.4-1
  193. - Update to new upstream release (0.14.4).
  194. - Drop outdated Boost patch.
  195. * Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-2
  196. - Rebuild for the Boost 1.39.0 update.
  197. * Mon Apr 27 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-1
  198. - Update to new upstream bug-fix release (0.14.3).
  199. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.2-2
  200. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  201. * Fri Feb 20 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.2-1
  202. - Update to new upstream bug-fix release (0.14.2)
  203. - Drop Python 2.6 and configure fix patches (fixed upstream):
  204. - python26.patch
  205. - configure-dont-use-locate.patch
  206. * Fri Jan 16 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-2
  207. - Rebuild for the soname bump in openssl-0.9.8j
  208. * Mon Jan 05 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-1
  209. - Update to new upstream release (0.14.1)
  210. - Add asio-devel as runtime dependency for the devel subpackage (#478589)
  211. - Add patch to build with Python 2.6:
  212. + python26.patch
  213. - Add patch to make the configure script use the proper python include
  214. directory instead of calling locate, as that can cause failures in a chroot
  215. with no db file (and is a bit silly in the first place):
  216. + configure-dont-use-locate.patch
  217. - Drop manual setup.py for building the python module (fixed upstream):
  218. - setup.py
  219. - Update Source0 URL back to SourceForge's hosting.
  220. - Reenable the examples, since the Makefiles are fixed.
  221. * Fri Dec 19 2008 Petr Machata <pmachata@redhat.com> - 0.13.1-7
  222. - Rebuild for boost-1.37.0.
  223. * Wed Dec 17 2008 Benjamin Kosnik <bkoz@redhat.com> - 0.13.1-6
  224. - Rebuild for boost-1.37.0.
  225. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-5
  226. - Fix locations for Python 2.6
  227. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-4
  228. - Rebuild for Python 2.6
  229. * Thu Nov 20 2008 Peter Gordon <peter@thecodergeek.com>
  230. - Update Source0 URL, for now.
  231. * Wed Sep 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.13.1-3
  232. - fix license tag
  233. * Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-2
  234. - Add python bindings in a -python subpackage.
  235. * Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-1
  236. - Update to new upstream release (0.13.1): Contains an incompatible ABI/API
  237. bump.
  238. - Drop GCC 4.3 patch (fixed upstream):
  239. - gcc43.patch
  240. - Disable building the examples for now. (Attempted builds fail due to missing
  241. Makefile support.)
  242. - Drop the source permissions and pkgconfig file tweaks (fixed upstream).
  243. * Sat Feb 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.12.1-1
  244. - Update to new upstream bug-fix release (0.12.1)
  245. - Rebuild for GCC 4.3
  246. - Drop security fix patch (merged upstream):
  247. - svn1968-bdecode_recursive-security-fix.patch
  248. - Add GCC 4.3 build fixes (based on patch from Adel Gadllah, bug 432778):
  249. + gcc43.patch
  250. * Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.12-3
  251. - Add upstream patch (changeset 1968) to fix potential security vulnerability:
  252. malformed messages passed through the bdecode_recursive routine could cause
  253. a potential stack overflow.
  254. + svn1968-bdecode_recursive-security-fix.patch
  255. * Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  256. - Rebuild against new Boost libraries.
  257. * Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  258. - Update to new upstream release (0.12 Final)
  259. - Split examples into a subpackage. Applications that use rb_libtorrent
  260. don't need the example binaries installed; and splitting the package in this
  261. manner is a bit more friendly to multilib environments.
  262. * Sun Mar 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-0.rc1
  263. - Update to new upstream release (0.12 RC).
  264. - Forcibly use the system libtool to ensure that we remove any RPATH hacks.
  265. * Sun Jan 28 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-5
  266. - Fix installed pkgconfig file: Strip everything from Libs except for
  267. '-ltorrent', as its [libtorrent's] DSO will ensure proper linking to other
  268. needed libraries such as zlib and boost_thread. (Thanks to Michael Schwendt
  269. and Mamoru Tasaka; bug #221372)
  270. * Sat Jan 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-4
  271. - Clarify potential licensing issues in the -devel subpackage:
  272. + COPYING.zlib
  273. + COPYING.Boost
  274. - Add my name in the Fedora-specific documentation (README-renames.Fedora) and
  275. fix some spacing issues in it.
  276. - Strip the @ZLIB@ (and thus, the extra '-lz' link option) from the installed
  277. pkgconfig file, as that is only useful when building a statically-linked
  278. libtorrent binary.
  279. - Fix conflict: The -devel subpackage should conflict with the -devel
  280. subpackage of libtorrent, not the main package.
  281. - Preserve timestamps in %%install.
  282. * Wed Jan 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-3
  283. - Fix License (GPL -> BSD)
  284. - Don't package RST (docs sources) files.
  285. - Only make the -devel subpackage conflict with libtorrent-devel.
  286. - Rename some of the examples more appropriately; and add the
  287. README-renames.Fedora file to %%doc which explains this.
  288. * Fri Jan 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-2
  289. - Add Requires: pkgconfig to the -devel subpackage since it installs a .pc
  290. file.
  291. * Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  292. - Initial packaging for Fedora Extras