123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- %define _unpackaged_files_terminate_build 1
- %define talloc_version 2.1.9
- %define tdb_version 1.3.14
- %define tevent_version 0.9.32
- Name: libldb
- Summary: A schema-less, ldap like, API and database
- Version: 1.1.31
- Release: 1%{?_dist_release}
- Group: System Environment/Libraries
- License: LGPLv3+
- URL: http://ldb.samba.org/
- Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
- # Patches
- Patch1001: FED01-fix-tevent-check.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: libtalloc-devel >= %{talloc_version}
- BuildRequires: libtdb-devel >= %{tdb_version}
- BuildRequires: libtevent-devel >= %{tevent_version}
- BuildRequires: popt-devel
- BuildRequires: autoconf
- BuildRequires: libxslt
- BuildRequires: docbook-style-xsl
- BuildRequires: python-devel
- BuildRequires: python-tdb
- BuildRequires: pytalloc-devel
- BuildRequires: python-tevent
- BuildRequires: doxygen
- Requires: libtalloc >= %{talloc_version}
- Requires: libtdb >= %{tdb_version}
- Requires: libtevent >= %{tevent_version}
- Provides: bundled(libreplace)
- Provides: bundled(libtdb_compat)
- Provides: bundled(libccan)
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: tomop
- %description
- An extensible library that implements an LDAP like API to access remote LDAP
- servers, or use local tdb databases.
- %package -n ldb-tools
- Group: Applications/System
- Summary: Tools to manage LDB files
- Requires: libldb = %{version}-%{release}
- %description -n ldb-tools
- Tools to manage LDB files
- %package devel
- Group: Development/Libraries
- Summary: Developer tools for the LDB library
- Requires: libldb = %{version}-%{release}
- Requires: libtdb-devel >= %{tdb_version}
- Requires: libtalloc-devel >= %{talloc_version}
- Requires: libtevent-devel >= %{tevent_version}
- Requires: pkgconfig
- %description devel
- Header files needed to develop programs that link against the LDB library.
- %package -n pyldb
- Group: System Environment/Libraries
- Summary: Python bindings for the LDB library
- Requires: libldb = %{version}-%{release}
- Requires: python-tdb >= %{tdb_version}
- %description -n pyldb
- Python bindings for the LDB library
- %package -n pyldb-devel
- Group: Development/Libraries
- Summary: Development files for the Python bindings for the LDB library
- Requires: pyldb = %{version}-%{release}
- %description -n pyldb-devel
- Development files for the Python bindings for the LDB library
- %if %build_compat32
- %package -n compat32-%{name}
- Summary: A schema-less, ldap like, API and database
- Group: System Environment/Libraries
- %description -n compat32-%{name}
- An extensible library that implements an LDAP like API to access remote LDAP
- servers, or use local tdb databases.
- %endif
- %prep
- %setup -q -n ldb-%{version}
- %patch1001 -p1
- %build
- # tdb_compat and ccan have no upstream releases to link against yet and their
- # API is in flux. It is unsafe to make them public and shared at this time.
- %configure --disable-rpath \
- --disable-rpath-install \
- --bundled-libraries=cmocka \
- --builtin-libraries=tdb_compat,ccan,replace \
- --with-modulesdir=%{_libdir}/ldb/modules \
- --with-privatelibdir=%{_libdir}/ldb
- make V=1 %{?_smp_mflags}
- doxygen Doxyfile
- %install
- make install DESTDIR=%{buildroot}
- rm -f %{buildroot}%{_libdir}/libldb.a
- # Remove _tevent.so (it's managed by python-tevent)
- #rm -f %{buildroot}/%{python_sitearch}/_tevent.so
- # Shared libraries need to be marked executable for
- # rpmbuild to strip them and include them in debuginfo
- find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
- # Install API docs
- cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
- # drop garbages
- rm -f %{buildroot}%{_mandir}/man3/_home_vbuilder_rpm_BUILD_ldb-*_include_.3*
- rm -f %{buildroot}%{_mandir}/man3/ldif_read_file_state.3*
- %clean
- rm -rf %{buildroot}
- %post
- /sbin/ldconfig
- %postun
- /sbin/ldconfig
- %post -n pyldb
- /sbin/ldconfig
- %postun -n pyldb
- /sbin/ldconfig
- %if %build_compat32
- %post -n compat32-%{name}
- /sbin/ldconfig
- %postun -n compat32-%{name}
- /sbin/ldconfig
- %endif
- %files
- %defattr(-,root,root,-)
- %dir %{_libdir}/ldb
- %{_libdir}/libldb.so.*
- %dir %{_libdir}/ldb/modules
- %dir %{_libdir}/ldb/modules/ldb
- %{_libdir}/ldb/libldb-cmdline.so
- %{_libdir}/ldb/libcmocka-ldb.so
- %{_libdir}/ldb/modules/ldb/*.so
- %files -n ldb-tools
- %defattr(-,root,root,-)
- %{_bindir}/ldbadd
- %{_bindir}/ldbdel
- %{_bindir}/ldbedit
- %{_bindir}/ldbmodify
- %{_bindir}/ldbrename
- %{_bindir}/ldbsearch
- %{_mandir}/man1/ldbadd.1.*
- %{_mandir}/man1/ldbdel.1.*
- %{_mandir}/man1/ldbedit.1.*
- %{_mandir}/man1/ldbmodify.1.*
- %{_mandir}/man1/ldbrename.1.*
- %{_mandir}/man1/ldbsearch.1.*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/ldb_module.h
- %{_includedir}/ldb_handlers.h
- %{_includedir}/ldb_errors.h
- %{_includedir}/ldb_version.h
- %{_includedir}/ldb.h
- %{_libdir}/libldb.so
- %{_libdir}/pkgconfig/ldb.pc
- %{_mandir}/man3/ldb*.gz
- %files -n pyldb
- %defattr(-,root,root,-)
- %{python_sitearch}/ldb.so
- %{python_sitearch}/_ldb_text.*
- %{_libdir}/libpyldb-util.so.1*
- %files -n pyldb-devel
- %defattr(-,root,root,-)
- %{_includedir}/pyldb.h
- %{_libdir}/libpyldb-util.so
- %{_libdir}/pkgconfig/pyldb-util.pc
- %{_mandir}/man*/Py*.gz
- %if %build_compat32
- %files -n compat32-%{name}
- %defattr(-,root,root,-)
- %dir %{_libdir}/ldb
- %{_libdir}/libldb.so.*
- %dir %{_libdir}/ldb/modules
- %dir %{_libdir}/ldb/modules/ldb
- %{_libdir}/ldb/libldb-cmdline.so
- %{_libdir}/ldb/libcmocka-ldb.so
- %{_libdir}/ldb/modules/ldb/*.so
- %endif
- %changelog
- * Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
- - new upstream release.
- * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
- - new upstream release.
- * Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
- - new upstream release.
- * Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
- - new upstream release.
- * Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
- - new upstream release.
- * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
- - new upstream release.
- * Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
- - new upstream release.
- * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
- - added compat32 package.
- * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
- - new upstream release.
- * Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
- - new upstream release.
- * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
- - new upstream release.
- * Fri Oct 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
- - moved libldb and pyldb to System Environment/Libraries Group
- - moved ldb-tool to Applications/System Group
- * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
- - new upstream release.
- * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
- - rebuilt with current environment.
- * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
- - new upstream release.
- * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
- - new upstream release.
- * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
- - moved libldb-cmdline.so to main package.
- * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
- - fixed dependency.
- * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
- - new upstream release.
- - initial build for Vine Linux.
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
- - New upstream release
- - Add ldb_module_error() routine
- - Fedora: work around unreliable configure check for pytevent
- - Drop patch to ignore --disable-silent-rules (included in tarball)
- * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
- - Add patch to ignore --disable-silent-rules
- * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
- - Add explicit mention of the bundled libreplace
- - https://fedorahosted.org/fpc/ticket/120
- - Add explicit mention of bundled libtdb_compat and libccan
- - https://fedorahosted.org/fpc/ticket/119
- * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
- - Build and install API documentation
- - Build tdb_compat and ccan statically. They have no upstream releases to
- link against yet and their API is in flux. It is unsafe to make them
- public and shared at this time.
- * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
- - New upstream release
- - Required for building newer samba4 packages
- * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
- - Update to 1.1.0
- (dependency for samba4 alpha16 snapshot)
- * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
- - Update to 1.0.2
- (dependency for samba4 alpha15 snapshot)
- * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
- - Disable rpath
- * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
- - New upstream release 1.0.0
- - SOname bump to account for module loading changes
- - Rename libldb-tools to ldb-tools to make upgrades easier
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
- - Fixes from package review
- - Change Requires: on tools subpackage to be the exact version/release
- - Remove unnecessary BuildRoot directive
- * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
- - Update to 0.9.22 (first independent release of libldb upstream)
|