libdb-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define __soversion_major 5
  3. %define __soversion %{__soversion_major}.3
  4. %bcond_with java
  5. Summary: The Berkeley DB database library for C
  6. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  7. Name: libdb
  8. Version: 5.3.28
  9. Release: 11%{?_dist_release}
  10. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  11. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  12. # For mt19937db.c
  13. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  14. Patch0: libdb-multiarch.patch
  15. # db-1.85 upstream patches
  16. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  17. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  18. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  19. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  20. # other patches
  21. Patch20: db-1.85-errno.patch
  22. Patch22: db-4.6.21-1.85-compat.patch
  23. Patch24: db-4.5.20-jni-include-dir.patch
  24. # License clarification patch
  25. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  26. Patch25: 007-mt19937db.c_license.patch
  27. #Adds missing constant to Optcodes.java and changes ClassReader.java to use it. This makes package to build with Java 8.
  28. Patch26: java8-fix.patch
  29. # memp_stat fix provided by upstream (rhbz#1211871)
  30. Patch27: db-5.3.21-memp_stat-upstream-fix.patch
  31. # fix for mutexes not being released provided by upstream (rhbz#1277887)
  32. Patch28: db-5.3.21-mutex_leak.patch
  33. # fix for overflowing hash variable inside bundled lemon
  34. Patch29: db-5.3.28-lemon_hash.patch
  35. # upstream patch adding the ability to recreate libdb's environment on version mismatch
  36. # or when libpthread.so is modified (rhbz#1394862)
  37. Patch30: db-5.3.28-condition_variable.patch
  38. # additional changes to the upstream patch to address rhbz#1460003
  39. Patch31: db-5.3.28-condition-variable-ppc.patch
  40. # downstream patch that adds a check for rpm transaction lock in order to be able to update libdb
  41. # FIXME: remove when able
  42. Patch32: db-5.3.28-rpm-lock-check.patch
  43. # downstream patch to hotfix rhbz#1464033, sent upstream
  44. Patch33: db-5.3.28-cwd-db_config.patch
  45. Patch34: libdb-5.3.21-region-size-check.patch
  46. # Patch sent upstream
  47. Patch35: checkpoint-opd-deadlock.patch
  48. URL: http://www.oracle.com/database/berkeley-db/
  49. License: BSD and LGPLv2 and Sleepycat
  50. Group: System Environment/Libraries
  51. BuildRequires: perl libtool
  52. BuildRequires: tcl-devel >= 8.5.2-3
  53. %if %{with java}
  54. BuildRequires: java-devel >= 1:1.6.0
  55. %endif
  56. #BuildRequires: chrpath
  57. #Conflicts: filesystem < 3
  58. Vendor: Project Vine
  59. Distribution: Vine Linux
  60. Packager: tomop
  61. %description
  62. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  63. provides embedded database support for both traditional and
  64. client/server applications. The Berkeley DB includes B+tree, Extended
  65. Linear Hashing, Fixed and Variable-length record access methods,
  66. transactions, locking, logging, shared memory caching, and database
  67. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  68. used by many applications, including Python and Perl, so this should
  69. be installed on all systems.
  70. %package utils
  71. Summary: Command line tools for managing Berkeley DB databases
  72. Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
  73. Group: Applications/Databases
  74. Requires: %{name}%{?_isa} = %{version}-%{release}
  75. Obsoletes: db4-utils
  76. Provides: db4-utils
  77. %description utils
  78. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  79. provides embedded database support for both traditional and
  80. client/server applications. Berkeley DB includes B+tree, Extended
  81. Linear Hashing, Fixed and Variable-length record access methods,
  82. transactions, locking, logging, shared memory caching, and database
  83. recovery. DB supports C, C++, Java and Perl APIs.
  84. %package devel
  85. Summary: C development files for the Berkeley DB library
  86. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  87. Group: Development/Libraries
  88. Requires: %{name}%{?_isa} = %{version}-%{release}
  89. Obsoletes: db4-devel
  90. Provides: db4-devel
  91. %description devel
  92. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  93. provides embedded database support for both traditional and
  94. client/server applications. This package contains the header files
  95. and libraries for building programs which use the Berkeley DB.
  96. %package devel-doc
  97. Summary: C development documentation files for the Berkeley DB library
  98. Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
  99. Group: Documentation
  100. Requires: %{name} = %{version}-%{release}
  101. Requires: %{name}-devel = %{version}-%{release}
  102. BuildArch: noarch
  103. %description devel-doc
  104. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  105. provides embedded database support for both traditional and
  106. client/server applications. This package contains the documentation
  107. for building programs which use the Berkeley DB.
  108. %package devel-static
  109. Summary: Berkeley DB static libraries
  110. Summary(ja): Berkeley DB 静的ライブラリ
  111. Group: Development/Libraries
  112. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  113. %description devel-static
  114. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  115. provides embedded database support for both traditional and
  116. client/server applications. This package contains static libraries
  117. needed for applications that require static linking of
  118. Berkeley DB.
  119. %package cxx
  120. Summary: The Berkeley DB database library for C++
  121. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  122. Group: System Environment/Libraries
  123. Requires: %{name}%{?_isa} = %{version}-%{release}
  124. %description cxx
  125. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  126. provides embedded database support for both traditional and
  127. client/server applications. The Berkeley DB includes B+tree, Extended
  128. Linear Hashing, Fixed and Variable-length record access methods,
  129. transactions, locking, logging, shared memory caching, and database
  130. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  131. used by many applications, including Python and Perl, so this should
  132. be installed on all systems.
  133. %package cxx-devel
  134. Summary: C++ development files for the Berkeley DB library
  135. Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
  136. Group: Development/Libraries
  137. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  138. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  139. %description cxx-devel
  140. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  141. provides embedded database support for both traditional and
  142. client/server applications. This package contains the header files,
  143. libraries, and documentation for building programs which use the
  144. Berkeley DB in C++.
  145. %package tcl
  146. Summary: The Berkeley DB library for tcl
  147. Summary(ja): tcl 用 Berkeley DB データベースライブラリ
  148. Group: System Environment/Libraries
  149. Requires: %{name}%{?_isa} = %{version}-%{release}
  150. %description tcl
  151. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  152. provides embedded database support for both traditional and
  153. client/server applications. This package contains the libraries
  154. for building programs which use the Berkeley DB in Tcl.
  155. %package tcl-devel
  156. Summary: Development files for using the Berkeley DB with tcl
  157. Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
  158. Group: Development/Libraries
  159. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  160. %description tcl-devel
  161. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  162. provides embedded database support for both traditional and
  163. client/server applications. This package contains the libraries
  164. for building programs which use the Berkeley DB in Tcl.
  165. %package sql
  166. Summary: The Berkeley DB library for SQL
  167. Summary(ja): SQL 用 Berkeley DB データベースライブラリ
  168. Group: System Environment/Libraries
  169. Requires: %{name}%{?_isa} = %{version}-%{release}
  170. %description sql
  171. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  172. provides embedded database support for both traditional and
  173. client/server applications. This package contains the libraries
  174. for building programs which use the Berkeley DB in SQL.
  175. %package sql-devel
  176. Summary: Development files for using the Berkeley DB with sql
  177. Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
  178. Group: Development/Libraries
  179. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  180. %description sql-devel
  181. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  182. provides embedded database support for both traditional and
  183. client/server applications. This package contains the libraries
  184. for building programs which use the Berkeley DB in SQL.
  185. %if %{with java}
  186. %package java
  187. Summary: The Berkeley DB library for Java
  188. Summary(ja): Java 用 Berkeley DB データベースライブラリ
  189. Group: System Environment/Libraries
  190. Requires: %{name}%{?_isa} = %{version}-%{release}
  191. %description java
  192. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  193. provides embedded database support for both traditional and
  194. client/server applications. This package contains the libraries
  195. for building programs which use the Berkeley DB in Java.
  196. %package java-devel
  197. Summary: Development files for using the Berkeley DB with Java
  198. Summary(ja): Java で Berkeley DB を利用するための開発ファイル
  199. Group: Development/Libraries
  200. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  201. %description java-devel
  202. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  203. provides embedded database support for both traditional and
  204. client/server applications. This package contains the libraries
  205. for building programs which use the Berkeley DB in Java.
  206. %endif
  207. # compat32
  208. %package -n compat32-%{name}
  209. Summary: The Berkeley DB database library for C
  210. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  211. Group: System Environment/Libraries
  212. Requires: libdb = %{version}-%{release}
  213. %description -n compat32-%{name}
  214. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  215. provides embedded database support for both traditional and
  216. client/server applications. The Berkeley DB includes B+tree, Extended
  217. Linear Hashing, Fixed and Variable-length record access methods,
  218. transactions, locking, logging, shared memory caching, and database
  219. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  220. used by many applications, including Python and Perl, so this should
  221. be installed on all systems.
  222. %package -n compat32-%{name}-cxx
  223. Summary: The Berkeley DB database library for C++
  224. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  225. Group: System Environment/Libraries
  226. Requires: %{name}-cxx = %{version}-%{release}
  227. Requires: compat32-%{name} = %{version}-%{release}
  228. %description -n compat32-%{name}-cxx
  229. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  230. provides embedded database support for both traditional and
  231. client/server applications. The Berkeley DB includes B+tree, Extended
  232. Linear Hashing, Fixed and Variable-length record access methods,
  233. transactions, locking, logging, shared memory caching, and database
  234. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  235. used by many applications, including Python and Perl, so this should
  236. be installed on all systems.
  237. %package -n compat32-%{name}-devel
  238. Summary: C development files for the Berkeley DB library
  239. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  240. Group: Development/Libraries
  241. Requires: compat32-%{name} = %{version}-%{release}
  242. Requires: %{name}-devel = %{version}-%{release}
  243. Obsoletes: compat32-db4-devel
  244. Provides: compat32-db4-devel
  245. %description -n compat32-%{name}-devel
  246. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  247. provides embedded database support for both traditional and
  248. client/server applications. This package contains the header files,
  249. libraries, and documentation for building programs which use the
  250. Berkeley DB.
  251. %prep
  252. %setup -q -n db-%{version} -a 1
  253. cp %{SOURCE2} .
  254. %patch0 -p1 -b .multiarch
  255. pushd db.1.85/PORT/linux
  256. %patch10 -p0 -b .1.1
  257. popd
  258. pushd db.1.85
  259. %patch11 -p0 -b .1.2
  260. %patch12 -p0 -b .1.3
  261. %patch13 -p0 -b .1.4
  262. %patch20 -p1 -b .errno
  263. popd
  264. %patch22 -p1 -b .185compat
  265. %patch24 -p1 -b .4.5.20.jni
  266. %patch25 -p1 -b .licensefix
  267. %patch26 -p1 -b .java8-fix
  268. %patch27 -p1 -b .memp_stat-fix
  269. %patch28 -p1
  270. %patch29 -p1
  271. %patch30 -p1
  272. %patch31 -p1
  273. %patch32 -p1
  274. %patch33 -p1
  275. %patch34 -p1
  276. %patch35 -p1
  277. cd dist
  278. ./s_config
  279. cd ..
  280. %build
  281. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  282. CFLAGS="$CFLAGS -DSHAREDSTATEDIR='\"%{_sharedstatedir}\"' -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  283. export CFLAGS
  284. # Build the old db-185 libraries.
  285. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  286. test -d dist/dist-tls || mkdir dist/dist-tls
  287. # Static link db_dump185 with old db-185 libraries.
  288. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  289. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  290. # Update config files to understand aarch64
  291. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  292. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  293. #done
  294. pushd dist/dist-tls
  295. %define _configure ../configure
  296. %configure -C \
  297. --enable-compat185 \
  298. --enable-dump185 \
  299. --enable-shared \
  300. --enable-static \
  301. --enable-tcl \
  302. --with-tcl=%{_libdir} \
  303. --enable-cxx \
  304. --enable-sql \
  305. --enable-test \
  306. --disable-rpath \
  307. --with-tcl=%{_libdir}/tcl8.5 \
  308. %if %{with java}
  309. --enable-java
  310. %endif
  311. # Remove libtool predep_objects and postdep_objects wonkiness so that
  312. # building without -nostdlib doesn't include them twice. Because we
  313. # already link with g++, weird stuff happens if you don't let the
  314. # compiler handle this.
  315. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  316. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  317. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  318. make %{?_smp_mflags}
  319. %if %{with java}
  320. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  321. LDBJ=./.libs/libdb_java-%{__soversion}.la
  322. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  323. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  324. fi
  325. %endif
  326. popd
  327. %install
  328. rm -rf ${RPM_BUILD_ROOT}
  329. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  330. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  331. %makeinstall STRIP=/bin/true -C dist/dist-tls
  332. # XXX Nuke non-versioned archives and symlinks
  333. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  334. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  335. # Move the header files to a subdirectory, in case we're deploying on a
  336. # system with multiple versions of DB installed.
  337. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  338. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  339. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  340. for i in db.h db_cxx.h db_185.h; do
  341. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  342. done
  343. %if %{with java}
  344. # Move java jar file to the correct place
  345. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  346. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  347. %endif
  348. # Eliminate installed doco
  349. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  350. # XXX Avoid Permission denied. strip when building as non-root.
  351. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  352. # remove unneeded .la files (#225675)
  353. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  354. # remove RPATHs
  355. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  356. # unify documentation and examples, remove stuff we don't need
  357. rm -rf docs/csharp
  358. rm -rf examples/csharp
  359. rm -rf docs/installation
  360. mv examples docs
  361. %clean
  362. rm -rf ${RPM_BUILD_ROOT}
  363. %post -p /sbin/ldconfig
  364. %postun -p /sbin/ldconfig
  365. %post cxx -p /sbin/ldconfig
  366. %postun cxx -p /sbin/ldconfig
  367. %post sql -p /sbin/ldconfig
  368. %postun sql -p /sbin/ldconfig
  369. %post tcl -p /sbin/ldconfig
  370. %postun tcl -p /sbin/ldconfig
  371. %if %{with java}
  372. %post java -p /sbin/ldconfig
  373. %postun java -p /sbin/ldconfig
  374. %endif
  375. %if %{build_compat32}
  376. %post -n compat32-%{name} -p /sbin/ldconfig
  377. %postun -n compat32-%{name} -p /sbin/ldconfig
  378. %post -n compat32-%{name}-cxx -p /sbin/ldconfig
  379. %postun -n compat32-%{name}-cxx -p /sbin/ldconfig
  380. %endif
  381. %files
  382. %defattr(-,root,root,-)
  383. %doc LICENSE README lgpl-2.1.txt
  384. %{_libdir}/libdb-%{__soversion}.so
  385. %{_libdir}/libdb-%{__soversion_major}.so
  386. %files devel
  387. %defattr(-,root,root,-)
  388. %{_libdir}/libdb.so
  389. %dir %{_includedir}/%{name}
  390. %{_includedir}/%{name}/db.h
  391. %{_includedir}/%{name}/db_185.h
  392. %{_includedir}/db.h
  393. %{_includedir}/db_185.h
  394. %files devel-doc
  395. %defattr(-,root,root,-)
  396. %doc docs/*
  397. %files devel-static
  398. %defattr(-,root,root,-)
  399. %{_libdir}/libdb-%{__soversion}.a
  400. %{_libdir}/libdb_cxx-%{__soversion}.a
  401. %{_libdir}/libdb_tcl-%{__soversion}.a
  402. %{_libdir}/libdb_sql-%{__soversion}.a
  403. %if %{with java}
  404. %{_libdir}/libdb_java-%{__soversion}.a
  405. %endif
  406. %files utils
  407. %defattr(-,root,root,-)
  408. %{_bindir}/db*_archive
  409. %{_bindir}/db*_checkpoint
  410. %{_bindir}/db*_deadlock
  411. %{_bindir}/db*_dump*
  412. %{_bindir}/db*_hotbackup
  413. %{_bindir}/db*_load
  414. %{_bindir}/db*_printlog
  415. %{_bindir}/db*_recover
  416. %{_bindir}/db*_replicate
  417. %{_bindir}/db*_stat
  418. %{_bindir}/db*_upgrade
  419. %{_bindir}/db*_verify
  420. %{_bindir}/db*_tuner
  421. %files cxx
  422. %defattr(-,root,root,-)
  423. %{_libdir}/libdb_cxx-%{__soversion}.so
  424. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  425. %files cxx-devel
  426. %defattr(-,root,root,-)
  427. %{_includedir}/%{name}/db_cxx.h
  428. %{_includedir}/db_cxx.h
  429. %{_libdir}/libdb_cxx.so
  430. %files tcl
  431. %defattr(-,root,root,-)
  432. %{_libdir}/libdb_tcl-%{__soversion}.so
  433. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  434. %files tcl-devel
  435. %defattr(-,root,root,-)
  436. %{_libdir}/libdb_tcl.so
  437. %files sql
  438. %defattr(-,root,root,-)
  439. %{_libdir}/libdb_sql-%{__soversion}.so
  440. %{_libdir}/libdb_sql-%{__soversion_major}.so
  441. %files sql-devel
  442. %defattr(-,root,root,-)
  443. %{_bindir}/dbsql
  444. %{_libdir}/libdb_sql.so
  445. %{_includedir}/%{name}/dbsql.h
  446. %if %{with java}
  447. %files java
  448. %defattr(-,root,root,-)
  449. %{_libdir}/libdb_java-%{__soversion_major}*.so
  450. %{_datadir}/java/*.jar
  451. %files java-devel
  452. %defattr(-,root,root,-)
  453. %{_libdir}/libdb_java.so
  454. %endif
  455. %if %{build_compat32}
  456. %files -n compat32-%{name}
  457. %defattr(-,root,root)
  458. %{_libdir}/libdb-%{__soversion}.so
  459. %{_libdir}/libdb-%{__soversion_major}.so
  460. %files -n compat32-%{name}-cxx
  461. %defattr(-,root,root)
  462. %{_libdir}/libdb_cxx-%{__soversion}.so
  463. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  464. %files -n compat32-%{name}-devel
  465. %defattr(-,root,root)
  466. %{_libdir}/libdb.so
  467. %endif
  468. %changelog
  469. * Fri Dec 22 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-11
  470. - added Patch28-15.
  471. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-10
  472. - rebuilt with new toolchain.
  473. * Thu May 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-9
  474. - added Patch27.
  475. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
  476. - added compat32 subpackages
  477. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
  478. - updated Summary and Group
  479. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  480. - added "Provides: db4-{utils,devel}".
  481. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  482. - initial build for Vine Linux.
  483. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  484. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  485. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  486. - Fix configure macro usage for better aarch64 build fix
  487. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  488. - Updated config files to allow build on aarch64 (#1022970)
  489. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  490. - Added Sleepycat to the license list (#1013841)
  491. - Updated to 5.3.28 (#1013233)
  492. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  493. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  494. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  495. - add copy of lgpl-2.1.txt
  496. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  497. - Fix missing debuginfo issue for utils subpackage
  498. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  499. - add license clarification fix
  500. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  501. - Added sqlite compability CFLAGS (#788496)
  502. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  503. - Cleaning the specfile - removed gcc-java dependecy other way
  504. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  505. - Removed dependency on obsolete gcc-java package (#927742)
  506. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  507. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  508. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  509. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  510. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  511. - fix license tag
  512. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  513. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  514. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  515. - Specify tag for libtool (fixes FTBFS # 838334 )
  516. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  517. - update to 5.3.21
  518. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  519. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  520. - move C++ header files to cxx-devel
  521. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  522. - fix -devel packages dependencies yet more (#832225)
  523. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  524. - package -devel packages correctly
  525. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  526. - fix multiarch conflict in libdb-devel (#812901)
  527. - remove unneeded dos2unix BR
  528. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  529. - update to 5.3.15
  530. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  531. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  532. - Resolves rhbz#794472
  533. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  534. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  535. - add filesystem guard
  536. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  537. - install everything in /usr
  538. https://fedoraproject.org/wiki/Features/UsrMove
  539. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  540. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  541. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  542. - update to 5.2.36,
  543. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  544. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  545. - move development documentation to devel-doc subpackage (#705386)
  546. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  547. - update to 5.2.28
  548. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  549. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  550. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  551. - update to 5.1.25
  552. * Wed Sep 29 2010 jkeating - 5.1.19-2
  553. - Rebuilt for gcc bug 634757
  554. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  555. - update to 5.1.19
  556. - rename -devel-static to -static subpackage (#617800)
  557. - build java on all arches
  558. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  559. - update to 5.0.26
  560. - drop BR: ed
  561. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  562. - add Requires: libdb-cxx to libdb-devel
  563. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  564. - initial build
  565. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  566. - remove C# documentation
  567. - disable/remove rpath
  568. - fix description
  569. - tighten dependencies
  570. - run ldconfig for cxx and sql subpackages
  571. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  572. - enable sql
  573. - package 5.0.21