gnucash-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292
  1. %global srcdir gnucash-3.8
  2. Name: gnucash
  3. Summary: GnuCash is an application to keep track of your finances.
  4. Summary(ja): 個人用財務管理アプリケーション
  5. Version: 3.8b
  6. Release: 1%{?_dist_release}
  7. License: GPL/LGPL/GFDL
  8. Group: Applications/Productivity
  9. URL: https://www.gnucash.org/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: kenta, inagaki
  13. Source: https://github.com/Gnucash/gnucash/releases/download/%{version}/%{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libappstream-glib-devel
  16. BuildRequires: aqbanking-devel >= 3.7.2
  17. BuildRequires: bzip2-devel
  18. BuildRequires: cmake
  19. BuildRequires: desktop-file-utils
  20. BuildRequires: expat-devel
  21. BuildRequires: gwenhywfar-devel
  22. BuildRequires: gettext
  23. BuildRequires: gmock-devel
  24. BuildRequires: gtest-devel
  25. BuildRequires: gtk3-devel
  26. BuildRequires: guile-devel
  27. BuildRequires: libappstream-glib
  28. BuildRequires: libboost-date-time
  29. BuildRequires: libboost-devel
  30. BuildRequires: libboost-locale
  31. BuildRequires: libboost-regex
  32. BuildRequires: libboost-filesystem
  33. BuildRequires: libicu-devel
  34. BuildRequires: libofx-devel
  35. BuildRequires: libdbi-devel
  36. BuildRequires: libjpeg-devel
  37. BuildRequires: libsecret-devel
  38. BuildRequires: libtool-ltdl-devel
  39. BuildRequires: libxslt-devel
  40. BuildRequires: pcre-devel
  41. BuildRequires: popt-devel
  42. BuildRequires: python3-devel
  43. BuildRequires: swig
  44. BuildRequires: webkitgtk4-devel
  45. #BuildRequires: slib
  46. BuildRequires: libdbi-dbd-pgsql
  47. BuildRequires: libdbi-dbd-mysql
  48. BuildRequires: libdbi-dbd-sqlite
  49. Requires: aqbanking
  50. Requires: perl-DateManip
  51. Requires: yelp
  52. Requires(post,postun): gtk3
  53. Requires(postun,posttrans): glib2
  54. Obsoletes: gnucash-backend-postgres
  55. %description
  56. GnuCash is a personal finance manager. A check-book like
  57. register GUI allows you to enter and track bank accounts,
  58. stocks, income and even currency trades. The interface is
  59. designed to be simple and easy to use, but is backed with
  60. double-entry accounting principles to ensure balanced books.
  61. %description -l ja
  62. GnuCashは 個人用財務管理をするアプリケーションです.
  63. 預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
  64. グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
  65. 使用できるようにデザインされています.
  66. %prep
  67. %setup -q -n %{srcdir}
  68. %build
  69. %global optflags %{optflags} -Wno-parentheses
  70. %cmake . \
  71. -DCMAKE_INSTALL_DOCDIR=%{_datadir}/doc/gnucash-%{version} \
  72. -DWITH_SQL=OFF
  73. %make_build
  74. %install
  75. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  76. %make_install
  77. %find_lang %name
  78. rm -rf $RPM_BUILD_ROOT%{_infodir} \
  79. $RPM_BUILD_ROOT%{_includedir} \
  80. $RPM_BUILD_ROOT%{_datadir}/aclocal \
  81. $RPM_BUILD_ROOT%{_libdir}/lib*.a \
  82. $RPM_BUILD_ROOT%{_libdir}/gnucash/lib*.a \
  83. $RPM_BUILD_ROOT%{_bindir}/gnc-test-env \
  84. $RPM_BUILD_ROOT%{_bindir}/gnc-fq-update
  85. find $RPM_BUILD_ROOT%{_libdir} -name *.la -exec rm -f {} \;
  86. %clean
  87. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  88. %post
  89. /sbin/ldconfig
  90. touch --no-create %{_datadir}/icons/hicolor || :
  91. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  92. %postun
  93. if [ $1 -eq 0 ] ; then
  94. /sbin/ldconfig
  95. touch --no-create %{_datadir}/icons/hicolor || :
  96. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  97. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  98. fi
  99. %posttrans
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %files -f %{name}.lang
  102. %defattr(-,root,root,755)
  103. %doc %{_docdir}/gnucash-%{version}/*
  104. %license LICENSE
  105. %dir %{_sysconfdir}/%{name}
  106. %{_bindir}/*
  107. %{_libdir}/*
  108. %{_datadir}/glib-2.0/schemas/*
  109. %{_datadir}/%{name}
  110. %{_datadir}/metainfo/*
  111. %{_datadir}/applications/*
  112. %{_datadir}/icons/hicolor/*/apps/*
  113. %{_mandir}/man*/*
  114. %config %{_sysconfdir}/%{name}/*
  115. %changelog
  116. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8b-1
  117. - new upstream release.
  118. - built with icu-66.
  119. * Sun Oct 13 2019 Toshiaki Ara <ara_t@384.jp> 3.7-2
  120. - rebuild with libicu-65
  121. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7-1
  122. - new upstream release.
  123. * Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.12-1
  124. - new upstream release
  125. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
  126. - new upstream release
  127. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
  128. - remove *.la files
  129. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
  130. - new upstream release
  131. - add BuildRequires: libtool-ltdl-devel
  132. * Mon Mar 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
  133. - rebuilt with libofx 0.9.10
  134. - added Vendor and Distribution tag
  135. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  136. - update to 2.6.5
  137. - remove old patches
  138. - add BuildRequires: libdbi-devel
  139. - change BuildRequires: goffice08-devel instead of goffice-devel
  140. * Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
  141. - rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
  142. - added Patch1 for building with aqbanking-4.2.4
  143. - added Patch2 for building with goffice-0.8.10
  144. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
  145. - added slib to BuildRequires: and Requires:
  146. * Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
  147. - new upstream release
  148. * Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
  149. - new upstream release
  150. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
  151. - rebuild with guile-1.8.6
  152. - add BuildRequires: gwenhywfar-devel
  153. * Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
  154. - new upstream release
  155. - applied new versioning policy
  156. - built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
  157. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
  158. - new upstream release
  159. - rebuilt with goffice-0.6.0
  160. * Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
  161. - new upstream release
  162. * Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
  163. - new upstream release
  164. - enable HBCI (Home Banking Computer Interface)
  165. * Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
  166. - rebuild with libofx-0.8.3 (libofx.so.3)
  167. * Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
  168. - new upstream release
  169. - disable postgresql backend, as it is unmaintained upstream
  170. - added Patch0: gnucash-2.2.0-quiet.patch
  171. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
  172. - new upstream release
  173. - remove BuildRequiers: autoconf213
  174. - update ja.po
  175. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  176. - new upstream release
  177. - added BuildPrereq: libtool-ltdl-devel
  178. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  179. - rebuild with new toolchains
  180. - update ja.po
  181. * Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
  182. - new upstream release
  183. * Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
  184. - merged gnucash-docs-1.8.3
  185. - added patch from Redhat Rawhide 1.8.7-1
  186. - changed Group, License
  187. * Mon Oct 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
  188. - updated to 1.8.7
  189. - updated print.patch
  190. - overwrite prefs.scm
  191. - s/Copyright/License/
  192. * Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
  193. - updated to 1.8.3
  194. - added datelength.patch
  195. - separated devel packages
  196. (and ofx, hbci, backend-postgres. But default is off)
  197. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
  198. - Build against with new gal.
  199. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
  200. - Fixed printing issue.
  201. * Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
  202. - New upstream release.
  203. * Thu Jul 26 2001 <sagami@vinelinux.org>
  204. - 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
  205. * Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  206. - %%make line is now commented out (bash2 complains it)
  207. (BTW, what the hell is the macro %%make anyway? I don't even know...)
  208. * Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  209. - update to 1.6.0 (stable release version)
  210. * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
  211. - update to 1.5.96 ( pre beta for 1.6.0 )
  212. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
  213. - added japanese patch for reporting and printing (thanx tagoh-san)
  214. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
  215. - updated to 1.5.6
  216. * Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
  217. - added translation messages to ja.po
  218. - enable guppi
  219. * Mon Apr 2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
  220. - upstream update
  221. - fixed broken ja.po
  222. * Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
  223. - fixed registor window cursor position problem(gnucash-cursor_pos.patch)
  224. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
  225. - initial relese package