wpa_supplicant-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362
  1. %define build_gui 1
  2. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  3. Name: wpa_supplicant
  4. Version: 2.9
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Base
  7. License: BSD
  8. URL: https://w1.fi/wpa_supplicant/
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Source0: https://w1.fi/releases/%{name}-%{version}.tar.gz
  12. Source2: %{name}.conf
  13. Source3: %{name}.init.d
  14. Source4: %{name}.sysconfig
  15. Source6: %{name}.logrotate
  16. # distro specific customization and not suitable for upstream,
  17. # Fedora-specific updates to defconfig
  18. Patch0: wpa_supplicant-config.patch
  19. # works around busted drivers
  20. Patch1: wpa_supplicant-assoc-timeout.patch
  21. # ensures that debug output gets flushed immediately to help diagnose driver
  22. # bugs, not suitable for upstream
  23. Patch2: wpa_supplicant-flush-debug-output.patch
  24. # quiet an annoying and frequent syslog message
  25. Patch3: wpa_supplicant-quiet-scan-results-message.patch
  26. # distro specific customization for Qt4 build tools, not suitable for upstream
  27. Patch4: wpa_supplicant-gui-qt4.patch
  28. # fix AP mode PMF disconnection protection bypass
  29. Patch5: 0001-AP-Silently-ignore-management-frame-from-unexpected-.patch
  30. ## Vine patches
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. %if %{build_gui}
  33. BuildRequires: qt4-devel
  34. %endif
  35. BuildRequires: openssl-devel
  36. BuildRequires: readline-devel
  37. BuildRequires: dbus-devel
  38. BuildRequires: libnl3-devel
  39. BuildRequires: docbook-utils
  40. Requires(post): /sbin/chkconfig
  41. Requires(preun): /sbin/chkconfig /sbin/service
  42. Requires(postun): /sbin/service
  43. %description
  44. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  45. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  46. component that is used in the client stations. It implements key negotiation
  47. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  48. authentication/association of the wlan driver.
  49. %if %{build_gui}
  50. %package gui
  51. Summary: Graphical User Interface for %{name}
  52. Summary(ja): %{name} のグラフィカルユーザインタフェース
  53. Group: Applications/System
  54. %description gui
  55. Graphical User Interface for wpa_supplicant written using QT4
  56. %description -l ja gui
  57. QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  58. %endif
  59. %prep
  60. %setup -q
  61. %autopatch -p1
  62. %build
  63. pushd wpa_supplicant
  64. cp defconfig .config
  65. export CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE"
  66. export CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE"
  67. export LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now"
  68. # yes, BINDIR=_sbindir
  69. export BINDIR="%{_sbindir}"
  70. export LIBDIR="%{_libdir}"
  71. make %{_smp_mflags} V=1
  72. %if %{build_gui}
  73. make wpa_gui-qt4 %{_smp_mflags} V=1 QTDIR=%{_libdir}/qt4
  74. %endif
  75. make eapol_test
  76. popd
  77. %install
  78. rm -rf %{buildroot}
  79. # init scripts
  80. install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
  81. install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  82. install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
  83. # config
  84. install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
  85. # binary
  86. install -d %{buildroot}/%{_sbindir}
  87. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  88. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  89. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  90. install -m 0755 wpa_supplicant/eapol_test %{buildroot}/%{_sbindir}
  91. install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf \
  92. %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  93. install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service \
  94. %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  95. %if %{build_gui}
  96. # gui
  97. install -d %{buildroot}/%{_bindir}
  98. install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
  99. %endif
  100. # running
  101. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  102. # man pages
  103. install -d %{buildroot}%{_mandir}/man{5,8}
  104. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  105. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  106. # some cleanup in docs
  107. rm -f %{name}/doc/.cvsignore
  108. rm -rf %{name}/doc/docbook
  109. chmod -R 0644 %{name}/examples/*.py
  110. %clean
  111. rm -rf %{buildroot}
  112. %post
  113. if [ $1 = 1 ]; then
  114. /sbin/chkconfig --add %{name}
  115. fi
  116. %preun
  117. if [ $1 = 0 ]; then
  118. /sbin/service %{name} stop > /dev/null 2>&1
  119. killall -TERM wpa_supplicant >/dev/null 2>&1
  120. /sbin/chkconfig --del %{name}
  121. fi
  122. %postun
  123. if [ $1 -ge 1 ]; then
  124. /sbin/service %{name} condrestart > /dev/null 2>&1
  125. fi
  126. %files
  127. %defattr(-, root, root)
  128. %license COPYING
  129. %doc %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  130. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  131. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  132. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  133. %{_sysconfdir}/rc.d/init.d/%{name}
  134. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  135. %{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  136. %{_sbindir}/wpa_passphrase
  137. %{_sbindir}/wpa_supplicant
  138. %{_sbindir}/wpa_cli
  139. %{_sbindir}/eapol_test
  140. %dir %{_localstatedir}/run/%{name}
  141. %dir %{_sysconfdir}/%{name}
  142. %{_mandir}/man8/*
  143. %{_mandir}/man5/*
  144. %if %{build_gui}
  145. %files gui
  146. %defattr(-, root, root)
  147. %{_bindir}/wpa_gui
  148. %endif
  149. %changelog
  150. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-1
  151. - new upstream release.
  152. - replaced all patches to rawhide's.
  153. * Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-2
  154. - rebuilt with openssl-1.1.1.
  155. - imported Patch62-64 from rawhide.
  156. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-1
  157. - updated to 2.6.
  158. - imported Patch9-60 from rawhide.
  159. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5-3
  160. - rebuilt with new toolchain.
  161. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
  162. - rebuild with openssl-1.0.2g
  163. * Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
  164. - update to 2.5
  165. - update SOURCE1
  166. - remove Patch7 (libnl3-includes.patch)
  167. - add Patch 9,10,11 from Fedora
  168. - remove Patch 6, 700
  169. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
  170. - updated to 2.3
  171. - built with libnl3 instead of libnl
  172. - added Patch 6, 7 and 8 from Fedora
  173. - added Patch700
  174. * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
  175. - import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
  176. - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
  177. - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
  178. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  179. - rebuild with openssl-1.0.0c
  180. - add BuildRequires: qt4-designer, libnl-devel
  181. * Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
  182. - new upstream release
  183. - update patches
  184. - change License to BSD due to linkage against OpsnSSL since there is no
  185. OpenSSL exception in upstream GPLv2 license text.
  186. - build with qt4
  187. - update build config
  188. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  189. - new upstream release
  190. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  191. - drop upstream patches
  192. - import some fedora patches
  193. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  194. - Better scanning behavior on resume from suspend/hibernate
  195. - Better interaction with newer kernels and drivers
  196. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  197. - start wpa_supplicant by default.
  198. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  199. - new upstream release
  200. - import some fedora patches
  201. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  202. - rebuild with new openssl
  203. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  204. - new upstream release
  205. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  206. - initial build for Vine Linux based on FC package.
  207. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  208. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  209. - Fix up madwifi-ng private ioctl()s for r1331 and later
  210. - Update madwifi headers to r1475
  211. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  212. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  213. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  214. - Fix control interface key obfuscation a bit
  215. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  216. - Work around older & incorrect drivers that return null-terminated SSIDs
  217. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  218. - Add patch to make orinoco happy with WEP keys
  219. - Enable Prism54-specific driver
  220. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  221. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  222. - Increase association timeout, mainly for drivers that don't
  223. fully support WPA ioctls yet
  224. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  225. - Add additional BuildRequires #rh181914#
  226. - Add prereq on chkconfig #rh182905# #rh182906#
  227. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  228. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  229. - Install wpa_passphrase too #rh183480#
  230. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  231. - Don't expose private data on the control interface unless requested
  232. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  233. - Downgrade to 0.4.8 stable release rather than a dev release
  234. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  235. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  236. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  237. - Move initscript to /etc/rc.d/init.d
  238. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  239. - bump again for double-long bug on ppc(64)
  240. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  241. - rebuilt for new gcc4.1 snapshot and glibc changes
  242. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  243. - Update to 0.5.1
  244. - Add WE auth fallback to actually work with older drivers
  245. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  246. - Bring package into Fedora Core
  247. - Add ap_scan control interface patch
  248. - Enable madwifi-ng driver
  249. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  250. - upgrade to 0.4.7
  251. - added package w/ wpa_gui in it
  252. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  253. - upgrade to 0.4.6
  254. - adding ctrl interface changes recommended
  255. by Hugo Paredes <hugo.paredes@e-know.org>
  256. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  257. - upgrade to 0.4.5
  258. - updated config file wpa_supplicant is built with
  259. especially, the ipw2100 driver changed to just ipw
  260. and enabled a bunch more EAP
  261. - disabled dist tag
  262. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  263. - fix typo in init script
  264. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  265. - fixing init script using fedora-extras' template
  266. - removing chkconfig default startup
  267. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  268. - upgrade to 0.4.2
  269. - new sample conf file that will use any unrestricted AP
  270. - make sysconfig config entry
  271. - new BuildRoot for Fedora Extras
  272. - adding dist tag to Release
  273. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  274. - upgrade to 0.3.8
  275. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  276. - compile ipw driver in
  277. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  278. - upgrade to 0.3.6
  279. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  280. - fixing init script
  281. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  282. - fixing init script
  283. - adding post/preun items to add/remove via chkconfig
  284. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  285. - adding sysV scripts
  286. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  287. - Initial RPM release.