upstart-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. %global prepare_systemd 1
  2. Name: upstart
  3. Version: 1.12.1
  4. Release: 6%{?_dist_release}
  5. Summary: An event-driven init system
  6. Summary(ja): イベントドリブン型 init システム
  7. Group: System Environment/Base
  8. License: GPLv2 and LGPLv2+
  9. URL: http://launchpad.net/upstart
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: http://launchpad.net/upstart/1.x/%{version}/+download/upstart-%{version}.tar.gz
  13. Source1: init-system-dbus.conf
  14. #Patch1: upstart-telinit.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. Obsoletes: SysVinit < 2.88
  17. Provides: SysVinit = 2.88
  18. BuildRequires: gettext, audit-libs-devel, expat-devel
  19. BuildRequires: dbus-devel >= 1.2.16
  20. BuildRequires: libnih-devel >= 1.0.3-2
  21. BuildRequires: json-c-devel >= 0.10
  22. BuildRequires: eudev-libudev-devel
  23. BuildRequires: dconf-devel
  24. Requires: initscripts >= 8.90.4
  25. Requires(post,postun): bash
  26. Provides: /sbin/halt
  27. Provides: /sbin/init
  28. Provides: /sbin/poweroff
  29. Provides: /sbin/reboot
  30. Provides: /sbin/runlevel
  31. Provides: /sbin/shutdown
  32. Provides: /sbin/telinit
  33. %description
  34. Upstart is an event-based replacement for the /sbin/init daemon which
  35. handles starting of tasks and services during boot, stopping them
  36. during shutdown and supervising them while the system is running.
  37. %description -l ja
  38. Upstart はイベントドリブン型の /sbin/init デーモンです。OSブート時の
  39. タスクやサービスの開始やシャットダウン時の終了およびそれらの管理を担
  40. 当します。
  41. %package devel
  42. Summary: Development files for upstart
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. Development files for upstart
  47. %package tools
  48. Summary: Misc tools for upstart
  49. Group: System Environment/Base
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: python3
  52. Requires: dbus-python3
  53. %description tools
  54. Misc tools for upstart
  55. %prep
  56. %setup -q
  57. #%patch1 -p1 -b .u
  58. %build
  59. %configure --sbindir=/sbin --libdir=/%{_lib}
  60. make %{?_smp_mflags}
  61. %install
  62. rm -rf %{buildroot}
  63. make install DESTDIR=%{buildroot}
  64. # don't ship default jobs
  65. rm -f %{buildroot}/%{_sysconfdir}/init/*
  66. install -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/init/
  67. # install upstart-{socket,udev}-bridge.conf
  68. install -m 644 extra/conf/*.conf %{buildroot}/%{_sysconfdir}/init/
  69. # remove unneeded files
  70. rm %{buildroot}/%{_lib}/*.{a,la}
  71. %find_lang %{name}
  72. # for alternatives
  73. %if 0%{?prepare_systemd}
  74. mkdir -p %{buildroot}/%{_lib}/upstart
  75. for f in init halt poweroff reboot runlevel shutdown telinit; do
  76. mv -f %{buildroot}/sbin/$f %{buildroot}/%{_lib}/upstart/
  77. done
  78. for f in halt poweroff reboot runlevel shutdown telinit; do
  79. mv -f %{buildroot}/%{_mandir}/man8/$f.8 \
  80. %{buildroot}/%{_mandir}/man8/upstart-$f.8
  81. done
  82. %endif
  83. %check
  84. #some tests fail in koji while pass in mock and local build
  85. #to run make check use "--with check"
  86. %if %{?_with_check:1}%{!?_with_check:0}
  87. make check
  88. %endif
  89. %if 0%{?prepare_systemd}
  90. %post
  91. /sbin/alternatives \
  92. --install /sbin/init init /%{_lib}/upstart/init 200 \
  93. --slave /sbin/halt halt /%{_lib}/upstart/halt \
  94. --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
  95. --slave /sbin/reboot reboot /%{_lib}/upstart/reboot \
  96. --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
  97. --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
  98. --slave /sbin/telinit telinit /%{_lib}/upstart/telinit \
  99. --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
  100. --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
  101. --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
  102. --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
  103. --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
  104. --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
  105. %postun
  106. if [ "$1" = "0" ]; then
  107. /sbin/alternatives --remove init /%{_lib}/upstart/init
  108. fi
  109. %triggerpostun -- upstart <= 1.12.1-5vl7
  110. /sbin/alternatives \
  111. --install /sbin/init init /%{_lib}/upstart/init 200 \
  112. --slave /sbin/halt halt /%{_lib}/upstart/halt \
  113. --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
  114. --slave /sbin/reboot reboot /%{_lib}/upstart/reboot \
  115. --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
  116. --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
  117. --slave /sbin/telinit telinit /%{_lib}/upstart/telinit \
  118. --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
  119. --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
  120. --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
  121. --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
  122. --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
  123. --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
  124. %endif
  125. %clean
  126. rm -rf %{buildroot}
  127. %files -f %{name}.lang
  128. %defattr(-,root,root,-)
  129. %doc AUTHORS
  130. %doc COPYING
  131. %doc NEWS
  132. %doc README
  133. %doc TODO
  134. %doc HACKING
  135. %{_sysconfdir}/init/
  136. %config(noreplace) %{_sysconfdir}/dbus-1/system.d/Upstart.conf
  137. /%{_lib}/libupstart.so.*
  138. %if 0%{?prepare_systemd}
  139. /%{_lib}/upstart
  140. %else
  141. /sbin/halt
  142. /sbin/init
  143. /sbin/poweroff
  144. /sbin/reboot
  145. /sbin/runlevel
  146. /sbin/shutdown
  147. /sbin/telinit
  148. %endif
  149. /sbin/initctl
  150. /sbin/start
  151. /sbin/status
  152. /sbin/stop
  153. /sbin/restart
  154. /sbin/reload
  155. /sbin/upstart-socket-bridge
  156. /sbin/upstart-udev-bridge
  157. /sbin/upstart-dbus-bridge
  158. /sbin/upstart-dconf-bridge
  159. /sbin/upstart-event-bridge
  160. /sbin/upstart-file-bridge
  161. /sbin/upstart-local-bridge
  162. %{_bindir}/init-checkconf
  163. %dir %{_datadir}/upstart
  164. %dir %{_datadir}/upstart/sessions
  165. %{_datadir}/upstart/sessions/*
  166. %{_mandir}/man5/init.5.gz
  167. %{_mandir}/man5/inittab.5.gz
  168. %{_mandir}/man7/*.7*
  169. %{_mandir}/man8/*.8*
  170. %exclude %{_mandir}/man8/initctl2dot.8*
  171. %exclude %{_mandir}/man8/upstart-monitor.8*
  172. %files devel
  173. %defattr(-,root,root,-)
  174. /%{_lib}/libupstart.so
  175. %{_includedir}/upstart*
  176. %{_prefix}/lib/pkgconfig/*.pc
  177. %files tools
  178. %defattr(-,root,root,-)
  179. %{_bindir}/upstart-monitor
  180. %{_bindir}/initctl2dot
  181. %{_datadir}/applications/*.desktop
  182. %{_datadir}/icons/hicolor/scalable/apps/*.svg
  183. %{_datadir}/upstart/icons/*.svg
  184. %{_mandir}/man8/initctl2dot.8*
  185. %{_mandir}/man8/upstart-monitor.8*
  186. %changelog
  187. * Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-6
  188. - manuals for {halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
  189. * Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-5
  190. - rebuilt with json-c-0.13.
  191. - /sbin/{init,halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
  192. * Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-4
  193. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  194. * Sun Jun 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-3
  195. - rebuild with libnih-1.0.3-2
  196. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-2
  197. - add -tools subpackage
  198. - split initctl2dot and upstart-monitor to -tools subpackage
  199. - add R: dbus-python3 to upstart-tools
  200. * Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-1
  201. - update to 1.12.1
  202. - add BR: dconf-devel
  203. - add -devel subpackage
  204. * Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-2
  205. - install upstart-{socket,udev}-bridge.conf
  206. * Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
  207. - update to 1.6
  208. - add BR: libudev-devel
  209. - add BR: json-c-devel >= 0.10
  210. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  211. - new upstream release
  212. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.7-1
  213. - new upstream release
  214. * Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-2
  215. - add R: initscripts >= 8.90.4
  216. * Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
  217. - initial build for Vine Linux
  218. * Wed Feb 24 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-3
  219. - run "make check" only with --with check
  220. * Fri Feb 19 2010 Casey Dahlin <cdahlin@redhat.com> 0.6.5-2
  221. - be more specific about which libnih we need.
  222. * Wed Feb 17 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-1
  223. - upgrade to 0.6.5
  224. * Fri Jan 29 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-7
  225. - add SIGUSR1 handler and init-system-dbus.conf (#559660)
  226. * Sun Jan 17 2010 Dennis Gilmore <dennis@ausil.us> - 0.6.3-6
  227. - add patch from upstream fixing sparc alignment issues
  228. * Mon Jan 11 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-5
  229. - License changed to GPLv2 and LGPLv2+
  230. * Wed Dec 16 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-4
  231. - audit events patch rebased for 0.6 (#470661)
  232. * Thu Dec 3 2009 Bill Nottingham <notting@redhat.com> 0.6.3-3
  233. - make 'telinit u' a no-op, temporarily
  234. * Fri Nov 27 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-2
  235. - Removed tests which fail in koji
  236. * Fri Nov 20 2009 Casey Dahlin <cdahlin@redhat.com> - 0.6.3-1
  237. - Upgrade to 0.6.3
  238. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.11-3
  239. - rebuilt with new audit
  240. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-2
  241. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  242. * Mon Jun 22 2009 Petr Lautrbach <plautrba@redhat.com> - 0.3.11-1
  243. - Update to 0.3.11
  244. * Mon Apr 27 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-24
  245. - Apply the audit patch correctly (#470661)
  246. * Fri Apr 3 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-23
  247. - Add audit events patch from Steve Grubb <sgrubb@redhat.com> (Bug #470661)
  248. * Fri Jan 23 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-22
  249. - Re-add 'telinit u' support along with patch to fix it (#450488). Patch due to
  250. <pspencer@fields.utoronto.ca>
  251. * Mon Jan 12 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-21
  252. - Remove 'telinit u' support as it is broken (#450488, <cjdahlin@ncsu.edu>)
  253. * Fri Apr 25 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-19
  254. - with the merge of event-compat-sysv, move the sysvinit obsoletes/provides here
  255. * Thu Apr 24 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-18
  256. - fix some man page typos (#444008, <archimerged@gmail.com>)
  257. * Wed Apr 09 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-17
  258. - Added list of stock events to events(5)
  259. * Tue Apr 08 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-16
  260. - Add telinit u support
  261. * Fri Apr 04 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-15
  262. - Add a events(5) manpage that describes event syntax
  263. * Thu Apr 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-14
  264. - Change bug report email address to fedora-devel-list@redhat.com
  265. * Fri Mar 14 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-13
  266. - Ignore rpm temporary files of the foo;<somehex> format
  267. - Make ignores of .rpm{new,orig,save} match only at the end of the name
  268. * Thu Mar 13 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-12
  269. - forgot about rpmorig too (ugh)
  270. * Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-11
  271. - Make logd a noreplace
  272. * Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-10
  273. - Add patch to ignore .rpm{new,save} files
  274. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-9
  275. - Remove automake dependency, build Makefile.in changes into patch
  276. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-8
  277. - Run automake after patching
  278. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-7
  279. - Added BuildRequires: automake
  280. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-6
  281. - Added patch to allow runtime tty changes
  282. * Fri Feb 15 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-5
  283. - Added patch to imply --force on runlevels 0 and 6
  284. * Wed Feb 06 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-4
  285. - Patched for GCC 4.3
  286. * Thu Jan 31 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-3
  287. - Added AUTHORS, COPYING, etc.
  288. - Made config --libdir option relative
  289. * Mon Jan 21 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-2
  290. - Remove libnih and libupstart
  291. * Sun Jan 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-1
  292. - Initial packaging