rwho-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228
  1. Summary: Displays who is logged in to local network machines.
  2. Summary(ja): ローカルネットワーク機に誰がログインしているか表示する
  3. Name: rwho
  4. Version: 0.17
  5. Release: 55%{?_dist_release}
  6. # part of rwhod is under GPL+, other parts are under BSD
  7. License: BSD and GPL+
  8. Group: System Environment/Daemons
  9. Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-rwho-%{version}.tar.gz
  10. Source1: rwhod.init
  11. Patch0: netkit-rwho-0.15-alpha.patch
  12. Patch1: netkit-rwho-0.17-bug22014.patch
  13. Patch2: rwho-0.17-fixbcast.patch
  14. Patch3: rwho-0.17-fixhostname.patch
  15. Patch4: netkit-rwho-0.17-strip.patch
  16. Patch5: netkit-rwho-0.17-include.patch
  17. Patch6: netkit-rwho-0.17-wd_we.patch
  18. Patch7: netkit-rwho-0.17-time.patch
  19. Patch8: netkit-rwho-0.17-gcc4.patch
  20. Patch9: rwho-0.17-waitchild.patch
  21. Patch10: rwho-0.17-neighbours.patch
  22. Patch11: rwho-0.17-hostnamelen.patch
  23. Patch12: rwho-0.17-stderr.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. #Requires: /sbin/chkconfig /etc/init.d
  26. Requires: /sbin/chkconfig
  27. %description
  28. The rwho command displays output similar to the output of the who
  29. command (it shows who is logged in) for all machines on the local
  30. network running the rwho daemon.
  31. Install the rwho command if you need to keep track of the users who
  32. are logged in to your local network.
  33. %description -l ja
  34. rwho コマンドは who コマンド (誰がログインしているかを表示します) の
  35. 出力に似た表示をするプログラムで,rwho デーモンが動作しているローカル
  36. ネットワーク上の全マシンの情報を出力します.
  37. あなたのローカルネットワーク上のマシンに誰がログインしているかを
  38. 知りたい場合は rwho コマンドをインストールして下さい.
  39. %prep
  40. %setup -q -n netkit-rwho-%{version}
  41. %patch0 -p1 -b .alpha
  42. %patch1 -p1 -b .bug22014
  43. %patch2 -p1 -b .fixbcast
  44. %patch3 -p1 -b .fixhostname
  45. %patch4 -p1 -b .strip
  46. %patch5 -p1 -b .include
  47. %patch6 -p1 -b .wd_we
  48. %patch7 -p1 -b .time
  49. %patch8 -p1 -b .gcc4
  50. %patch9 -p1 -b .waitchild
  51. %patch10 -p1 -b .neighbours
  52. %patch11 -p1 -b .hostnamelen
  53. %patch12 -p1 -b .stderr
  54. %{__perl} -pi -e '
  55. s|^LDFLAGS=|LDFLAGS="-pie -Wl,-z,relro,-z,now"|;
  56. s,^BINDIR=.*$,BINDIR=%{_bindir},;
  57. s,^MANDIR=.*$,MANDIR=%{_mandir},;
  58. s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
  59. ' configure
  60. %build
  61. CFLAGS="$RPM_OPT_FLAGS -I../include -fPIC" \
  62. sh configure --with-c-compiler=gcc
  63. make %{?_smp_mflags}
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  67. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,8}
  68. mkdir -p $RPM_BUILD_ROOT%{_sbindir}
  69. mkdir -p $RPM_BUILD_ROOT%{_initdir}
  70. mkdir -p $RPM_BUILD_ROOT/var/spool/rwho
  71. make INSTALLROOT=$RPM_BUILD_ROOT install
  72. make INSTALLROOT=$RPM_BUILD_ROOT install -C ruptime
  73. install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/rwhod
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %post
  77. /sbin/chkconfig --add rwhod
  78. %preun
  79. if [ $1 = 0 ]; then
  80. /sbin/chkconfig --del rwhod
  81. fi
  82. %files
  83. %defattr(-,root,root)
  84. %doc README
  85. %{_bindir}/ruptime
  86. %{_mandir}/man1/ruptime.1*
  87. %{_bindir}/rwho
  88. %{_mandir}/man1/rwho.1*
  89. %{_sbindir}/rwhod
  90. %{_mandir}/man8/rwhod.8*
  91. /var/spool/rwho
  92. %config %{_initdir}/rwhod
  93. %changelog
  94. * Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.17-55
  95. - added Patch9, 10, 11 and 12 from Fedora 0.17-54
  96. * Wed Nov 07 2012 Honza Horak <hhorak@redhat.com> - 0.17-47
  97. - Remove linkage against systemd-daemon
  98. - Print errors into stderr
  99. * Wed Dec 07 2011 Honza Horak <hhorak@redhat.com> - 0.17-37
  100. - allow longer hostnames (bug #212076)
  101. - add -n option to ruptime manpage
  102. * Thu Jun 02 2011 Honza Horak <hhorak@redhat.com> - 0.17-35
  103. - applied patch from Ian Donaldson to transmit status reliably
  104. (bug #708385)
  105. * Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 0.17-26
  106. - exit daemon, if child process dies (bug #202493)
  107. - moved to System Environment/Daemons
  108. * Sun May 1 2011 Shu KONNO <owa@bg.wakwak.com> 0.17-27
  109. - rebuilt with current VineSeed
  110. * Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-26vl5
  111. - added netkit-rwho-0.17-getloadavg.patch
  112. - applied new versioning policy, spec in utf-8
  113. * Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-19vl1
  114. - added Patch5, 6, 7 and 8 from Fedora 0.17-25.2.1
  115. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-25
  116. - gcc4 rebuild fixes
  117. * Fri Oct 22 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-23
  118. - Fixed long standig bug with only 42 entries per host showing up (#27643)
  119. - Fixed some warnings of missing prototypes.
  120. * Wed May 12 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-21
  121. - Enabled PIE for server and application.
  122. - changed Group to Applications/Internet
  123. * Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-19vl1
  124. - based on Redhat Rawhide 0.17-19
  125. - added Patch2, 3 and 4
  126. - rebuild with new toolchains
  127. * Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  128. - 0.17-7vl1
  129. - based on 0.17-7 from Rawhide
  130. - use better macros (%%{_initdir})
  131. - added Japanese summary and description
  132. * Wed Dec 27 2000 Jeff Johnson <jhbj@redhat.com>
  133. - use glibc's <protocols/rwhod.h>, internal version broken on alpha (#22014).
  134. * Thu Aug 10 2000 Bill Nottingham <notting@redhat.com>
  135. - fix broken init script
  136. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  137. - condrestart fixes
  138. * Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
  139. - move initscript back
  140. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  141. - automatic rebuild
  142. * Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
  143. - move initscript
  144. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
  145. - FHS packaging.
  146. - update to 0.17.
  147. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  148. - compress man pages.
  149. * Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
  150. - update to 0.16.
  151. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  152. - postun should have been preun.
  153. * Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
  154. - fix unaligned trap on alpha.
  155. - update to 0.15.
  156. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  157. - initscript munging
  158. * Fri Apr 9 1999 Jeff Johnson <jbj@redhat.com>
  159. - add ruptime (#2023)
  160. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  161. - auto rebuild in the new build environment (release 22)
  162. * Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
  163. - compile for 6.0.
  164. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  165. - translations modified for de, fr, tr
  166. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  167. - enhanced initscripts
  168. * Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
  169. - added /var/spool/rwho
  170. * Fri Oct 31 1997 Donnie Barnes <djb@redhat.com>
  171. - fixed init script
  172. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  173. - added an init script
  174. - uses chkconfig
  175. - uses %attr tags
  176. * Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
  177. - initial build