riece-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origver 8.0.0
  4. %define origname riece
  5. Summary: Riece is emacs based irc client
  6. Summary(ja): Riece は Emacsen 上で動作する IRC のクライアント
  7. Name: %{origname}
  8. Version: %{origver}
  9. Release: 1%{?_dist_release}
  10. Source0: http://dl.sv.gnu.org/releases/riece/%{name}-%{version}.tar.gz
  11. Source1: %{name}-install.sh
  12. Source2: %{name}-remove.sh
  13. Source3: %{name}-init.el
  14. License: GPL
  15. Group: Applications/Editors/Emacs
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildArch: noarch
  18. Requires(post): emacsen
  19. Requires(post): /sbin/install-info
  20. Requires(preun): emacsen
  21. Requires(preun): /sbin/install-info
  22. %prereq_ge emacsen-common
  23. %prereq_ge flim
  24. %description
  25. Riece is a user interface for IRC (Internet Relay Chat). You should spell it
  26. with the first letter capitalized and pronounce it as /ri:s/.
  27. The features of Riece are as follows:
  28. * Several IRC servers may be used at the same time.
  29. * Many features built upon the extension mechanism called add-on.
  30. Currently 30 such add-ons are available.
  31. * Installation is easy. Riece doesn't depend on other packages.
  32. * Setup is easy. Automatically save/restore the configuration.
  33. * Step-by-step instructions are included.
  34. * Mostly compliant with the latest IRC client protocol (RFC2812).
  35. #'
  36. %description -l ja
  37. Riece は IRC (Internet Relay Chat) の世界でチャットを楽しむためのユーザインタ
  38. ーフェースです。Riece は「りーす」と読みます。
  39. Riece の主な特長は以下の通りです。
  40. * 複数の IRC サーバに同時に接続可能
  41. * アドオンにより機能の追加や取り外しが容易
  42. * 他の elisp パッケージに依存しないため、インストールが簡単
  43. * 設定が簡単で、前回起動時の設定を記録・復元する仕組みを提供
  44. * 段階的な操作説明書が附属
  45. * 最新の IRC のクライアントプロトコル (RFC2812) に準拠
  46. %prep
  47. %setup -q
  48. %build
  49. %configure
  50. %install
  51. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  52. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  53. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  54. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  55. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  56. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  57. #
  58. # install el files
  59. #
  60. cp -a lisp/* ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  61. #
  62. # build & install info
  63. #
  64. make DESTDIR=${RPM_BUILD_ROOT} install-info
  65. #
  66. # install script( bytecompile el and install elc , remove )
  67. #
  68. %_installemacsenscript %{origname} %{SOURCE1}
  69. %_removeemacsenscript %{origname} %{SOURCE2}
  70. #
  71. # install info file
  72. #
  73. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  74. #
  75. # install site-start script
  76. #
  77. install %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  78. ## remove unpackaged files
  79. %__rm ${RPM_BUILD_ROOT}%{_infodir}/dir
  80. %pre
  81. if (grep -q "Riece: (liece)" /usr/share/info/dir) ; then
  82. cp /usr/share/info/dir /usr/share/info/dir.rpmsave
  83. grep -v "Riece: (liece)" /usr/share/info/dir.rpmsave > /usr/share/info/dir
  84. rm -f /usr/share/info/dir.rpmsave
  85. fi
  86. %post
  87. #
  88. # bytecompile and install
  89. #
  90. if [ "$1" = 2 ]; then
  91. %_emacsenPackageRemove %{origname}
  92. fi
  93. %_addemacsenlist %{origname}
  94. %_emacsenPackageInstall %{origname}
  95. /sbin/install-info %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
  96. --entry="* Riece: (riece-ja). IRC Client On Emacsen" --section="Emacs" ||:
  97. %preun
  98. if [ "$1" = 0 ]; then
  99. %_emacsenPackageRemove %{origname}
  100. %_removeemacsenlist %{origname}
  101. /sbin/install-info --delete %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
  102. --entry="* Riece: (riece-ja). IRC Client On Emacsen" --section="Emacs" ||:
  103. fi
  104. %clean
  105. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  106. %files
  107. %defattr(-,root,root)
  108. %doc AUTHORS COPYING ChangeLog* INSTALL NEWS* README*
  109. %{_datadir}/emacs/site-lisp/%{origname}
  110. %{emacsen_pkgdir}/install/%{origname}
  111. %{emacsen_pkgdir}/remove/%{origname}
  112. %{_infodir}/%{origname}-*.info*
  113. %changelog
  114. * Thu Dec 1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.0-1
  115. - new upstream release
  116. * Wed Feb 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.3-1
  117. - new upstream release
  118. - dropped riece-7.0.0-check-make-local-hook.patch
  119. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-2
  120. - applied riece-7.0.0-check-make-local-hook.patch
  121. * Wed Nov 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-1
  122. - new upstream release
  123. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.1.0-1
  124. - new upstream release
  125. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-2
  126. - updated riece-install.sh
  127. - *-init.el: changed from hard copy to symbolic link
  128. on /etc/emacs-XX.YY/site-start.d
  129. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-1
  130. - new upstream release
  131. * Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.0-1
  132. - applied new versioning policy
  133. - spec in UTF-8
  134. * Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.0-0vl1
  135. - new upstream release
  136. * Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl4
  137. - fixed %post script <BTS:VineLinux:177>
  138. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl3
  139. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  140. - s/Copyright/License/
  141. * Sat Sep 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl2
  142. - change BuildArch to noarch
  143. * Fri Sep 9 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl1
  144. - initial build