rest-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %define package_version 0.8.1
  4. %define package_release 1%{?_dist_release}
  5. Name: rest
  6. Version: %{package_version}
  7. Release: %{package_release}
  8. Summary: RESTful web api query library
  9. Group: System Environment/Libraries
  10. License: LGPLv2+
  11. URL: http://git.gnome.org/browse/librest
  12. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: glib2-devel
  15. BuildRequires: gobject-introspection-devel
  16. BuildRequires: libsoup-devel
  17. BuildRequires: ca-certificates
  18. BuildRequires: gtk-doc
  19. Requires: ca-certificates
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: Takemikaduchi
  23. %description
  24. This library has been designed to make it easier to access web services that
  25. claim to be "RESTful". A reasonable definition of what this means can be found
  26. on Wikipedia [1]. However a reasonable description is that a RESTful service
  27. should have urls that represent remote objects which methods can then be
  28. called on.
  29. %package devel
  30. Summary: Development tools for rest
  31. Summary(ja): rest の開発環境
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: pkgconfig
  35. Requires: glib2-devel
  36. Requires: libsoup-devel
  37. Requires: libxml2-devel
  38. %description devel
  39. Header files and libraries for building a extension library for the
  40. rest.
  41. %package doc
  42. Summary: Documentation for rest
  43. Summary(ja): rest 用のドキュメント
  44. Group: Documentation
  45. Requires: %{name} = %{version}-%{release}
  46. BuildArch: noarch
  47. %description doc
  48. This package contains documentation for rest.
  49. # compat32
  50. %package -n compat32-%{name}
  51. Summary: RESTful web api query library
  52. Group: System Environment/Libraries
  53. %description -n compat32-%{name}
  54. This library has been designed to make it easier to access web services that
  55. claim to be "RESTful". A reasonable definition of what this means can be found
  56. on Wikipedia [1]. However a reasonable description is that a RESTful service
  57. should have urls that represent remote objects which methods can then be
  58. called on.
  59. %prep
  60. %setup -q
  61. %build
  62. %configure \
  63. --enable-gtk-doc \
  64. --disable-static \
  65. --enable-introspection=yes
  66. make %{?_smp_mflags}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make DESTDIR=$RPM_BUILD_ROOT install
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %post -p /sbin/ldconfig
  74. %postun -p /sbin/ldconfig
  75. %post -n compat32-%{name} -p /sbin/ldconfig
  76. %postun -n compat32-%{name} -p /sbin/ldconfig
  77. %files
  78. %defattr(-,root,root,-)
  79. %doc ChangeLog AUTHORS COPYING README
  80. %{_libdir}/*.so.*
  81. %{_libdir}/girepository-1.0/*.typelib
  82. %files devel
  83. %defattr(-, root, root)
  84. %{_includedir}/%{name}-0.7
  85. %{_libdir}/*.so
  86. %{_libdir}/pkgconfig/*.pc
  87. %{_datadir}/gir-1.0/*.gir
  88. %files doc
  89. %defattr(-, root, root)
  90. %{_datadir}/gtk-doc/html/%{name}-0.7
  91. %if %{build_compat32}
  92. %files -n compat32-%{name}
  93. %defattr(-,root,root,-)
  94. %{_libdir}/*.so.*
  95. %endif
  96. %changelog
  97. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.1-1
  98. - new upstream release.
  99. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-2
  100. - create compat32-rest subpakcage
  101. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-1
  102. - new upstream release
  103. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.92-1
  104. - new upstream release
  105. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.91-1
  106. - new upstream release
  107. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-2
  108. - rebuild with VineSeed environment
  109. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-1
  110. - new upstream release
  111. - change BuildRequires: ca-certificates instead of openssl-devel
  112. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-2
  113. - fix URL
  114. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
  115. - new upstream release
  116. - add BuildRequires: openssl
  117. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
  118. - new upstream release
  119. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
  120. - initial build for Vine Linux