python-pip-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %bcond_with bootstrap
  2. %bcond_without python3
  3. %global srcname pip
  4. %global python_wheelname %{srcname}-%{version}-py2.py3-none-any.whl
  5. %if %{without bootstrap}
  6. %global python2_wheelname %python_wheelname
  7. %if %{with python3}
  8. %global python3_wheelname %python_wheelname
  9. %endif
  10. %endif
  11. Summary: Pip installs Python packages. An easy_install replacement
  12. Summary(ja): Pip は easy_install を置き換える Python パッケージインストーラです。
  13. Name: python-%{srcname}
  14. Version: 20.0.2
  15. Release: 1%{?_dist_release}
  16. Group: Development/Libraries
  17. License: MIT
  18. URL: https://pip.pypa.io/en/stable/
  19. Source0: https://pypi.python.org/packages/source/p/pip/%{srcname}-%{version}.tar.gz
  20. # # Patch until the following issue gets implemented upstream:
  21. # # https://github.com/pypa/pip/issues/1351
  22. # Patch0: allow-stripping-given-prefix-from-wheel-RECORD-files.patch
  23. # # Downstream only patch
  24. # # Emit a warning to the user if pip install is run with root privileges
  25. # # Issue upstream: https://github.com/pypa/pip/issues/4288
  26. # Patch1: emit-a-warning-when-running-with-root-privileges.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. BuildArch: noarch
  29. BuildRequires: python-rpm-macros
  30. BuildRequires: python3-rpm-macros
  31. BuildRequires: python-devel
  32. BuildRequires: python-setuptools
  33. BuildRequires: python3-devel
  34. BuildRequires: python3-setuptools
  35. Requires: python-setuptools
  36. %if %{without bootstrap}
  37. BuildRequires: python-pip
  38. BuildRequires: python-wheel
  39. %endif
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. %description
  43. pip is a package management system used to install and manage software packages
  44. written in Python. Many packages can be found in the Python Package Index
  45. (PyPI). pip is a recursive acronym that can stand for either "Pip Installs
  46. Packages" or "Pip Installs Python".
  47. %package -n python3-%{srcname}
  48. Summary: A tool for installing and managing Python3 packages
  49. Group: Development/Libraries
  50. %if %{without bootstrap}
  51. BuildRequires: python3-pip
  52. BuildRequires: python3-wheel
  53. %endif
  54. Requires: python3-setuptools
  55. %description -n python3-%{srcname}
  56. pip is a package management system used to install and manage software packages
  57. written in Python. Many packages can be found in the Python Package Index
  58. (PyPI). pip is a recursive acronym that can stand for either "Pip Installs
  59. Packages" or "Pip Installs Python".
  60. %prep
  61. %setup -q -n %{srcname}-%{version}
  62. # %patch0 -p1
  63. # %patch1 -p1
  64. # Remove ordereddict as it is only required for python <= 2.6
  65. #rm pip/_vendor/ordereddict.py
  66. %build
  67. %if %{without bootstrap}
  68. %py_build_wheel
  69. %else
  70. %py_build
  71. %endif
  72. %if %{with python3}
  73. %if %{without bootstrap}
  74. %py3_build_wheel
  75. %else
  76. %py3_build
  77. %endif
  78. %endif # with python3
  79. %install
  80. %{__rm} -rf %{buildroot}
  81. %if %{with python3}
  82. %if %{without bootstrap}
  83. %py3_install_wheel %{python3_wheelname}
  84. %else
  85. %py3_install
  86. %endif
  87. # TODO: we have to remove this by hand now, but it'd be nice if we wouldn't have to
  88. # (pip install wheel doesn't overwrite)
  89. rm %{buildroot}%{_bindir}/pip
  90. %endif # with python3
  91. %if %{without bootstrap}
  92. %py_install_wheel %{python_wheelname}
  93. %else
  94. %py_install
  95. %endif
  96. %clean
  97. %{__rm} -rf %{buildroot}
  98. %files
  99. %defattr(-,root,root,-)
  100. %license LICENSE.txt
  101. %doc README.rst docs
  102. %attr(755,root,root) %{_bindir}/pip
  103. %attr(755,root,root) %{_bindir}/pip2*
  104. %{python_sitelib}/pip*
  105. %files -n python3-pip
  106. %defattr(-,root,root,-)
  107. %license LICENSE.txt
  108. %doc README.rst docs
  109. %attr(755,root,root) %{_bindir}/pip3*
  110. %{python3_sitelib}/pip*
  111. %changelog
  112. * Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.0.2-1
  113. - new upstream release.
  114. * Sat Oct 06 2018 Toshiaki Ara <ara_t@384.jp> 18.1-1
  115. - new upstream release.
  116. - drop Patches
  117. - change URL
  118. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  119. - new upstream release.
  120. - made to use python{,3}-rpm-macros.
  121. - added a sub-package for python3.
  122. * Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.6-1
  123. - new upstream release
  124. - didn't rename pip to python-pip
  125. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-3
  126. - rebuild with VineSeed environment
  127. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-2
  128. - rebuild with python-2.7.2
  129. * Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
  130. - updated pip to 0.8.1
  131. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8-1
  132. - initial build for Vine Linux
  133. * Mon Aug 30 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.8-1
  134. - update to 0.8 of pip
  135. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.7.2-5
  136. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  137. * Wed Jul 7 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.2-1
  138. - update to 0.7.2 of pip
  139. * Sun May 23 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.1-1
  140. - update to 0.7.1 of pip
  141. * Fri Jan 1 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1.4
  142. - fix dependency issue
  143. * Fri Dec 18 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-2
  144. - fix spec file
  145. * Thu Dec 17 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-1
  146. - upgrade to 0.6.1 of pip
  147. * Mon Aug 31 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.4-1
  148. - Initial package