python-cups-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. %{?filter_setup:
  2. %filter_provides_in %{python_sitearch}/.*\.so$
  3. %filter_setup
  4. }
  5. %define py3dir %{_builddir}/python3-%{name}-%{version}-%{release}
  6. %define __python3 /usr/bin/python3
  7. %define python3_sitearch %(%{__python3} -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")
  8. %define python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(0))")
  9. Summary: Python bindings for CUPS
  10. Name: python-cups
  11. Version: 1.9.74
  12. Release: 1%{?_dist_release}
  13. URL: http://cyberelk.net/tim/software/pycups/
  14. Source: http://cyberelk.net/tim/data/pycups/pycups-%{version}.tar.bz2
  15. License: GPLv2+
  16. Group: Development/Languages
  17. BuildRequires: cups-devel
  18. BuildRequires: python-devel
  19. BuildRequires: python3-devel
  20. BuildRequires: epydoc
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: tomop
  24. %description
  25. This package provides Python bindings for CUPS API,
  26. known as pycups. It was written for use with
  27. system-config-printer, but can be put to other uses as well.
  28. %package -n python3-cups
  29. Summary: Python3 bindings for CUPS API, known as pycups.
  30. Group: Development/Languages
  31. %description -n python3-cups
  32. This package provides Python bindings for CUPS API,
  33. known as pycups. It was written for use with
  34. system-config-printer, but can be put to other uses as well.
  35. This is a ported release for python 3
  36. %package doc
  37. Summary: Documentation for python-cups
  38. Group: Documentation
  39. %description doc
  40. Documentation for python-cups.
  41. %prep
  42. %setup -q -n pycups-%{version}
  43. rm -rf %{py3dir}
  44. cp -a . %{py3dir}
  45. %build
  46. make CFLAGS="%{optflags} -fno-strict-aliasing"
  47. make doc
  48. pushd %{py3dir}
  49. CFLAGS="%{optflags}" %{__python3} setup.py build
  50. popd
  51. %install
  52. make install DESTDIR="%{buildroot}"
  53. pushd %{py3dir}
  54. %{__python3} setup.py install -O1 --skip-build --root %{buildroot}
  55. chmod 755 %{buildroot}%{python3_sitearch}/cups*.so
  56. popd
  57. %files
  58. %license COPYING
  59. %doc README NEWS TODO
  60. %{python_sitearch}/cups.so
  61. %{python_sitearch}/pycups*.egg-info
  62. %{_rpmconfigdir}/fileattrs/psdriver.attr
  63. %{_rpmconfigdir}/postscriptdriver.prov
  64. %files -n python3-cups
  65. %license COPYING
  66. %doc README NEWS
  67. %{python3_sitearch}/cups.cpython-3*.so
  68. %{python3_sitearch}/pycups*.egg-info
  69. %{_rpmconfigdir}/fileattrs/psdriver.attr
  70. %{_rpmconfigdir}/postscriptdriver.prov
  71. %files doc
  72. %doc examples html
  73. %changelog
  74. * Wed Apr 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.74-1
  75. - new upstream release.
  76. * Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> 1.9.72-1
  77. - new upstream release.
  78. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.66-1
  79. - new upstream release.
  80. * Sat Sep 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.58-1
  81. - new upstream release.
  82. - built for Vine Linux.
  83. * Thu Jun 9 2011 Tim Waugh <twaugh@redhat.com> - 1.9.57-1
  84. - 1.9.57. Fixes rpm provides script (bug #712027).
  85. * Sun Mar 20 2011 Tim Waugh <twaugh@redhat.com> - 1.9.55-1
  86. - 1.9.55. Support for IPP "resolution" type.
  87. * Wed Feb 23 2011 Tim Waugh <twaugh@redhat.com> - 1.9.54-1
  88. - 1.9.54. The rpm hook is now upstream.
  89. * Wed Feb 23 2011 Tim Waugh <twaugh@redhat.com> - 1.9.53-5
  90. - Use rpmconfigdir macro throughout.
  91. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.53-4
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  93. * Tue Jan 25 2011 Tim Waugh <twaugh@redhat.com> - 1.9.53-3
  94. - Fixed typo in psdriver.attr that prevented PPD files from being
  95. scanned when generating postscriptdriver tags.
  96. * Thu Jan 20 2011 Tim Waugh <twaugh@redhat.com> - 1.9.53-2
  97. - Moved postscriptdriver RPM tagging machinery here. Fixed
  98. leading/trailing whitespace in tags as well.
  99. * Wed Dec 15 2010 Tim Waugh <twaugh@redhat.com> - 1.9.53-1
  100. - 1.9.53 fixing a thread-local storage issue (bug #662805).
  101. * Wed Nov 17 2010 Jiri Popelka <jpopelka@redhat.com> - 1.9.52-2
  102. - Fixed rpmlint errors/warnings (#648986)
  103. - doc subpackage
  104. * Mon Nov 01 2010 Jiri Popelka <jpopelka@redhat.com> - 1.9.52-1
  105. - Initial RPM spec file