pygobject-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Name: pygobject
  3. Summary: Python bindings for GObject
  4. Summary(ja): GObject の Python バインディング
  5. Version: 2.28.6
  6. Release: 7%{?_dist_release}
  7. Group: Development/Languages
  8. License: LGPL
  9. URL: http://www.pygtk.org/
  10. Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.28/pygobject-%{version}.tar.xz
  11. Patch0: 00git_cairo_init.patch
  12. Patch1: 00git_enum_properties.patch
  13. Patch2: 00git_fix_qdata_warning.patch
  14. Patch3: 00git_gio_flag_type.patch
  15. Patch4: 00git_gio_test.patch
  16. Patch5: 00git_messagebox_type.patch
  17. Patch6: 00git_python3-maketrans.patch
  18. Patch7: 00git_python3_build.patch
  19. Patch8: 00git_test_case_hang.patch
  20. Patch9: 00git_textiter_crash.patch
  21. Patch10: 20_deprecated_spam.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: glib2-devel >= 2.26.0
  24. BuildRequires: python-devel >= 2.6
  25. BuildRequires: libffi-devel
  26. BuildRequires: libtool, automake
  27. BuildRequires: pycairo-devel >= 1.8.10
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: daisuke
  31. %description
  32. pygobject provides a convenient wrapper for the GObject library
  33. for use in Python programs.
  34. %package devel
  35. Summary: Development files for building add-on libraries
  36. Group: Development/Libraries
  37. Requires: pygobject = %{version}-%{release}
  38. #Requires: pygobject-doc = %{version}-%{release}
  39. Requires: glib2-devel
  40. Requires: libffi-devel
  41. Requires: pkgconfig
  42. %description devel
  43. This package contains files required to build wrappers for
  44. pygobject-based libraries such as pygtk2.
  45. %package doc
  46. Summary: Documentation files for pygobject
  47. Group: Documentation
  48. %description doc
  49. This package contains documentation files for pygobject.
  50. %prep
  51. %setup -q
  52. %patch0 -p1
  53. %patch1 -p1
  54. %patch2 -p1
  55. %patch3 -p1
  56. %patch4 -p1
  57. %patch5 -p1
  58. %patch6 -p1
  59. %patch7 -p1
  60. %patch8 -p1
  61. %patch9 -p1
  62. %patch10 -p1
  63. %build
  64. # --disable-docs doesn't work; it builds the docs anyway.
  65. %configure \
  66. --enable-silent-rules \
  67. --disable-static \
  68. --enable-thread \
  69. --disable-introspection \
  70. --disable-docs
  71. export tagname=CC
  72. make LIBTOOL=/usr/bin/libtool
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. export tagname=CC
  76. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
  77. find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
  78. rm -f examples/Makefile*
  79. %clean
  80. rm -fr $RPM_BUILD_ROOT
  81. %files
  82. %defattr(644, root, root, 755)
  83. %doc AUTHORS NEWS README ChangeLog
  84. %doc examples
  85. %{_libdir}/libpyglib-2.0-python.so.*
  86. %dir %{python_sitearch}/gtk-2.0
  87. %{python_sitearch}/gtk-2.0/dsextras.*
  88. %{python_sitearch}/pygtk.*
  89. %defattr(755, root, root, 755)
  90. %{python_sitearch}/gtk-2.0/gio
  91. %{python_sitearch}/glib
  92. %{python_sitearch}/gobject
  93. %files devel
  94. %defattr(755, root, root, 755)
  95. %{_bindir}/pygobject-codegen-2.0
  96. %defattr(644, root, root, 755)
  97. %dir %{_datadir}/pygobject
  98. %dir %{_datadir}/pygobject/2.0
  99. %dir %{_includedir}/pygtk-2.0
  100. %{_datadir}/pygobject/2.0/codegen
  101. %{_datadir}/pygobject/2.0/defs
  102. %{_datadir}/pygobject/xsl
  103. %{_includedir}/pygtk-2.0/pyglib.h
  104. %{_includedir}/pygtk-2.0/pygobject.h
  105. %{_libdir}/libpyglib-2.0-python.so
  106. %{_libdir}/pkgconfig/pygobject-2.0.pc
  107. %files doc
  108. %defattr(644, root, root, 755)
  109. %{_datadir}/gtk-doc/html/pygobject
  110. %changelog
  111. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.28.6-7
  112. - rebuilt with libffi-3.3.
  113. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-6
  114. - rebuild with libffi-3.0.13
  115. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-5
  116. - rebuild with VineSeed environment
  117. * Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.28.6-4
  118. - added Patch0-10 from Debian sid
  119. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-3
  120. - rebuild with python-2.7.2
  121. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-2
  122. - remove BuildRequires: gobject-introspection-devel
  123. - change configure option --disable-introspection instead of --enable-introspection=yes
  124. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  125. - new upstream release
  126. * Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.4-1
  127. - update to 2.28.4
  128. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  129. - new upstream release
  130. - add BuildRequires: gobject-introspection-devel, pycairo-devel
  131. - change configure option --enable-introspection=yes instead of --disable-introspection
  132. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.21.5-1
  133. - new upstream release
  134. - added --disable-intropection option (it needs gobject-introspection >= 0.9)
  135. - moved xsl files to devel package
  136. - built with rpm-4.8.1
  137. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  138. - new upstream release
  139. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
  140. - build for python-2.6
  141. * Wed Dec 2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
  142. - added Requires: libffi-devel to devel package <BTS:830>
  143. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
  144. - new upstream release
  145. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
  146. - new upstream release
  147. * Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
  148. - new upstream release
  149. * Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
  150. - new upstream release
  151. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
  152. - rebuilt with python-2.5.2
  153. * Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
  154. - new upstream release
  155. - spec in UTF-8
  156. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
  157. - rebuilt with python-2.4.5 and glib2-2.16.1
  158. - used %%{?_dist_release} macro
  159. * Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  160. - new upstream release
  161. * Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  162. - new upstream release
  163. - dropped Patch1 (merged into upstream)
  164. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  165. - initial build for Vine Linux
  166. * Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
  167. - Add patch for RH bug #237179 (memory leak).
  168. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
  169. - rebuild against python 2.5
  170. * Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
  171. - Update to 2.12.3
  172. * Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
  173. - Add subpackage pygobject2-doc (bug #205231).
  174. * Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
  175. - Use python_sitearch instead of python_sitelib.
  176. * Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
  177. - Update to 2.12.2
  178. * Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
  179. - Require glib2-devel for the -devel package.
  180. * Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
  181. - Define a python_sitelib macro for files under site_packages.
  182. - Spec file cleanups.
  183. * Tue Sep 5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
  184. - Update to 2.12.1
  185. - Require pkgconfig for the -devel package
  186. * Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
  187. - Update to 2.11.4
  188. - Use pre-built docs
  189. * Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
  190. - Update to 2.11.3
  191. * Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
  192. - BR libxslt
  193. * Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
  194. - Update to 2.11.2
  195. * Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
  196. - rebuild
  197. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
  198. - Update to 2.11.0
  199. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
  200. - rebuild
  201. - Add missing br libtool
  202. * Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
  203. - Cleanup
  204. * Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
  205. - Initial package