123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183 |
- Name: polkit-qt
- Summary: Qt bindings for PolicyKit
- Summary(ja): PolicyKit の Qt バインディング
- Version: 0.112.0
- Release: 3%{?_dist_release}
- Group: System Environment/Libraries
- License: GPLv2+
- URL: http://api.kde.org/kdesupport-api/kdesupport-apidocs/polkit-qt/html/
- Source0: ftp://ftp.kde.org/pub/kde/stable/polkit-qt-1/polkit-qt-1-%{version}.tar.bz2
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: automoc4
- BuildRequires: cmake
- BuildRequires: glib2-devel
- BuildRequires: polkit-devel
- BuildRequires: qt4-devel
- BuildRequires: qt5-qtbase-devel
- %description
- Polkit-qt is a library that lets developers use the PolicyKit API through a nice
- Qt-styled API. It is mainly a wrapper around QAction and QAbstractButton that
- lets you integrate those two component easily with PolicyKit.
- %package devel
- Summary: Development files for %{name}
- Summary(ja): %{name} の開発用ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: polkit-devel
- Requires: pkgconfig
- %description devel
- %{summary}.
- %package -n polkit-qt5
- Summary: Qt5 bindings for PolicyKit
- Summary(ja): PolicyKit の Qt5 バインディング
- Group: System Environment/Libraries
- %description -n polkit-qt5
- %{summary}.
- %package -n polkit-qt5-devel
- Summary: Development files for polkit-qt5
- Summary(ja): polkit-qt5 の開発用ファイル
- Group: Development/Libraries
- Requires: polkit-qt5 = %{version}-%{release}
- Requires: polkit-devel
- Requires: pkgconfig
- %description -n polkit-qt5-devel
- %{summary}.
- #package examples
- #Summary: Example files for %{name}
- #Group: Development/Libraries
- #Requires: %{name} = %{version}-%{release}
- #description examples
- #%{summary}.
- %prep
- %setup -q -n polkit-qt-1-%{version}
- %build
- %ifarch x86_64
- PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
- %endif
- mkdir -p build_qt4
- pushd build_qt4
- %cmake \
- -DUSE_QT4=ON \
- -DCMAKE_BUILD_TYPE=release \
- -DBUILD_EXAMPLES=0 ..
- make %{?_smp_mflags}
- popd
- mkdir -p build_qt5
- pushd build_qt5
- %cmake \
- -DUSE_QT5=ON \
- -DCMAKE_BUILD_TYPE=release \
- -DBUILD_EXAMPLES=0 ..
- make %{?_smp_mflags}
- popd
- %install
- rm -rf $RPM_BUILD_ROOT
- make install/fast DESTDIR=$RPM_BUILD_ROOT -C build_qt4
- make install/fast DESTDIR=$RPM_BUILD_ROOT -C build_qt5
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %license COPYING
- %doc AUTHORS README
- %{_libdir}/libpolkit-qt-*.so.*
- %files -n polkit-qt5
- %defattr(-,root,root,-)
- %license COPYING
- %doc AUTHORS README
- %{_libdir}/libpolkit-qt5-*.so.*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/polkit-qt-1/
- %{_libdir}/libpolkit-qt-*.so
- %{_libdir}/pkgconfig/polkit-qt-*.pc
- %{_libdir}/cmake/PolkitQt-1
- %files -n polkit-qt5-devel
- %defattr(-,root,root,-)
- %{_includedir}/polkit-qt5-1/
- %{_libdir}/libpolkit-qt5-*.so
- %{_libdir}/pkgconfig/polkit-qt5-*.pc
- %{_libdir}/cmake/PolkitQt5-1
- #%files examples
- #%defattr(-,root,root,-)
- #%{_sysconfdir}/dbus-1/system.d/org.qt.policykit.examples.conf
- #%{_bindir}/polkit-example-helper
- #%{_datadir}/PolicyKit/policy/org.qt.policykit.examples.policy
- #%{_datadir}/dbus-1/system-services/org.qt.policykit.examples.service
- %changelog
- * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.112-0-3
- - enabled Qt5.
- * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.112.0-2
- - rebuild with gcc-5.4.0
- * Sun Nov 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.112.0-1
- - update to 0.112.0
- * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.103.0-1
- - update to 0.103.0
- * Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.99.0-1
- - new upstream release
- * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.96.1-2
- - rebuilt with rpm-4.8.1 for pkg-config
- * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.96.1-1
- - new upstream release
- * Thu Feb 11 2010 Shu KONNO <owa@bg.wakwak.com> - 0.95.1-2
- - added qmake path to PATH (if x86_64)
- * Thu Feb 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.95.1-1
- - new upstream release
- - added BR: polkit-devel instead of PolicyKit-devel
- * Tue Sep 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9.2-4
- - use %%cmake macro
- * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-3
- - Initial build for Vine Linux
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Apr 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.2-1
- - polkit-0.9.2
|