pod-mode-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. %define origname pod-mode
  5. %define origver 0.5
  6. Summary: A major mode for editing .pod-files in (X)Emacs
  7. Summary(ja): (X)Emacs で POD ファイルを編集するためのメジャーモード
  8. Name: %{origname}
  9. Version: %{origver}
  10. Release: 2%{?_dist_release}
  11. Source0: http://search.cpan.org/CPAN/authors/id/S/SC/SCHWIGON/pod-mode/pod-mode-%{version}.tgz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. Source3: vine-default-pod-mode.el
  15. Source4: pod-mode-init.el
  16. License: GPL
  17. Group: Applications/Editors/Emacs
  18. URL: http://search.cpan.org/author/SCHWIGON/pod-mode/
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildArch: noarch
  21. Requires: emacsen
  22. PreReq: emacsen
  23. %prereq_ge emacsen-common
  24. Distribution: Vine Linux
  25. Vendor: Project Vine
  26. %description
  27. pod-mode.el - A major mode for editing .pod-files in (X)Emacs
  28. POD is the Plain Old Documentation format of Perl.
  29. This mode mainly defines a grammar for syntax highlighting.
  30. %description -l ja
  31. pod-mode.el - (X)Emacs で POD ファイルを編集するためのメジャー
  32. モード
  33. POD は Plain Old Documentation format of Perl という意味です。
  34. このモードは、構文ハイライトのための文法を定義している程度です。
  35. %prep
  36. %setup -q -n %{origname}-%{origver}
  37. %build
  38. %install
  39. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  40. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  41. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  42. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  43. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  44. #
  45. # install el files
  46. #
  47. cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  48. #
  49. # install script (bytecompile el and install elc , remove)
  50. #
  51. %_installemacsenscript %{origname} %{SOURCE1}
  52. %_removeemacsenscript %{origname} %{SOURCE2}
  53. %clean
  54. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  55. %post
  56. #
  57. # bytecompile and install
  58. #
  59. if [ "$1" = 2 ]; then
  60. %_emacsenPackageRemove %{origname}
  61. fi
  62. %_addemacsenlist %{origname}
  63. %_emacsenPackageInstall %{origname}
  64. %preun
  65. if [ "$1" = 0 ]; then
  66. %_emacsenPackageRemove %{origname}
  67. %_removeemacsenlist %{origname}
  68. fi
  69. %files
  70. %defattr(-,root,root)
  71. %doc README ChangeLog
  72. %{_datadir}/emacs/site-lisp/%{origname}
  73. %{emacsen_pkgdir}/install/%{origname}
  74. %{emacsen_pkgdir}/remove/%{origname}
  75. %changelog
  76. * Tue Apr 6 2010 IWAI, Masaharu <iwai@alib.jp> 0.5-2
  77. - correct output message on js2-mode-install.sh (SOURCE1)
  78. * Mon Dec 21 2009 IWAI, Masaharu <iwai@alib.jp> 0.5-1
  79. - new upstream release
  80. - apply vine-default
  81. - add vine-default-pod-mode.el (Source3)
  82. - add pod-mode-init.el (Source4)
  83. - update pod-mode-{install,remove}.sh
  84. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
  85. - applied new versioning policy, spec in utf-8
  86. - added macro %%emacsen_pkgdir
  87. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4-0vl1
  88. - updated to 0.4
  89. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  90. - s/Copyright/License/
  91. * Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 0.2-0vl2
  92. - add Japanese description
  93. * Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 0.2-0vl1
  94. - first release for Vine Linux