perl-Thread-Pool-vl.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. %define real_name Thread-Pool
  2. Summary: Group of threads for performing similar jobs
  3. Name: perl-Thread-Pool
  4. Version: 0.33
  5. Release: 2%{?_dist_release}
  6. License: Artistic
  7. Group: Development/Libraries
  8. URL: http://search.cpan.org/dist/Thread-Pool/
  9. Source: http://www.cpan.org/modules/by-module/Thread/Thread-Pool-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. BuildArch: noarch
  12. BuildRequires: perl
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(load)
  15. BuildRequires: perl(Thread::Conveyor) >= 0.15
  16. BuildRequires: perl(Thread::Conveyor::Monitored) >= 0.11
  17. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. The Thread::Pool allows you to set up a group of (worker) threads to
  22. execute a (large) number of similar jobs that need to be executed
  23. asynchronously. The routine that actually performs the job (the "do"
  24. routine), must be specified as a name or a reference to a (anonymous)
  25. subroutine.
  26. This module only functions on Perl versions 5.8.0 and later.
  27. And then only when threads are enabled with -Dusethreads. It
  28. is of no use with any version of Perl before 5.8.0 or without
  29. threads enabled.
  30. %prep
  31. %setup -q -n %{real_name}-%{version}
  32. %build
  33. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  34. make %{?_smp_mflags}
  35. %install
  36. rm -rf %{buildroot}
  37. make pure_install DESTDIR=%{buildroot}
  38. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  39. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  40. %{_fixperms} %{buildroot}
  41. %check
  42. make test
  43. %clean
  44. %{__rm} -rf %{buildroot}
  45. %files
  46. %defattr(-, root, root, 0755)
  47. %doc MANIFEST README CHANGELOG TODO
  48. %{perl_vendorlib}/*
  49. %{_mandir}/man3/*
  50. %changelog
  51. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.33-2
  52. - rebuilt with perl 5.16.3
  53. * Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.33-1
  54. - initial build for Vine Linux