perl-Perl-Critic-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-Perl-Critic
  4. Version: 1.132
  5. Release: 1%{?_dist_release}
  6. Summary: Critique Perl source code for best-practices
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/Perl-Critic/
  10. Source0: http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Perl-Critic-%{version}.tar.gz
  11. Patch0: PPI-1.248.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  15. # Build process
  16. BuildRequires: perl(Module::Build)
  17. BuildRequires: perl(Task::Weaken)
  18. # Module requirements
  19. BuildRequires: aspell-en
  20. Requires: aspell
  21. BuildRequires: perl(B::Keywords)
  22. BuildRequires: perl(Carp)
  23. BuildRequires: perl(charnames)
  24. BuildRequires: perl(Config::Tiny)
  25. BuildRequires: perl(Email::Address)
  26. BuildRequires: perl(English)
  27. BuildRequires: perl(Exception::Class)
  28. BuildRequires: perl(Exporter)
  29. BuildRequires: perl(File::Basename)
  30. BuildRequires: perl(File::Find)
  31. BuildRequires: perl(File::Path)
  32. BuildRequires: perl(File::ShareDir)
  33. BuildRequires: perl(File::Spec)
  34. BuildRequires: perl(File::Spec::Unix)
  35. BuildRequires: perl(File::Temp)
  36. BuildRequires: perl(Getopt::Long)
  37. BuildRequires: perl(IO::String)
  38. BuildRequires: perl(List::MoreUtils)
  39. BuildRequires: perl(List::Util)
  40. BuildRequires: perl-Module-Pluggable
  41. Requires: perl-Module-Pluggable
  42. BuildRequires: perl(overload)
  43. BuildRequires: perl(Perl::Tidy)
  44. BuildRequires: perl(Pod::Parser)
  45. Requires: perl(Pod::Parser)
  46. BuildRequires: perl(Pod::PlainText)
  47. BuildRequires: perl(Pod::Select)
  48. BuildRequires: perl(Pod::Spell)
  49. BuildRequires: perl(Pod::Usage)
  50. BuildRequires: perl(PPI)
  51. Requires: perl(PPI)
  52. BuildRequires: perl(PPIx::Regexp)
  53. BuildRequires: perl(PPIx::Utilities::Statement)
  54. BuildRequires: perl(Readonly)
  55. BuildRequires: perl(Scalar::Util)
  56. BuildRequires: perl(strict)
  57. BuildRequires: perl(String::Format)
  58. BuildRequires: perl(Text::ParseWords)
  59. BuildRequires: perl(version)
  60. BuildRequires: perl(warnings)
  61. # Optional module requirements
  62. BuildRequires: perl(File::HomeDir)
  63. Requires: perl(File::HomeDir)
  64. BuildRequires: perl(File::Which)
  65. Requires: perl(File::Which)
  66. BuildRequires: perl(Readonly::XS)
  67. Requires: perl(Readonly::XS)
  68. BuildRequires: perl(Term::ANSIColor)
  69. Requires: perl(Term::ANSIColor)
  70. # Main test suite
  71. BuildRequires: perl(Test::Deep)
  72. BuildRequires: perl(Test::Memory::Cycle)
  73. BuildRequires: perl(Test::More)
  74. # Author tests: not run if we're bootstrapping
  75. %if 0%{!?perl_bootstrap:1}
  76. BuildRequires: perl(Devel::EnforceEncapsulation)
  77. BuildRequires: perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables)
  78. BuildRequires: perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions)
  79. BuildRequires: perl(Test::Kwalitee)
  80. BuildRequires: perl(Test::Perl::Critic)
  81. BuildRequires: perl(Test::Pod)
  82. BuildRequires: perl(Test::Pod::Coverage)
  83. BuildRequires: perl(Test::Without::Module)
  84. %endif
  85. # don't "provide" private Perl libs
  86. %{?perl_default_filter}
  87. Vendor: Project Vine
  88. Distribution: Vine Linux
  89. Packager: shaolin
  90. %description
  91. Perl::Critic is an extensible framework for creating and applying coding
  92. standards to Perl source code. Essentially, it is a static source code
  93. analysis engine. Perl::Critic is distributed with a number of
  94. Perl::Critic::Policy modules that attempt to enforce various coding
  95. guidelines. Most Policy modules are based on Damian Conway's book Perl
  96. Best Practices. However, Perl::Critic is not limited to PBP and will
  97. even support Policies that contradict Conway. You can enable, disable,
  98. and customize those Polices through the Perl::Critic interface. You can
  99. also create new Policy modules that suit your own tastes.
  100. %package -n perl-Test-Perl-Critic-Policy
  101. Summary: A framework for testing your custom Policies
  102. Group: Development/Libraries
  103. License: GPL+ or Artistic
  104. %description -n perl-Test-Perl-Critic-Policy
  105. This module provides a framework for function-testing your custom
  106. Perl::Critic::Policy modules. Policy testing usually involves feeding it a
  107. string of Perl code and checking its behavior. In the old days, those strings
  108. of Perl code were mixed directly in the test script. That sucked.
  109. %prep
  110. %setup -q -n Perl-Critic-%{version}
  111. find . -type f -exec chmod -c -x {} ';'
  112. %patch0 -p1
  113. %build
  114. perl Build.PL installdirs=vendor
  115. ./Build
  116. %install
  117. ./Build install destdir=%{buildroot} create_packlist=0
  118. %{_fixperms} %{buildroot}
  119. %check
  120. LC_ALL=en_US ./Build %{!?perl_bootstrap:author}test
  121. %files
  122. %license LICENSE
  123. %doc Changes README TODO.pod examples/ extras/ tools/
  124. %{_bindir}/perlcritic
  125. %{perl_vendorlib}/Perl/
  126. %{_mandir}/man1/perlcritic.1*
  127. %{_mandir}/man3/Perl::Critic*.3pm*
  128. %files -n perl-Test-Perl-Critic-Policy
  129. %{perl_vendorlib}/Test/
  130. %{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
  131. %changelog
  132. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.132-1
  133. - new upstream release.
  134. - rebuilt with perl-5.26.
  135. * Fri Nov 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.120-1
  136. - updated to 1.120
  137. - built with perl 5.16.3
  138. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-2
  139. - rebuild
  140. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-1
  141. - initial build for Vine Linux
  142. * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 1.117-2
  143. - drop %%defattr, no longer needed
  144. * Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 1.117-1
  145. - update to 1.117
  146. New Policies:
  147. - Variables::ProhibitAugmentedAssignmentInDeclaration reports constructs like
  148. 'my $x += 1'
  149. Policy Changes:
  150. - BuiltinFunctions::ProhibitLvalueSubstr: add explicit 'use version'
  151. (CPAN RT#68498)
  152. - CodeLayout::ProhibitHardTabs: add 'pbp' to the default_themes list
  153. (CPAN RT#71093)
  154. - ControlStructures::ProhibitMutatingListFunctions now understands that
  155. tr///r (introduced in 5.13.7) does not change its operand
  156. - ControlStructures::ProhibitMutatingListFunctions now understands that
  157. '//=', '<<=', and '>>=' are assignment operators (CPAN RT#70901)
  158. - ErrorHandling::RequireCheckingReturnValueOfEval now allows things
  159. like grep { eval $_ } (CPAN RT#69489)
  160. - Modules::RequireExplicitPackage now has configuraion option
  161. allow_import_of, to allow the import of specified modules before the
  162. package statement (CPAN RT#72660)
  163. - RegularExpressions::ProhibitEnumeratedClasses no longer thinks
  164. that [A-Za-z_] matches \w. RT #69322.
  165. - RegularExpressions::ProhibitUnusedCaptures now skips the first block of
  166. an 'if' or 'elsif' if the regular expression is bound to its operand with
  167. the '!~' operator (CPAN RT#69867)
  168. - RegularExpressions::ProhibitUnusedCaptures now looks into lists and blocks
  169. in the replacement portion of the regular expression if /e is asserted
  170. (CPAN RT#72086)
  171. - RegularExpressions::RequireDotMatchAnything,
  172. RegularExpressions::RequireExtendedFormatting and
  173. RegularExpressions::RequireLineBoundaryMatching now honor defaults set with
  174. 'use re "/modifiers"' (CPAN RT#72151)
  175. - Subroutines::ProhibitManyArgs now recognizes '+' as a prototype character
  176. - Variables::ProhibitPunctuationVars now recognizes bracketed variables
  177. embedded in interpolated strings (e.g. "${$}"); for the purpose of the
  178. 'allow' configuration, these are considered equivalent to the unbracketed
  179. form (CPAN RT#72910)
  180. Other Changes:
  181. - corrected POD in Perl::Critic::PPI::Utils (CPAN RT#68898)
  182. - Perl::Critic::Violation source() method now returns the line containing
  183. the violation (not the first line) when the statement containing the
  184. violation spans multiple lines
  185. - this release by THALJEF -> update source URL
  186. - drop stopwords patch, now included upstream
  187. * Fri Jul 22 2011 Paul Howarth <paul@city-fan.org> - 1.116-6
  188. - reinstate author tests: META.yml creation issue fixed in perl-5.14.1-182
  189. * Fri Jul 22 2011 Petr Sabata <contyk@redhat.com> - 1.116-5
  190. - completely disable author tests to avoid Kwalitee META complaints
  191. * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.116-4
  192. - Perl mass rebuild
  193. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.116-3
  194. - Perl mass rebuild
  195. * Wed Jun 29 2011 Paul Howarth <paul@city-fan.org> - 1.116-2
  196. - move BR: perl(Test::Perl::Critic) to author test section where it belongs
  197. - run the author tests if we're not bootstrapping
  198. * Mon May 16 2011 Paul Howarth <paul@city-fan.org> - 1.116-1
  199. - update to 1.116
  200. - BuiltInFunctions::ProhibitLvalueSubstr does not report violations if the
  201. document contains an explicit 'use n.nnn;' where the version is before
  202. 5.005 (CPAN RT#59112)
  203. - Documentation::RequirePodSections no longer blows up on code having POD but
  204. no =head1 (CPAN RT#67231)
  205. - RegularExpressions::ProhibitUnusedCapture should more reliably find things
  206. like s/(a)/${1}2/ (CPAN RT#67273)
  207. - ValuesAndExpressions::ProhibitMagicNumbers and Module::RequireVersionVar
  208. now treat versions passed as the second argument of a 'package' statement
  209. the same as versions declared as 'our $VERSION ...' (CPAN RT#67159)
  210. - Variables::RequireLexicalLoopIterators does not report violations if the
  211. document contains an explicit 'use n.nnn;' where the version is before
  212. 5.004 (CPAN RT#67760)
  213. * Fri Apr 1 2011 Paul Howarth <paul@city-fan.org> - 1.115-1
  214. - update to 1.115
  215. - fatal error in RegularExpressions::ProhibitUnusedCapture here document
  216. check (CPAN RT#67116)
  217. - internal POD error in Documentation::RequirePodLinksIncludeText
  218. (CPAN RT#67012)
  219. * Tue Mar 29 2011 Paul Howarth <paul@city-fan.org> 1.114-1
  220. - update to 1.114
  221. - Documentation::RequirePodLinksIncludeText now handles nested POD formatting
  222. (CPAN RT#65569)
  223. - clarified relation of severity numbers to names in Perl::Critic POD
  224. (CPAN RT#66017)
  225. - removed caveats from Variables::RequireLocalizedPunctuationVars, no longer
  226. necessary with PPI 1.208 (CPAN RT#65514)
  227. - have InputOutput::RequireBriefOpen attempt to expand scope as necessary to
  228. deal with the case where the open() and the corresponding close() are not
  229. in the same scope (CPAN RT#64437)
  230. - RegularExpressions::ProhibitUnusedCapture now looks inside double-quotish
  231. things (CPAN RT#38942)
  232. - RegularExpressions::ProhibitUnusedCapture now takes logical alternation
  233. into account, so that (e.g.)
  234. if ( /(a)/ || /(b)/ ) {
  235. say $1;
  236. }
  237. is not a violation (CPAN RT#38942)
  238. - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
  239. 'return { foo => 1, bar => 2 }' as containing a hash constructor, not a
  240. block; this was fixed by PPI 1.215 (CPAN RT#61301)
  241. - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
  242. 'bless { foo => 1, bar => 2 }' as containing a hash constructor, not a
  243. block; this was fixed by PPI 1.215 (CPAN RT#64132)
  244. - bump PPI version requirement to 1.215
  245. - BR/R: perl(Pod::Parser)
  246. - BR/R: optional modules perl(Readonly::XS), perl(Term::ANSIColor) >= 2.02
  247. - BR: perl(Pod::Spell) >= 1
  248. - BR: perl(Text::ParseWords) >= 3
  249. - add runtime deps for optional modules perl(File::HomeDir), perl(File::Which)
  250. - drop redundant (for modern rpm) BuildRoot tag and buildroot cleaning
  251. - split Test::Perl::Critic::Policy off into its own package
  252. - add dependency on aspell for Perl::Critic::Policy::Documentation::PodSpelling
  253. - add version 1.889 requirement for perl(Email::Address)
  254. - add version 0.19 requirement for perl(List::MoreUtils)
  255. - add version 0.010 requirement for perl(PPIx::Regexp)
  256. - add version 1.001 requirement for perl(PPIx::Utilities::Statement)
  257. - add version 0.77 requirement for perl(version)
  258. - drop unused buildreq perl(Test::Spelling)
  259. - drop bogus buildreqs perl(lib) and perl(base)
  260. - add option for building with author tests enabled (--with authortests)
  261. - add patch with words not in Fedora dictionaries for spell check tests
  262. - split buildreqs into separate sections for build process, the module, the
  263. main test suite and the author tests
  264. * Mon Mar 7 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.113-1
  265. - update to 1.113
  266. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.111-2
  267. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  268. * Mon Jan 3 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.111-1
  269. - update
  270. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-2
  271. - rebuild to fix problems with vendorarch/lib (#661697)
  272. * Fri Aug 6 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-1
  273. - update
  274. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.105-4
  275. - mass rebuild with perl-5.12.0
  276. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-3
  277. - rebuild against perl 5.10.1
  278. * Wed Nov 25 2009 Stepan Kasal <skasal@redhat.com> - 1.105-2
  279. - use the new filtering macros (verified that the resulting provides
  280. and requires are the same)
  281. - add version to perl(PPI) require (#541020)
  282. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-1
  283. - new upstream version
  284. - update build requires
  285. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.098-3
  286. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  287. * Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.098-1
  288. - "neaten" filtering
  289. - auto-update to 1.098 (by cpan-spec-update 0.01)
  290. - added a new br on perl(strict) (version 0)
  291. - added a new br on perl(Scalar::Util) (version 0)
  292. - added a new br on perl(File::Temp) (version 0)
  293. - added a new br on perl(Pod::Usage) (version 0)
  294. - added a new br on perl(File::Find) (version 0)
  295. - added a new br on perl(PPI::Token::Whitespace) (version 1.203)
  296. - added a new br on perl(charnames) (version 0)
  297. - added a new br on perl(PPI::Document::File) (version 1.203)
  298. - added a new br on perl(File::Spec::Unix) (version 0)
  299. - added a new br on perl(List::Util) (version 0)
  300. - added a new br on perl(lib) (version 0)
  301. - added a new br on perl(Getopt::Long) (version 0)
  302. - added a new br on perl(Exporter) (version 0)
  303. - added a new br on perl(Test::More) (version 0)
  304. - added a new br on perl(overload) (version 0)
  305. - added a new br on perl(base) (version 0)
  306. - added a new br on perl(version) (version 0)
  307. - added a new br on perl(Carp) (version 0)
  308. - added a new br on perl(warnings) (version 0)
  309. - added a new br on perl(PPI::Document) (version 1.203)
  310. - added a new br on perl(File::Basename) (version 0)
  311. - added a new br on perl(PPI::Token::Quote::Single) (version 1.203)
  312. - added a new br on perl(File::Spec) (version 0)
  313. - added a new br on perl(File::Path) (version 0)
  314. - added a new br on perl(Pod::PlainText) (version 0)
  315. - added a new br on perl(Pod::Select) (version 0)
  316. - added a new br on perl(PPI::Node) (version 1.203)
  317. - added a new br on perl(English) (version 0)
  318. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.092-2
  319. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  320. * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.092-1
  321. - update to 1.092
  322. * Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.082-1
  323. - update to 1.082
  324. - resolve BZ#431577
  325. - add t/ examples/ extras/ tools/, and filter
  326. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-3
  327. - Rebuild for perl 5.10 (again)
  328. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-2
  329. - add missing BR: perl-Exception-Class
  330. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-1
  331. - bump to 1.080
  332. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.053-2
  333. - rebuild for new perl
  334. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.053-1
  335. - Update to 1.053.
  336. * Tue Mar 20 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  337. - Update to 1.05.
  338. * Thu Feb 15 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  339. - Update to 1.03.
  340. * Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-2
  341. - Bumping release (forgot to commit sources and .cvsignore changes).
  342. * Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
  343. - Update to 1.01.
  344. - New build requirement: perl(Test::Memory::Cycle).
  345. * Thu Jan 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-2
  346. - perl(Set::Scalar) is no longer required.
  347. * Wed Jan 24 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-1
  348. - Update to 0.23.
  349. - New requirement: perl(B::Keywords).
  350. - Author tests coverage improved.
  351. * Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
  352. - Enabled author tests.
  353. - BR perl(HomeDir).
  354. * Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
  355. - Update to 0.22.
  356. * Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
  357. - Update to 0.21.
  358. - New BR: perl(Set::Scalar).
  359. * Sat Sep 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.2-1
  360. - First build.