perl-PPI-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-PPI
  4. Version: 1.269
  5. Release: 1%{?_dist_release}
  6. Summary: Parse, Analyze and Manipulate Perl
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/PPI/
  10. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
  11. #Patch0: PPI-1.215-UTF8.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. BuildRequires: perl(List::Util)
  16. BuildRequires: perl(Storable)
  17. BuildRequires: perl(Clone)
  18. BuildRequires: perl(Digest::MD5)
  19. BuildRequires: perl(File::Remove)
  20. BuildRequires: perl(IO::String)
  21. BuildRequires: perl(List::MoreUtils)
  22. BuildRequires: perl(Params::Util)
  23. BuildRequires: perl(Test::Deep)
  24. BuildRequires: perl(Task::Weaken)
  25. BuildRequires: perl(Test::More)
  26. BuildRequires: perl(Test::NoWarnings)
  27. BuildRequires: perl(Test::Object)
  28. BuildRequires: perl(Test::SubCalls)
  29. BuildRequires: perl(Class::Inspector)
  30. # Circular dependencies in release tests, so don't do them when bootstrapping:
  31. # Perl::MinimumVersion -> PPI
  32. %if 0%{!?perl_bootstrap:1}
  33. BuildRequires: perl(File::Find::Rule)
  34. BuildRequires: perl(File::Find::Rule::Perl)
  35. BuildRequires: perl(Perl::MinimumVersion)
  36. BuildRequires: perl(Test::ClassAPI)
  37. BuildRequires: perl(Test::CPAN::Meta)
  38. BuildRequires: perl(Test::MinimumVersion)
  39. BuildRequires: perl(Test::Pod)
  40. %endif
  41. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. Packager: shaolin
  45. %description
  46. Parse, analyze and manipulate Perl (without perl).
  47. %prep
  48. %setup -q -n PPI-%{version}
  49. # Re-code docs as UTF-8
  50. #%patch0 -p1
  51. # Filter out redundant unversioned provides
  52. %if %{_dist_release} > "vl6"
  53. %global __provides_exclude ^perl\\(PPI::.+\\)$
  54. %else
  55. cat << \EOF > %{name}-prov
  56. #!/bin/sh
  57. %{__perl_provides} $* |\
  58. sed -e '/^perl(PPI::.\+)$/d'
  59. EOF
  60. %global __perl_provides %{_builddir}/PPI-%{version}/%{name}-prov
  61. chmod +x %{__perl_provides}
  62. %endif
  63. %build
  64. perl Makefile.PL INSTALLDIRS=vendor
  65. make %{?_smp_mflags}
  66. %install
  67. make pure_install DESTDIR=%{buildroot}
  68. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  69. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  70. %{_fixperms} %{buildroot}
  71. %check
  72. make test
  73. %if 0%{!?perl_bootstrap:1}
  74. make test TEST_FILES="xt/*.t" RELEASE_TESTING=1
  75. %endif
  76. %files
  77. %license LICENSE
  78. %doc Changes README inline2test.conf inline2test.tpl
  79. %{perl_vendorlib}/PPI/
  80. %{perl_vendorlib}/PPI.pm
  81. %{_mandir}/man3/PPI*.3pm*
  82. %changelog
  83. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.269-1
  84. - new upstream release.
  85. - rebuilt with perl-5.26.
  86. * Sat Nov 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.215-3
  87. - rebuilt with perl 5.16.3
  88. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-2
  89. - rebuild
  90. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-1
  91. - initial build for Vine Linux
  92. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.215-4
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  94. * Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 1.215-3
  95. - always run test suite but don't run release tests when bootstrapping
  96. - nobody else likes macros for commands
  97. - clean up for modern rpm:
  98. - drop explicit buildroot tag
  99. - drop buildroot cleaning
  100. - drop %%defattr
  101. - use native provides filtering
  102. - use a patch rather than scripting iconv to fix character encoding
  103. - upstream file permissions no longer need fixing
  104. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.215-2
  105. - rebuild with Perl 5.14.1
  106. - use perl_bootstrap macro
  107. * Sun Mar 27 2011 Paul Howarth <paul@city-fan.org> - 1.215-1
  108. - update to 1.215 (general fix release):
  109. - index_locations on an empty document no longer warns
  110. - Corrected a bug in line-spanning attribute support
  111. - Regression test for line-spanning attribute support
  112. - return { foo => 1 } should parse curlys as hash constructor, not block
  113. (CPAN RT#61305)
  114. - Fixed bug with map and regexp confusing PPI (CPAN RT#63943)
  115. - Updated copyright year to 2011
  116. - Fix bless {} probably contains a hash constructor (CPAN RT#64247)
  117. - Backed out glob fix
  118. - Fix cast can trump braces in PPI::Token::Symbol->symbol (CPAN RT#65199)
  119. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.213-3
  120. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  121. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.213-2
  122. - rebuild to fix problems with vendorarch/lib (#661697)
  123. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.213-1
  124. - update to 1.213 (targeted bug fix, no changes to parsing or normal usage)
  125. - Updated to Module::Install 1.00
  126. - Updated module dependencies in xt author tests
  127. - Fixed extremely broken PPI::Token::Pod::merge and added test case
  128. - bump perl(Perl::MinimumVersion) requirement to 1.25
  129. - bump perl(Test::CPAN::Meta) requirement to 0.17
  130. - bump perl(Test::Pod) requirement to 1.44
  131. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.212-1
  132. - update to 1.212 (experimental/development support and bugfixes)
  133. - Fixed bug in ForLoop back-compatibility warning (CPAN RT#48819)
  134. - Added support for $ENV{X_TOKENIZER} --> $PPI::Lexer::X_TOKENIZER
  135. - Upgraded to Module::Install 0.93
  136. - Added support for $PPI::Lexer::X_TOKENIZER, for alternate tokenizers
  137. - Added an extra test case to validate we handle byte order marks properly
  138. - Moved author tests from t to xt
  139. - Fixed CPAN RT#26082: scalar { %%x } is misparsed
  140. - Fixed CPAN RT#26591: VMS patch for PPI 1.118
  141. - Fixed CPAN RT#44862: PPI cannot parse "package Foo::100;" correctly
  142. - Fixed CPAN RT#54208: PPI::Token::Quote::Literal::literal missing
  143. - run release tests as well as regular test suite
  144. - BR: perl(File::Find::Rule) >= 0.32, perl(File::Find::Rule::Perl) >= 1.09,
  145. perl(Perl::MinimumVersion) >= 1.24 and perl(Test::MinimumVersion) >= 0.101080
  146. for release tests
  147. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.210-1
  148. - update to 1.210 (packaging fixes)
  149. - use RELEASE_TESTING rather than AUTOMATED_TESTING for better test coverage
  150. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.209-1
  151. - update to 1.209 (small optimisation release, no functional changes)
  152. * Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.208-1
  153. - update to 1.208
  154. - don't assign '' to $^W, it generates a warning on Gentoo
  155. - added missing PPI::Token::Regexp fix to Changes file
  156. - updating Copyright to the new year
  157. - fixed #50309: literal() wrong result on "qw (a b c)"
  158. - PPI::Dumper no longer causes Elements to flush location data
  159. - PPI::Dumper no longer disables location information for non-Documents
  160. - +{ package => 1 } doesn't create a PPI::Statement::Package
  161. - extra methods in PPI::Token::Regexp and PPI::Token::QuoteLike::Regexp
  162. - use %%{_fixperms} macro instead of our own chmod incantation
  163. * Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.206-6
  164. - BR: perl(Task::Weaken) and perl(Test::CPAN::Meta) for improved test coverage
  165. - enable AUTOMATED_TESTING
  166. - use DESTDIR rather than PERL_INSTALL_ROOT
  167. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.206-5
  168. - Mass rebuild with perl-5.12.0
  169. * Thu Feb 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-4
  170. - fix filtering, provide versioned provides
  171. * Wed Feb 10 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-3
  172. - make rpmlint happy
  173. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-2
  174. - rebuild against perl 5.10.1
  175. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-1
  176. - new upstream version
  177. - update build requires
  178. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-3
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  180. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-2
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  182. * Tue Sep 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.203-1
  183. - update to 1.203
  184. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-3
  185. - Rebuild for perl 5.10 (again)
  186. * Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-2
  187. - rebuild for new perl
  188. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-1
  189. - bump to 1.201
  190. * Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.118-1
  191. - Update to 1.118.
  192. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.117-1
  193. - Update to 1.117.
  194. * Sun Jun 4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-2
  195. - Removed the perl(IO::Scalar) build requirement.
  196. * Sun Jun 4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-1
  197. - Update to 1.115.
  198. * Wed May 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.113-1
  199. - Update to 1.113.
  200. * Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.112-1
  201. - Update to 1.112.
  202. * Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.111-1
  203. - First build.