perl-Mail-DKIM-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. #
  2. # - Mail::DKIM -
  3. # This spec file was automatically generated by cpan2rpm [ver: 2.028]
  4. # The following arguments were used:
  5. # Mail::DKIM
  6. # For more information on cpan2rpm please visit: http://perl.arix.com/
  7. #
  8. %define pkgname Mail-DKIM
  9. %define filelist %{pkgname}-%{version}-filelist
  10. %define NVR %{pkgname}-%{version}-%{release}
  11. %define maketest 1
  12. Name: perl-Mail-DKIM
  13. Summary: Mail-DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
  14. Version: 0.55
  15. Release: 1%{?_dist_release}
  16. License: Artistic
  17. Group: Development/Libraries
  18. URL: http://search.cpan.org/~jaslong/Mail-DKIM/
  19. Source: http://search.cpan.org//CPAN/authors/id/J/JA/JASLONG/Mail-DKIM-%{version}.tar.gz
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildArch: noarch
  22. BuildRequires: perl(Crypt::OpenSSL::RSA)
  23. BuildRequires: perl(Mail::Address)
  24. BuildRequires: perl(Net::DNS)
  25. BuildRequires: perl(Net::DNS::Resolver::Mock)
  26. BuildRequires: perl(Test::RequiresInternet)
  27. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: tomop
  31. %description
  32. This module implements the various components of the DKIM and
  33. DomainKeys message-signing and verifying standards for Internet mail.
  34. It currently tries to implement these specifications:
  35. =over
  36. =item RFC4871, for DKIM
  37. =item RFC4870, for DomainKeys
  38. =back
  39. The module uses an object-oriented interface. You use one of
  40. two different classes, depending on whether you are signing or verifying
  41. a message. To sign, use the L<Mail::DKIM::Signer> class. To verify, use
  42. the L<Mail::DKIM::Verifier> class. Simple, eh?
  43. #
  44. # This package was generated automatically with the cpan2rpm
  45. # utility. To get this software or for more information
  46. # please visit: http://perl.arix.com/
  47. #
  48. %prep
  49. %setup -q -n %{pkgname}-%{version}
  50. chmod -R u+w %{_builddir}/%{pkgname}-%{version}
  51. %build
  52. grep -rsl '^#!.*perl' . |
  53. grep -v '.bak$' |xargs --no-run-if-empty \
  54. %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
  55. CFLAGS="$RPM_OPT_FLAGS"
  56. %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLDIRS=vendor
  57. %{__make}
  58. %if %maketest
  59. %{__make} test
  60. %endif
  61. %install
  62. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  63. %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
  64. cmd=/usr/share/spec-helper/compress_files
  65. [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
  66. [ -x $cmd ] && $cmd
  67. # SuSE Linux
  68. if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
  69. then
  70. %{__mkdir_p} %{buildroot}/var/adm/perl-modules
  71. %{__cat} `find %{buildroot} -name "perllocal.pod"` \
  72. | %{__sed} -e s+%{buildroot}++g \
  73. > %{buildroot}/var/adm/perl-modules/%{name}
  74. fi
  75. # remove special files
  76. find %{buildroot} -name "perllocal.pod" \
  77. -o -name ".packlist" \
  78. -o -name "*.bs" \
  79. |xargs -i rm -f {}
  80. # no empty directories
  81. find %{buildroot}%{_prefix} \
  82. -type d -depth \
  83. -exec rmdir {} \; 2>/dev/null
  84. %{__perl} -MFile::Find -le '
  85. find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
  86. print "%doc TODO scripts Changes README";
  87. for my $x (sort @dirs, @files) {
  88. push @ret, $x unless indirs($x);
  89. }
  90. print join "\n", sort @ret;
  91. sub wanted {
  92. return if /auto$/;
  93. local $_ = $File::Find::name;
  94. my $f = $_; s|^\Q%{buildroot}\E||;
  95. return unless length;
  96. return $files[@files] = $_ if -f $f;
  97. $d = $_;
  98. /\Q$d\E/ && return for reverse sort @INC;
  99. $d =~ /\Q$_\E/ && return
  100. for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
  101. $dirs[@dirs] = $_;
  102. }
  103. sub indirs {
  104. my $x = shift;
  105. $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
  106. }
  107. ' > %filelist
  108. [ -z %filelist ] && {
  109. echo "ERROR: empty %files listing"
  110. exit -1
  111. }
  112. %clean
  113. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  114. %files -f %filelist
  115. %defattr(-,root,root)
  116. %changelog
  117. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.55-1
  118. - new upstream release.
  119. - rebuilt with perl-5.26.
  120. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.40-3
  121. - added BR: perl(Crypt::OpenSSL::RSA), perl(Net::DNS)
  122. - moved to Development/Libraries
  123. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-2
  124. - rebuilt with perl-5.16.3.
  125. * Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-1
  126. - new upstream release.
  127. * Fri Dec 02 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.39-1
  128. - Initial build.