pcre2-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: pcre2
  3. Version: 10.34
  4. Release: 1%{?_dist_release}
  5. Summary: Perl-compatible regular expression library
  6. Summary(ja): Perl 互換の正規表現ライブラリ
  7. Group: System Environment/Libraries
  8. License: BSD
  9. URL: http://www.pcre.org/
  10. Source0: https://ftp.pcre.org/pub/pcre/%{name}-%{version}.tar.bz2
  11. # Upstream thinks RPATH is good idea.
  12. Patch0: pcre2-10.31-multilib.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: zlib-devel
  15. BuildRequires: bzip2-devel
  16. BuildRequires: libedit-devel
  17. # New libtool to get rid of rpath
  18. BuildRequires: autoconf, automake, libtool
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: inagaki
  22. %description
  23. Perl-compatible regular expression library.
  24. PCRE has its own native API, but a set of "wrapper" functions that are based on
  25. the POSIX API are also supplied in the library libpcreposix. Note that this
  26. just provides a POSIX calling interface to PCRE: the regular expressions
  27. themselves still follow Perl syntax and semantics. The header file
  28. for the POSIX-style functions is called pcreposix.h.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Summary(ja): %{name} の開発用ファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. Development files (Headers, libraries for static linking, etc) for %{name}.
  36. %package -n compat32-%{name}
  37. Summary: Perl-compatible regular expression library
  38. Summary(ja): Perl 互換の正規表現ライブラリ
  39. Group: System Environment/Libraries
  40. %description -n compat32-%{name}
  41. Perl-compatible regular expression library.
  42. PCRE has its own native API, but a set of "wrapper" functions that are based on
  43. the POSIX API are also supplied in the library libpcreposix. Note that this
  44. just provides a POSIX calling interface to PCRE: the regular expressions
  45. themselves still follow Perl syntax and semantics. The header file
  46. for the POSIX-style functions is called pcreposix.h.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development files for %{name}
  49. Summary(ja): %{name} の開発用ファイル
  50. Group: Development/Libraries
  51. Requires: compat32-%{name} = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. Development files (Headers, libraries for static linking, etc) for %{name}.
  54. %prep
  55. %setup -q
  56. # Get rid of rpath
  57. %patch0 -p1 -b .multilib
  58. # Because of rpath patch
  59. libtoolize --copy --force && autoreconf -vif
  60. # One contributor's name is non-UTF-8
  61. for F in ChangeLog; do
  62. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  63. touch --reference "$F" "${F}.utf8"
  64. mv "${F}.utf8" "$F"
  65. done
  66. %build
  67. %configure \
  68. --enable-jit \
  69. --disable-static \
  70. --enable-utf8 \
  71. --enable-unicode-properties \
  72. --enable-pcregrep-libz \
  73. --enable-pcregrep-libbz2 \
  74. --enable-pcretest-libedit \
  75. --enable-pcre2-8 \
  76. --enable-pcre2-16 \
  77. --enable-pcre2-32
  78. make %{?_smp_mflags}
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  84. %check
  85. %ifarch s390 s390x ppc
  86. # larger stack is needed on s390, ppc
  87. ulimit -s 10240
  88. %endif
  89. make %{?_smp_mflags} check VERBOSE=yes
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %post -p /sbin/ldconfig
  93. %postun -p /sbin/ldconfig
  94. %post -n compat32-%{name} -p /sbin/ldconfig
  95. %postun -n compat32-%{name} -p /sbin/ldconfig
  96. %files
  97. %defattr(-,root,root)
  98. %license COPYING LICENCE
  99. %doc AUTHORS ChangeLog NEWS README
  100. %{_bindir}/pcre2grep
  101. %{_libdir}/*.so.*
  102. %{_mandir}/man1/pcre2grep.*
  103. %files devel
  104. %defattr(-,root,root)
  105. %doc doc/html/*
  106. %{_bindir}/pcre2-config
  107. %{_bindir}/pcre2test
  108. %{_includedir}/*
  109. %{_libdir}/*.so
  110. %{_libdir}/pkgconfig/*.pc
  111. %{_mandir}/man1/pcre2-config.*
  112. %{_mandir}/man1/pcre2test.*
  113. %{_mandir}/man3/*
  114. %if %{build_compat32}
  115. %files -n compat32-%{name}
  116. %defattr(-, root, root)
  117. %{_libdir}/*.so.*
  118. %files -n compat32-%{name}-devel
  119. %defattr(-, root, root)
  120. %{_libdir}/*.so
  121. %endif
  122. %changelog
  123. * Sun Mar 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.34-1
  124. - new upstream release.
  125. * Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 10.31-1
  126. - new: pcre2 package
  127. - update multilib patch (Patch0)
  128. - drop unnecessary patch (Patch1)
  129. * Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
  130. - create comapt32 packages
  131. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  132. - new upstream release.
  133. - dropped Patch1000,1001: fixed in upstream.
  134. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  135. - new upstream release.
  136. - removed Patch2,Patch3 (no longer needed).
  137. - added Patch1000 to fix CVE-2016-1283.
  138. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  139. - new upstream release
  140. - added patches including security fix from Fedora (CVE-2014-8964)
  141. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  142. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  143. (bug #1165626)
  144. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  145. - Reset non-matched groups within capturing group up to forced match
  146. (bug #1161587)
  147. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  148. - Fix typos in manual pages (bugs #675476, #675477)
  149. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  150. - new upstream release
  151. - add --enable-pcre32 and --enable-pcretest-libedit
  152. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  153. - new upstream release
  154. - add --enable-pcre16 --enable-pcre8 --enable-jit
  155. - API change
  156. - change includedir to /usr/include
  157. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  158. - new upstream release
  159. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  160. - new upstream release
  161. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  162. - rebuilt with rpm-4.8.1 for pkg-config
  163. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  164. - new upstream release
  165. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  166. - new upstream release with security fix
  167. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  168. - new upstream release
  169. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  170. - new upstream release
  171. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  172. - add --enable-unicode-properties to configure option
  173. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  174. - new upstream release
  175. - added BR: zlib-devel, bzip2-devel
  176. - removed static libraries from devel package
  177. - added Packager tag
  178. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  179. - new upstream release
  180. - spec in UTF-8
  181. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  182. - new upstream release
  183. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  184. - use macro for Release
  185. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  186. - apply new virsioning policy.
  187. - remove *.la
  188. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  189. - new upstream release
  190. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  191. - new upstream release
  192. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  193. - new upstream release
  194. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  195. - rebuild with new environment/toolchain
  196. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  197. - new upstream release
  198. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  199. - added --enable-utf8 option
  200. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  201. - new upstream release
  202. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  203. - new upstream release
  204. - added Japanese summary
  205. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  206. - new upstream release
  207. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  208. - new upstream release
  209. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  210. - skip 'make check' on alpha
  211. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  212. - change install section
  213. - change files section
  214. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  215. - update to 4.1
  216. - add %{_bindir}/pcretest
  217. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  218. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  219. - rebuild with new toolchains
  220. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  221. - Update to 3.9
  222. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  223. - Update to 3.7
  224. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  225. - Update to 3.5
  226. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  227. - Build for VineSeed
  228. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  229. - Move libpcre to /lib, grep uses it these days (#41104)
  230. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  231. - Move this to a separate package, used to be in kdesupport, but it's
  232. generally useful...