gtk3-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534
  1. # Note that this is NOT a relocatable package
  2. %define glib2_base_version 2.48.0
  3. %define glib2_version %{glib2_base_version}-1
  4. %define pango_base_version 1.40.0
  5. %define pango_version %{pango_base_version}-1
  6. %define atk_base_version 2.20.0
  7. %define atk_version %{atk_base_version}-1
  8. %define cairo_base_version 1.14.4
  9. %define cairo_version %{cairo_base_version}-1
  10. %define gdkpixbuf2_base_version 2.32.0
  11. %define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
  12. %define gobject_introspection_version 1.46.0
  13. %define base_version 3.22.30
  14. %define bin_version 3.0.0
  15. # biarch support
  16. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  17. %define _query_suffix %{nil}
  18. %if %{build_compat32}
  19. %define _query_suffix -32
  20. %endif
  21. %define _unpackaged_files_terminate_build 1
  22. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  23. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  24. Name: gtk3
  25. Version: %{base_version}
  26. Release: 1%{?_dist_release}
  27. License: LGPL
  28. Group: System Environment/Libraries
  29. Source: http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.22/gtk+-%{version}.tar.xz
  30. Patch0: gtk3-3.10.0-gtk-widget-size-allocate.patch
  31. # for Vine
  32. Patch100: gtk+-3.14.0-vine-default-theme.patch
  33. # from CentOS
  34. # - 3.22.10-5.el7_4
  35. # Downstream fix to filter out X-RHEL-AliasOf
  36. # https://bugzilla.redhat.com/show_bug.cgi?id=1259292
  37. Source10001: ja.po
  38. Patch10018: app-chooser-fixes.patch
  39. # https://bugzilla.redhat.com/show_bug.cgi?id=1507113
  40. Patch10019: 0001-Add-_gtk_printer_get_hard_margins_for_paper_size.patch
  41. # https://bugzilla.redhat.com/show_bug.cgi?id=1571422
  42. Patch10020: 0001-gdkseatdefault-Don-t-hide-GdkWindow-on-grab-failure.patch
  43. BuildRequires: atk-devel >= %{atk_version}
  44. BuildRequires: at-spi2-atk-devel
  45. BuildRequires: pango-devel >= %{pango_version}
  46. BuildRequires: glib2-devel >= %{glib2_version}
  47. BuildRequires: cairo-devel >= %{cairo_version}
  48. BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  49. BuildRequires: gtk2-devel
  50. BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
  51. BuildRequires: libtiff-devel >= 3.7
  52. BuildRequires: libjpeg-turbo-devel
  53. BuildRequires: libpng-devel
  54. BuildRequires: jasper-devel
  55. BuildRequires: colord-devel
  56. BuildRequires: gtk-doc >= 1.20
  57. BuildRequires: gamin-devel
  58. BuildRequires: cups-devel
  59. BuildRequires: rest-devel
  60. BuildRequires: json-glib-devel
  61. BuildRequires: libepoxy-devel
  62. BuildRequires: libICE-devel
  63. BuildRequires: libXext-devel
  64. BuildRequires: libXi-devel
  65. BuildRequires: libXrandr-devel >= 1.3.0
  66. BuildRequires: libXrender-devel
  67. BuildRequires: libXcursor-devel
  68. BuildRequires: libXfixes-devel
  69. BuildRequires: libXinerama-devel
  70. BuildRequires: libXcomposite-devel
  71. BuildRequires: libXdamage-devel
  72. BuildRoot: %{_tmppath}/gtk-%{version}-root
  73. URL: http://www.gtk.org
  74. # required for icon themes apis to work
  75. Requires: hicolor-icon-theme
  76. # We need to prereq these so we can run gtk-query-immodules-2.0
  77. Requires(post): glib2 >= %{glib2_version}
  78. Requires(post): atk >= %{atk_version}
  79. Requires(post): pango >= %{pango_version}
  80. Requires(post): libSM >= 1.1.0
  81. # We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
  82. Requires(post): libtiff >= 3.7
  83. Requires: libXrandr >= 1.3.0
  84. Vendor: Project Vine
  85. Distribution: Vine Linux
  86. Packager: Takemikaduchi
  87. %description
  88. GTK+ is a multi-platform toolkit for creating graphical user
  89. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  90. projects ranging from small one-off tools to complete application
  91. suites.
  92. %package devel
  93. Summary: Development tools for GTK+ applications.
  94. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  95. Group: Development/Libraries
  96. Requires: %{name} = %{version}-%{release}
  97. Requires: pango-devel >= %{pango_version}
  98. Requires: atk-devel >= %{atk_version}
  99. Requires: glib2-devel >= %{glib2_version}
  100. Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
  101. Requires: libX11-devel, libXcursor-devel, libXinerama-devel
  102. Requires: libXext-devel, libXi-devel, libXrandr-devel
  103. Requires: libXfixes-devel, libXcomposite-devel
  104. Requires: libpng-devel
  105. %description devel
  106. The gtk+-devel package contains the header files and developer
  107. docs for the GTK+ widget toolkit.
  108. #######################################################################
  109. # compat32
  110. %package -n compat32-%{name}
  111. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  112. Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
  113. Group: System Environment/Libraries
  114. Requires(post): compat32-glib2 >= %{glib2_version}
  115. Requires(post): compat32-atk >= %{atk_version}
  116. Requires(post): compat32-pango >= %{pango_version}
  117. Requires(post): compat32-libSM >= 1.1.0
  118. Requires(post): compat32-libtiff >= 3.7
  119. Requires: compat32-libXrandr >= 1.3.0
  120. %description -n compat32-%{name}
  121. GTK+ is a multi-platform toolkit for creating graphical user
  122. interfaces. Offering a complete set of widgets, GTK+ is suitable for
  123. projects ranging from small one-off tools to complete application
  124. suites.
  125. %package -n compat32-%{name}-devel
  126. Summary: Development tools for GTK+ applications.
  127. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  128. Group: Development/Libraries
  129. Requires: compat32-%{name} = %{version}-%{release}
  130. Requires: %{name}-devel = %{version}
  131. Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
  132. Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
  133. Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
  134. Requires: compat32-libpng-devel
  135. %description -n compat32-%{name}-devel
  136. The gtk+-devel package contains the header files and developer
  137. docs for the GTK+ widget toolkit.
  138. %prep
  139. %setup -q -n gtk+-%{version}
  140. %patch0 -p1 -b .allocate
  141. %patch100 -p1 -b .vine-default-theme
  142. # from CentOS
  143. %patch10018 -p1
  144. %patch10019 -p1
  145. %patch10020 -p1
  146. cp %{SOURCE10001} po/
  147. #for i in config.guess config.sub ; do
  148. # test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
  149. #done
  150. %build
  151. # if ! pkg-config --exists pangoxft ; then
  152. # echo "No pangoxft.pc!"
  153. # exit 1
  154. # fi
  155. #libtoolize --force --copy
  156. #autoreconf -i
  157. %configure \
  158. --enable-gtk2-dependency \
  159. --enable-man \
  160. --enable-gtk-doc \
  161. --enable-debug=minimum \
  162. --disable-rebuilds \
  163. --disable-glibtest \
  164. --enable-introspection=yes \
  165. --enable-xkb=yes \
  166. --enable-xinerama=yes \
  167. --enable-xrandr=yes \
  168. --enable-xfixes=yes \
  169. --enable-xcomposite=yes \
  170. --enable-xdamage=yes \
  171. --enable-x11-backend \
  172. --disable-packagekit \
  173. --enable-colord=yes
  174. # fight unused direct deps
  175. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  176. make %{?_smp_mflags}
  177. %install
  178. rm -rf $RPM_BUILD_ROOT
  179. make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
  180. %find_lang gtk30
  181. %find_lang gtk30-properties
  182. cat gtk30.lang gtk30-properties.lang > all.lang
  183. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
  184. # We need to have separate 32-bit and 64-bit binaries
  185. # for places where we have two copies of the GTK+ package installed.
  186. # (we might have x86_64 and i686 packages on the same system, for example.)
  187. %if %{build_compat32}
  188. cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
  189. $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  190. %endif
  191. touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
  192. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
  193. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
  194. # Remove unpackaged files
  195. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  196. rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
  197. %clean
  198. rm -rf $RPM_BUILD_ROOT
  199. %post
  200. /sbin/ldconfig
  201. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  202. %postun
  203. /sbin/ldconfig
  204. if [ $1 -gt 0 ]; then
  205. %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
  206. fi
  207. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  208. %posttrans
  209. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  210. %if %{build_compat32}
  211. %post -n compat32-%{name}
  212. /sbin/ldconfig
  213. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  214. %postun -n compat32-%{name}
  215. /sbin/ldconfig
  216. if [ $1 = 0 ]; then
  217. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
  218. fi
  219. %endif
  220. %files -f all.lang
  221. %defattr(-, root, root)
  222. %doc AUTHORS COPYING ChangeLog NEWS README
  223. %{_bindir}/gtk3-demo
  224. %{_bindir}/gtk3-demo-application
  225. %{_bindir}/gtk3-widget-factory
  226. %{_bindir}/gtk-encode-symbolic-svg
  227. %{_bindir}/gtk3-icon-browser
  228. %{_bindir}/gtk-builder-tool
  229. %{_bindir}/gtk-launch
  230. %{_bindir}/gtk-query-settings
  231. %exclude %{_bindir}/gtk-update-icon-cache
  232. %{_bindir}/gtk-query-immodules-3.0
  233. %{_libdir}/libgtk-3.so.*
  234. %{_libdir}/libgdk-3.so.*
  235. %{_libdir}/libgailutil-3.so.*
  236. %dir %{_libdir}/gtk-3.0
  237. %{_libdir}/gtk-3.0/%{bin_version}
  238. %dir %{_libdir}/gtk-3.0/modules
  239. %{_libdir}/girepository-1.0/*.typelib
  240. %{_datadir}/applications/gtk3-demo.desktop
  241. %{_datadir}/applications/gtk3-icon-browser.desktop
  242. %{_datadir}/applications/gtk3-widget-factory.desktop
  243. %{_datadir}/gettext/its/gtkbuilder*
  244. %{_datadir}/gtk-3.0
  245. %{_datadir}/icons/hicolor/*/apps/*
  246. %{_datadir}/themes/Default
  247. %{_datadir}/themes/Emacs
  248. %dir %{_sysconfdir}/gtk-3.0
  249. %{_sysconfdir}/gtk-3.0/im-multipress.conf
  250. %{_datadir}/glib-2.0/schemas/*.xml
  251. %files devel
  252. %defattr(-, root, root)
  253. %{_libdir}/lib*.so
  254. %dir %{_libdir}/gtk-3.0
  255. %{_datadir}/gtk-doc/
  256. %{_datadir}/gir-1.0/*.gir
  257. %{_mandir}/man1/*
  258. %exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
  259. %{_includedir}/*
  260. %{_datadir}/aclocal/*
  261. %{_libdir}/pkgconfig/*
  262. # compat32
  263. %if %{build_compat32}
  264. %files -n compat32-%{name}
  265. %defattr(-, root, root)
  266. %{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
  267. %{_libdir}/libgtk-3.so.*
  268. %{_libdir}/libgdk-3.so.*
  269. %{_libdir}/libgailutil-3.so.*
  270. %dir %{_libdir}/gtk-3.0
  271. %{_libdir}/gtk-3.0/%{bin_version}
  272. %dir %{_libdir}/gtk-3.0/modules
  273. %dir %{_sysconfdir}/gtk-3.0
  274. %files -n compat32-%{name}-devel
  275. %defattr(-, root, root)
  276. %{_libdir}/lib*.so
  277. %dir %{_libdir}/gtk-3.0
  278. %endif
  279. %changelog
  280. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.22.30-1
  281. - update to 3.22.30
  282. - dropped Patch10019.
  283. - imported Patch10019 and 10020 from CentOS.
  284. * Mon Mar 26 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.22.10-1
  285. - update to 3.22.10
  286. - sync CentOS 7 - 3.22.10-5.el7_4
  287. - add ja.po (Source10001)
  288. - add patches (Patch10018, 10019)
  289. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.6-1
  290. - new upstream release
  291. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.6-1
  292. - new upstream release
  293. * Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
  294. - new upstream release
  295. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
  296. - new upstream release
  297. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  298. - new upstream release
  299. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.7-1
  300. - new upstream release
  301. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.6-1
  302. - new upstream release
  303. * Fri Jul 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
  304. - new upstream release
  305. * Thu Jun 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
  306. - new upstream release
  307. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  308. - new upstream release
  309. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  310. - new upstream release
  311. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  312. - new upstream release
  313. - add BuildRequires: libepoxy-devel
  314. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.9-1
  315. - new upstream release
  316. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.8-1
  317. - new upstream release
  318. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.7-1
  319. - new upstream release
  320. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.6-1
  321. - new upstream release
  322. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.5-1
  323. - new upstream release
  324. - add BuildRequires: gtk2-devel, rest-devel, json-glib-devel
  325. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.4-1
  326. - new upstream release
  327. - update Patch100 (gtk+-3.14.0-vine-default-theme.patch)
  328. * Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  329. - new upstream release
  330. * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  331. - new upstream release
  332. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  333. - new upstream release
  334. - update Patch100 (gtk+-3.12.0-vine-default-theme.patch)
  335. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.7-1
  336. - new upstream release
  337. * Sat Dec 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.6-1
  338. - new upstream release
  339. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.5-1
  340. - new upstream release
  341. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  342. - new upstream release
  343. - update Patch0 (gtk3-3.10.0-gtk-widget-size-allocate.patch)
  344. - remove Patch1 (gtk3-3.8.2-immodule.patch)
  345. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  346. - new upstream release
  347. * Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
  348. - add Patch1 (gtk3-3.8.2-immodule.patch)
  349. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  350. - new upstream release
  351. * Fri Apr 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  352. - new upstream release
  353. * Tue Jan 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
  354. - new upstream release
  355. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  356. - new upstream release
  357. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  358. - new upstream release
  359. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  360. - new upstream release
  361. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  362. - new upstream release
  363. - add BuildRequires: at-spi2-atk-devel
  364. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  365. - new upstream release
  366. * Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  367. - new upstream release
  368. * Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  369. - new upstream release
  370. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  371. - new upstream release
  372. - update Patch100 (gtk+-3.4.0-vine-default-theme.patch)
  373. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
  374. - new upstream release
  375. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
  376. - new upstream release
  377. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  378. - new upstream release
  379. - remove Patch1
  380. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  381. - new upstream release
  382. - add Patch1 (gtk3-3.2.1-bug658772.patch)
  383. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  384. - new upstream release
  385. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  386. - new upstream release
  387. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.18-1
  388. - new upstream release
  389. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.16-1
  390. - new upstream release
  391. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.12-1
  392. - new upstream release
  393. - add Patch0 (gtk3-3.1.12-gtk-widget-size-allocate.patch)
  394. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-2
  395. - fix %%files
  396. * Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10-1
  397. - new upstream release
  398. - add BuildRequires: colord-devel
  399. * Sun Jun 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.11-1
  400. - new upstream release
  401. * Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-1
  402. - new upstream release
  403. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
  404. - new upstream release
  405. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
  406. - new upstream release
  407. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
  408. - new upstream release
  409. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
  410. - new upstream release
  411. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  412. - new upstream release
  413. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  414. - new upstream release
  415. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  416. - new upstream release
  417. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  418. - initial build for Vine Linux