gtk+-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634
  1. # Note that this is NOT a relocatable package
  2. %define ver 1.2.10
  3. %define rel 5%{?_dist_release}
  4. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  5. Name: gtk+
  6. Version: %{ver}
  7. Release: %{rel}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. URL: http://www.gtk.org
  11. Obsoletes: gtk
  12. BuildRequires: glib-devel >= 1.2.10
  13. BuildRequires: libX11-devel libXext-devel libXi-devel
  14. BuildRequires: linuxdoc-tools automake14 autoconf213
  15. BuildRequires: libXt-devel
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Source: ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{ver}.tar.gz
  18. Source1: gtkrc-default
  19. Source2: gtkrc.ja-vine
  20. #
  21. # merged RH patches.
  22. #
  23. Patch1: gtk+-1.2.6-ahiguti.patch
  24. Patch5: gtk+-1.2.8-wrap-alnum.patch
  25. ## Supress alignment warnings on ia64
  26. Patch10: gtk+-1.2.10-alignment.patch
  27. ## Improve exposure compression
  28. Patch11: gtk+-1.2.10-expose.patch
  29. ## Handle focus tracking for embedded window properly
  30. Patch12: gtk+-1.2.10-focus.patch
  31. ## Find gtkrc files for the current encoding better
  32. Patch13: gtk+-1.2.10-encoding.patch
  33. ## Don't screw up CTEXT encoding for UTF-8
  34. Patch14: gtk+-1.2.10-ctext.patch
  35. ## Don't warn about missing fonts for UTF-8
  36. Patch15: gtk+-1.2.10-utf8fontset.patch
  37. ## Accept KP_Enter as a synonym for Return everywhere
  38. Patch16: gtk+-1.2.10-kpenter.patch
  39. ## Allow theme switching to work properly when no windows are realized
  40. Patch17: gtk+-1.2.10-themeswitch.patch
  41. ## Fix crash when switching themes
  42. Patch18: gtk+-1.2.10-pixmapref.patch
  43. ## Fix computation of width of missing characters
  44. Patch19: gtk+-1.2.10-missingchar.patch
  45. # Fix sizes of Ukrainian fontsets
  46. Patch20: gtk+-1.2.10-ukfont.patch
  47. # Fix file selection delete-dir when changing directory problem
  48. # also, fix memory corruption problem when changing directories.
  49. Patch21: gtk+-1.2.10-deletedir.patch
  50. # Improve warning for missing fonts
  51. Patch22: gtk+-1.2.10-fontwarning.patch
  52. # Allow themes to make scrollbar trough always repaint
  53. Patch23: gtk+-1.2.10-troughpaint.patch
  54. # Fix a crash that can happen in some apps when the current
  55. # locale is not supported by XLib.
  56. Patch24: gtk+-1.2.10-localecrash.patch
  57. # Use lib64 in X11R6 path if it exists.
  58. Patch25: gtk+-1.2.10-xlibs.patch
  59. # Patch from CVS to fix b.g.o #56349
  60. Patch26: gtk+-1.2.10-dndorder.patch
  61. # Patch from CVS to fix b.g.o #94812
  62. Patch27: gtk+-1.2.10-clistfocusrow.patch
  63. # Fix GTK+ to obey X server's default bell volume
  64. Patch28: gtk+-1.2.10-bellvolume.patch
  65. # Hack up the configure scripts to deal with some obscure
  66. # breakage with ancient libtool
  67. Patch29: gtk+-1.2.10-libtool.patch
  68. # Add a dependency on libgdk to libgtk
  69. Patch30: gtk+-1.2.10-gtkgdkdep.patch
  70. # Add x86_64
  71. Patch31: gtk+-1.2.10-config.sub-x86_64.patch
  72. #
  73. # Vine-specific patches.
  74. #
  75. # This is still necessary.
  76. Patch101: gtk+-1.2.3-eventmask.patch
  77. Patch102: gtk+-1.2.8-fontselector.patch
  78. Patch103: gtk+-1.2.6-event_send.patch
  79. # Security Patch
  80. Patch110: gtk+-1.2.8-gtkmod.patch
  81. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  82. Summary(ja): X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
  83. %description
  84. The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
  85. graphical user interfaces for the X Window System. GTK+ was originally
  86. written for the GIMP (GNU Image Manipulation Program) image processing
  87. program, but is now used by several other programs as well.
  88. If you are planning on using the GIMP or another program that uses GTK+,
  89. you'll need to have the gtk+ package installed.
  90. %description -l ja
  91. gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
  92. ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
  93. (GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
  94. プログラムで用いられています。
  95. もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
  96. パッケージをインストールしてください。
  97. %package -n compat32-%{name}
  98. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  99. Summary(ja): X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
  100. Group: System Environment/Libraries
  101. Requires: %{name} = %{version}-%{release}
  102. %description -n compat32-%{name}
  103. The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
  104. graphical user interfaces for the X Window System. GTK+ was originally
  105. written for the GIMP (GNU Image Manipulation Program) image processing
  106. program, but is now used by several other programs as well.
  107. If you are planning on using the GIMP or another program that uses GTK+,
  108. you'll need to have the gtk+ package installed.
  109. %description -n compat32-%{name} -l ja
  110. gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
  111. ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
  112. (GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
  113. プログラムで用いられています。
  114. もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
  115. パッケージをインストールしてください。
  116. %package devel
  117. Summary: Development tools for GTK+ (GIMP ToolKit) applications.
  118. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  119. Group: Development/Libraries
  120. Requires: %{name} = %{version}-%{release}
  121. Requires: glib-devel
  122. Requires: libX11-devel
  123. Requires: libXext-devel
  124. Requires: libXi-devel
  125. Obsoletes: gtk-devel
  126. Requires(post): /sbin/install-info
  127. Requires(preun): /sbin/install-info
  128. %description devel
  129. The gtk+-devel package contains the static libraries and header files
  130. needed for developing GTK+ (GIMP ToolKit) applications. The gtk+-devel
  131. package contains glib (a collection of routines for simplifying the
  132. development of GTK+ applications), GDK (the General Drawing Kit, which
  133. simplifies the interface for writing GTK+ widgets and using GTK+ widgets
  134. in applications), and GTK+ (the widget set).
  135. Install gtk+-devel if you need to develop GTK+ applications. You'll also
  136. need to install the gtk+ package.
  137. %description devel -l ja
  138. gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
  139. な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
  140. glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
  141. ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
  142. そして、GTK+ (ウィジッド・セット) を含んでいます。
  143. もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
  144. ールしてください。gtk+ パッケージもインストールしておく必要があります。
  145. %package -n compat32-%{name}-devel
  146. Summary: Development tools for GTK+ (GIMP ToolKit) applications.
  147. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  148. Group: Development/Libraries
  149. Requires: %{name}-devel = %{version}-%{release}
  150. Requires: compat32-%{name} = %{version}-%{release}
  151. %description -n compat32-%{name}-devel
  152. The gtk+-devel package contains the static libraries and header files
  153. needed for developing GTK+ (GIMP ToolKit) applications. The gtk+-devel
  154. package contains glib (a collection of routines for simplifying the
  155. development of GTK+ applications), GDK (the General Drawing Kit, which
  156. simplifies the interface for writing GTK+ widgets and using GTK+ widgets
  157. in applications), and GTK+ (the widget set).
  158. Install gtk+-devel if you need to develop GTK+ applications. You'll also
  159. need to install the gtk+ package.
  160. %description -n compat32-%{name}-devel -l ja
  161. gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
  162. な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
  163. glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
  164. ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
  165. そして、GTK+ (ウィジッド・セット) を含んでいます。
  166. もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
  167. ールしてください。gtk+ パッケージもインストールしておく必要があります。
  168. %prep
  169. %setup -q
  170. %patch1 -p1 -b .ahiguti
  171. %patch5 -p1 -b .alnum
  172. %patch10 -p1 -b .alignment
  173. %patch11 -p1 -b .expose
  174. %patch12 -p1 -b .focus
  175. %patch13 -p1 -b .encoding
  176. %patch14 -p1 -b .ctext
  177. %patch15 -p1 -b .utf8fontset
  178. %patch16 -p1 -b .kpenter
  179. %patch17 -p1 -b .themeswitch
  180. %patch18 -p1 -b .pixmapref
  181. %patch19 -p1 -b .missingchar
  182. %patch20 -p1 -b .ukfont
  183. %patch21 -p1 -b .deletedir
  184. %patch22 -p1 -b .fontwarning
  185. %patch23 -p0 -b .troughpaint
  186. %patch24 -p1 -b .localecrash
  187. %patch25 -p1 -b .xlibs
  188. %patch26 -p0 -b .dndorder
  189. %patch27 -p0 -b .clistfocusrow
  190. %patch28 -p1 -b .bellvolume
  191. %patch29 -p1 -b .libtool
  192. %patch31 -p1 -b .x86_64
  193. %patch101 -p1 -b .nocore
  194. %patch102 -p1 -b .fontsel
  195. %patch103 -p1 -b .event_send
  196. %patch110 -p1 -b .gtkmod
  197. #libtoolize --force
  198. #aclocal-1.4
  199. automake-1.4
  200. autoconf-2.13
  201. autoheader-2.13
  202. %build
  203. %configure --with-xinput=xfree --with-native-locale --disable-static
  204. make %{?_smp_mflags}
  205. %install
  206. rm -rf ${RPM_BUILD_ROOT}
  207. make install DESTDIR=${RPM_BUILD_ROOT}
  208. # rename gtk-config to gtk-config-32 if build_compat32 option is enabled
  209. %if %{build_compat32}
  210. #mv $RPM_BUILD_ROOT%{_bindir}/gtk-config $RPM_BUILD_ROOT%{_bindir}/gtk-config-32
  211. cp -p $RPM_BUILD_ROOT%{_bindir}/gtk-config $RPM_BUILD_ROOT%{_bindir}/gtk-config-32
  212. %endif
  213. #
  214. # Make cleaned-up versions of examples and tutorial for installation
  215. #
  216. ./mkinstalldirs tmpdocs/tutorial
  217. install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
  218. for dir in examples/*; do
  219. if [ -d $dir ]; then
  220. ./mkinstalldirs tmpdocs/$dir
  221. for file in $dir/*; do
  222. case $file in
  223. *pre1.2.7)
  224. ;;
  225. *)
  226. install -m 0644 $file tmpdocs/$dir
  227. ;;
  228. esac
  229. done
  230. fi
  231. done
  232. install -m 444 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc
  233. install -m 444 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc.ja
  234. %find_lang %{name}
  235. # remove unneeded files
  236. %__rm -f %{buildroot}%{_libdir}/lib{gdk,gtk}.la
  237. %clean
  238. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  239. %post -p /sbin/ldconfig
  240. %postun -p /sbin/ldconfig
  241. %post -n compat32-%{name} -p /sbin/ldconfig
  242. %postun -n compat32-%{name} -p /sbin/ldconfig
  243. %post devel
  244. /sbin/install-info %{_infodir}/gdk.info.gz %{_infodir}/dir
  245. /sbin/install-info %{_infodir}/gtk.info.gz %{_infodir}/dir
  246. %preun devel
  247. if [ $1 = 0 ]; then
  248. /sbin/install-info --delete %{_infodir}/gdk.info.gz %{_infodir}/dir
  249. /sbin/install-info --delete %{_infodir}/gtk.info.gz %{_infodir}/dir
  250. fi
  251. %files -f %{name}.lang
  252. %defattr(-, root, root)
  253. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  254. %{_libdir}/libgtk-1.2.so.*
  255. %{_libdir}/libgdk-1.2.so.*
  256. %{_datadir}/themes/Default
  257. %config %{_sysconfdir}/gtk/*
  258. %files devel
  259. %defattr(-, root, root)
  260. %{_libdir}/lib*.so
  261. %{_libdir}/pkgconfig
  262. %{_mandir}/man1/*
  263. %{_includedir}/*
  264. %{_infodir}/*info*
  265. %{_datadir}/aclocal/*
  266. #%{_bindir}/*
  267. %{_bindir}/gtk-config
  268. %doc tmpdocs/tutorial
  269. %doc tmpdocs/examples
  270. %if %{build_compat32}
  271. %files -n compat32-%{name}
  272. %defattr(-, root, root)
  273. %{_libdir}/libgtk-1.2.so.*
  274. %{_libdir}/libgdk-1.2.so.*
  275. %files -n compat32-%{name}-devel
  276. %defattr(-, root, root)
  277. %{_libdir}/lib*.so
  278. %{_bindir}/gtk-config-32
  279. %endif
  280. %changelog
  281. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-5
  282. - rebuild with VineSeed environement
  283. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.10-4
  284. - fixed missing of gtk-config (on i686)
  285. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-3
  286. - rebuild with rpm-4.8.1 for pkg-config file
  287. - add BuildRequires: libXt-devel
  288. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.10-2
  289. - spec in utf-8
  290. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
  291. - applied new versioning policy
  292. - rebuilt with xorg-x11 7.3 (updated denepdancies)
  293. * Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl10
  294. - rename gtk-config to gtk-config-32 if build_compat32 option is enabled
  295. * Mon Mar 06 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.10-0vl9
  296. - added compat32-* packages for x86_64 architecture support
  297. * Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl8
  298. - added gtk+-1.2.10-config.sub-x86_64.patch
  299. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl7
  300. - rebuild
  301. - not run libtoolize --force, aclocal-1.4
  302. - remove %%{_libdir}/lib{gdk,gtk}.la
  303. - compress info files by brp-compress
  304. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl6
  305. - merge more RH patches (Patch26-Patch29)
  306. * Mon Oct 27 2003 Owen Taylor <otaylor@redhat.com> 1:1.2.10-28.1
  307. - Cave like a cheap house of cards and add gdk-pixbuf dependency (#105613)
  308. - Add gtkrc.*.utf8 RC files for CJK (#84593)
  309. - Add a dependency on libgdk to libgtk (#106677)
  310. * Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 1.2.10-26
  311. - Run libtoolize/auto* to get an updated libtool that recognizes ppc64
  312. * Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com> 1.2.10-24
  313. - Add a couple of patches from GNOME CVS, fixing a crash
  314. with CList focus row tracking, and a place where DND
  315. would get confused.
  316. - Obey the system bell volume (#74802)
  317. - Ship the pkg-config files
  318. * Mon Nov 4 2002 Tim Waugh <twaugh@redhat.com> 1.2.10-23
  319. - Don't install files not shipped.
  320. - Fix gtk-config output for multilib archs.
  321. * Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl5
  322. - merge more RH patches (Patch20-Patch25)
  323. - rawhide's changelog since last merge (except "automated rebuild") are:
  324. - Thu Aug 22 2002 Owen Taylor <otaylor@redhat.com>
  325. - Fix a crash that can happen in some apps when the current
  326. locale is not supported by XLib. (#72157)
  327. - Fri Jul 26 2002 Owen Taylor <otaylor@redhat.com>
  328. - Fix a small memory leak in the .encoding patch (Kjartan Maraas)
  329. - Fri Jul 19 2002 Alexander Larsson <alexl@redhat.com>
  330. - Add troughpaint patch
  331. - Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
  332. - Fix UTF-8 font specification not to pick up *-c-* fonts
  333. - Thu May 16 2002 Alex Larsson <alexl@redhat.com>
  334. - Require automake 1.4
  335. - Wed Apr 17 2002 Owen Taylor <otaylor@redhat.com>
  336. - Fix problem with incorrect directory contents when changing directories (#63726)
  337. - Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
  338. - Fix filesel delete-filename-on-dir-change problem
  339. - Improve warning for missing fontset elements
  340. - Thu Apr 11 2002 Owen Taylor <otaylor@redhat.com>
  341. - Fix ukrainian font sizes, minor tweak to russian fonts (#63135)
  342. - Own /etc/gtk/ as well as the files in it (#63139)
  343. * Thu Mar 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl4
  344. - changed default theme to BeCool.
  345. * Mon Oct 15 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
  346. - Merged several RH patches.
  347. * Mon Aug 13 2001 Owen Taylor <otaylor@redhat.com>
  348. - Fix problem with width computation for missing characters
  349. * Sun Aug 12 2001 Owen Taylor <otaylor@redhat.com>
  350. - Fix refcounting problem in gtk_style_copy() that might affect
  351. theme switching. (#51580)
  352. * Wed Aug 8 2001 Owen Taylor <otaylor@redhat.com>
  353. - Add fix for theme switching in nautilus sidebar tabs
  354. (and other similar situations)
  355. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  356. - Accept KP_Enter as well as Return (#21111)
  357. * Wed Jul 11 2001 Owen Taylor <otaylor@redhat.com>
  358. - Further improve exposure compression code
  359. * Tue Jul 10 2001 Owen Taylor <otaylor@redhat.com>
  360. - Omit warnings about character sets not found in fontset,
  361. if current locale is UTF-8 based. (Hack!)
  362. * Tue Jul 3 2001 Owen Taylor <otaylor@redhat.com>
  363. - Add patch for alignment warnings on ia64
  364. - Add from Alex to vastly improve expose compression
  365. - Add patch to fix focus tracking for embedded windows
  366. - Add patch by Pablo Saratxaga to improve encoding handling
  367. - Add patch to not screw up CTEXT for UTF-8 locales
  368. * Tue Jul 17 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
  369. - 1.2.10-0vl2
  370. - change CFLAGS on alpha (gcc-2.95.3 with -O2 causes problems)
  371. * Tue Apr 3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
  372. - New upstream release.
  373. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
  374. - New upstream release.
  375. * Wed Feb 14 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl6
  376. - correct configure for stablity
  377. * Tue Feb 13 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl5
  378. - correct configure (for --enable-xinput)
  379. - add DESTDIR patch for po/Makefile.in.in
  380. * Wed Feb 7 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl4
  381. - add gtk+-1.2.8-gtktextwcfix.patch
  382. * Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  383. - 1.2.8-0vl2
  384. - applied security patch (http://www.securityfocus.com/bid/2165)
  385. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  386. - updated to 1.2.8
  387. * Fri Feb 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  388. - added fontselector based on kondara's patch
  389. * Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  390. - updated to 1.2.7
  391. - remove morioka marged to the original gtk source tree.
  392. Tue Dec 28 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  393. - added event_send patch to be more stable when switching themes.
  394. * Sat Dec 11 1999 Jun Nishii <jun@flatout.org>
  395. - smaller fontset in gtkrc.ja
  396. * Thu Nov 25 1999 Jun NISHII <jun@flatout.org>
  397. - use morioka patch instead of fontsel patches
  398. * Sat Oct 23 1999 Jun Nishii <jun@flatout.org>
  399. - gtk+-1.2.6-1vl2
  400. - added fontsel patches from gtk/gnome-ML
  401. * Tue Oct 12 1999 Jun Nishii <jun@flatout.org>
  402. - gtk+-1.2.6-1vl1
  403. * Thu Sep 30 1999 Jun Nishii <jun@flatout.org>
  404. - gtk+-1.2.5-1vl2
  405. - with wordwrap patch
  406. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  407. - gtk+-1.2.5-1vl1
  408. * Sat Sep 11 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  409. [gtk+-1.2.4-1vl2]
  410. - removed fontsel patch.
  411. * Mon Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  412. [gtk+-1.2.4-1vl1]
  413. - install gzipped info.
  414. - changed release tag with 'vl.'
  415. * Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  416. [gtk+-1.2.4-1]
  417. - Update for GTK+-1.2.4.
  418. - bzip2 source.
  419. - use %{sysconfdir} as /etc.
  420. * Sun Aug 22 1999 Jun Nishii <jun@flatout.org>
  421. - bzip2 source
  422. * Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
  423. - build for Vine-1.9
  424. - merge fontset patch
  425. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  426. - Update for GTK+-1.2.3
  427. - Patches that will be in GTK+-1.2.4
  428. - Patch to keep GTK+ from coredumping on X IO errors
  429. - Patch to improve compatilibity with GTK-1.2.1 (allow
  430. event mask to be set on realized widgets)
  431. * Mon Apr 19 1999 Michael Fulbright <drmike@redhat.com>
  432. - fixes memory leak
  433. * Mon Apr 12 1999 Owen Taylor <otaylor@redhat.com>
  434. - The important bug fixes that will be in GTK+-1.2.2
  435. * Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
  436. - patches from owen to handle various gdk bugs
  437. * Sun Mar 28 1999 Michael Fulbright <drmike@redhat.com>
  438. - added XFree86-devel requirement for gtk+-devel
  439. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  440. - version 1.2.1
  441. * Wed Mar 17 1999 Michael Fulbright <drmike@redhat.com>
  442. - removed /usr/info/dir.gz file from package
  443. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  444. - Version 1.2.0
  445. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  446. - version 1.2.0pre2, patched to use --sysconfdir=/etc
  447. * Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
  448. - patched in Owen's patch to fix Metal theme
  449. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  450. - bumped up to 1.1.15
  451. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  452. - bumped up to 1.1.14
  453. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  454. - bumped up to 1.1.13
  455. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  456. - bumped up to 1.1.12
  457. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  458. - added Theme directory to file list
  459. - up to 1.1.7 for GNOME freeze
  460. * Sun Oct 25 1998 Shawn T. Amundson <amundson@gtk.org>
  461. - Fixed Source: to point to v1.1
  462. * Tue Aug 04 1998 Michael Fulbright <msf@redhat.com>
  463. - change %postun to %preun
  464. * Sat Jun 27 1998 Shawn T. Amundson
  465. - Changed version to 1.1.0
  466. * Thu Jun 11 1998 Dick Porter <dick@cymru.net>
  467. - Removed glib, since it is its own module now
  468. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  469. - Split out glib package
  470. * Wed Apr 8 1998 Shawn T. Amundson <amundson@gtk.org>
  471. - Changed version to 1.0.0
  472. * Tue Apr 7 1998 Owen Taylor <otaylor@gtk.org>
  473. - Changed version to 0.99.10
  474. * Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
  475. - Changed version to 0.99.9
  476. - Changed gtk home page to www.gtk.org
  477. * Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
  478. - Changed version to 0.99.8
  479. * Sun Mar 15 1998 Marc Ewing <marc@redhat.com>
  480. - Added aclocal and bin stuff to file list.
  481. - Added -k to the SMP make line.
  482. - Added lib/glib to file list.
  483. * Sat Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
  484. - Changed version to 0.99.7
  485. * Sat Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
  486. - Updated ftp url and changed version to 0.99.6
  487. * Thu Mar 12 1998 Marc Ewing <marc@redhat.com>
  488. - Reworked to integrate into gtk+ source tree
  489. - Truncated ChangeLog. Previous Authors:
  490. Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  491. Michael K. Johnson <johnsonm@redhat.com>
  492. Otto Hammersmith <otto@redhat.com>