gpaste-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. %global alt_name GPaste
  2. Name: gpaste
  3. Version: 3.0.2
  4. Release: 1%{?_dist_release}
  5. Summary: Clipboard management system
  6. Summary(ja): クリップボード管理システム
  7. Group: User Interface/Desktops
  8. License: GPLv3+
  9. URL: https://github.com/Keruspe/GPaste
  10. Source0: https://github.com/downloads/Keruspe/%{alt_name}/%{name}-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: chrpath
  13. BuildRequires: dbus-devel
  14. BuildRequires: desktop-file-utils
  15. BuildRequires: gettext
  16. BuildRequires: glib2-devel >= 2.30
  17. BuildRequires: gobject-introspection-devel
  18. BuildRequires: gtk3-devel
  19. BuildRequires: intltool >= 0.40.0
  20. BuildRequires: libxml2-devel
  21. BuildRequires: libXtst-devel
  22. BuildRequires: vala-devel >= 0.14
  23. BuildRequires: vala-tools >= 0.14
  24. BuildRequires: xcb-util-keysyms-devel
  25. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  26. %description
  27. gpasted is a clipboard management daemon with DBus interface. gpaste is its CLI
  28. client and gpaste-settings is a tool to edit gpasted settings.
  29. %package libs
  30. Summary: Library to manage the clipboard history
  31. Group: System Environment/Libraries
  32. %description libs
  33. libgpaste is a library to manage the clipboard history (used by gpasted).
  34. %package devel
  35. Summary: Development files for %{name}
  36. Summary(ja): %{name} の開発ファイル
  37. Group: Development/Libraries
  38. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  39. %description devel
  40. The %{name}-devel package contains libraries and header files for
  41. developing applications that use %{name}.
  42. %package -n gnome-shell-extensions-%{name}
  43. Summary: GNOME Shell extension for GPaste
  44. Summary(ja): GPaste 用の Gnome Shell 機能拡張
  45. Group: User Interface/Desktops
  46. Requires: gnome-shell >= 3.3.5
  47. Requires: %{name} = %{version}-%{release}
  48. BuildArch: noarch
  49. %description -n gnome-shell-extensions-%{name}
  50. %{summary}.
  51. %prep
  52. %setup -q
  53. %build
  54. ./autogen.sh
  55. # Applet disabled since it is unusable in GNOME 3
  56. %configure \
  57. --disable-applet \
  58. --disable-schemas-compile
  59. make %{?_smp_mflags}
  60. %install
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  63. # Fix Rpath issues
  64. chrpath --delete $RPM_BUILD_ROOT%{_libexecdir}/%{name}/gpasted
  65. chrpath --delete $RPM_BUILD_ROOT%{_libexecdir}/%{name}/gpaste-settings
  66. # Install bash/zsh completion support
  67. install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
  68. install -pm 0644 data/completions/%{name} -t $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
  69. install -d $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions/
  70. install -pm 0644 data/completions/_%{name} -t $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions/
  71. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-settings.desktop
  72. %find_lang %{alt_name}
  73. %post libs -p /sbin/ldconfig
  74. %postun libs -p /sbin/ldconfig
  75. %postun
  76. if [ $1 -eq 0 ]; then
  77. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
  78. fi
  79. %posttrans
  80. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
  81. %files -f %{alt_name}.lang
  82. %defattr(-,root,root,-)
  83. %doc AUTHORS ChangeLog COPYING NEWS THANKS TODO
  84. %{_bindir}/%{name}
  85. %{_libexecdir}/%{name}/
  86. %{_datadir}/applications/%{name}-settings.desktop
  87. %{_datadir}/dbus-1/services/*.service
  88. %{_datadir}/glib-2.0/schemas/*.xml
  89. %{_datadir}/vala/vapi/*
  90. %{_datadir}/zsh/
  91. %{_mandir}/man1/%{name}.1.*
  92. %{_sysconfdir}/bash_completion.d/
  93. %files libs
  94. %defattr(-,root,root,-)
  95. %{_libdir}/girepository-1.0/%{alt_name}-1.0.typelib
  96. %{_libdir}/*.so.*
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %{_datadir}/gir-1.0/*.gir
  100. %{_includedir}/%{name}/
  101. %{_libdir}/*.so
  102. %{_libdir}/pkgconfig/*.pc
  103. %files -n gnome-shell-extensions-%{name}
  104. %defattr(-,root,root,-)
  105. %{_datadir}/gnome-shell/extensions/GPaste@gnome-shell-extensions.gnome.org/
  106. %changelog
  107. * Sat Aug 31 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
  108. - initial build for VineSeed
  109. * Sat May 19 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.8.1-1
  110. - Update to 2.8.1
  111. * Thu May 03 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.8-1
  112. - Update to 2.8
  113. * Sun Apr 08 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.5-2
  114. - Fix Group and Requires tags in subpackages
  115. * Fri Mar 30 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.5-1
  116. - Update to 2.5
  117. * Sat Jan 07 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.2.1-1
  118. - Update to 2.2.1
  119. * Fri Dec 09 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.1-1
  120. - Update to 2.1
  121. * Tue Nov 29 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.0-1
  122. - Update to 2.0
  123. * Sun Sep 25 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.6-1
  124. - Update to 1.6
  125. - Remove no longer needed gpaste-1.5-DOS.patch patch
  126. * Wed Sep 14 2011 Mohamed El Morabity <melmorabity@fedorapeople.org> - 1.5-1
  127. - Update to 1.5
  128. - Remove gpaste-1.3-remove_applet_refs.patch patch (there is no more reference
  129. to the GNOME 2 applet in documentation and completion files)
  130. - Add gpaste-1.5-DSO.patch to fix DSO linking
  131. * Sat Sep 03 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.3-1
  132. - Update to 1.3
  133. * Sun Jul 10 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.2-1
  134. - Update to 1.2
  135. * Sat Jun 25 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.99-1.17dd47git
  136. - Initial RPM release