gnome-vfs-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. # Note that this is NOT a relocatable package
  2. %define name gnome-vfs
  3. %define ver 1.0.5
  4. %define rel 13vl4
  5. Summary: The GNOME virtual file-system libraries
  6. Name: gnome-vfs
  7. Version: 1.0.5
  8. Release: 14%{?_dist_release}
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.0/%{name}-%{ver}.tar.gz
  12. Source2: macros.tar.gz
  13. Source3: gnome-vfs-pofiles.tar.gz
  14. Patch1: gnome-vfs-1.0.5-charset-and-rpmsave.patch
  15. Patch2: gnome-vfs-1.0.5-lib64.patch
  16. Patch3: gnome-vfs-1.0.5-mimesniffcrash-backport.patch
  17. Patch4: gnome-vfs-1.0.5-compilation-fix.patch
  18. Patch100: gnome-vfs-1.0.5-configure.patch
  19. URL: http://www.gnome.org/
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Requires: glib >= 1.2.4
  22. Requires: GConf >= 0.9
  23. Requires: oaf >= 0.3.0
  24. Requires: gnome-mime-data
  25. BuildRequires: GConf-devel, oaf-devel, glib-devel, libxml-devel, zlib-devel
  26. BuildRequires: popt-devel, bzip2-devel, ORBit-devel, libX11-devel
  27. BuildRequires: gnome-libs-devel, pkgconfig, intltool, gettext, openjade
  28. BuildRequires: gnome-mime-data
  29. BuildRequires: automake14
  30. %description
  31. GNOME VFS is the GNOME virtual file system. It is the foundation of the
  32. Nautilus file manager. It provides a modular architecture and ships with
  33. several modules that implement support for file systems, http, ftp and others.
  34. It provides a URI-based API, a backend supporting asynchronous file operations,
  35. a MIME type manipulation library and other features.
  36. %package devel
  37. Summary: Libraries and include files for developing GNOME VFS applications.
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}
  40. Requires: GConf-devel
  41. Requires: oaf-devel
  42. %description devel
  43. This package provides the necessary development libraries for writing
  44. GNOME VFS modules and applications that use the GNOME VFS APIs.
  45. %prep
  46. %setup -q
  47. %patch1 -p1 -b .charset-and-rpmsave
  48. if [ "%{_lib}" == "lib64" ] ; then
  49. %patch2 -p1 -b .lib64
  50. fi
  51. %patch3 -p1 -b .mimecrash
  52. %patch4 -p1 -b .compilation-fix
  53. tar zxf %{SOURCE2}
  54. # unpack translations
  55. tar zxf %{SOURCE3}
  56. %patch100 -p1 -b .configure
  57. # workaround glibc21.m4 being installed
  58. mkdir tmp-macros
  59. cp libgnomevfs/libcharset/*.m4 tmp-macros
  60. rm tmp-macros/glibc21.m4
  61. # for patch 1
  62. aclocal-1.4 -I macros -I tmp-macros
  63. automake-1.4
  64. autoheader
  65. autoconf
  66. %build
  67. if pkg-config openssl ; then
  68. CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
  69. LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
  70. fi
  71. %configure --disable-gtk-doc
  72. export tagname=CC
  73. make LIBTOOL=/usr/bin/libtool
  74. %install
  75. rm -rf %{buildroot}
  76. export tagname=CC
  77. %makeinstall LIBTOOL=/usr/bin/libtool
  78. %find_lang %{name}
  79. # Remove files which we won't include in this package.
  80. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  81. rm -f $RPM_BUILD_ROOT/%{_libdir}/libgnomevfs-pthread.a
  82. rm -f $RPM_BUILD_ROOT/%{_libdir}/vfs/modules/*.la
  83. rm -f $RPM_BUILD_ROOT/%{_libdir}/vfs/modules/*.a
  84. %clean
  85. rm -rf %{buildroot}
  86. %post -p /sbin/ldconfig
  87. %postun -p /sbin/ldconfig
  88. %files -f %{name}.lang
  89. %defattr(-, root, root)
  90. %doc AUTHORS COPYING ChangeLog NEWS README
  91. %dir %{_sysconfdir}/vfs
  92. %dir %{_sysconfdir}/vfs/modules
  93. %config %{_sysconfdir}/vfs/modules/*.conf
  94. %{_libdir}/lib*.so.*
  95. %{_libdir}/libgnomevfs-pthread.so
  96. %{_libdir}/vfs/extfs/*
  97. %{_libdir}/vfs/modules/*.so
  98. #{_datadir}/gtk-doc/html/*
  99. %files devel
  100. %defattr(-, root, root)
  101. %{_bindir}/gnome-vfs-config
  102. %{_includedir}/gnome-vfs-1.0
  103. %{_libdir}/gnome-vfs-1.0
  104. %{_libdir}/lib*.a
  105. %{_libdir}/lib*.so
  106. %{_libdir}/*.sh
  107. #{_libdir}/vfs/modules/*.a
  108. %changelog
  109. * Sat Oct 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-14vl5
  110. - applied new versioning policy
  111. * Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-13vl4
  112. - rebuild with new toolchain
  113. - added Patch100
  114. * Sun Apr 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-13vl3
  115. - rebuild with openssl-0.9.7d
  116. - s/Copyright/License/
  117. - added BuildRequires gettext
  118. * Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.5-13vl2
  119. - added BuildRequires intltool
  120. * Sat Apr 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.5-13vl1
  121. - synced with Rawhide
  122. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-0vl1
  123. - new upstream release
  124. - split mime stuff to gnome-mime-data.
  125. * Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.3-0vl1
  126. - updated to the new upstream release
  127. * Fri May 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  128. - Added mime of .ttc
  129. * Wed May 9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  130. - New upstream release.
  131. * Thu Apr 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0-0vl3
  132. - Include the API documents.
  133. * Mon Apr 9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0-0vl2
  134. - Added some build depends.
  135. - Fixed relative config.
  136. * Tue Apr 3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0-0vl1
  137. - New upstream release.
  138. - Use find_lang macro.
  139. * Fri Mar 9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.6.2-0vl1
  140. - New upstream release.
  141. * Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.4.2-0vl1
  142. - Build for Vine
  143. * Tue Feb 22 2000 Ross Golder <rossigee@bigfoot.com>
  144. - Integrate into source tree