gnome-shell-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377
  1. %define pkg_version 3.30.2
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Summary(ja): GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
  5. Name: gnome-shell
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
  9. # settings for Vine
  10. Patch101: gnome-shell-3.14.1-vine-settings.patch
  11. Patch102: gnome-shell-3.16.0-revert-loginManager.patch
  12. Patch103: gnome-shell-3.16.2-disable-packagekit.patch
  13. Patch104: gnome-shell-3.20.3-vine-themes.patch
  14. Patch105: ja_po.patch
  15. License: GPLv2+
  16. Group: User Interface/Desktops
  17. URL: http://live.gnome.org/GnomeShell
  18. Requires: mutter
  19. Requires: caribou
  20. Requires: ca-certificates
  21. Requires: at-spi2-atk
  22. Requires: telepathy-logger
  23. Requires: network-manager-applet
  24. Requires: gnome-tweak-tool
  25. BuildRequires: meson
  26. BuildRequires: gnome-common
  27. BuildRequires: pkgconfig
  28. BuildRequires: gtk2-devel
  29. BuildRequires: clutter-devel
  30. BuildRequires: mutter-devel
  31. BuildRequires: gjs-devel
  32. BuildRequires: gnome-desktop3-devel
  33. BuildRequires: gnome-menus-devel
  34. BuildRequires: libSM-devel
  35. BuildRequires: libffi-devel
  36. BuildRequires: startup-notification-devel
  37. BuildRequires: gnome-doc-utils
  38. BuildRequires: desktop-file-utils
  39. BuildRequires: libcroco-devel
  40. BuildRequires: librsvg2-devel
  41. BuildRequires: gobject-introspection-devel
  42. BuildRequires: control-center-devel
  43. BuildRequires: gcr-devel
  44. BuildRequires: gstreamer1-devel
  45. BuildRequires: dbus-glib-devel
  46. BuildRequires: telepathy-logger-devel
  47. BuildRequires: polkit-devel
  48. BuildRequires: pulseaudio-libs-devel
  49. BuildRequires: evolution-data-server-devel
  50. BuildRequires: folks-devel
  51. BuildRequires: NetworkManager-glib-devel
  52. BuildRequires: NetworkManager-libnm-devel
  53. BuildRequires: libnm-gtk-devel
  54. BuildRequires: libgudev1-devel
  55. BuildRequires: libcanberra-gtk3-devel
  56. BuildRequires: caribou-devel
  57. BuildRequires: ca-certificates
  58. BuildRequires: python3-devel
  59. BuildRequires: intltool
  60. BuildRequires: ibus-devel
  61. BuildRequires: gnome-bluetooth-devel
  62. BuildRequires: sassc
  63. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  64. Vendor: Project Vine
  65. Distribution: Vine Linux
  66. %description
  67. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  68. It provides core interface functions like switching to windows and launching
  69. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  70. hardware and introduces innovative user interface concepts to provide a delightful
  71. and easy to use experience.
  72. %package docs
  73. Summary: Documentation for %{name}
  74. Summary(ja): %{name} 用のドキュメント
  75. Group: Documentation
  76. Requires: %{name} = %{version}-%{release}
  77. BuildArch: noarch
  78. %description docs
  79. This package contains documentation for %{name}.
  80. %prep
  81. %setup -q
  82. #%patch101 -p1 -b .vine
  83. #%patch102 -p1 -b .vine
  84. #%patch103 -p1 -b .vine
  85. #%patch104 -p1 -b .vine
  86. %patch105 -p1 -b .ja
  87. %build
  88. export LANG=ja_JP.UTF-8
  89. %meson \
  90. -Dsystemd=false \
  91. -Dgtk_doc=true
  92. %meson_build
  93. %install
  94. export LANG=ja_JP.UTF-8
  95. %{__rm} -rf %{buildroot}
  96. %meson_install
  97. %find_lang %{name}
  98. %clean
  99. %{__rm} -rf ${RPM_BUILD_ROOT}
  100. %post
  101. /sbin/ldconfig
  102. touch --no-create %{_datadir}/icons/hicolor
  103. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  104. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  105. fi
  106. %postun
  107. /sbin/ldconfig
  108. touch --no-create %{_datadir}/icons/hicolor
  109. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  110. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  111. fi
  112. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  113. %posttrans
  114. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  115. %files -f %{name}.lang
  116. %defattr(-,root,root,-)
  117. %license COPYING
  118. %doc NEWS README.md
  119. %dir %{_sysconfdir}/xdg
  120. %dir %{_sysconfdir}/xdg/autostart
  121. %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
  122. %{_bindir}/gnome-shell
  123. %{_bindir}/gnome-shell-extension-tool
  124. %{_bindir}/gnome-shell-extension-prefs
  125. %{_bindir}/gnome-shell-perf-tool
  126. %{_libdir}/%{name}/*
  127. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  128. %{_libexecdir}/gnome-shell-calendar-server
  129. %{_libexecdir}/gnome-shell-hotplug-sniffer
  130. %{_libexecdir}/gnome-shell-overrides-migration.sh
  131. %{_libexecdir}/gnome-shell-perf-helper
  132. %{_libexecdir}/gnome-shell-portal-helper
  133. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  134. %{_datadir}/applications/org.gnome.Shell.desktop
  135. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  136. %{_datadir}/applications/evolution-calendar.desktop
  137. %{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
  138. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
  139. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  140. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
  141. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
  142. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  143. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  144. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  145. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  146. %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
  147. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  148. %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
  149. %{_datadir}/%{name}/*
  150. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  151. %dir %{_datadir}/xdg-desktop-portal
  152. %dir %{_datadir}/xdg-desktop-portal/portals
  153. %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
  154. %{_mandir}/man1/%{name}.1.gz
  155. %files docs
  156. %defattr(-,root,root,-)
  157. %{_datadir}/gtk-doc/html/shell
  158. %{_datadir}/gtk-doc/html/st
  159. %changelog
  160. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.2-1
  161. - new upstream release.
  162. - dropped Patch102: session tracker was switched to elogind.
  163. - added Patch105.
  164. * Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-1
  165. - new upstream release.
  166. * Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
  167. - new upstream release
  168. - add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
  169. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
  170. - new upstream release
  171. - update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
  172. * Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
  173. - new upstream release
  174. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  175. - new upstream release
  176. * Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  177. - new upstream release
  178. - update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
  179. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  180. - new upstream release
  181. * Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  182. - add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
  183. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  184. - add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
  185. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  186. - new upstream release
  187. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  188. - new upstream release
  189. * Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  190. - new upstream release
  191. - add BuildRequires: python3-devel
  192. - update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
  193. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
  194. - rebuilt with libical 1.0.1
  195. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  196. - new upstream release
  197. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  198. - new upstream release
  199. * Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
  200. - new upstream release
  201. - update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
  202. - add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
  203. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  204. - new upstream release
  205. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  206. - new upstream release
  207. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  208. - new upstream release
  209. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  210. - new upstream release
  211. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  212. - new upstream release
  213. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  214. - new upstream release
  215. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  216. - new upstream release
  217. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  218. - new upstream release
  219. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  220. - new upstream release
  221. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  222. - new upstream release
  223. - update Patch101 (gnome-shell-vine-settings.patch)
  224. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  225. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  226. - create %%{name}-docs subpackage
  227. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  228. - new upstream release
  229. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  230. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  231. - new upstream release
  232. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  233. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  234. - new upstream release
  235. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  236. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  237. - rebuild with telepathy-logger-0.6.0
  238. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  239. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  240. - new upstream release
  241. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  242. - new upstream release
  243. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  244. - update Patch101 (gnome-shell-vine-settings.patch)
  245. - change BuildRequires: ca-certificates instead of openssl
  246. - add BuildRequires: libcanberra-gtl3-devel
  247. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  248. - new upstream release
  249. - remove Patch103 (gnome-shell-ja.po-date.patch)
  250. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  251. - new upstream release
  252. - update Patch101,103
  253. - remove Patch0,102
  254. - add BuildRequires: gcr-devel
  255. - remove BuildRequires: GConf2-devel
  256. - add Requires: at-spi2-atk
  257. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  258. - new upstream release
  259. - remove Patch1
  260. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  261. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  262. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  263. - rename Patch103 (gnome-shell-ja.po-date.patch)
  264. - drop Patch102
  265. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  266. - new upstream release
  267. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  268. - new upstream release
  269. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  270. - new upstream release
  271. - update Patch101
  272. - update Patch102
  273. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  274. - add BuildRequires: libgudev1-devel, openssl
  275. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  276. - new upstream release
  277. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  278. - add Requires: caribou
  279. - remove Patch0
  280. - update Patch101
  281. - update Patch102
  282. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  283. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  284. - rebuild with gnome-menus-3.1.5
  285. - add Patch0 (gnome-shell-git20110821.patch)
  286. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  287. - new upstream release
  288. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  289. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  290. - remove BuildRequires: xulrunner-devel
  291. - add Patch101 (gnome-shell-vine-settings.patch)
  292. - add Patch102 (gnome-shell-vine-customize.patch)
  293. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  294. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  295. - add Requires: mutter
  296. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  297. - new upstream release
  298. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  299. - initial build for Vine Linux