glib2-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A library of handy utility functions.
  4. Name: glib2
  5. Version: 2.64.2
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: LGPLv2+
  12. URL: http://www.gtk.org
  13. %define shortver %(echo %{version} | cut -d. -f1-2)
  14. Source: https://download.gnome.org/sources/glib/%{shortver}/glib-%{version}.tar.xz
  15. Source2: glib2.sh
  16. Source3: glib2.csh
  17. BuildRoot: %{_tmppath}/glib-%{version}-root
  18. BuildRequires: dbus-devel
  19. BuildRequires: docbook-style-xsl
  20. BuildRequires: gamin-devel
  21. BuildRequires: libattr-devel
  22. BuildRequires: libffi-devel
  23. BuildRequires: libmount-devel
  24. BuildRequires: libxslt
  25. BuildRequires: meson
  26. BuildRequires: pcre-devel >= 8.13
  27. BuildRequires: pkgconfig >= 0.14
  28. BuildRequires: python3-devel
  29. BuildRequires: zlib-devel
  30. Obsoletes: glib-gtkbeta
  31. # for gio-querymodules
  32. Requires(post,postun): libffi
  33. %description
  34. GLib is the low-level core library that forms the basis
  35. for projects such as GTK+ and GNOME. It provides data structure
  36. handling for C, portability wrappers, and interfaces for such runtime
  37. functionality as an event loop, threads, dynamic loading, and an
  38. object system.
  39. This package provides version %{shortver} of GLib.
  40. %package devel
  41. Summary: Development files for the GLib library
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}
  44. Requires: pkgconfig >= 0.14
  45. Requires: libffi-devel
  46. Requires: zlib-devel
  47. Requires: python3
  48. Obsoletes: glib-gtkbeta-devel
  49. Conflicts: glib-devel <= 1.2.8
  50. %description devel
  51. The glib-devel package includes the header files for
  52. version %{shortver} of the GLib library.
  53. ## to build compat32 for x86_64 architecture support
  54. %package -n compat32-%{name}
  55. Summary: A library of handy utility functions.
  56. Group: System Environment/Libraries
  57. %description -n compat32-%{name}
  58. GLib is the low-level core library that forms the basis
  59. for projects such as GTK+ and GNOME. It provides data structure
  60. handling for C, portability wrappers, and interfaces for such runtime
  61. functionality as an event loop, threads, dynamic loading, and an
  62. object system.
  63. This package provides version %{shortver} of GLib.
  64. %package -n compat32-%{name}-devel
  65. Summary: Development files for the GLib library
  66. Group: Development/Libraries
  67. Requires: pkgconfig >= 0.14
  68. Requires: compat32-%{name} = %{version}
  69. Conflicts: glib-devel <= 1.2.8
  70. %description -n compat32-%{name}-devel
  71. The glib-devel package includes the header files for
  72. version %{shortver} of the GLib library.
  73. %prep
  74. %setup -q -n glib-%{version}
  75. %build
  76. %meson \
  77. -Dselinux=disabled \
  78. -Dman=true
  79. %meson_build
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. %meson_install
  83. ## glib2.sh and glib2.csh
  84. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  85. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  86. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  87. #mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  88. #ln -sf %{_libdir}/gdbus-2.0/codegen $RPM_BUILD_ROOT%{python_sitearch}/codegen
  89. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gio/modules
  90. touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
  91. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  92. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  94. %find_lang glib20
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post
  98. /sbin/ldconfig
  99. gio-querymodules %{_libdir}/gio/modules
  100. %postun
  101. /sbin/ldconfig
  102. gio-querymodules %{_libdir}/gio/modules
  103. %post -n compat32-%{name} -p /sbin/ldconfig
  104. %postun -n compat32-%{name} -p /sbin/ldconfig
  105. %files -f glib20.lang
  106. %defattr(-, root, root)
  107. %license COPYING
  108. %doc AUTHORS NEWS README*
  109. %{_bindir}/gapplication
  110. %{_bindir}/gdbus
  111. %{_bindir}/gio
  112. #{_bindir}/gio-launch-desktop
  113. %{_bindir}/gio-querymodules
  114. %{_bindir}/glib-compile-schemas
  115. %{_bindir}/gsettings
  116. %{_libdir}/libglib-2.0.so.*
  117. %{_libdir}/libgthread-2.0.so.*
  118. %{_libdir}/libgmodule-2.0.so.*
  119. %{_libdir}/libgobject-2.0.so.*
  120. %{_libdir}/libgio-2.0.so.*
  121. %dir %{_libdir}/gio
  122. %dir %{_libdir}/gio/modules
  123. #%{_libdir}/gio/modules/giomodule.cache
  124. #%{_libdir}/gio/modules/lib*.so
  125. %{_sysconfdir}/profile.d/*
  126. %dir %{_datadir}/bash-completion/completions
  127. %dir %{_datadir}/bash-completion
  128. %{_datadir}/bash-completion/completions/gapplication
  129. %{_datadir}/bash-completion/completions/gdbus
  130. %{_datadir}/bash-completion/completions/gio
  131. %{_datadir}/bash-completion/completions/gsettings
  132. %files devel
  133. %defattr(-, root, root)
  134. %{_bindir}/gdbus-codegen
  135. %{_bindir}/glib-compile-resources
  136. %{_bindir}/glib-genmarshal
  137. %{_bindir}/glib-gettextize
  138. %{_bindir}/glib-mkenums
  139. %{_bindir}/gobject-query
  140. %{_bindir}/gresource
  141. %{_bindir}/gtester
  142. %{_bindir}/gtester-report
  143. %{_libdir}/lib*.so
  144. #%{_libdir}/lib*.a
  145. #%{_libdir}/gdbus-2.0/codegen/*
  146. %{_libdir}/glib-2.0
  147. %{_libdir}/pkgconfig/*
  148. #%{python_sitearch}/codegen
  149. %{_includedir}/*
  150. %{_datadir}/aclocal/*
  151. %{_datadir}/glib-2.0
  152. %{_datadir}/gettext/its/gschema.its
  153. %{_datadir}/gettext/its/gschema.loc
  154. #%doc %{_datadir}/gtk-doc/html/*
  155. %doc %{_mandir}/man1/*
  156. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  157. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  158. %dir %{_datadir}/bash-completion/completions
  159. %dir %{_datadir}/bash-completion
  160. %{_datadir}/bash-completion/completions/gresource
  161. %if %{build_compat32}
  162. %files -n compat32-%{name}
  163. %defattr(-, root, root)
  164. %{_libdir}/libglib-2.0.so.*
  165. %{_libdir}/libgthread-2.0.so.*
  166. %{_libdir}/libgmodule-2.0.so.*
  167. %{_libdir}/libgobject-2.0.so.*
  168. %{_libdir}/libgio-2.0.so.*
  169. %dir %{_libdir}/gio
  170. %dir %{_libdir}/gio/modules
  171. %files -n compat32-%{name}-devel
  172. %defattr(-, root, root)
  173. %{_libdir}/lib*.so
  174. %{_libdir}/glib-2.0
  175. %endif
  176. %changelog
  177. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-2
  178. - rebuilt with libffi-3.3.
  179. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-1
  180. - new upstream release.
  181. * Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
  182. - new upstream release.
  183. * Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
  184. - new upstream release.
  185. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
  186. - new upstream release.
  187. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
  188. - new upstream release.
  189. - dropped Patch0: fixed in upstream.
  190. - added BR:libmount-devel.
  191. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
  192. - new upstream release
  193. - add BuildRequires: pcre-devel
  194. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
  195. - add Requires: libffi
  196. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
  197. - new upstream release
  198. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
  199. - new upstream release
  200. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
  201. - new upstream release
  202. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
  203. - new upstream release
  204. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
  205. - new upstream release
  206. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
  207. - new upstream release
  208. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
  209. - new upstream release
  210. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
  211. - rebuild with libffi-3.0.13
  212. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
  213. - new upstream release
  214. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
  215. - new upstream release
  216. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  217. - new upstream release
  218. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  219. - new upstream release
  220. - remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  221. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  222. - new upstream release
  223. - add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  224. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
  225. - new upstream release
  226. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  227. - new upstream release
  228. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
  229. - new upstream release
  230. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  231. - new upstream release
  232. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  233. - new upstream release
  234. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  235. - new upstream release
  236. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
  237. - new upstream release
  238. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
  239. - new upstream release
  240. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  241. - new upstream release
  242. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  243. - new upstream release
  244. - add BuildRequires: python-devel
  245. - add Patch0 (glib-2.32.1-dconf-path.patch)
  246. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  247. - new upstream release
  248. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  249. - new upstream release
  250. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  251. - new upstream release
  252. - add Requires: libffi-devel, zlib-devel (-devel sub package)
  253. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
  254. - new upstream release
  255. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
  256. - new upstream release
  257. - remove Patch0,1
  258. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
  259. - new upstream release
  260. - Patch0: glib-2.29.16-fixes-bug-656387.patch
  261. - Patch1: glib-2.29.16-fixes-bug-656675.patch
  262. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
  263. - new upstream release
  264. - add BuildRequires: libffi-devel, dbus-devel
  265. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
  266. - new upstream release
  267. * Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  268. - new upstream release
  269. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
  270. - new upstream release
  271. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
  272. - new upstream release
  273. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  274. - new upstream release
  275. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  276. - new upstream release
  277. * Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  278. - new upstream release
  279. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  280. - new upstream release
  281. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  282. - move the following files from glib2-devel to glib2 package
  283. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  284. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  285. - new upstream release
  286. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  287. - new upstream release
  288. - fix Source (add URL)
  289. - fix %files to add /etc/bash_completion.d files
  290. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  291. - build with rpm-4.8.1-1 for pkg-config file
  292. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  293. - new upstream release
  294. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  295. - new upstream release
  296. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  297. - new upstream release
  298. - add BuildRequires: zlib-devel
  299. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  300. - new upstream release
  301. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  302. - new upstream release
  303. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  304. - new upstream release
  305. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  306. - new upstream release
  307. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  308. - new upstream release
  309. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  310. - new upstream release
  311. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  312. - new upstream release
  313. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  314. - new upstream release
  315. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  316. - new upstream release
  317. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  318. - new upstream release
  319. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  320. - new upstream release
  321. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  322. - new upstream release
  323. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  324. - new upstream release
  325. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  326. - new upstream release
  327. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  328. - new upstream release
  329. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  330. - new upstream release
  331. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  332. - updated %%if %%{build_compat32} case related statements
  333. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  334. - new upstream release
  335. - removed lib*.la files from devel package
  336. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  337. - new upstream release
  338. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  339. - added %%{?_dist_release}
  340. - BuildRequires: gamin-devel
  341. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  342. - new upstream release
  343. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  344. - new upstream release
  345. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  346. - new upstream release
  347. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  348. - new upstream release
  349. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  350. - new upstream release
  351. - removed BuildRequires: automake17
  352. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  353. - new upstream release
  354. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  355. - new upstream release
  356. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  357. - new upstream release
  358. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  359. - rebuild with new environment
  360. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  361. - new upstream release
  362. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  363. - new upstream release
  364. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  365. - new upstream release
  366. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  367. - new upstream release
  368. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  369. - new upstream release
  370. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  371. - new upstream release
  372. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  373. - new upstream release
  374. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  375. - rebuild
  376. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  377. - update glib2.{sh,csh}
  378. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  379. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  380. - new upstream release
  381. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  382. - new upstream release
  383. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  384. - new upstream release
  385. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  386. - new upstream release
  387. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  388. - added compat32-* packages for x86_64 architecture support
  389. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  390. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  391. - new upstream release
  392. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  393. - new upstream release
  394. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  395. - new upstream release
  396. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  397. - new upstream release
  398. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  399. - fixed typo in glib2.csh
  400. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  401. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  402. G_BROKEN_FILENAMES.
  403. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  404. - new upstream release
  405. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  406. - new upstream release
  407. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  408. - new upstream release
  409. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  410. - new upstream release
  411. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  412. - new upstream release
  413. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  414. - new upstream release
  415. - add *.la to build arts (should be fixed in arts?)
  416. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  417. - new upstream release
  418. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  419. - new upstream release
  420. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  421. - new upstream release
  422. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  423. - new upstream release
  424. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  425. - new upstream release
  426. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  427. - rebuilt
  428. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  429. - new upstream release
  430. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  431. - new upstream release
  432. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  433. - new upstream release
  434. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  435. - new upstream release
  436. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  437. - new upstream release
  438. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  439. - new upstream release
  440. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  441. - new upstream release
  442. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  443. - rebuild with new toolchain
  444. * Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  445. - new upstream release
  446. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  447. - new upstream release
  448. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  449. - new upstream release
  450. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  451. - new upstream release
  452. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  453. - new upstream release
  454. - build for Vine Linux
  455. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  456. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  457. - blow away unpackaged files in install
  458. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  459. - Version 2.0.6
  460. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  461. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  462. - automated rebuild
  463. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  464. - 2.0.4
  465. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  466. - automated rebuild
  467. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  468. - rebuild in different environment
  469. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  470. - Fix missing .po files (#63336)
  471. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  472. - Update to version 2.0.1
  473. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  474. - Version 2.0.0
  475. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  476. - Update to 1.3.15
  477. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  478. - Bump for rebuild
  479. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  480. - Update to 1.3.14
  481. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  482. - add horrible buildrequires hack
  483. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  484. - 1.3.13.91 cvs snap
  485. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  486. - rebuild from CVS snapshot
  487. - use setup -q
  488. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  489. - rebuild
  490. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  491. - 1.3.13
  492. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  493. - attempting rebuild in rawhide
  494. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  495. - remove 64-bit patch now upstream, 1.3.12.90
  496. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  497. - add some missing files to file list, langify
  498. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  499. - add temporary patch to fix GTypeFundamentals on 64-bit
  500. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  501. - Version 1.3.11
  502. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  503. - Version 1.3.10
  504. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  505. - Version 1.3.9
  506. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  507. - Version 1.3.8
  508. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  509. - Make -devel package require main package (#45388)
  510. - Fix description and summary
  511. - Configure with --disable-gtk-doc
  512. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  513. - add some portability fixes needed at least on s390
  514. - copy config.{guess,sub} instead of calling libtoolize
  515. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  516. - try a new glib tarball with Makefile changes to work around
  517. libtool linking to installed .la files
  518. - make -devel require pkgconfig
  519. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  520. - either libtool or the bad libtool hacks caused link
  521. against glib-gobject 1.3.2, rebuild
  522. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  523. - 1.3.6
  524. - bad libtool workarounds
  525. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  526. - 1.3.5, rename to glib2
  527. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  528. - Final 1.3.2
  529. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  530. - Version 1.3.2pre1
  531. - Remove pkgconfig
  532. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  533. - Call 1.3.1b instead of snap... the snap* naming doesn't
  534. order correctly.
  535. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  536. - new snapshot with fixed .pc files
  537. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  538. - include .pc files in file list
  539. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  540. - Include pkg-config
  541. - Upgrade to a glib CVS snapshot
  542. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  543. - rebuild to cope with glibc locale binary incompatibility
  544. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  545. - Remove glib-config.1 manpage from build since
  546. it conflicts with glib-devel. When we go to
  547. glib glib1.2 setup, we should add it back
  548. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  549. - Version 1.3.1
  550. - Move back to standard %{prefix}
  551. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  552. - Rebuild in /opt/gtk-beta
  553. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  554. - New version (adds gobject)
  555. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  556. - Don't blow away /etc/ld.so.conf (sorry!)
  557. * Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  558. - Snapshot RPM for Pango testing
  559. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  560. - Added fixes from stable branch of CVS
  561. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  562. - version 1.2.6
  563. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  564. - version 1.2.5
  565. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  566. - version 1.2.4
  567. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  568. - version 1.2.3
  569. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  570. - version 1.2.1
  571. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  572. - Version 1.2
  573. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  574. - version 1.2.0pre1
  575. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  576. - new description tags
  577. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  578. - removed libtoolize from %build
  579. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  580. - added libgthread to file list
  581. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  582. - version 1.1.15
  583. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  584. - version 1.1.14
  585. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  586. - version 1.1.13
  587. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  588. - version 1.1.12
  589. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  590. - updated in preparation for the GNOME freeze
  591. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  592. - Split out glib package