ghc-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182
  1. %define pkg_name ghc
  2. %define pkg_version 8.6.3
  3. # %define pkg_subversion b
  4. %define pkg_release 1%{?_dist_release}
  5. %ifarch %{ix86}
  6. %define rpmarch i386
  7. %endif
  8. %ifarch x86_64
  9. %define rpmarch x86_64
  10. %endif
  11. Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
  12. Name: %{pkg_name}
  13. Version: %{pkg_version}
  14. Release: %{pkg_release}
  15. License: BSD-like
  16. Group: Applications/Languages
  17. URL: https://www.haskell.org/ghc
  18. # Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
  19. Source0: %{name}-%{version}-src.tar.xz
  20. Source1: macros.ghc
  21. # # https://phabricator.haskell.org/D4159
  22. # # ghc-pkg: recompute `abi-depends` for updated packages
  23. # Patch1: ghc-8.2.2-fix-shadowed_dependencies.patch
  24. # # https://ghc.haskell.org/trac/ghc/ticket/15260
  25. # # Xmobar crashes with segmentation fault
  26. # Patch2: ghc.git-3ec1d931218e603ba1622faa2b52884b2477a7db.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: ghc
  29. BuildRequires: gmp-devel
  30. BuildRequires: libffi-devel
  31. BuildRequires: ncurses-devel readline-devel freeglut-devel
  32. BuildRequires: gtk2-devel
  33. BuildRequires: python-sphinx
  34. Requires: gmp-devel
  35. Requires: libffi-devel
  36. Requires: freeglut
  37. Conflicts: ghc-bootstrap
  38. Conflicts: haskell-platform-base
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: ara_t
  42. %description
  43. The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
  44. compiler and interactive environment for the functional language Haskell.
  45. Highlights:
  46. - GHC supports the entire Haskell 2010 language plus a wide variety of
  47. extensions.
  48. - GHC has particularly good support for concurrency and parallelism,
  49. including support for Software Transactional Memory (STM).
  50. - GHC generates fast code, particularly for concurrent programs.
  51. - Take a look at GHC's performance on The Computer Language Benchmarks Game.
  52. GHC works on several platforms including Windows, Mac, Linux,
  53. most varieties of Unix, and several different processor architectures.
  54. There are detailed instructions for porting GHC to a new platform.
  55. - GHC has extensive optimisation capabilities, including inter-module
  56. optimisation.
  57. - GHC compiles Haskell code either directly to native code or using LLVM
  58. as a back-end.
  59. GHC can also generate C code as an intermediate target for porting to
  60. new platforms.
  61. The interactive environment compiles Haskell to bytecode,
  62. and supports execution of mixed bytecode/compiled programs.
  63. - Profiling is supported, both by time/allocation and various kinds of heap
  64. profiling.
  65. - GHC comes with several libraries, and thousands more are available on Hackage.
  66. #'
  67. %prep
  68. %{__rm} -rf ${RPM_BUILD_ROOT}
  69. %setup -q
  70. # %patch1 -p1 -b .fix-shadowed_dependencies
  71. # %patch2 -p1 -b .fix-xmobar_segfault
  72. %build
  73. %{_configure} \
  74. --prefix=%{_prefix} \
  75. --libdir=%{_libdir} \
  76. --docdir=%{_docdir}/%{name}-%{version} \
  77. --with-system-libffi
  78. %{__make} %{?_smp_mflags}
  79. %install
  80. %{make_install}
  81. %{__cp} ANNOUNCE LICENSE \
  82. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  83. # macros for building haskell-platform-related packages
  84. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
  85. %{__sed} -e "s/@GHC_VERSION@/%{version}/" %{SOURCE1} \
  86. > ${RPM_BUILD_ROOT}/%{_sysconfdir}/rpm/macros.ghc
  87. %clean
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %post -p %{_syssbindir}/ldconfig
  90. %postun -p %{_syssbindir}/ldconfig
  91. %files
  92. %defattr(-, root, root)
  93. %{_bindir}/
  94. %{_libdir}/ghc-%{version}/
  95. %{_docdir}/ghc-%{version}/
  96. %{_mandir}/man1/
  97. %{_sysconfdir}/rpm/
  98. %changelog
  99. * Mon Dec 10 2018 Toshiaki Ara <ara_t@384.jp> 8.6.3-1
  100. - update to 8.6.3
  101. - drop Patch2 (fixed at upstream)
  102. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 8.4.3-2
  103. - add Patch2 (fixed that xmobar crashes with segmentation fault)
  104. * Thu Jul 19 2018 Toshiaki Ara <ara_t@384.jp> 8.4.3-1
  105. - update to 8.4.3
  106. - drop Patch1 (fixed at upstream)
  107. * Thu May 17 2018 Toshiaki Ara <ara_t@384.jp> 8.4.2-1
  108. - update to 8.4.2
  109. - add /etc/rpm/macros.ghc
  110. * Sat Jan 06 2018 Toshiaki Ara <ara_t@384.jp> 8.2.2-1
  111. - update to 8.2.2
  112. - add Patch1 (ghc-8.2.2-fix-shadowed_dependencies.patch)
  113. * Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
  114. - update to 8.0.1
  115. - add Requires: libffi-devel
  116. - add Requires: freeglut
  117. - add BuildRequires: python-sphinx for building HTML documents
  118. - add Conflicts: ghc-bootstrap
  119. - add Conflicts: haskell-platform-base
  120. - delete BuildRequires: hscolour
  121. - delete bindist subpackage
  122. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
  123. - add Requires: gmp-devel
  124. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
  125. - correct SPEC file
  126. * Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
  127. - update to 7.10.3
  128. - add BuildRequires: texlive-collection-fontutils
  129. - add Requires: libffi
  130. - add Requires: freeglut
  131. - provide binary tarball for building haskell-platform
  132. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
  133. - rebuild with ghc-7.6.3-4
  134. * Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
  135. - add Patchs to use --with-system-libffi option
  136. * Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
  137. - empty
  138. * Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
  139. - add BuildRequires: dblatex
  140. - add BuildRequires: texlive-collection-bibtexextra
  141. - add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  142. - change BuildRequires from ghc-bootstrap to ghc
  143. * Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
  144. - new package