g-wrap-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208
  1. Summary: A tool for creating Scheme interfaces to C libraries.
  2. Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
  3. Name: g-wrap
  4. Version: 1.9.15
  5. Release: 2%{?_dist_release}
  6. Group: Development/Libraries
  7. License: GPL
  8. URL: https://www.nongnu.org/g-wrap/
  9. Source: http://savannah.nongnu.org/download/g-wrap/%{name}-%{version}.tar.gz
  10. Requires: guile
  11. BuildRequires: guile-devel, libffi-devel
  12. BuildRequires: glib2-devel
  13. Requires(pre): /sbin/install-info /sbin/ldconfig
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  19. the moment it is most heavily focused on providing access to C
  20. libraries from guile, but it also supports RScheme.
  21. The g-wrap package contains the libraries necessary to run
  22. applications built with g-wrap. If you wish to build applications
  23. that use g-wrap, you should install the g-wrap-devel package.
  24. %description -l ja
  25. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  26. guile から C言語のライブライリへのアクセスを提供することを目的
  27. としています。 RScheme もサポートしています
  28. g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
  29. 必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
  30. 作成したい場合 g-wrap-devel をinstallしてください.
  31. %package devel
  32. Summary: Include files and libraries needed for g-wrap development.
  33. Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
  34. Group: Development/Libraries
  35. Requires(pre): /sbin/install-info
  36. Requires: g-wrap = %{version}, guile-devel
  37. %description devel
  38. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  39. the moment it is most heavily focused on providing access to C
  40. libraries from guile, but it also supports RScheme.
  41. You can provide access to a given C API by creating a specification
  42. file describing the interface you want published at the Scheme level.
  43. g-wrap will handle generating all the lower level library interface
  44. code so that the C library shows up as a set of Scheme functions.
  45. You should install g-wrap-devel if you need to compile programs that
  46. need to use g-wrap C<->Scheme functionality
  47. %description devel -l ja
  48. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  49. guile から C言語のライブライリへのアクセスを提供することを目的
  50. としています。 RScheme もサポートしています
  51. Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
  52. することによりC PAI へのアクセスを提供します.
  53. g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
  54. できます。したがって C ライブラリには Schem 関数の集合としてみえます.
  55. g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
  56. 場合 g-wrap-devel をinstallしておかねかればなりません.
  57. %prep
  58. %setup -q
  59. %build
  60. CFLAGS="%{optflags} -Wno-deprecated-declarations" \
  61. %configure --disable-static
  62. #remove Rpath
  63. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  64. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  65. #Is not parallel-build-safe
  66. %{__make}
  67. %install
  68. %{__rm} -rf ${RPM_BUILD_ROOT}
  69. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  70. #Remove unneeded file
  71. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
  72. rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
  73. mv ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
  74. cat config.old > config.scm
  75. install -p -m 644 config.scm ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
  76. %clean
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %post -p /sbin/ldconfig
  79. %post devel
  80. /sbin/install-info \
  81. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  82. %preun -p /sbin/ldconfig
  83. %preun devel
  84. if [ "$1" = "0" ]; then
  85. /sbin/install-info --delete \
  86. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  87. fi
  88. %files
  89. %defattr(-,root,root)
  90. %license COPYING.LIB
  91. %doc AUTHORS ChangeLog INSTALL NEWS README THANKS
  92. %dir %{_libdir}/%{name}
  93. %dir %{_libdir}/%{name}/modules
  94. %{_libdir}/%{name}/modules/*.so.*
  95. %{_libdir}/*.so.*
  96. %{_datadir}/guile/site/*
  97. %files devel
  98. %defattr(-,root,root)
  99. %{_bindir}/*
  100. %{_libdir}/*.so
  101. %{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
  102. %{_libdir}/%{name}/modules/libgw-guile-standard.so
  103. %{_includedir}/*
  104. %{_datadir}/aclocal/*
  105. %{_libdir}/pkgconfig/*
  106. %{_mandir}/man1/g-wrap-config.1.gz
  107. %doc %{_infodir}/g-wrap.*
  108. %changelog
  109. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.15-2
  110. - rebuilt with libffi-3.3.
  111. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.15-1
  112. - new upstream release.
  113. - built with guile-2.2.6.
  114. - dropped Patch0.
  115. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-3
  116. - rebuild with guile-2.0.11
  117. - add Patch0 (g-wrap-1.9.14-guile-2.0.patch)
  118. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-2
  119. - rebuild with libffi-3.0.13
  120. * Tue Jun 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-1
  121. - update to 1.9.14
  122. - remove old patches
  123. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
  124. - new upstream release
  125. - update BuildRequires: umb-scheme -> slib
  126. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
  127. - applied new versioning policy, spec in utf-8
  128. - removed *.la
  129. * Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
  130. - added Patches from Fedora
  131. * Thu Jul 7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
  132. - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
  133. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
  134. - rebuild with new toolchains
  135. - s/Copyright/License/
  136. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
  137. - build against new guile 1.6.4
  138. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
  139. - based on rawhide 1.3.4-2
  140. - update to 1.3.4
  141. - move .la files to main package (#79068)
  142. - rebuild with new guile 1.6.3
  143. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
  144. - updated to 1.1.10
  145. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
  146. - add defattr
  147. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
  148. - japanized spec file ( add %descripsion -l ja Summary(ja)
  149. * Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
  150. - Don't destroy the build directory -- RPM can do that on its own
  151. - Properly build both g-wrap and g-wrap-devel (info file into -devel)
  152. - currently only one info file
  153. * Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
  154. - use /usr/info/* for automatic gzipping
  155. * Sat May 27 2000 Mark Horning <rip6@rip6.net>
  156. - Created spec file