fusion-icon-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define commit 5e2dc9
  3. %define without_qt 1
  4. Name: fusion-icon
  5. Version: 0.1.0
  6. Release: 3%{?_dist_release}
  7. Summary: Compiz Fusion panel applet
  8. Summary(ja): Compiz Fusion パネルアプレット
  9. Group: User Interface/Desktops
  10. License: GPLv2+
  11. # The source for this package was pulled from upstream's vcs. Use the
  12. # following commands to generate the tarball:
  13. # git clone git://anongit.opencompositing.org/users/crdlb/fusion-icon fusion-icon-5e2dc9
  14. # cd fusion-icon-5e2dc9
  15. # git checkout 5e2dc9
  16. # rm -rf .git ; cd ../
  17. # tar -czvf fusion-icon-5e2dc9.tar.gz fusion-icon-5e2dc9
  18. URL: http://www.opencompositing.org
  19. Source0: %{name}-%{commit}.tar.gz
  20. Patch0: %{name}-runpatch.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: python-devel
  23. BuildRequires: desktop-file-utils
  24. Requires: ccsm %{name}-ui=%{version}-%{release}
  25. BuildArch: noarch
  26. ExcludeArch: ppc64
  27. %description
  28. The Compiz Fusion Icon is a simple panel applet for starting and controlling
  29. Compiz Fusion. Upon launch, it will attempt to start Compiz Fusion
  30. automatically. You may need to select a window decorator, if one does not
  31. appear.
  32. %package gtk
  33. Requires: pygtk2
  34. Requires: %{name} = %{version}-%{release}
  35. Group: User Interface/Desktops
  36. Summary: GTK UI for fusion-icon
  37. Summary(ja): GTK UI for fusion-icon
  38. Provides: %{name}-ui=%{version}-%{release}
  39. %description gtk
  40. This package provides the gtk UI for fusion-icon
  41. %package qt
  42. Requires: PyQt4
  43. Requires: %{name} = %{version}-%{release}
  44. Group: User Interface/Desktops
  45. Summary: QT UI for fusion-icon
  46. Summary(ja): QT UI for fusion-icon
  47. Provides: %{name}-ui=%{version}-%{release}
  48. %description qt
  49. This package provides the qt UI for fusion-icon
  50. %prep
  51. %setup -q -n %{name}-%{commit}
  52. %patch0
  53. %build
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install DESTDIR=$RPM_BUILD_ROOT
  57. desktop-file-install --vendor="" \
  58. --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
  59. --delete-original \
  60. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  61. %post
  62. touch --no-create %{_datadir}/icons/hicolor
  63. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  64. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  65. fi
  66. %postun
  67. touch --no-create %{_datadir}/icons/hicolor
  68. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  69. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  70. fi
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files
  74. %defattr(-,root,root,-)
  75. %{_bindir}/fusion-icon
  76. %{_datadir}/applications/%{name}.desktop
  77. %dir %{python_sitelib}/FusionIcon/
  78. %{python_sitelib}/FusionIcon/*py*
  79. %{_datadir}/icons/hicolor/*/apps/fusion-icon.png
  80. %{_datadir}/icons/hicolor/scalable/apps/fusion-icon.svg
  81. %if "%{fedora}" > "8"
  82. %{python_sitelib}/fusion_icon-%{version}-py2.5.egg-info
  83. %endif
  84. %doc COPYING
  85. %files gtk
  86. %defattr(-,root,root,-)
  87. %{python_sitelib}/FusionIcon/interface_gtk/
  88. %if ! %{without_qt}
  89. %files qt
  90. %defattr(-,root,root,-)
  91. %{python_sitelib}/FusionIcon/interface_qt4/
  92. %endif
  93. %changelog
  94. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-3
  95. - remove vendor prefix from desktop file
  96. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.0-2
  97. - rebuilt with python-2.5.2
  98. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-1
  99. - initial build for Vine Linux
  100. * Mon Mar 17 2008 Karol Trzcionka <karlikt at gmail.com> - 0.1.0-0.2.5e2dc9git
  101. - Fix typo in %%files
  102. * Mon Mar 17 2008 Karol Trzcionka <karlikt at gmail.com> - 0.1.0-0.1.5e2dc9git
  103. - Update tarball
  104. - Change method of releasing
  105. * Wed Feb 13 2008 Karol Trzcionka <karlikt at gmail.com> - 0-0.5.20080213git
  106. - Update tarball
  107. * Tue Jan 22 2008 Karol Trzcionka <karlikt at gmail.com> - 0-0.4.20071206git.1
  108. - Fix name of egg-info
  109. * Tue Jan 22 2008 Karol Trzcionka <karlikt at gmail.com> - 0-0.4.20071206git
  110. - Add egg-info in files section
  111. * Fri Dec 21 2007 Karol Trzcionka <karlikt at gmail.com> - 0-0.3.20071206git
  112. - Fix qt interface
  113. - Add Provides/Requires fusion-icon-ui
  114. * Thu Dec 06 2007 Karol Trzcionka <karlikt at gmail.com> - 0-0.2.20071206git
  115. - Set excludearch: ppc64
  116. - Delete .git directory from tarball
  117. * Mon Nov 26 2007 Karol Trzcionka <karlikt at gmail.com> - 0-0.1.20071126git
  118. - Initial release