flim-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. %define _noVersionedDependencies 1
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. %define origver 1.14.9
  4. %define origname flim
  5. Summary: Library to provide basic features about message for Emacsen
  6. Summary(ja): Emacsen 用の message に関する表現形式や符号化のためのライブラリです。
  7. Name: %{origname}
  8. Version: %{origver}
  9. Release: 5%{?_dist_release}
  10. License: 1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
  11. Group: Applications/Editors/Emacs
  12. URL: http://git.chise.org/elisp/flim/
  13. Source0: http://git.chise.org/elisp/dist/flim/flim-1.14/%{name}-%{version}.tar.gz
  14. Source1: %{origname}-install.sh
  15. Source2: %{origname}-remove.sh
  16. Source3: %{origname}-init.el
  17. Patch0: FLIM-CFG.emacs.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildArch: noarch
  20. Requires(post,preun): emacsen emacsen-common
  21. Requires(post): apel
  22. Requires: apel
  23. Obsoletes: flim-el
  24. Conflicts: semi <= 1.14.5-0vl2
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: shaolin
  28. %description
  29. FLIM is a library to provide basic features about message
  30. representation or encoding.
  31. Note: in order to rebuild this SRPM package, you need
  32. emacsen, emacsen-common and apel installed.
  33. %description -l ja
  34. FLIM は Internet message に関する様々な表現形式や符号化に関する
  35. 基礎的な機能を提供するための汎用部品です.
  36. 注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common
  37. 及び apel がインストールされている必要があります.
  38. %prep
  39. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  40. %setup -q -n %{origname}-%{origver}
  41. %patch0 -p1
  42. iconv -f iso8859-1 -t utf8 -o ChangeLog.new ChangeLog
  43. iconv -f iso2022jp -t utf8 -o README.ja.new README.ja
  44. mv ChangeLog.new ChangeLog
  45. mv README.ja.new README.ja
  46. %install
  47. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  48. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  49. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  50. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  51. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  52. #
  53. # remove unnecessary file
  54. #
  55. ## upstream is dropped in FLIM-ELS: see ChangeLog file 2002-11-15
  56. %{__rm} -f mailcap.el
  57. #
  58. # install el files
  59. #
  60. cp Makefile FLIM-* *.el %{SOURCE3} \
  61. ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
  62. #
  63. # install script( bytecompile el and install elc , remove )
  64. #
  65. %_installemacsenscript %{origname} %{SOURCE1}
  66. %_removeemacsenscript %{origname} %{SOURCE2}
  67. #
  68. # install info file
  69. #
  70. mkdir -p ${RPM_BUILD_ROOT}/usr/info
  71. %post
  72. #
  73. # bytecompile and install
  74. #
  75. if [ "$1" = 2 ]; then
  76. %_emacsenPackageRemove %{origname}
  77. fi
  78. %_addemacsenlist %{origname}
  79. %_emacsenPackageInstall %{origname}
  80. %preun
  81. if [ "$1" = 0 ]; then
  82. %_emacsenPackageRemove %{origname}
  83. %_removeemacsenlist %{origname}
  84. fi
  85. %triggerpostun -- flim-el
  86. %_emacsenPackageInstall %{origname}
  87. %clean
  88. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  89. rm -rf ${RPM_BUILD_DIR}/apel-%{apelver}
  90. %files
  91. %defattr(-,root,root)
  92. %doc ChangeLog NEWS README* VERSION
  93. /usr/share/emacs/site-lisp/%{origname}/
  94. %{emacsen_pkgdir}/install/%{origname}
  95. %{emacsen_pkgdir}/remove/%{origname}
  96. %changelog
  97. * Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.14.9-5
  98. - rebuilt on current VineSeed
  99. - added URL tag
  100. - updated Source0
  101. * Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.14.9-4
  102. - add Requires: apel
  103. - add Requires(preun): emacsen emacsen-common: fix 1.14.9-3
  104. * Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.14.9-3
  105. - drop defining prereq_ge macro
  106. - using Requires(post) tag
  107. * Thu Mar 4 2010 IWAI, Masaharu <iwai@alib.jp> 1.14.9-2
  108. - remove mailcap.el: <BTS:VineLinux:935>
  109. - update Packager's syntax
  110. - update description-{en,ja}
  111. * Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.14.9-1vl5
  112. - applied new versioning policy, spec in utf-8
  113. - added %%emacsen_pkgdir macro
  114. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.9-0vl1
  115. - updated to 1.14.9
  116. * Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.8-0vl1
  117. - updated in sync with 1.14.8 release
  118. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.7-0vl2
  119. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  120. - s/Copyright/License/
  121. * Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.7-0vl1
  122. - updated in sync with 1.14.7 release
  123. * Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.6-0vl1
  124. - updated in sync with 1.14.6 release
  125. * Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.5-0vl2
  126. - increased release number for the new apel release
  127. * Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.5-0vl1
  128. - updated in sync with 1.14.5 release
  129. * Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.4-0vl1
  130. - updated in sync with 1.14.4 release
  131. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl9
  132. - Obsoletes: flim-el now, instead of Conflicts:
  133. - added %%triggerpostun -- flim-el
  134. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl8
  135. - package name changed flim-el -> flim again
  136. - added Source3 for forthcoming site-start mechanism
  137. * Sun Dec 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl7
  138. - modified Source1 to remove mel-b-ccl.el* if the flavor is xemacs-21.1.x
  139. (see http://lists.airs.net/wl/archive/200101/msg00077.html)
  140. * Fri Nov 9 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  141. - change Patch0( fixed load-path)
  142. * Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  143. - requires: emacsen-common -> prereq
  144. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  145. - emacsenize
  146. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  147. - 1.14.3-0vl2
  148. - back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
  149. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  150. - 1.14.3-0vl1
  151. - updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
  152. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  153. - 1.13.7-8
  154. - added %define _noVersionedDependencies 1
  155. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  156. - 1.13.7-7
  157. - modified %files section to handle compressed man page(s)
  158. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  159. - 1.13.7-6
  160. - apel updated to 10.2
  161. * Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
  162. - 1.13.7-5
  163. - added patch (see emacs-mime-ja: 00303) to format texinfo correctly
  164. * Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
  165. - 1.13.7-4
  166. - updated in sync with apel-10.0 / clime-1.13.6 release
  167. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji
  168. - 1.13.7-3
  169. - change Group to Applications/Editors/EmacsLisp
  170. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  171. - 1.13.7-2
  172. - added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
  173. - now emh-1.10.1 and rmail-mime-1.13.0 are also included
  174. - documentation files are properly stored under /usr/doc directory
  175. * Wed Nov 3 1999 MATSUBAYASHI 'Shaolin' Kohji
  176. - 1.13.7-1
  177. - updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
  178. - added Japanese / English info files to be installed