dejagnu-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. Summary: A front end for testing other programs.
  2. Summary(ja): 各種プログラムをテストするためのフロントエンド
  3. Name: dejagnu
  4. Version: 1.5.1
  5. Release: 1%{?_dist_release}
  6. Epoch: 1
  7. Group: Development/Tools
  8. License: GPLv2
  9. Source: ftp://ftp.gnu.org/gnu/dejagnu/dejagnu-%{version}.tar.gz
  10. Patch1: dejagnu-1.5-smp-1.patch
  11. Patch2: dejagnu-1.5-runtest.patch
  12. Patch3: dejagnu-1.5-usrmove.patch
  13. Patch4: dejagnu-1.5-gfortran.patch
  14. Patch5: dejagnu-1.5-aarch64.patch
  15. Requires: tcl >= 8.0, expect >= 5.21
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildArch: noarch
  18. BuildRequires: expect screen texinfo
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: shaolin
  22. %description
  23. DejaGnu is an Expect/Tcl based framework for testing other programs.
  24. DejaGnu has several purposes: to make it easy to write tests for any
  25. program; to allow you to write tests which will be portable to any
  26. host or target where a program must be tested; and to standardize the
  27. output format of all tests (making it easier to integrate the testing
  28. into software development).
  29. %prep
  30. %setup -q -n dejagnu-%{version}
  31. find . -name \*.rej -exec rm {} \;
  32. %patch1 -p1
  33. %patch2 -p1
  34. %patch3 -p1
  35. %patch4 -p1
  36. %patch5 -p1
  37. %build
  38. %configure -v
  39. %check
  40. echo ============TESTING===============
  41. # Dejagnu test suite also has to test reporting to user. It needs a
  42. # terminal for that. That doesn't compute in mock. Work around it by
  43. # running the test under screen and communicating back to test runner
  44. # via temporary file. If you have better idea, we accept patches.
  45. TMP=`mktemp`
  46. screen -D -m sh -c '(make check RUNTESTFLAGS="RUNTEST=`pwd`/runtest"; echo $?) >> '$TMP
  47. RESULT=`tail -n 1 $TMP`
  48. cat $TMP
  49. rm -f $TMP
  50. echo ============END TESTING===========
  51. exit $RESULT
  52. %install
  53. rm -rf %{buildroot}
  54. %makeinstall
  55. rm -f %{buildroot}%{_infodir}/dir
  56. chmod a-x %{buildroot}/%{_datadir}/dejagnu/runtest.exp
  57. make DESTDIR=%{buildroot} install-man
  58. install -D -m 644 doc/dejagnu.info %{buildroot}/%{_infodir}/%{name}.info
  59. %clean
  60. rm -rf %{buildroot}
  61. %post
  62. /sbin/install-info %{_infodir}/%{name}.info.gz --dir-file=%{_infodir}/dir ||:
  63. %preun
  64. if [ $1 = 0 ]; then
  65. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
  66. fi
  67. %files
  68. %defattr(-,root,root)
  69. %doc COPYING NEWS README AUTHORS INSTALL ChangeLog doc/dejagnu.texi
  70. %{_bindir}/runtest
  71. %{_datadir}/dejagnu
  72. %{_includedir}/dejagnu.h
  73. %{_mandir}/*/*
  74. %{_infodir}/*
  75. %changelog
  76. * Mon Jan 13 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:1.5.1-1
  77. - updated to 1.5.1; import patches from Fedora; spec cleanup
  78. * Sun May 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.4-2
  79. - rebuilt with current VineSeed
  80. - added BR: texinfo
  81. * Fri Sep 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.4-1
  82. - new versioning policy; spec in UTF-8
  83. - add Source2, Patch3 and Patch4 from Fedora 1.4.4-13
  84. * Tue Mar 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl3
  85. - rebuilt with gcc-4.1.x
  86. - imported Patch1 from FC 1.4.4-5
  87. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.4-0vl2
  88. - use License instead of Copyright
  89. * Tue Mar 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
  90. - updated to 1.4.4
  91. * Sun May 09 2004 Satoshi MACHINO <machino@vinelinux.org> 1.4.2-6vl2
  92. - moved %%{_libexecdir}/config.guess into %%{_datadir}/dejagnu
  93. - included overview docs
  94. - added BuildRequires
  95. * Sun Nov 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-6vl1
  96. - based on 1.4.2-6 from Rawhide and built for Vine Linux
  97. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  98. - automated rebuild
  99. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  100. - automated rebuild
  101. * Mon Apr 29 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-4
  102. - fix makefile style variable passing (#63984)
  103. * Thu Feb 28 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-3
  104. - rebuild
  105. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  106. - automated rebuild
  107. * Wed Nov 28 2001 Jakub Jelinek <jakub@redhat.com> 1.4.2-1
  108. - update to 1.4.2, mainly so that it can be built with gcc3+
  109. * Fri Sep 7 2001 Jakub Jelinek <jakub@redhat.com> 1.4.1-3
  110. - make it noarch again
  111. * Wed Aug 29 2001 Jakub Jelinek <jakub@redhat.com>
  112. - fix a typo (#52404)
  113. * Thu Jun 28 2001 Tim Powers <timp@redhat.com>
  114. - rebuilt for the distro
  115. * Tue Feb 27 2001 Tim Powers <timp@redhat.com>
  116. - minor modifications to the spec file. Built for Powertools.
  117. - added Epoch
  118. * Wed Feb 21 2001 Rob Savoye <rob@welcomehome.org>
  119. - Fixed Requires line, and changed the URL to the new ftp site.
  120. * Sun Oct 31 1999 Rob Savoye <rob@welcomehome.org>
  121. - updated to the latest snapshot
  122. - added doc files
  123. - added the site.exp config file
  124. * Mon Jul 12 1999 Tim Powers <timp@redhat.com>
  125. - updated to 19990628
  126. - updated patches as needed
  127. - added %defattr in files section
  128. * Wed Mar 10 1999 Jeff Johnson <jbj@redhat.com>
  129. - add alpha expect patch (#989)
  130. - use %configure
  131. * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
  132. - Update to 19981215.
  133. * Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
  134. - Update to 1998-10-29.
  135. * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
  136. - Update to 1998-05-28.
  137. * Sun Feb 1 1998 Jeff Johnson <jbj@jbj.org>
  138. - Create.