db42-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
  3. %define java_arches %{ix86} alpha ia64 ppc ppc64 s390 s390x sparc sparcv9 x86_64
  4. # borrow the definition of nptl_arches from glibc's .spec file
  5. %define nptl_arches %{ix86} ia64 ppc ppc64 s390 s390x sparcv9 x86_64
  6. # define nptl_java_arches to be the intersection of java_arches and nptl_arches
  7. %define nptl_java_arches %{ix86} ia64 ppc ppc64 s390 s390x sparcv9 x86_64
  8. %undefine java_arches
  9. %undefine nptl_arches
  10. %undefine nptl_java_arches
  11. # compatibility with legacy versions of rpm
  12. %{!?_lib:%define _lib lib}
  13. %define __soversion 4.2
  14. %define _libdb_a libdb-%{__soversion}.a
  15. %define _libcxx_a libdb_cxx-%{__soversion}.a
  16. Summary: The Berkeley DB database library (version 4) for C.
  17. Name: db42
  18. Version: 4.2.52
  19. Release: 6vl7
  20. Source: http://www.sleepycat.com/update/%{version}/db-%{version}.tar.gz
  21. Source1: http://www.sleepycat.com/update/1.85/db.1.85.tar.gz
  22. Source2: nptl-abi-note.S
  23. Patch0: db-4.1.25-no-jni-includes.patch
  24. Patch1: db-4.2.52-java.patch
  25. Patch2: patch.4.2.52.1
  26. Patch3: patch.4.2.52.2
  27. Patch4: db-4.2.52-gcj.patch
  28. Patch5: db-4.2.52-disable-pthreadsmutexes.patch
  29. Patch10: http://www.sleepycat.com/update/1.85/patch.1.1
  30. Patch11: http://www.sleepycat.com/update/1.85/patch.1.2
  31. Patch12: http://www.sleepycat.com/update/1.85/patch.1.3
  32. Patch13: http://www.sleepycat.com/update/1.85/patch.1.4
  33. Patch14: db-1.85-errno.patch
  34. URL: http://www.sleepycat.com/
  35. License: GPL
  36. Group: System Environment/Libraries
  37. #Obsoletes: db1, db1-devel
  38. Obsoletes: db1-devel
  39. BuildPreReq: perl, libtool, ed, tcl >= 8.4.4
  40. %ifarch %{java_arches}
  41. BuildPreReq: gcc-java
  42. %endif
  43. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  44. Provides: db4 = %{version}
  45. %description
  46. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  47. provides embedded database support for both traditional and
  48. client/server applications. The Berkeley DB includes B+tree, Extended
  49. Linear Hashing, Fixed and Variable-length record access methods,
  50. transactions, locking, logging, shared memory caching, and database
  51. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  52. used by many applications, including Python and Perl, so this should
  53. be installed on all systems.
  54. %package -n compat32-%{name}
  55. Summary: The Berkeley DB database library (version 4) for C.
  56. Group: System Environment/Libraries
  57. Requires: db4 = %{version}-%{release}
  58. %description -n compat32-%{name}
  59. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  60. provides embedded database support for both traditional and
  61. client/server applications. The Berkeley DB includes B+tree, Extended
  62. Linear Hashing, Fixed and Variable-length record access methods,
  63. transactions, locking, logging, shared memory caching, and database
  64. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  65. used by many applications, including Python and Perl, so this should
  66. be installed on all systems.
  67. %package utils
  68. Summary: Command line tools for managing Berkeley DB (version 4) databases.
  69. Group: Applications/System
  70. Requires: db4 = %{version}-%{release}
  71. Obsoletes: db2-utils, db3-utils
  72. %description utils
  73. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  74. provides embedded database support for both traditional and
  75. client/server applications. Berkeley DB includes B+tree, Extended
  76. Linear Hashing, Fixed and Variable-length record access methods,
  77. transactions, locking, logging, shared memory caching, and database
  78. recovery. DB supports C, C++, Java and Perl APIs.
  79. This package contains command line tools for managing Berkeley DB
  80. (version 4) databases.
  81. %package devel
  82. Summary: Development files for the Berkeley DB (version 4) library.
  83. Group: Development/Libraries
  84. Requires: %{name} = %{version}-%{release}
  85. Obsoletes: db2-devel, db3-devel
  86. %description devel
  87. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  88. provides embedded database support for both traditional and
  89. client/server applications. This package contains the header files,
  90. libraries, and documentation for building programs which use the
  91. Berkeley DB.
  92. %package -n compat32-%{name}-devel
  93. Summary: Development files for the Berkeley DB (version 4) library.
  94. Group: Development/Libraries
  95. Requires: compat32-%{name} = %{version}-%{release}
  96. Requires: %{name}-devel = %{version}-%{release}
  97. %description -n compat32-%{name}-devel
  98. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  99. provides embedded database support for both traditional and
  100. client/server applications. This package contains the header files,
  101. libraries, and documentation for building programs which use the
  102. Berkeley DB.
  103. %package tcl
  104. Summary: Development files for using the Berkeley DB (version 4) with tcl.
  105. Group: Development/Libraries
  106. Requires: %{name} = %{version}-%{release}
  107. %description tcl
  108. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  109. provides embedded database support for both traditional and
  110. client/server applications. This package contains the libraries
  111. for building programs which use the Berkeley DB in Tcl.
  112. %package -n compat32-%{name}-tcl
  113. Summary: Development files for using the Berkeley DB (version 4) with tcl.
  114. Group: Development/Libraries
  115. Requires: compat32-%{name} = %{version}-%{release}
  116. Requires: %{name}-tcl = %{version}-%{release}
  117. %description -n compat32-%{name}-tcl
  118. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  119. provides embedded database support for both traditional and
  120. client/server applications. This package contains the libraries
  121. for building programs which use the Berkeley DB in Tcl.
  122. %package java
  123. Summary: Development files for using the Berkeley DB (version 4) with Java.
  124. Group: Development/Libraries
  125. Requires: %{name} = %{version}-%{release}
  126. %description java
  127. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  128. provides embedded database support for both traditional and
  129. client/server applications. This package contains the libraries
  130. for building programs which use the Berkeley DB in Java.
  131. %prep
  132. %setup -q -n db-%{version} -a 1
  133. #%patch0 -p1 -b .no-jni-includes
  134. %patch1 -p1 -b .java
  135. %patch2 -p0 -b .4.2.52.1
  136. %patch3 -p0 -b .4.2.52.2
  137. %patch4 -p1 -b .gcj
  138. %patch5 -p1 -b .disable-pthreadsmutexes
  139. pushd dist
  140. libtoolize --copy --force
  141. cp -f %{_datadir}/aclocal/libtool.m4 aclocal/libtool.ac
  142. popd
  143. pushd db.1.85/PORT/linux
  144. %patch10 -p0 -b .1
  145. popd
  146. pushd db.1.85
  147. %patch11 -p0 -b .1
  148. %patch12 -p0 -b .2
  149. %patch13 -p0 -b .3
  150. %patch14 -p1 -b .errno
  151. popd
  152. # Remove tags files which we don't need.
  153. find . -name tags | xargs rm -f
  154. # Define a shell function for fixing HREF references in the docs, which
  155. # would otherwise break when we split the docs up into subpackages.
  156. fixup_href() {
  157. for doc in $@ ; do
  158. chmod u+w ${doc}
  159. sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
  160. -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
  161. -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
  162. -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
  163. -e 's,="../api_java/,="../../%{name}-devel-%{version}/api_java/,g' \
  164. -e 's,="api_java/,="../%{name}-devel-%{version}/api_java/,g' \
  165. -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
  166. -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
  167. -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
  168. -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
  169. -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
  170. -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
  171. -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
  172. -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
  173. -e 's,="../sleepycat/,="../../%{name}-devel-%{version}/sleepycat/,g' \
  174. -e 's,="sleepycat/,="../%{name}-devel-%{version}/sleepycat/,g' \
  175. -e 's,="../images/,="../../%{name}-%{version}/images/,g' \
  176. -e 's,="images/,="../%{name}-%{version}/images/,g' \
  177. -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
  178. -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
  179. touch -r ${doc} ${doc}.new
  180. cat ${doc}.new > ${doc}
  181. touch -r ${doc}.new ${doc}
  182. rm -f ${doc}.new
  183. done
  184. }
  185. set +x # XXX painful to watch
  186. # Fix all of the HTML files.
  187. fixup_href `find . -name "*.html"`
  188. set -x # XXX painful to watch
  189. cd dist
  190. ./s_config
  191. %build
  192. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  193. # Build the old db-185 libraries.
  194. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  195. build() {
  196. test -d dist/$1 || mkdir dist/$1
  197. # Static link db_dump185 with old db-185 libraries.
  198. /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
  199. /bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  200. pushd dist/$1
  201. # Force the threading model used, for selecting whether or not we will
  202. # depend on NPTL-specific features.
  203. local mutexes_arg=""
  204. if test -n "$2" ; then
  205. mutexes_arg="--enable-posixmutexes --with-mutex=$2"
  206. else
  207. mutexes_arg="--disable-pthreadsmutexes"
  208. fi
  209. if test -n "$nptl_lo" ; then
  210. /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS \
  211. -o $nptl_lo -c $nptl_s
  212. fi
  213. ln -sf ../configure .
  214. # XXX --enable-diagnostic should be disabled for production (but is
  215. # useful).
  216. # XXX --enable-debug_{r,w}op should be disabled for production.
  217. %configure -C \
  218. --enable-compat185 --enable-dump185 \
  219. --enable-shared --enable-static --enable-rpc \
  220. --enable-tcl --with-tcl=%{_libdir} \
  221. --enable-cxx \
  222. %ifarch %{java_arches}
  223. --enable-java \
  224. %else
  225. --disable-java \
  226. %endif
  227. --enable-test \
  228. $mutexes_arg \
  229. # --enable-diagnostic \
  230. # --enable-debug --enable-debug_rop --enable-debug_wop \
  231. # Remove libtool predep_objects and postdep_objects wonkiness so that
  232. # building without -nostdlib doesn't include them twice. Because we
  233. # already link with g++, weird stuff happens if you don't let the
  234. # compiler handle this.
  235. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  236. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  237. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  238. # VINE: remove more {pre,post}dep_objects wonkiness
  239. perl -pi -e 's/^predep_objects=\`echo.*$/predep_objects=""/' libtool
  240. perl -pi -e 's/^postdep_objects=\`echo.*$/postdep_objects=""/' libtool
  241. make libdb=%{_libdb_a} libcxx=%{_libcxx_a} %{?_smp_mflags} \
  242. LIBSO_LIBS='$(LIBS)'" $nptl_lo" \
  243. LIBXSO_LIBS='$(LIBS)'" $nptl_lo" \
  244. LIBJSO_LIBS='$(LIBS)'" $nptl_lo" \
  245. LIBTSO_LIBS='$(LIBS)'" $nptl_lo"
  246. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  247. LDBJ=./.libs/libdb_java-%{__soversion}.la
  248. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  249. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  250. fi
  251. popd
  252. }
  253. # comment out %ifarch for Vine Linux x86 arch
  254. #%ifarch %{nptl_arches}
  255. unset nptl_s nptl_lo
  256. #case %{_os} in
  257. #linux|Linux)
  258. # nptl_s=$RPM_SOURCE_DIR/nptl-abi-note.S
  259. # nptl_lo=nptl-abi-note.lo
  260. # ;;
  261. #esac
  262. build dist-tls POSIX/pthreads/library
  263. unset nptl_s nptl_lo
  264. #%endif
  265. build dist-notls
  266. %install
  267. rm -rf ${RPM_BUILD_ROOT}
  268. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  269. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  270. mkdir -p ${RPM_BUILD_ROOT}/%{_lib}
  271. # comment out %ifarch for Vine Linux x86 arch
  272. #%ifarch %{nptl_arches}
  273. %makeinstall -C dist/dist-tls
  274. chmod +x ${RPM_BUILD_ROOT}/%{_libdir}/*.so*
  275. mkdir -p ${RPM_BUILD_ROOT}{/%{_lib},%{_libdir}}/tls
  276. mv ${RPM_BUILD_ROOT}/%{_libdir}/libdb*%{__soversion}.so ${RPM_BUILD_ROOT}/%{_libdir}/tls/
  277. #%endif
  278. %makeinstall -C dist/dist-notls
  279. # XXX Nuke non-versioned archives and symlinks
  280. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
  281. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
  282. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
  283. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
  284. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
  285. chmod +x $RPM_BUILD_ROOT/%{_libdir}/*.so*
  286. # Move the main shared library to lib directory, but leave the unversioned .so
  287. # symlink in the usual place to link against.
  288. if [ "%{_libdir}" != "/%{_lib}" ]; then
  289. # Move the non-tls library.
  290. mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
  291. # Move the tls library, if we have one.
  292. mkdir -p $RPM_BUILD_ROOT/%{_lib}/tls
  293. if test -e $RPM_BUILD_ROOT/%{_libdir}/tls/libdb-%{__soversion}.so ; then
  294. mv $RPM_BUILD_ROOT/%{_libdir}/tls/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/tls/
  295. fi
  296. # Leave relative symlinks in %{_libdir}.
  297. touch $RPM_BUILD_ROOT/rootfile
  298. root=..
  299. while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
  300. root=${root}/..
  301. done
  302. rm $RPM_BUILD_ROOT/rootfile
  303. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
  304. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
  305. # Leave relative symlinks in %{_libdir}/tls.
  306. if test -e $RPM_BUILD_ROOT/%{_lib}/tls/libdb-%{__soversion}.so ; then
  307. ln -sf ${root}/../%{_lib}/tls/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/tls/
  308. fi
  309. fi
  310. # Move the x86 libraries into platform-specific subdirectories so that the
  311. # tls-enabled glibc doesn't try to use NPTL-dependent libdb on real i386s,
  312. # because it doesn't provide an NPTL libpthread for that platform.
  313. %ifarch %{ix86}
  314. case %{_target_platform} in
  315. i386*|i486*) arches="i486 i586 i686";;
  316. i586*) arches="i586 i686";;
  317. i686*) arches="i686";;
  318. athlon*) arches="athlon";;
  319. *) arches=%{_target_cpu};;
  320. esac
  321. # "Move" the libraries by linking them.
  322. for targetarch in $arches ; do
  323. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}
  324. ln $RPM_BUILD_ROOT/%{_libdir}/tls/lib* $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}/
  325. if [ "%{_libdir}" != "/%{_lib}" ]; then
  326. mkdir -p $RPM_BUILD_ROOT/%{_lib}/tls/${targetarch}
  327. ln $RPM_BUILD_ROOT/%{_lib}/tls/lib* $RPM_BUILD_ROOT/%{_lib}/tls/${targetarch}/
  328. fi
  329. done
  330. rm $RPM_BUILD_ROOT/{%{_lib},%{_libdir}}/tls/lib*
  331. # Now fix the symlinks.
  332. if [ "%{_libdir}" != "/%{_lib}" ]; then
  333. # In with the new.
  334. for targetarch in $arches ; do
  335. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}
  336. ln -sf ${root}/../../%{_lib}/tls/${targetarch}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}/
  337. done
  338. fi
  339. %endif
  340. # Move the header files to a subdirectory, in case we're deploying on a
  341. # system with multiple versions of DB installed.
  342. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/db4
  343. mv $RPM_BUILD_ROOT/%{_includedir}/*.h $RPM_BUILD_ROOT/%{_includedir}/db4/
  344. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  345. for i in db.h db_cxx.h db_185.h; do
  346. ln -s db4/$i $RPM_BUILD_ROOT%{_includedir}
  347. done
  348. %ifarch %{java_arches}
  349. # Move java jar file to the correct place
  350. mkdir -p $RPM_BUILD_ROOT%{_datadir}/java
  351. mv $RPM_BUILD_ROOT%{_libdir}/*.jar $RPM_BUILD_ROOT%{_datadir}/java
  352. %endif
  353. # Eliminate installed doco
  354. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  355. # XXX Avoid Permission denied. strip when building as non-root.
  356. chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
  357. %clean
  358. rm -rf ${RPM_BUILD_ROOT}
  359. %post -p /sbin/ldconfig
  360. %postun -p /sbin/ldconfig
  361. %post -n compat32-%{name} -p /sbin/ldconfig
  362. %postun -n compat32-%{name} -p /sbin/ldconfig
  363. %post -p /sbin/ldconfig tcl
  364. %postun -p /sbin/ldconfig tcl
  365. %post -n compat32-%{name}-tcl -p /sbin/ldconfig
  366. %postun -n compat32-%{name}-tcl -p /sbin/ldconfig
  367. %post -p /sbin/ldconfig java
  368. %postun -p /sbin/ldconfig java
  369. %files
  370. %defattr(-,root,root)
  371. %doc LICENSE README docs/images
  372. /%{_lib}/libdb-%{__soversion}.so
  373. %{_libdir}/libdb-%{__soversion}.so
  374. %{_libdir}/libdb_cxx-%{__soversion}.so
  375. %ifarch %{nptl_arches}
  376. %ifarch %{ix86}
  377. /%{_lib}/tls/*/libdb-%{__soversion}.so
  378. %{_libdir}/tls/*/libdb-%{__soversion}.so
  379. %{_libdir}/tls/*/libdb_cxx-%{__soversion}.so
  380. %else
  381. /%{_lib}/tls/libdb-%{__soversion}.so
  382. %{_libdir}/tls/libdb-%{__soversion}.so
  383. %{_libdir}/tls/libdb_cxx-%{__soversion}.so
  384. %endif
  385. %endif
  386. #%files utils
  387. #%defattr(-,root,root)
  388. #%doc docs/utility
  389. #%{_bindir}/berkeley_db*_svc
  390. #%{_bindir}/db*_archive
  391. #%{_bindir}/db*_checkpoint
  392. #%{_bindir}/db*_deadlock
  393. #%{_bindir}/db*_dump*
  394. #%{_bindir}/db*_load
  395. #%{_bindir}/db*_printlog
  396. #%{_bindir}/db*_recover
  397. #%{_bindir}/db*_stat
  398. #%{_bindir}/db*_upgrade
  399. #%{_bindir}/db*_verify
  400. #%files devel
  401. #%defattr(-,root,root)
  402. #%doc docs/api_c docs/api_cxx docs/api_tcl docs/index.html
  403. #%doc docs/ref docs/sleepycat
  404. #%doc examples_c examples_cxx
  405. #%{_libdir}/libdb.so
  406. #%{_libdir}/libdb-%{__soversion}.la
  407. #%{_libdir}/libdb_cxx-%{__soversion}.la
  408. #%{_libdir}/%{_libdb_a}
  409. #%{_libdir}/%{_libcxx_a}
  410. #%{_includedir}/%{name}
  411. #%{_includedir}/*.h
  412. #%files tcl
  413. #%defattr(-,root,root)
  414. #%{_libdir}/libdb_tcl-%{__soversion}.a
  415. #%{_libdir}/libdb_tcl-%{__soversion}.la
  416. #%{_libdir}/libdb_tcl-%{__soversion}.so
  417. #%ifarch %{nptl_arches}
  418. #%ifnarch %{ix86}
  419. #%{_libdir}/tls/libdb_tcl-%{__soversion}.so
  420. #%else
  421. #%{_libdir}/tls/*/libdb_tcl-%{__soversion}.so
  422. #%endif
  423. #%endif
  424. #%ifarch %{java_arches}
  425. #%files java
  426. #%defattr(-,root,root)
  427. #%doc docs/java
  428. #%doc examples_java
  429. #%{_libdir}/libdb_java*
  430. #%{_datadir}/java/*.jar
  431. #%endif
  432. #%ifarch %{nptl_java_arches}
  433. #%ifnarch %{ix86}
  434. #%{_libdir}/tls/libdb_java*
  435. #%else
  436. #%{_libdir}/tls/*/libdb_java*
  437. #%endif
  438. #%endif
  439. %if %{build_compat32}
  440. %files -n compat32-%{name}
  441. %defattr(-,root,root)
  442. /%{_lib}/libdb-%{__soversion}.so
  443. %{_libdir}/libdb-%{__soversion}.so
  444. %{_libdir}/libdb_cxx-%{__soversion}.so
  445. %ifarch %{nptl_arches}
  446. /%{_lib}/tls/*/libdb-%{__soversion}.so
  447. %{_libdir}/tls/*/libdb-%{__soversion}.so
  448. %{_libdir}/tls/*/libdb_cxx-%{__soversion}.so
  449. %endif
  450. #%files -n compat32-%{name}-devel
  451. #%defattr(-,root,root)
  452. #%{_libdir}/libdb.so
  453. #%{_libdir}/libdb-%{__soversion}.la
  454. #%{_libdir}/libdb_cxx-%{__soversion}.la
  455. #%{_libdir}/%{_libdb_a}
  456. #%{_libdir}/%{_libcxx_a}
  457. #%files -n compat32-%{name}-tcl
  458. #%defattr(-,root,root)
  459. #%{_libdir}/libdb_tcl-%{__soversion}.a
  460. #%{_libdir}/libdb_tcl-%{__soversion}.la
  461. #%{_libdir}/libdb_tcl-%{__soversion}.so
  462. #%ifarch %{nptl_arches}
  463. #%{_libdir}/tls/*/libdb_tcl-%{__soversion}.so
  464. #%endif
  465. %endif
  466. %changelog
  467. * Tue May 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.52-6vl7
  468. - package name renamed from db4 to db42 (VineSeed now has db4-4.3.x)
  469. - rebuilt with new toolchain
  470. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.52-6vl6
  471. - changed db4-utils Group to Applications/System <BTS:VineLinux:163>
  472. - changed *-devel Group to Development/Libraries
  473. - changed db4-tcl Group to Devalopment/Libraries
  474. * Fri Feb 10 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.2.52-6vl5
  475. - added compat32-* packages for x86_64 architecture support
  476. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.2.52-6vl4
  477. - add Patch5.
  478. - disable mutexes.
  479. * Thu Oct 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.52-6vl3
  480. - fixed spec file for build on x86 arch
  481. comment out %ifarch and nptl_s, nptl_so
  482. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.52-6vl2
  483. - undefine nptl_arches (as Vine's glibc does)
  484. * Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.52-6vl1
  485. - updated to 4.2.52 (based on Fedora's 4.2.52-6) and merged with 4.0.14-15vl3
  486. - java_arches and nptl_java_arches undefined
  487. - older Vine package's changelogs were as follows:
  488. - Fri Feb 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.14-15vl3
  489. - remove Obsoletes: db[123]
  490. - Tue Feb 17 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.14-15vl2
  491. - rebuild
  492. - added Obsoletes: db[123]
  493. - remove BuildPreReq: jdkgcj
  494. - undefine java_arches
  495. - Sat Jan 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.14-15vl1
  496. - deleted Obsoletes: db1
  497. (Obsoletes: db1 is too early for Vine:
  498. we need more work/time to resolve db[1234] disorder...)
  499. - Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.14-15vl0
  500. - rebuilt for Vine Linux
  501. * Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
  502. - on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
  503. the availability of an NPTL libpthread in glibc > 2.3.3-48
  504. - run ldconfig in db4-java's %%post/%%postun
  505. - when building java support, assume that libgcj is equivalent enough to 1.3
  506. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  507. - rebuilt
  508. * Mon Jun 7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
  509. - remove dangling symlinks (#123721 et al).
  510. - remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
  511. - apply 2 patches from sleepycat.
  512. - resurrect db4-java using sun jvm-1.4.2.
  513. - cripple autoconf sufficiently to build db4-java with gcj, without jvm.
  514. - check javac first, gcj34 next, then gcj-ssa, finally gcj.
  515. - add ed build dependency (#125180).
  516. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  517. - rebuilt
  518. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  519. - rebuilt
  520. * Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
  521. - fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
  522. * Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
  523. - upgrade to db-4.2.52, no db4-java for the moment.
  524. * Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
  525. - Add build requires tcl-devel
  526. * Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
  527. - symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
  528. that the run-time linker can find the right copy for of apps which use an
  529. RPATH to point at %%{_libdir}/libdb-4.1.so
  530. * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
  531. - add another section to the ABI note for the TLS libdb so that it's marked as
  532. not needing an executable stack (from Arjan Van de Ven)
  533. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
  534. - build both with and without support for shared mutex locks, which require NPTL
  535. - make behavior wrt where we put libdb the same for all OSs
  536. - revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
  537. doesn't work
  538. - fix dangling HREFs in utility docs (pointed to main docs dir, while they're
  539. actually in the -utils docs dir)
  540. - run ldconfig when installing/removing the -utils subpackage, as it contains
  541. shared libraries
  542. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
  543. - fix multiple-inclusion problem of startup files when building shlibs without
  544. the -nostdlib flag
  545. * Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
  546. - link shared libraries without -nostdlib, which created an unresolvable dep
  547. on a hidden symbol
  548. * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  549. - allow compiling without tcl dependency
  550. * Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
  551. - update to 4.2.42.
  552. - build in build_unix subdir.
  553. - eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
  554. - create db4-tcl sub-pkg to isolate libtcl dependencies.
  555. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
  556. - rebuild
  557. * Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
  558. - add missing tcl-devel buildrequires (#101814)
  559. * Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
  560. - rebuild
  561. * Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
  562. - build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
  563. - whack out libtool predep_objects wonkiness.
  564. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
  565. - rebuild.
  566. * Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
  567. - hack out O_DIRECT support in db4 for now.
  568. * Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
  569. - replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
  570. cause a mismatch
  571. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  572. - rebuilt
  573. * Wed Jun 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
  574. - change configure to only warn if JNI includes aren't found, assuming that
  575. the C compiler can find them
  576. - remove build requirement on jdkgcj -- gcj is sufficient
  577. * Mon May 5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
  578. - upgrade to 4.1.25, crypto version.
  579. - enable posix mutexes using nptl on all arches.
  580. * Mon Mar 3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
  581. - enabled db4-java for x86_64
  582. * Wed Feb 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
  583. - add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
  584. linking with -ldb-4.0 will work again
  585. * Tue Feb 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
  586. - rebuild to use link the shared object with the same libraries we use
  587. for the bundled utils, should pull in libpthread when needed
  588. - move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
  589. * Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
  590. - add java for s390x
  591. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
  592. - rebuilt
  593. * Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
  594. - add java for s390
  595. * Tue Oct 8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
  596. - add java bits back in for x86 boxes
  597. * Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
  598. - Added better fix for s390/s390x/x86_64
  599. * Thu Sep 05 2002 Arjan van de Ven
  600. - remove java bits for x86-64
  601. * Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
  602. - include libdb_tcl-4.1.a library.
  603. - obsolete db1 packages.
  604. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
  605. - include patch to avoid db_recover (#70362)
  606. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  607. - rebuilt with gcc-3.2 (we hope)
  608. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
  609. - own %%{_includedir}/%{name}
  610. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
  611. - build using gcc-3.2-0.1
  612. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  613. - automated rebuild
  614. * Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
  615. - Add java bindings
  616. - Fix C++ bindings
  617. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  618. - automated rebuild
  619. * Thu May 9 2002 Jeff Johnson <jbj@redhat.com>
  620. - re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
  621. - make sure that -ldb is functional.
  622. * Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
  623. - avoid db_util name collisions with multiple versions installed.
  624. * Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
  625. - remove relocatability stuffs
  626. - swallow a local copy of db1 and build db185_dump statically with it, to
  627. remove the build dependency and simplify bootstrapping new arches
  628. * Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
  629. - have subpackages obsolete their db3 counterparts, because they conflict anyway
  630. * Tue Jan 8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
  631. - upgrade to 4.0.14.
  632. * Sun Aug 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  633. - fix dangling docs symlinks
  634. - fix dangling doc HREFs (#33328)
  635. - apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
  636. * Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
  637. - turn off --enable-debug
  638. * Thu May 10 2001 Than Ngo <than@redhat.com>
  639. - fixed to build on s390x
  640. * Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
  641. - update to 3.2.9.
  642. * Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
  643. - rebuild to remove 777 directories.
  644. * Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
  645. - don't build with --enable-diagnostic.
  646. - add build prereq on tcl.
  647. - default value for %%_lib macro if not found.
  648. * Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
  649. - add /usr/lib/libdb-3.1.so symlink to %%files.
  650. - remove dangling tags symlink from examples.
  651. * Mon Oct 9 2000 Jeff Johnson <jbj@redhat.com>
  652. - rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
  653. - turn off --enable-diagnostic for performance.
  654. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  655. - update to 3.1.17.
  656. - disable posix mutexes Yet Again.
  657. * Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
  658. - add c++ and posix mutex support.
  659. * Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
  660. - put nss_db into a separate package
  661. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  662. - rebuild to cope with glibc locale binary incompatibility, again
  663. * Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
  664. - remove redundant strip of libnss_db* that is nuking symbols.
  665. - change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
  666. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  667. - summaries from specspo.
  668. - all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
  669. * Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
  670. - temporarily build nss_db in this package, should be moved
  671. into separate nss_db package soon
  672. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  673. - rebuild to cope with glibc locale binary incompatibility
  674. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  675. - automatic rebuild
  676. * Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
  677. - upgrade to 3.1.14.
  678. - create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
  679. - FHS packaging.
  680. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  681. - disable tcl Yet Again, base packages cannot depend on libtcl.so.
  682. * Sat Jun 3 2000 Jeff Johnson <jbj@redhat.com>
  683. - enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
  684. * Tue May 30 2000 Matt Wilson <msw@redhat.com>
  685. - include /lib/libdb.so in the devel package
  686. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  687. - put in "System Environment/Libraries" per msw instructions.
  688. * Tue May 9 2000 Jeff Johnson <jbj@redhat.com>
  689. - install shared library in /lib, not /usr/lib.
  690. - move API docs to db3-devel.
  691. * Mon May 8 2000 Jeff Johnson <jbj@redhat.com>
  692. - don't rename db_* to db3_*.
  693. * Tue May 2 2000 Jeff Johnson <jbj@redhat.com>
  694. - disable --enable-test --enable-debug_rop --enable-debug_wop.
  695. - disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
  696. problems.
  697. * Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
  698. - add 3.0.55.1 alignment patch.
  699. - add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
  700. - add --enable-tcl (needed -lpthreads).
  701. * Sat Apr 1 2000 Jeff Johnson <jbj@redhat.com>
  702. - add --enable-debug_{r,w}op for now.
  703. - add variable to set shm perms.
  704. * Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
  705. - update to 3.0.55
  706. * Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
  707. - Add --enable-cxx to configure.
  708. * Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
  709. - Create.