freetds-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. %define git_commit 0a42888
  2. %ifarch alpha ia64 x86_64 ppc64 ppc64le sparc64 s390x aarch64
  3. %define bits 64
  4. %else
  5. %define bits 32
  6. %endif
  7. Name: freetds
  8. Summary: Implementation of the TDS (Tabular DataStream) protocol
  9. Version: 0.91.103
  10. Release: 16%{?_dist_release}
  11. Group: System Environment/Libraries
  12. License: LGPLv2+ and GPLv2+
  13. URL: http://www.freetds.org/
  14. # download the latest git source for 0.91 branch from
  15. # http://gitorious.org/freetds/freetds/archive-tarball/Branch-0_91
  16. # then
  17. # mv freetds-freetds-Branch-0_91.tar.gz freetds-%{version}-%{git_commit}.tar.gz
  18. #Source0: freetds-%{version}-%{git_commit}.tar.gz
  19. Source0: ftp://ftp.freetds.org/pub/freetds/stable/freetds-%{version}.tar.gz
  20. Source1: freetds-tds_sysdep_public.h
  21. Patch1: freetds-0.91-printf.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: unixODBC-devel, readline-devel, gnutls-devel, krb5-devel
  24. BuildRequires: libgcrypt-devel
  25. BuildRequires: libtool
  26. BuildRequires: doxygen, docbook-style-dsssl
  27. %description
  28. FreeTDS is a project to document and implement the TDS (Tabular
  29. DataStream) protocol. TDS is used by Sybase(TM) and Microsoft(TM) for
  30. client to database server communications. FreeTDS includes call
  31. level interfaces for DB-Lib, CT-Lib, and ODBC.
  32. %package devel
  33. Summary: Header files and development libraries for %{name}
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. This package contains the header files and development libraries
  38. for %{name}. If you like to develop programs using %{name}, you will need
  39. to install %{name}-devel.
  40. %package doc
  41. Summary: Development documentation for %{name}
  42. Group: Documentation
  43. BuildArch: noarch
  44. %description doc
  45. This package contains the development documentation for %{name}.
  46. If you like to develop programs using %{name}, you will need to install
  47. %{name}-doc.
  48. %prep
  49. #setup -q -n freetds-freetds
  50. %setup -q
  51. %patch1 -p1
  52. # correct perl path
  53. sed -i '1 s,#!.*/perl,#!%{__perl},' samples/*.pl
  54. chmod -x samples/*.sh samples/*.pl
  55. find . -name .cvsignore -print | xargs rm -f
  56. find . -name .gitignore -print | xargs rm -f
  57. %build
  58. export LIBS=-lgcrypt
  59. [ -f configure ] || NOCONFIGURE=yes ./autogen.sh
  60. %configure \
  61. --disable-dependency-tracking \
  62. --disable-rpath \
  63. %{!?_with_static: --disable-static} \
  64. --with-tdsver="4.2" \
  65. --with-unixodbc="%{_prefix}" \
  66. --enable-msdblib \
  67. --enable-sybase-compat \
  68. --with-gnutls \
  69. --enable-krb5
  70. make %{?_smp_mflags} DOCBOOK_DSL="`rpm -ql docbook-style-dsssl | fgrep html/docbook.dsl`"
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install DOCDIR=doc/%{name} DESTDIR=$RPM_BUILD_ROOT
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  75. rm -rf $RPM_BUILD_ROOT%{_docdir}/freetds
  76. mv -f $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h \
  77. $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public_%{bits}.h
  78. install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h
  79. rm -f samples/Makefile* samples/*.in samples/README
  80. rm -f doc/doc/freetds-%{version}/reference/installdox
  81. mv -f samples/unixodbc.freetds.driver.template \
  82. samples/unixodbc.freetds.driver.template-%{bits}
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files
  88. %defattr(-, root, root, -)
  89. %{_bindir}/*
  90. %{_libdir}/*.so.*
  91. %config(noreplace) %{_sysconfdir}/*.conf
  92. %doc AUTHORS BUGS COPYING* NEWS README TODO doc/*.html
  93. %doc doc/doc/freetds-%{version}/userguide doc/images
  94. %{_mandir}/*/*
  95. %files devel
  96. %defattr (-, root, root, -)
  97. %doc samples
  98. %{?_with_static: %{_libdir}/*.a}
  99. %{_libdir}/*.so
  100. %{_includedir}/*
  101. %files doc
  102. %defattr (-, root, root, -)
  103. %doc doc/doc/freetds-%{version}/reference
  104. %changelog
  105. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.91.103-16
  106. - Initial build for Vine Linux
  107. - source as 0.91.103
  108. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-15.git0a42888
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  110. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-14.git0a42888
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  112. * Tue Apr 22 2014 Tomáš Mráz <tmraz@redhat.com> - 0.91-13.git0a42888
  113. - Rebuild for new libgcrypt
  114. * Fri Jan 10 2014 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-12.git0a42888
  115. - add ppc64le to the list of 64bit arches (#1051199)
  116. * Tue Dec 3 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-11.git0a42888
  117. - update to the latest git source for 0_91 branch
  118. - fix format-security issue (#1037071)
  119. * Thu Aug 22 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-10.git748aa26
  120. - update to the latest git source for 0_91 branch
  121. - fix #999696
  122. * Wed Aug 7 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-9.gitb760a89
  123. - update to the latest git source for 0_91 branch
  124. - fix #992295, #993762
  125. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-8.gitf3ae29d
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  127. * Thu Jun 13 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-7.gitf3ae29d
  128. - add aarch64 to the list of 64bit arches (#966129)
  129. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-6.gitf3ae29d
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  131. * Wed Nov 7 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-5.gitf3ae29d
  132. - update to the latest git source for 0_91 branch
  133. - fix #870483
  134. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-4
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  136. * Mon Feb 27 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-3
  137. - Enable Kerberos support (#797276)
  138. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  140. * Wed Oct 26 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-1
  141. - Upgrade to 0.91
  142. - Drop shared-libtds support
  143. * Wed Mar 9 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.3.20110306dev
  144. - update to the latest stable snapshot 0.82.1.dev.20110306
  145. - make build with shared-libtds conditional
  146. - disable shared-libtds patch by default (seems noone uses it for now)
  147. * Mon Feb 14 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.2.20100810dev
  148. - fix again shared-libtds patch to provide increased library version
  149. * Thu Feb 10 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.1.20100810dev
  150. - update to the latest stable snapshot 0.82.1.dev.20100810
  151. - fix shared-libtds patch to provide properly library names
  152. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-7
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  154. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-6
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  156. * Thu Mar 26 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-5
  157. - add upstream patch cspublic.BLK_VERSION_150.patch (#492393)
  158. * Tue Feb 24 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-4
  159. - fix autoconf data for libtool2 (patch by Tom Lane <tgl@redhat.com>)
  160. * Fri Jan 30 2009 Karsten Hopp <karsten@redhat.com> 0.82-3
  161. - add s390x to 64 bit archs
  162. * Sun Jan 11 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-3
  163. - Use gnutls for SSL (#479148)
  164. * Tue Jun 17 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-2
  165. - Continue to provide an internal libtds library as public
  166. (patch from Hans de Goede, #451021). This shared library is needed
  167. for some existing applications (libgda etc.), which still use it directly.
  168. * Mon Jun 9 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-1
  169. - Upgrade to 0.82
  170. * Tue Feb 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-11
  171. - fix "64 or 32 bit" test (#434975)
  172. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.64-10
  173. - Autorebuild for GCC 4.3
  174. * Mon Jan 28 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-9
  175. - drop "Obsoletes:" from -doc subpackage to avoid extra complexity.
  176. * Fri Jan 25 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-8
  177. - resolve multiarch conflicts (#341181):
  178. - split references to separate freetds-doc subpackage
  179. - add arch-specific suffixes for arch-specific filenames in -devel
  180. - add wrapper for tds_sysdep_public.h
  181. - add readline support (#430196)
  182. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.64-7
  183. - Rebuild for selinux ppc32 issue.
  184. * Thu Aug 16 2007 Dmitry Butskoy <Dmitry@Butskoy.name>
  185. - Change License tag to "LGPLv2+ and GPLv2+"
  186. * Fri Jun 15 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-6
  187. - bump release to provide update path over Livna
  188. * Wed Jun 13 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-5
  189. - spec file cleanups
  190. - allowed for Fedora (no patent issues exist), clarification by
  191. James K. Lowden <jklowden [AT] freetds.org>
  192. - approved for Fedora (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
  193. * Wed Aug 2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
  194. - approved for Livna (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
  195. * Tue Aug 1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
  196. - add patch to fix sed scripts in the doc/ Makefile
  197. - avoid using rpath in binaries
  198. - cleanup in samples/ dir
  199. * Thu Jul 27 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-3
  200. - rebuild userguide too.
  201. - move reference docs to -devel
  202. * Mon Jul 24 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-2
  203. - Properly clear extra executable bit in source
  204. - Regenerate docs using doxygen
  205. * Thu Jul 20 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-1
  206. - Upgrade to 0.64
  207. - Some spec file and distro cleanups
  208. * Tue Sep 20 2005 V.C.G.Yeah <VCGYeah@iname.com> - 0.63-1
  209. - Upgrade to 0.63
  210. - spec file cleanups
  211. - build static libs conditional
  212. * Thu Sep 2 2004 V.C.G.Yeah <VCGYeah@iname.com> - 0.62.4-1Y
  213. - Updated to release 0.62.4.
  214. - Leave includes in system default include dir (needed for php-mssql build)
  215. * Mon May 17 2004 Dag Wieers <dag@wieers.com> - 0.62.3-1
  216. - Updated to release 0.62.3.
  217. * Wed Feb 04 2004 Dag Wieers <dag@wieers.com> - 0.61.2-0
  218. - Added --enable-msdblib configure option. (Dean Mumby)
  219. - Updated to release 0.61.2.
  220. * Fri Jun 13 2003 Dag Wieers <dag@wieers.com> - 0.61-0
  221. - Initial package. (using DAR)