gzip-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309
  1. Summary: The GNU data compression program.
  2. Summary(ja): GNU データ圧縮プログラム
  3. Name: gzip
  4. Version: 1.10
  5. Release: 1%{?_dist_release}
  6. Group: Applications/Archiving
  7. License: GPLv3+ and GFDL
  8. URL: http://www.gzip.org/
  9. Source: https://ftp.gnu.org/gnu/gzip/gzip-%{version}.tar.xz
  10. Source1: https://www.gnu.org/licenses/fdl-1.3.txt
  11. # downstream solution for coloured z*grep (#1034839)
  12. Source100: colorzgrep.csh
  13. Source101: colorzgrep.sh
  14. Patch1: gnulib.patch
  15. Patch2: gzexe.patch
  16. Requires(post): install-info
  17. Requires(preun): install-info
  18. Requires: mktemp, less, coreutils
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: texinfo
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: daisuke
  24. %description
  25. The gzip package contains the popular GNU gzip data compression
  26. program. Gzipped files have a .gz extension.
  27. Gzip should be installed on your Red Hat Linux system, because it is a
  28. very commonly used data compression program.
  29. %description -l ja
  30. gzip パッケージには有名な GNU gzip データ圧縮プログラムが収められています.
  31. gzip で圧縮されたファイルには .gz の拡張子がつきます.
  32. gzip は大変一般的に使われる圧縮プログラムなので,Linux システムには
  33. 是非ともインストールされている必要があります.
  34. %prep
  35. %setup -q
  36. #%patch1 -p1 -b .gnulib
  37. %patch2 -p1 -b .gzexe
  38. cp %{SOURCE1} .
  39. autoreconf
  40. %build
  41. export DEFS="NO_ASM"
  42. export CPPFLAGS="-DHAVE_LSTAT"
  43. export CC="%{__cc}"
  44. export CPP="%{__cpp}"
  45. export CXX="%{__cxx}"
  46. %configure --bindir=/bin
  47. make %{?_smp_mflags}
  48. make check
  49. #make gzip.info
  50. %clean
  51. rm -rf $RPM_BUILD_ROOT
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. %makeinstall bindir=$RPM_BUILD_ROOT/bin
  55. mkdir -p $RPM_BUILD_ROOT/usr/bin
  56. ln -sf ../../bin/gzip $RPM_BUILD_ROOT/usr/bin/gzip
  57. ln -sf ../../bin/gunzip $RPM_BUILD_ROOT/usr/bin/gunzip
  58. for i in zcmp zegrep zforce zless znew gzexe zdiff zfgrep zgrep zmore ; do
  59. mv $RPM_BUILD_ROOT/bin/$i $RPM_BUILD_ROOT/usr/bin/$i
  60. done
  61. gzip -9nf $RPM_BUILD_ROOT%{_infodir}/gzip.info*
  62. # we don't ship it, so let's remove it from ${RPM_BUILD_ROOT}
  63. rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  64. # uncompress is a part of ncompress package
  65. rm -f ${RPM_BUILD_ROOT}/bin/uncompress
  66. cat > $RPM_BUILD_ROOT%{_bindir}/zless <<EOF
  67. #!/bin/sh
  68. /bin/zcat "\$@" | /usr/bin/less
  69. EOF
  70. chmod 755 $RPM_BUILD_ROOT%{_bindir}/zless
  71. # coloured z*grep (#1034839)
  72. %global profiledir %{_sysconfdir}/profile.d
  73. mkdir -p %{buildroot}%{profiledir}
  74. install -p -m 644 %{SOURCE100} %{buildroot}%{profiledir}
  75. install -p -m 644 %{SOURCE101} %{buildroot}%{profiledir}
  76. %post
  77. /sbin/install-info %{_infodir}/gzip.info.gz %{_infodir}/dir
  78. %preun
  79. if [ $1 = 0 ]; then
  80. /sbin/install-info --delete %{_infodir}/gzip.info.gz %{_infodir}/dir
  81. fi
  82. %files
  83. %defattr(-,root,root)
  84. %license COPYING fdl-1.3.txt
  85. %doc NEWS README AUTHORS ChangeLog THANKS TODO
  86. /bin/*
  87. %{_bindir}/*
  88. %{_mandir}/*/*
  89. %{_infodir}/gzip.info*
  90. %{profiledir}/*
  91. %changelog
  92. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10-1
  93. - new upstream release.
  94. - dropped all patches.
  95. - imported Patch1 and 2 from rawhide.
  96. - imported Source1, 100 and 101 from rawhide.
  97. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
  98. - update to 1.6
  99. - add BR: texinfo
  100. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
  101. - update to 1.5
  102. - remove unneeded patches
  103. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.13-2
  104. - build on current VineSeed
  105. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.13-1
  106. - new upstream release
  107. * Fri Jan 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  108. - add patch18 for fix CVE-2009-2624 (decompressing dynamic Huffman code)
  109. - add patch19 for fix CVE-2010-0001 (unlzw)
  110. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.12-2
  111. - spec in utf-8
  112. * Wed Mar 26 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.12-1
  113. - new upstream release
  114. - drop old patches and update patches to fit new release
  115. - add Vendor/Distribution tag
  116. - add smp_mflags into make section
  117. - remove uncompress (uncompress is a part of ncompress package)
  118. - build under new versioning policy
  119. * Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-6vl3
  120. - [security fix] add patches to fix several vulnerabilities
  121. - cve-2006-4334 - null dereference problem
  122. - cve-2006-4335 - buffer overflow problem
  123. - cve-2006-4336 - buffer underflow problem
  124. - cve-2006-4338 - infinite loop problem
  125. - cve-2006-4337 - buffer overflow problem
  126. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-6vl2
  127. - changed Group to Applications/Archiving
  128. * Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-6vl1
  129. - based on 1.3.5-6 from Fedora
  130. * Fri Apr 29 2005 Ivana Varekova <varekova@redhat.com> 1.3.5-5
  131. - fix bug 156269 - CAN-2005-1228 directory traversal bug
  132. (using the patch from Ulf Harnhammar)
  133. * Tue Apr 26 2005 Ivana Varekova <varekova@redhat.com> 1.3.5-4
  134. - fix bug 155746 - CAN-2005-0988 Race condition in gzip (patch9)
  135. * Tue Mar 22 2005 Tomas Mraz <tmraz@redhat.com> 1.3.5-2
  136. - upstream 1.3.5
  137. - dropped long ago obsolete dirinfo patch
  138. - escape file names in zgrep (#123012)
  139. - make stack in match.S nonexecutable
  140. * Mon Dec 13 2004 Ivana Varekova <varekova@redhat.com>
  141. - fix bug #106551 problem with zmore which requires the suffix .gz
  142. in file name
  143. * Fri Jan 31 2003 Jeff Johnson <jbj@redhat.com> 1.3.3-9
  144. - enlarge window buffer to avoid accessing beyond end-of-buffer
  145. (#78413,#83095).
  146. - re-enable rsync ready patch.
  147. * Fri May 2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.2-2vl2
  148. - rebuild with new toolchain
  149. - fix typo in %%changelog
  150. * Mon Jan 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-2vl1
  151. - based on 1.3.2-2 from Rawhide and rebuilt for Vine Linux
  152. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  153. - automated rebuild
  154. * Mon Nov 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.3.2-1
  155. - 1.3.2: no need for autoconf 2.5x hacks anymore
  156. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  157. - update to 1.3.1:
  158. - disable patch2
  159. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 1.3.0-16
  160. - replace tempfile patches with improved ones solar@openwall.com
  161. - Add less to the dependency chain - zless needs it
  162. * Thu Aug 23 2001 Trond Eivind Glomsr <teg@redhat.com> 1.3.0-15
  163. - Fix typo in comment in zgrep (#52465)
  164. - Copyright -> License
  165. * Tue Jun 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  166. - Patch various uses of $$ in the bundled scripts
  167. * Mon Jun 4 2001 Trond Eivind Glomsr <teg@redhat.com>
  168. - Fix the SIGPIPE patch to avoid blank lines (#43319)
  169. * Thu Feb 08 2001 Philipp Knirsch <pknirsch@redhat.de>
  170. - Fixed buzilla bug #26680. Wrong skip value after mktemp patch and forced
  171. overwrite for output file during decompression.
  172. * Tue Jan 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  173. - trap SIGPIPE in zgrep, so "zgrep | less" gets a happy ending
  174. (#24104)
  175. * Sun Dec 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  176. - add HAVE_LSTAT define, to avoid it doing weird things to symlinks
  177. instead of ignoring them as the docs say it should (#22045)
  178. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  179. - rebuild
  180. * Thu Nov 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  181. - patch all scripts so usage error messages are written to
  182. stderr (#20597)
  183. * Mon Oct 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  184. - disable assembly, as it is faster without it (bug #19910)
  185. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  186. - automatic rebuild
  187. * Tue Jun 27 2000 Trond Eivind Glomsr <teg@redhat.com>
  188. - rebuild
  189. * Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
  190. - Use %%{_mandir}, %%{_infodir}, %%configure, %%makeinstall
  191. and %%{_tmppath}
  192. * Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
  193. - Add root as default owner of the files, permits building
  194. as non-root user
  195. * Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  196. - Build system handles stripping
  197. - Don't do thing the system does, like creating directories
  198. - use --bindir /bin
  199. - Added URL
  200. - skip unnecesarry sed step
  201. - Include THANKS, AUTHORS, ChangeLog, TODO
  202. * Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  203. - 1.3
  204. - handle RPM_OPT_FLAGS
  205. * Tue Feb 15 2000 Cristian Gafton <gafton@redhat.com>
  206. - handle compressed man pages even better
  207. * Tue Feb 08 2000 Cristian Gafton <gafton@redhat.com>
  208. - adopt patch from Paul Eggert to fix detection of the improper tables in
  209. inflate.c(huft_build)
  210. - the latest released version 1.2.4a, which provides documentation updates
  211. only. But it lets us use small revision numbers again
  212. - add an dirinfo entry for gzip.info so we can get rid of the ugly --entry
  213. args to install-info
  214. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  215. - handle compressed manpages
  216. * Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
  217. - Fix bug #7970
  218. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  219. - auto rebuild in the new build environment (release 14)
  220. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  221. - built against gliibc 2.1
  222. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  223. - translations modified for de, fr, tr
  224. * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
  225. - added /usr/bin/gzip and /usr/bin/gunzip symlinks as some programs are too
  226. brain dead to figure out they should be at least trying to use $PATH
  227. - added BuildRoot
  228. * Wed Jan 28 1998 Erik Troan <ewt@redhat.com>
  229. - fix /tmp races
  230. * Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
  231. - uses install-info
  232. - applied patch for gzexe
  233. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  234. - built against glibc
  235. * Tue Apr 22 1997 Marc Ewing <marc@redhat.com>
  236. - (Entry added for Marc by Erik) fixed gzexe to use /bin/gzip